parent
c0c8d4810b
commit
ea040e109c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=103617
@ -1,117 +0,0 @@
|
||||
--- ../config_office/configure.in.orig Wed Sep 17 05:28:53 2003
|
||||
+++ ../config_office/configure.in Sat Feb 21 11:09:36 2004
|
||||
@@ -77,6 +77,11 @@
|
||||
|
||||
Usage: --with-jdk-home=<absolute path to JDK 1.3 home>
|
||||
],,)
|
||||
+AC_ARG_WITH(gxx_include_path,
|
||||
+[ --with-gxx-include-path if you want to override the autodetected g++ include path.
|
||||
+
|
||||
+ Usage: --with-gxx-include-path=<absolute path to g++ include dir>
|
||||
+],,)
|
||||
AC_ARG_ENABLE(java,
|
||||
[ --disable-java Build without Java support. Use if there is no supported JDK
|
||||
for your platform. The build will have no support for Java
|
||||
@@ -191,8 +196,8 @@
|
||||
Usage: --with-asm-home=<path to ml.exe directory>
|
||||
],,)
|
||||
AC_ARG_WITH(os-version,
|
||||
-[ --with-os-version For FreeBSD users, use this option option to build
|
||||
- OpenOffice.org with the correct OSVERSION.
|
||||
+[ --with-os-version For FreeBSD users, use this option option to override
|
||||
+ the detected OSVERSION.
|
||||
|
||||
Usage: --with-os-version=<OSVERSION>
|
||||
],,)
|
||||
@@ -301,6 +306,33 @@
|
||||
"FreeBSD")
|
||||
test_x=yes
|
||||
test_gtk=yes
|
||||
+ AC_MSG_CHECKING([the FreeBSD operating system release])
|
||||
+ if test -n "$with_os_version"; then
|
||||
+ OSVERSION="$with_os_version"
|
||||
+ else
|
||||
+ OSVERSION=`/sbin/sysctl -n kern.osreldate`
|
||||
+ fi
|
||||
+ AC_MSG_RESULT([found OSVERSION=$OSVERSION])
|
||||
+ if test -z "$PTHREAD_CFLAGS"; then
|
||||
+ if test "$OSVERSION" -lt "502102"; then
|
||||
+ PTHREAD_CFLAGS="-D_THREAD_SAFE"
|
||||
+ else
|
||||
+ unset PTHREAD_CFLAGS
|
||||
+ fi
|
||||
+ fi
|
||||
+ AC_MSG_RESULT([use PTHREAD_CFLAGS=$PTHREAD_CFLAGS])
|
||||
+ if test -z "$PTHREAD_LIBS"; then
|
||||
+ if test "$OSVERSION" -lt "502102"; then
|
||||
+ PTHREAD_LIBS="-lc_r"
|
||||
+ fi
|
||||
+ if test "$OSVERSION" -lt "500016"; then
|
||||
+ PTHREAD_LIBS="-pthread"
|
||||
+ fi
|
||||
+ if test "$OSVERSION" -ge "502102"; then
|
||||
+ PTHREAD_LIBS="-lpthread"
|
||||
+ fi
|
||||
+ fi
|
||||
+ AC_MSG_RESULT([use PTHREAD_LIBS=$PTHREAD_LIBS])
|
||||
;;
|
||||
"OSF1")
|
||||
test_x=dontknow
|
||||
@@ -326,6 +358,7 @@
|
||||
|
||||
AC_MSG_RESULT([checked ($_os)])
|
||||
|
||||
+AC_SUBST(OSVERSION)
|
||||
AC_SUBST(PTHREAD_CFLAGS)
|
||||
AC_SUBST(PTHREAD_LIBS)
|
||||
|
||||
@@ -813,30 +846,20 @@
|
||||
dnl ===================================================================
|
||||
dnl Set the gcc/gxx include directories
|
||||
dnl ===================================================================
|
||||
-if test "$_os" = "FreeBSD" && test "$CC" != "cc"; then
|
||||
-if test "$GXX" = "yes"; then
|
||||
- if test -n "$enable_gcc3"; then
|
||||
- _gccincname1="g++-v3"
|
||||
- else
|
||||
- _gccincname1="g++-3"
|
||||
- fi
|
||||
- _gcc_include_path=".."
|
||||
- _gxx_include_path="$_gcc_include_path/$_gccincname1"
|
||||
-fi
|
||||
-else
|
||||
-if test "$GXX" = "yes"; then
|
||||
- _gxx_include_path=`echo "#include <cstring>" | $CXX -E -xc++ - | $SED -n '/.*1*"\(.*\)\/cstring".*/s//\1/p' | head -n 1`
|
||||
- if test "$_gxx_include_path" = "/usr/libexec/(null)/include"; then
|
||||
- _gxx_include_path="/usr/include"
|
||||
+# Removed the special FreeBSD treatment. The problem was that with_gxx_include_path
|
||||
+# often contains an i386 which is expanded as a macro. Solved in stlport.
|
||||
+if test "$GXX" = "yes" -a -z "$with_gxx_include_path"; then
|
||||
+ with_gxx_include_path=`echo "#include <cstring>" | $CXX -E -xc++ - | $SED -n '/.*1*"\(.*\)\/cstring".*/s//\1/p' | head -n 1`
|
||||
+ if test "$with_gxx_include_path" = "/usr/libexec/(null)/include"; then
|
||||
+ with_gxx_include_path="/usr/include"
|
||||
fi
|
||||
dnl This is the original code...
|
||||
-dnl _gxx_include_path=`$CXX -print-search-dirs | grep instal |$AWK '{ print \$2 }'`/include
|
||||
+dnl with_gxx_include_path=`$CXX -print-search-dirs | grep instal |$AWK '{ print \$2 }'`/include
|
||||
fi
|
||||
+if test -z "$with_gxx_include_path"; then
|
||||
+ with_gxx_include_path="NO_GXX_INCLUDE"
|
||||
fi
|
||||
-if test -z "$_gxx_include_path"; then
|
||||
- _gxx_include_path="NO_GXX_INCLUDE"
|
||||
-fi
|
||||
-GXX_INCLUDE_PATH="$_gxx_include_path"
|
||||
+GXX_INCLUDE_PATH="$with_gxx_include_path"
|
||||
AC_SUBST(GXX_INCLUDE_PATH)
|
||||
|
||||
dnl ===================================================================
|
||||
@@ -1710,8 +1733,6 @@
|
||||
AC_SUBST(GCC_HOME)
|
||||
|
||||
AC_SUBST(WITH_MINGWIN)
|
||||
-OSVERSION="$with_os_version"
|
||||
-AC_SUBST(OSVERSION)
|
||||
|
||||
AC_OUTPUT([set_soenv])
|
||||
|
@ -1,117 +0,0 @@
|
||||
--- ../config_office/configure.in.orig Wed Sep 17 05:28:53 2003
|
||||
+++ ../config_office/configure.in Sat Feb 21 11:09:36 2004
|
||||
@@ -77,6 +77,11 @@
|
||||
|
||||
Usage: --with-jdk-home=<absolute path to JDK 1.3 home>
|
||||
],,)
|
||||
+AC_ARG_WITH(gxx_include_path,
|
||||
+[ --with-gxx-include-path if you want to override the autodetected g++ include path.
|
||||
+
|
||||
+ Usage: --with-gxx-include-path=<absolute path to g++ include dir>
|
||||
+],,)
|
||||
AC_ARG_ENABLE(java,
|
||||
[ --disable-java Build without Java support. Use if there is no supported JDK
|
||||
for your platform. The build will have no support for Java
|
||||
@@ -191,8 +196,8 @@
|
||||
Usage: --with-asm-home=<path to ml.exe directory>
|
||||
],,)
|
||||
AC_ARG_WITH(os-version,
|
||||
-[ --with-os-version For FreeBSD users, use this option option to build
|
||||
- OpenOffice.org with the correct OSVERSION.
|
||||
+[ --with-os-version For FreeBSD users, use this option option to override
|
||||
+ the detected OSVERSION.
|
||||
|
||||
Usage: --with-os-version=<OSVERSION>
|
||||
],,)
|
||||
@@ -301,6 +306,33 @@
|
||||
"FreeBSD")
|
||||
test_x=yes
|
||||
test_gtk=yes
|
||||
+ AC_MSG_CHECKING([the FreeBSD operating system release])
|
||||
+ if test -n "$with_os_version"; then
|
||||
+ OSVERSION="$with_os_version"
|
||||
+ else
|
||||
+ OSVERSION=`/sbin/sysctl -n kern.osreldate`
|
||||
+ fi
|
||||
+ AC_MSG_RESULT([found OSVERSION=$OSVERSION])
|
||||
+ if test -z "$PTHREAD_CFLAGS"; then
|
||||
+ if test "$OSVERSION" -lt "502102"; then
|
||||
+ PTHREAD_CFLAGS="-D_THREAD_SAFE"
|
||||
+ else
|
||||
+ unset PTHREAD_CFLAGS
|
||||
+ fi
|
||||
+ fi
|
||||
+ AC_MSG_RESULT([use PTHREAD_CFLAGS=$PTHREAD_CFLAGS])
|
||||
+ if test -z "$PTHREAD_LIBS"; then
|
||||
+ if test "$OSVERSION" -lt "502102"; then
|
||||
+ PTHREAD_LIBS="-lc_r"
|
||||
+ fi
|
||||
+ if test "$OSVERSION" -lt "500016"; then
|
||||
+ PTHREAD_LIBS="-pthread"
|
||||
+ fi
|
||||
+ if test "$OSVERSION" -ge "502102"; then
|
||||
+ PTHREAD_LIBS="-lpthread"
|
||||
+ fi
|
||||
+ fi
|
||||
+ AC_MSG_RESULT([use PTHREAD_LIBS=$PTHREAD_LIBS])
|
||||
;;
|
||||
"OSF1")
|
||||
test_x=dontknow
|
||||
@@ -326,6 +358,7 @@
|
||||
|
||||
AC_MSG_RESULT([checked ($_os)])
|
||||
|
||||
+AC_SUBST(OSVERSION)
|
||||
AC_SUBST(PTHREAD_CFLAGS)
|
||||
AC_SUBST(PTHREAD_LIBS)
|
||||
|
||||
@@ -813,30 +846,20 @@
|
||||
dnl ===================================================================
|
||||
dnl Set the gcc/gxx include directories
|
||||
dnl ===================================================================
|
||||
-if test "$_os" = "FreeBSD" && test "$CC" != "cc"; then
|
||||
-if test "$GXX" = "yes"; then
|
||||
- if test -n "$enable_gcc3"; then
|
||||
- _gccincname1="g++-v3"
|
||||
- else
|
||||
- _gccincname1="g++-3"
|
||||
- fi
|
||||
- _gcc_include_path=".."
|
||||
- _gxx_include_path="$_gcc_include_path/$_gccincname1"
|
||||
-fi
|
||||
-else
|
||||
-if test "$GXX" = "yes"; then
|
||||
- _gxx_include_path=`echo "#include <cstring>" | $CXX -E -xc++ - | $SED -n '/.*1*"\(.*\)\/cstring".*/s//\1/p' | head -n 1`
|
||||
- if test "$_gxx_include_path" = "/usr/libexec/(null)/include"; then
|
||||
- _gxx_include_path="/usr/include"
|
||||
+# Removed the special FreeBSD treatment. The problem was that with_gxx_include_path
|
||||
+# often contains an i386 which is expanded as a macro. Solved in stlport.
|
||||
+if test "$GXX" = "yes" -a -z "$with_gxx_include_path"; then
|
||||
+ with_gxx_include_path=`echo "#include <cstring>" | $CXX -E -xc++ - | $SED -n '/.*1*"\(.*\)\/cstring".*/s//\1/p' | head -n 1`
|
||||
+ if test "$with_gxx_include_path" = "/usr/libexec/(null)/include"; then
|
||||
+ with_gxx_include_path="/usr/include"
|
||||
fi
|
||||
dnl This is the original code...
|
||||
-dnl _gxx_include_path=`$CXX -print-search-dirs | grep instal |$AWK '{ print \$2 }'`/include
|
||||
+dnl with_gxx_include_path=`$CXX -print-search-dirs | grep instal |$AWK '{ print \$2 }'`/include
|
||||
fi
|
||||
+if test -z "$with_gxx_include_path"; then
|
||||
+ with_gxx_include_path="NO_GXX_INCLUDE"
|
||||
fi
|
||||
-if test -z "$_gxx_include_path"; then
|
||||
- _gxx_include_path="NO_GXX_INCLUDE"
|
||||
-fi
|
||||
-GXX_INCLUDE_PATH="$_gxx_include_path"
|
||||
+GXX_INCLUDE_PATH="$with_gxx_include_path"
|
||||
AC_SUBST(GXX_INCLUDE_PATH)
|
||||
|
||||
dnl ===================================================================
|
||||
@@ -1710,8 +1733,6 @@
|
||||
AC_SUBST(GCC_HOME)
|
||||
|
||||
AC_SUBST(WITH_MINGWIN)
|
||||
-OSVERSION="$with_os_version"
|
||||
-AC_SUBST(OSVERSION)
|
||||
|
||||
AC_OUTPUT([set_soenv])
|
||||
|
@ -1,117 +0,0 @@
|
||||
--- ../config_office/configure.in.orig Wed Sep 17 05:28:53 2003
|
||||
+++ ../config_office/configure.in Sat Feb 21 11:09:36 2004
|
||||
@@ -77,6 +77,11 @@
|
||||
|
||||
Usage: --with-jdk-home=<absolute path to JDK 1.3 home>
|
||||
],,)
|
||||
+AC_ARG_WITH(gxx_include_path,
|
||||
+[ --with-gxx-include-path if you want to override the autodetected g++ include path.
|
||||
+
|
||||
+ Usage: --with-gxx-include-path=<absolute path to g++ include dir>
|
||||
+],,)
|
||||
AC_ARG_ENABLE(java,
|
||||
[ --disable-java Build without Java support. Use if there is no supported JDK
|
||||
for your platform. The build will have no support for Java
|
||||
@@ -191,8 +196,8 @@
|
||||
Usage: --with-asm-home=<path to ml.exe directory>
|
||||
],,)
|
||||
AC_ARG_WITH(os-version,
|
||||
-[ --with-os-version For FreeBSD users, use this option option to build
|
||||
- OpenOffice.org with the correct OSVERSION.
|
||||
+[ --with-os-version For FreeBSD users, use this option option to override
|
||||
+ the detected OSVERSION.
|
||||
|
||||
Usage: --with-os-version=<OSVERSION>
|
||||
],,)
|
||||
@@ -301,6 +306,33 @@
|
||||
"FreeBSD")
|
||||
test_x=yes
|
||||
test_gtk=yes
|
||||
+ AC_MSG_CHECKING([the FreeBSD operating system release])
|
||||
+ if test -n "$with_os_version"; then
|
||||
+ OSVERSION="$with_os_version"
|
||||
+ else
|
||||
+ OSVERSION=`/sbin/sysctl -n kern.osreldate`
|
||||
+ fi
|
||||
+ AC_MSG_RESULT([found OSVERSION=$OSVERSION])
|
||||
+ if test -z "$PTHREAD_CFLAGS"; then
|
||||
+ if test "$OSVERSION" -lt "502102"; then
|
||||
+ PTHREAD_CFLAGS="-D_THREAD_SAFE"
|
||||
+ else
|
||||
+ unset PTHREAD_CFLAGS
|
||||
+ fi
|
||||
+ fi
|
||||
+ AC_MSG_RESULT([use PTHREAD_CFLAGS=$PTHREAD_CFLAGS])
|
||||
+ if test -z "$PTHREAD_LIBS"; then
|
||||
+ if test "$OSVERSION" -lt "502102"; then
|
||||
+ PTHREAD_LIBS="-lc_r"
|
||||
+ fi
|
||||
+ if test "$OSVERSION" -lt "500016"; then
|
||||
+ PTHREAD_LIBS="-pthread"
|
||||
+ fi
|
||||
+ if test "$OSVERSION" -ge "502102"; then
|
||||
+ PTHREAD_LIBS="-lpthread"
|
||||
+ fi
|
||||
+ fi
|
||||
+ AC_MSG_RESULT([use PTHREAD_LIBS=$PTHREAD_LIBS])
|
||||
;;
|
||||
"OSF1")
|
||||
test_x=dontknow
|
||||
@@ -326,6 +358,7 @@
|
||||
|
||||
AC_MSG_RESULT([checked ($_os)])
|
||||
|
||||
+AC_SUBST(OSVERSION)
|
||||
AC_SUBST(PTHREAD_CFLAGS)
|
||||
AC_SUBST(PTHREAD_LIBS)
|
||||
|
||||
@@ -813,30 +846,20 @@
|
||||
dnl ===================================================================
|
||||
dnl Set the gcc/gxx include directories
|
||||
dnl ===================================================================
|
||||
-if test "$_os" = "FreeBSD" && test "$CC" != "cc"; then
|
||||
-if test "$GXX" = "yes"; then
|
||||
- if test -n "$enable_gcc3"; then
|
||||
- _gccincname1="g++-v3"
|
||||
- else
|
||||
- _gccincname1="g++-3"
|
||||
- fi
|
||||
- _gcc_include_path=".."
|
||||
- _gxx_include_path="$_gcc_include_path/$_gccincname1"
|
||||
-fi
|
||||
-else
|
||||
-if test "$GXX" = "yes"; then
|
||||
- _gxx_include_path=`echo "#include <cstring>" | $CXX -E -xc++ - | $SED -n '/.*1*"\(.*\)\/cstring".*/s//\1/p' | head -n 1`
|
||||
- if test "$_gxx_include_path" = "/usr/libexec/(null)/include"; then
|
||||
- _gxx_include_path="/usr/include"
|
||||
+# Removed the special FreeBSD treatment. The problem was that with_gxx_include_path
|
||||
+# often contains an i386 which is expanded as a macro. Solved in stlport.
|
||||
+if test "$GXX" = "yes" -a -z "$with_gxx_include_path"; then
|
||||
+ with_gxx_include_path=`echo "#include <cstring>" | $CXX -E -xc++ - | $SED -n '/.*1*"\(.*\)\/cstring".*/s//\1/p' | head -n 1`
|
||||
+ if test "$with_gxx_include_path" = "/usr/libexec/(null)/include"; then
|
||||
+ with_gxx_include_path="/usr/include"
|
||||
fi
|
||||
dnl This is the original code...
|
||||
-dnl _gxx_include_path=`$CXX -print-search-dirs | grep instal |$AWK '{ print \$2 }'`/include
|
||||
+dnl with_gxx_include_path=`$CXX -print-search-dirs | grep instal |$AWK '{ print \$2 }'`/include
|
||||
fi
|
||||
+if test -z "$with_gxx_include_path"; then
|
||||
+ with_gxx_include_path="NO_GXX_INCLUDE"
|
||||
fi
|
||||
-if test -z "$_gxx_include_path"; then
|
||||
- _gxx_include_path="NO_GXX_INCLUDE"
|
||||
-fi
|
||||
-GXX_INCLUDE_PATH="$_gxx_include_path"
|
||||
+GXX_INCLUDE_PATH="$with_gxx_include_path"
|
||||
AC_SUBST(GXX_INCLUDE_PATH)
|
||||
|
||||
dnl ===================================================================
|
||||
@@ -1710,8 +1733,6 @@
|
||||
AC_SUBST(GCC_HOME)
|
||||
|
||||
AC_SUBST(WITH_MINGWIN)
|
||||
-OSVERSION="$with_os_version"
|
||||
-AC_SUBST(OSVERSION)
|
||||
|
||||
AC_OUTPUT([set_soenv])
|
||||
|
@ -1,117 +0,0 @@
|
||||
--- ../config_office/configure.in.orig Wed Sep 17 05:28:53 2003
|
||||
+++ ../config_office/configure.in Sat Feb 21 11:09:36 2004
|
||||
@@ -77,6 +77,11 @@
|
||||
|
||||
Usage: --with-jdk-home=<absolute path to JDK 1.3 home>
|
||||
],,)
|
||||
+AC_ARG_WITH(gxx_include_path,
|
||||
+[ --with-gxx-include-path if you want to override the autodetected g++ include path.
|
||||
+
|
||||
+ Usage: --with-gxx-include-path=<absolute path to g++ include dir>
|
||||
+],,)
|
||||
AC_ARG_ENABLE(java,
|
||||
[ --disable-java Build without Java support. Use if there is no supported JDK
|
||||
for your platform. The build will have no support for Java
|
||||
@@ -191,8 +196,8 @@
|
||||
Usage: --with-asm-home=<path to ml.exe directory>
|
||||
],,)
|
||||
AC_ARG_WITH(os-version,
|
||||
-[ --with-os-version For FreeBSD users, use this option option to build
|
||||
- OpenOffice.org with the correct OSVERSION.
|
||||
+[ --with-os-version For FreeBSD users, use this option option to override
|
||||
+ the detected OSVERSION.
|
||||
|
||||
Usage: --with-os-version=<OSVERSION>
|
||||
],,)
|
||||
@@ -301,6 +306,33 @@
|
||||
"FreeBSD")
|
||||
test_x=yes
|
||||
test_gtk=yes
|
||||
+ AC_MSG_CHECKING([the FreeBSD operating system release])
|
||||
+ if test -n "$with_os_version"; then
|
||||
+ OSVERSION="$with_os_version"
|
||||
+ else
|
||||
+ OSVERSION=`/sbin/sysctl -n kern.osreldate`
|
||||
+ fi
|
||||
+ AC_MSG_RESULT([found OSVERSION=$OSVERSION])
|
||||
+ if test -z "$PTHREAD_CFLAGS"; then
|
||||
+ if test "$OSVERSION" -lt "502102"; then
|
||||
+ PTHREAD_CFLAGS="-D_THREAD_SAFE"
|
||||
+ else
|
||||
+ unset PTHREAD_CFLAGS
|
||||
+ fi
|
||||
+ fi
|
||||
+ AC_MSG_RESULT([use PTHREAD_CFLAGS=$PTHREAD_CFLAGS])
|
||||
+ if test -z "$PTHREAD_LIBS"; then
|
||||
+ if test "$OSVERSION" -lt "502102"; then
|
||||
+ PTHREAD_LIBS="-lc_r"
|
||||
+ fi
|
||||
+ if test "$OSVERSION" -lt "500016"; then
|
||||
+ PTHREAD_LIBS="-pthread"
|
||||
+ fi
|
||||
+ if test "$OSVERSION" -ge "502102"; then
|
||||
+ PTHREAD_LIBS="-lpthread"
|
||||
+ fi
|
||||
+ fi
|
||||
+ AC_MSG_RESULT([use PTHREAD_LIBS=$PTHREAD_LIBS])
|
||||
;;
|
||||
"OSF1")
|
||||
test_x=dontknow
|
||||
@@ -326,6 +358,7 @@
|
||||
|
||||
AC_MSG_RESULT([checked ($_os)])
|
||||
|
||||
+AC_SUBST(OSVERSION)
|
||||
AC_SUBST(PTHREAD_CFLAGS)
|
||||
AC_SUBST(PTHREAD_LIBS)
|
||||
|
||||
@@ -813,30 +846,20 @@
|
||||
dnl ===================================================================
|
||||
dnl Set the gcc/gxx include directories
|
||||
dnl ===================================================================
|
||||
-if test "$_os" = "FreeBSD" && test "$CC" != "cc"; then
|
||||
-if test "$GXX" = "yes"; then
|
||||
- if test -n "$enable_gcc3"; then
|
||||
- _gccincname1="g++-v3"
|
||||
- else
|
||||
- _gccincname1="g++-3"
|
||||
- fi
|
||||
- _gcc_include_path=".."
|
||||
- _gxx_include_path="$_gcc_include_path/$_gccincname1"
|
||||
-fi
|
||||
-else
|
||||
-if test "$GXX" = "yes"; then
|
||||
- _gxx_include_path=`echo "#include <cstring>" | $CXX -E -xc++ - | $SED -n '/.*1*"\(.*\)\/cstring".*/s//\1/p' | head -n 1`
|
||||
- if test "$_gxx_include_path" = "/usr/libexec/(null)/include"; then
|
||||
- _gxx_include_path="/usr/include"
|
||||
+# Removed the special FreeBSD treatment. The problem was that with_gxx_include_path
|
||||
+# often contains an i386 which is expanded as a macro. Solved in stlport.
|
||||
+if test "$GXX" = "yes" -a -z "$with_gxx_include_path"; then
|
||||
+ with_gxx_include_path=`echo "#include <cstring>" | $CXX -E -xc++ - | $SED -n '/.*1*"\(.*\)\/cstring".*/s//\1/p' | head -n 1`
|
||||
+ if test "$with_gxx_include_path" = "/usr/libexec/(null)/include"; then
|
||||
+ with_gxx_include_path="/usr/include"
|
||||
fi
|
||||
dnl This is the original code...
|
||||
-dnl _gxx_include_path=`$CXX -print-search-dirs | grep instal |$AWK '{ print \$2 }'`/include
|
||||
+dnl with_gxx_include_path=`$CXX -print-search-dirs | grep instal |$AWK '{ print \$2 }'`/include
|
||||
fi
|
||||
+if test -z "$with_gxx_include_path"; then
|
||||
+ with_gxx_include_path="NO_GXX_INCLUDE"
|
||||
fi
|
||||
-if test -z "$_gxx_include_path"; then
|
||||
- _gxx_include_path="NO_GXX_INCLUDE"
|
||||
-fi
|
||||
-GXX_INCLUDE_PATH="$_gxx_include_path"
|
||||
+GXX_INCLUDE_PATH="$with_gxx_include_path"
|
||||
AC_SUBST(GXX_INCLUDE_PATH)
|
||||
|
||||
dnl ===================================================================
|
||||
@@ -1710,8 +1733,6 @@
|
||||
AC_SUBST(GCC_HOME)
|
||||
|
||||
AC_SUBST(WITH_MINGWIN)
|
||||
-OSVERSION="$with_os_version"
|
||||
-AC_SUBST(OSVERSION)
|
||||
|
||||
AC_OUTPUT([set_soenv])
|
||||
|
Loading…
Reference in New Issue
Block a user