add syndigator 0.14

An RSS feed reader based on Gtk2
This commit is contained in:
Ying-Chieh Liao 2004-04-20 09:37:37 +00:00
parent 67026c4d34
commit e9be62f966
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=107696
6 changed files with 89 additions and 0 deletions

View File

@ -562,6 +562,7 @@
SUBDIR += swiggle
SUBDIR += swish++
SUBDIR += swish-e
SUBDIR += syndigator
SUBDIR += tasks
SUBDIR += tclhttpd
SUBDIR += tdiary

40
www/syndigator/Makefile Normal file
View File

@ -0,0 +1,40 @@
# ex:ts=8
# Ports collection Makefile for: syndigator
# Date created: Apr 20, 2004
# Whom: ijliao
#
# $FreeBSD$
PORTNAME= syndigator
PORTVERSION= 0.14
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= An RSS feed reader based on Gtk2
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Gtk2.pm:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
${SITE_PERL}/XML/RSS.pm:${PORTSDIR}/textproc/p5-XML-RSS \
${SITE_PERL}/${PERL_ARCH}/Text/Iconv.pm:${PORTSDIR}/converters/p5-Text-Iconv \
${SITE_PERL}/${PERL_ARCH}/Gnome2.pm:${PORTSDIR}/x11-toolkits/p5-Gnome2 \
${SITE_PERL}/${PERL_ARCH}/Gtk2/Html2.pm:${PORTSDIR}/x11-toolkits/p5-Gtk2-Html2 \
${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
WRKSRC= ${WRKDIR}/${DISTNAME:S/.1-/-/}
USE_X_PREFIX= yes
USE_PERL5= yes
MAKE_ENV= SITE_PERL=${SITE_PERL} \
GNOMEDIR=${X11BASE}/share/gnome
post-install:
@${ECHO_CMD} "@cwd ${LOCALBASE}" >> ${TMPPLIST}
@${FIND} ${SITE_PERL}/syndigator ! -type d | \
${SED} 's,^${LOCALBASE}/,,' >> ${TMPPLIST}
@${FIND} ${SITE_PERL}/syndigator -type d | ${SORT} -r | \
${SED} 's,^${LOCALBASE}/,@dirrm ,' >> ${TMPPLIST}
.include <bsd.port.mk>

2
www/syndigator/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (syndigator-0.14.tar.gz) = 0ffd3c164677d4b9abcd9259c32abcd2
SIZE (syndigator-0.14.tar.gz) = 71981

View File

@ -0,0 +1,21 @@
--- Makefile.orig Tue Apr 20 16:33:54 2004
+++ Makefile Tue Apr 20 16:38:57 2004
@@ -1,12 +1,12 @@
# Makefile for Syndigator
-PREFIX=/usr
+#PREFIX=/usr
BINDIR=$(PREFIX)/bin
-LIBDIR=$(PREFIX)/lib
-DATADIR=$(PREFIX)/share
-IMAGESDIR=$(DATADIR)/syndigator/images
-ICONDIR=$(DATADIR)/pixmaps
-DESKTOPDIR=$(DATADIR)/applications
+LIBDIR=${SITE_PERL}
+DATADIR=$(PREFIX)/share/syndigator
+IMAGESDIR=$(GNOMEDIR)/images
+ICONDIR=$(GNOMEDIR)/pixmaps
+DESKTOPDIR=$(GNOMEDIR)/applications
all: syndigat

3
www/syndigator/pkg-descr Normal file
View File

@ -0,0 +1,3 @@
Syndigator is an RSS feed reader based on Gtk.
WWW: http://syndigator.sourceforge.net/

22
www/syndigator/pkg-plist Normal file
View File

@ -0,0 +1,22 @@
bin/syndigator
share/gnome/applications/syndigator.desktop
share/gnome/images/closed.png
share/gnome/images/comment-gs.png
share/gnome/images/comment.png
share/gnome/images/fetches_failed.png
share/gnome/images/fetches_failed_16.png
share/gnome/images/item-gtk2.png
share/gnome/images/item-notify-gtk2.png
share/gnome/images/item-notify.xpm
share/gnome/images/item.xpm
share/gnome/images/logo-124x22.xpm
share/gnome/images/logo-simple.gif
share/gnome/images/logo-simple.xpm
share/gnome/images/not_to_keep.xpm
share/gnome/images/offline.png
share/gnome/images/online.png
share/gnome/images/opened.png
share/gnome/images/post-comment.png
share/gnome/images/to_keep.png
share/gnome/images/tokeep-gtk2.png
share/gnome/pixmaps/syndigator.png