A port of `DrScheme', a graphical teaching environment and IDE for Scheme.
This commit is contained in:
parent
0a2ff7ac04
commit
e977d4f8a5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=44445
@ -22,6 +22,7 @@
|
||||
SUBDIR += cu-prolog
|
||||
SUBDIR += dis
|
||||
SUBDIR += diveintopython
|
||||
SUBDIR += drscheme
|
||||
SUBDIR += dylan
|
||||
SUBDIR += egcs
|
||||
SUBDIR += eiffel
|
||||
|
39
lang/drscheme/Makefile
Normal file
39
lang/drscheme/Makefile
Normal file
@ -0,0 +1,39 @@
|
||||
# New ports collection makefile for: DrScheme
|
||||
# Date created: 21 Jun 2001
|
||||
# Whom: Joseph Koshy <jkoshy@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= drscheme
|
||||
PORTVERSION= 103
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= http://www.cs.rice.edu/CS/PLT/packages/download/103/plt/ \
|
||||
ftp://ftp.pasteur.fr/pub/computing/Scheme/DrScheme/103/plt/ \
|
||||
ftp://archive.informatik.uni-tuebingen.de/unix/language/plt/103/plt/
|
||||
DISTNAME= plt.src.x
|
||||
|
||||
MAINTAINER= jkoshy@freebsd.org
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
WRKSRC= ${WRKDIR}/plt/src
|
||||
ALL_TARGET= all install
|
||||
USE_XLIB= yes
|
||||
|
||||
PLTHOME= ${PREFIX}/drscheme
|
||||
DRS_D= bin .bin install collects teachpack
|
||||
DRS_B= drscheme drscheme-jr mred mzc mzscheme
|
||||
MAN1= drscheme-jr.1 drscheme.1 mred.1 mzscheme.1
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${PLTHOME}
|
||||
cd ${WRKDIR}/plt && ${TAR} -cf - ${DRS_D} | tar -C ${PLTHOME} -xvf -
|
||||
cd ${PLTHOME} && ${PLTHOME}/install
|
||||
.for f in ${DRS_B}
|
||||
${LN} -s ${PLTHOME}/bin/$f ${PREFIX}/bin/$f
|
||||
.endfor
|
||||
.for f in ${MAN1}
|
||||
${INSTALL_MAN} ${WRKDIR}/plt/man/man1/$f ${PREFIX}/man/man1
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
1
lang/drscheme/distinfo
Normal file
1
lang/drscheme/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (plt.src.x.tar.gz) = 4a8abe4950351b68cbf0e03219250313
|
26
lang/drscheme/files/patch-aa
Normal file
26
lang/drscheme/files/patch-aa
Normal file
@ -0,0 +1,26 @@
|
||||
--- ../install-- Thu Jun 21 15:49:54 2001
|
||||
+++ ../install Thu Jun 21 15:58:35 2001
|
||||
@@ -134,21 +134,8 @@
|
||||
checklink "MzScheme/MrEd/DrScheme" ".bin/sparc-sunos4-static" ".bin/sparc-solaris" "sparc-sunos4-static" "SunOS4 Static" "Solaris"
|
||||
fi
|
||||
|
||||
-if [ -z "${RPM_INSTALL_PREFIX}" ] ; then
|
||||
- echo 'PLT software starts up much faster with .zo files, but creating .zo'
|
||||
- echo 'files now takes a few minutes and requires about 5MB of additional'
|
||||
- echo 'disk space. Create .zo files later by running plt/bin/setup-plt.'
|
||||
- echo -n ' Create .zo files now (y/n)? [y] '
|
||||
- read response
|
||||
-else
|
||||
- response="y"
|
||||
-fi
|
||||
-if [ "$response" != 'n' ] ; then
|
||||
- if [ "$response" != 'N' ] ; then
|
||||
- didnothing=""
|
||||
- bin/setup-plt
|
||||
- fi
|
||||
-fi
|
||||
+didnothing=""
|
||||
+bin/setup-plt
|
||||
|
||||
echo
|
||||
echo "PLT installation done${didnothing}."
|
1
lang/drscheme/pkg-comment
Normal file
1
lang/drscheme/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
An interactive, integrated, graphical Scheme programming environment
|
11
lang/drscheme/pkg-descr
Normal file
11
lang/drscheme/pkg-descr
Normal file
@ -0,0 +1,11 @@
|
||||
DrScheme is an interactive, integrated, graphical programming
|
||||
environment for the Scheme, MzScheme, and MrEd programming languages.
|
||||
DrScheme incorporates several features including highlighting of
|
||||
the source of syntax and run-time errors, support for multiple
|
||||
language levels, an algebraic stepper, objects, modules, a GUI
|
||||
library, TCP/IP, and much more. It includes an extensive, hyper-linked
|
||||
help system called Help Desk, available from the Help menu.
|
||||
DrScheme Jr is a textual version of DrScheme that offers some of the
|
||||
benefits of DrScheme, but without development tools or graphics.
|
||||
|
||||
WWW: http://www.cs.rice.edu/CS/PLT/packages/drscheme/
|
2377
lang/drscheme/pkg-plist
Normal file
2377
lang/drscheme/pkg-plist
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user