Add gnomoku 1.2, a Gomoku game for GNOME Desktop.
This commit is contained in:
parent
0c7ee9f95d
commit
e9474c7560
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=47668
@ -97,6 +97,7 @@
|
||||
SUBDIR += gnomekiss
|
||||
SUBDIR += gnomememoryblocks
|
||||
SUBDIR += gnomermind
|
||||
SUBDIR += gnomoku
|
||||
SUBDIR += gnuchess
|
||||
SUBDIR += gnugo
|
||||
SUBDIR += gnurobots
|
||||
|
32
games/gnomoku/Makefile
Normal file
32
games/gnomoku/Makefile
Normal file
@ -0,0 +1,32 @@
|
||||
# New ports collection makefile for: gnomoku
|
||||
# Date created: 21 May 2001
|
||||
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gnomoku
|
||||
PORTVERSION= 1.2
|
||||
CATEGORIES= games gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME}
|
||||
MASTER_SITE_SUBDIR= stable/sources/${PORTNAME}
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= gnomemm.9:${PORTSDIR}/x11-toolkits/gnome--
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
#USE_GMAKE= yes
|
||||
USE_GNOME= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-fpermissive -I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
|
||||
pre-patch:
|
||||
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
|
||||
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
|
||||
@find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
|
||||
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
|
||||
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
|
||||
|
||||
.include <bsd.port.mk>
|
1
games/gnomoku/distinfo
Normal file
1
games/gnomoku/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (gnomoku-1.2.tar.gz) = 05375da587ae497b4c260648037cddd1
|
14
games/gnomoku/files/patch-Makefile.in
Normal file
14
games/gnomoku/files/patch-Makefile.in
Normal file
@ -0,0 +1,14 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- Makefile.in 2001/09/11 13:48:15 1.1
|
||||
+++ Makefile.in 2001/09/11 13:48:31
|
||||
@@ -114,7 +114,7 @@
|
||||
# Main executable
|
||||
gnomoku_SOURCES = ai.cc ai.h gnomoku.cc mainwin.cc mainwin.h opponent.h options.cc options.h point.cc point.h user.cc user.h
|
||||
|
||||
-gnomoku_LDADD = $(GNOMEMM_LIBS) $(INTLLIBS) -lpthread
|
||||
+gnomoku_LDADD = $(GNOMEMM_LIBS) $(INTLLIBS)
|
||||
bin_PROGRAMS = gnomoku
|
||||
|
||||
# Desktop entry
|
14
games/gnomoku/files/patch-po::Makefile.in.in
Normal file
14
games/gnomoku/files/patch-po::Makefile.in.in
Normal file
@ -0,0 +1,14 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- po/Makefile.in.in 2001/09/11 13:53:23 1.1
|
||||
+++ po/Makefile.in.in 2001/09/11 13:53:37
|
||||
@@ -106,7 +106,7 @@
|
||||
@catalogs='$(CATALOGS)'; \
|
||||
for cat in $$catalogs; do \
|
||||
cat=`basename $$cat`; \
|
||||
- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
|
||||
+ lang=`echo $$cat | sed 's/\.mo$$//'`; \
|
||||
dir=$(localedir)/$$lang/LC_MESSAGES; \
|
||||
$(mkinstalldirs) $(DESTDIR)$$dir; \
|
||||
if test -r $$cat; then \
|
1
games/gnomoku/pkg-comment
Normal file
1
games/gnomoku/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A Gomoku game for GNOME Desktop
|
3
games/gnomoku/pkg-descr
Normal file
3
games/gnomoku/pkg-descr
Normal file
@ -0,0 +1,3 @@
|
||||
Gnomoku is a Gomoku game for GNOME Desktop.
|
||||
|
||||
WWW: http://www.gnome.org/
|
14
games/gnomoku/pkg-plist
Normal file
14
games/gnomoku/pkg-plist
Normal file
@ -0,0 +1,14 @@
|
||||
bin/gnomoku
|
||||
share/gnome/apps/Games/gnomoku.desktop
|
||||
share/gnome/pixmaps/gnomoku.png
|
||||
share/locale/de/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/es/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/fi/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/fr/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/hu/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/it/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/ja/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/no/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/ru/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/uk/LC_MESSAGES/gnomoku.mo
|
||||
share/locale/zh_TW.Big5/LC_MESSAGES/gnomoku.mo
|
Loading…
Reference in New Issue
Block a user