Remove expired ports:

2013-12-04 x11-themes/lila-xfwm4: Upstream development dead
2013-12-05 science/omnetpp: depends on expired textproc/libxml
This commit is contained in:
Rene Ladan 2013-12-05 12:14:33 +00:00
parent e401659024
commit e8a8b596c8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=335664
15 changed files with 2 additions and 408 deletions

2
MOVED
View File

@ -5290,3 +5290,5 @@ graphics/py-clutter||2013-12-01|Has expired: Broken for more than 6 month
graphics/py-clutter-gtk||2013-12-01|Has expired: depends on expired graphics/py-clutter
devel/zmq|net/zmq|2013-12-05|Rename according to upstream and move to more suitable category
devel/rubygem-ruby-statsd|devel/rubygem-statsd|2013-12-05|Rename to match upstream naming
x11-themes/lila-xfwm4||2013-12-05|Has expired: Upstream development dead
science/omnetpp||2013-12-05|Has expired: depends on expired textproc/libxml

View File

@ -109,7 +109,6 @@
SUBDIR += netcdf3-ftn
SUBDIR += netcdf4
SUBDIR += nifticlib
SUBDIR += omnetpp
SUBDIR += openbabel
SUBDIR += p5-Algorithm-SVMLight
SUBDIR += p5-Chemistry-3DBuilder

View File

@ -1,139 +0,0 @@
# Created by: bkoenig
# $FreeBSD$
PORTNAME= omnetpp
PORTVERSION= 3.3
PORTREVISION= 7
CATEGORIES= science
MASTER_SITES= http://www.omnetpp.org/download/release/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
EXTRACT_SUFX= .tgz
MAINTAINER= bkoenig@alpha-tierchen.de
COMMENT= A discrete event simulation environment
DEPRECATED= depends on expired textproc/libxml
EXPIRATION_DATE=2013-12-05
LIB_DEPENDS= libBLT25.so:${PORTSDIR}/x11-toolkits/blt
GNU_CONFIGURE= yes
USES= gmake pkgconfig perl5 tk
USE_GNOME= libxml libxslt
USE_LDCONFIG= yes
TCL_VER_NODOT= ${TCL_VER:S/.//}
TK_VER_NODOT= ${TK_VER:S/.//}
LIB_FILES= cmdenv envir nedxml sim_std tkenv
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
CONFIGUREUSER= ${WRKSRC}/configure.user
PKG_CONFIG?= ${LOCALBASE}/bin/pkg-config
PLIST= ${WRKDIR}/pkg-plist
INCLDIR= ${PREFIX}/include/${PORTNAME}
INCLDIR_REL= ${INCLDIR:S,^${PREFIX}/,,}
OPTIONS_DEFINE= MAGICK GRAPHVIZ DOXYGEN DOCS
OPTIONS_DEFAULT= MAGICK GRAPHVIZ DOXYGEN
MAGICK_DESC= Install ImageMagick for EPS-JPG conversion
GRAPHVIZ_DESC= Install Graphviz for generating diagrams
DOXYGEN_DESC= Install Doxygen to create the API reference
NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MMAGICK}
depend+= convert:${PORTSDIR}/graphics/ImageMagick
.endif
.if ${PORT_OPTIONS:MGRAPHVIZ}
depend+= dot:${PORTSDIR}/graphics/graphviz
.endif
.if ${PORT_OPTIONS:MDOXYGEN}
depend+= doxygen:${PORTSDIR}/devel/doxygen
.endif
BUILD_DEPENDS+= ${depend}
RUN_DEPENDS+= ${depend}
pre-configure:
@${REINPLACE_CMD} \
-e 's,-O2 -DNDEBUG=1,${CFLAGS} -fPIC,' \
-e 's,^#MSGC,MSGC,' \
${WRKSRC}/configure.user
@${ECHO} "CC=${CC}" >> ${CONFIGUREUSER}
@${ECHO} "CXX=${CXX}" >> ${CONFIGUREUSER}
@${ECHO} "OMNETPP_BITMAP_PATH=${DATADIR}/bitmaps" >> ${CONFIGUREUSER}
@${ECHO} "TK_CFLAGS=\"-I${LOCALBASE}/include -I${LOCALBASE}/include/tcl${TCL_VER} -I${LOCALBASE}/include/tk${TK_VER}\"" >> ${CONFIGUREUSER}
@${ECHO} "TK_LIBS=\"-L${LOCALBASE}/lib -L${LOCALBASE}/lib -lX11 -ltcl${TCL_VER_NODOT} -ltk${TK_VER_NODOT}\"" >> ${CONFIGUREUSER}
@${ECHO} "LIBXML_CFLAGS=\"`${PKG_CONFIG} --cflags libxml-2.0`\"" >> ${CONFIGUREUSER}
@${ECHO} "LIBXML_LIBS=\"`${PKG_CONFIG} --libs libxml-2.0`\"" >> ${CONFIGUREUSER}
@${ECHO} "WISH=wish${TK_VER}" >> ${CONFIGUREUSER}
pre-install:
@${CP} pkg-plist ${PLIST}
@(cd ${WRKSRC}; \
${FIND} -s include -type f | ${SED} "s,^include,${INCLDIR_REL}," >> ${PLIST}; \
${FIND} -s -d include -type d | ${SED} "s,^include,@dirrm ${INCLDIR_REL}," >> ${PLIST}; \
)
@(cd ${WRKSRC}; \
${FIND} -s bitmaps -type f | ${SED} "s,^,%%DATADIR%%/," >> ${PLIST}; \
${FIND} -s -d bitmaps -type d | ${SED} "s,^,@dirrm %%DATADIR%%/," >> ${PLIST} \
)
.if ${PORT_OPTIONS:MDOCS}
@(cd ${WRKSRC}; \
${FIND} -s doc/ -type f | ${SED} "s,^doc/,%%DOCSDIR%%/," >> ${PLIST}; \
${FIND} -s -d doc/ -type d | ${SED} "s,^doc/,@dirrm %%DOCSDIR%%/," >> ${PLIST} \
)
.endif
@${ECHO} "%%DATADIR%%/neddoc.xsl" >> ${PLIST}
@${ECHO} "%%DATADIR%%/neddocproc.pl" >> ${PLIST}
@${ECHO} "@dirrm %%DATADIR%%" >> ${PLIST}
do-install:
@${MKDIR} ${DATADIR}
@${INSTALL_PROGRAM} ${WRKSRC}/bin/gned ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/bin/nedtool ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/bin/plove ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/bin/seedtool ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/bin/scalars ${PREFIX}/bin
@${INSTALL_SCRIPT} ${WRKSRC}/bin/opp_* ${PREFIX}/bin
@${INSTALL_SCRIPT} ${WRKSRC}/bin/splitvec ${PREFIX}/bin
@${INSTALL_DATA} ${WRKSRC}/bin/neddoc.xsl ${DATADIR}
@${INSTALL_DATA} ${WRKSRC}/bin/neddocproc.pl ${DATADIR}
@${REINPLACE_CMD} -i '' \
-e 's,${WRKSRC}/bin,${PREFIX}/bin,' \
-e 's,${WRKSRC}/include,${INCLDIR},' \
-e 's,${WRKSRC}/lib,${PREFIX}/lib,' \
${PREFIX}/bin/opp_makemake
@${REINPLACE_CMD} -i '' \
-e 's,^\(.NEDDOC.* = "\).*/\(.*";\),\1${DATADIR}/\2,' \
${PREFIX}/bin/opp_neddoc
.for file in ${LIB_FILES}
@${INSTALL_DATA} ${WRKSRC}/lib/*.${PORTVERSION} ${PREFIX}/lib
@${LN} -s lib${file}.so.${PORTVERSION} ${PREFIX}/lib/lib${file}.so
.endfor
@(cd ${WRKSRC}/include;\
${FIND} . -type d -exec ${MKDIR} ${INCLDIR}/{} \; ;\
${FIND} . -type f | ${XARGS} -I% ${INSTALL_DATA} % ${INCLDIR}/% \
)
@(cd ${WRKSRC}/bitmaps;\
${FIND} . -type d -exec ${MKDIR} ${DATADIR}/bitmaps/{} \; ;\
${FIND} . -type f | ${XARGS} -I% ${INSTALL_DATA} % ${DATADIR}/bitmaps/% \
)
.if ${PORT_OPTIONS:MDOCS}
@(cd ${WRKSRC}/doc;\
${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/{} \; ;\
${FIND} . -type f | ${XARGS} -I% ${INSTALL_DATA} % ${DOCSDIR}/% \
)
.endif
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View File

@ -1,2 +0,0 @@
SHA256 (omnetpp-3.3-src.tgz) = f30fef40428a4177cc0ee3fb8a50d64101e6ddd5eaa464ec69f83a634b8c22f3
SIZE (omnetpp-3.3-src.tgz) = 6942933

View File

@ -1,18 +0,0 @@
--- configure.orig 2006-10-21 17:47:44.000000000 +0200
+++ configure 2008-04-06 15:04:21.000000000 +0200
@@ -5152,6 +5152,7 @@
echo "$as_me: error: Cannot find wish, part of Tcl/Tk -- maybe it is not in the PATH or has some exotic name (tested names were: wish wish85 wish8.5 wish84 wish8.4 cygwish cygwish85 cygwish84)" >&2;}
{ (exit 1); exit 1; }; }
fi
+if false; then
if echo 'puts OK; exit' | $WISH | grep OK >/dev/null; then :; else
{ { echo "$as_me:$LINENO: error: Cannot run wish (wish command \"puts OK; exit\" failed): maybe you're not running X or DISPLAY environment variable not set?" >&5
echo "$as_me: error: Cannot run wish (wish command \"puts OK; exit\" failed): maybe you're not running X or DISPLAY environment variable not set?" >&2;}
@@ -5162,6 +5163,7 @@
echo "$as_me: error: wish command \"package require Tk 8.4\" failed: probably old Tcl/Tk version, version 8.4.0+ required" >&2;}
{ (exit 1); exit 1; }; }
fi
+fi
# note: square brackets necessary otherwise M4 messes up the Tcl command
tcl_library=`echo 'puts [info library]; exit' | $WISH`

View File

@ -1,66 +0,0 @@
--- src/sim/cstat.cc.orig 2006-10-21 16:44:55.000000000 +0200
+++ src/sim/cstat.cc 2008-04-06 14:42:30.000000000 +0200
@@ -370,8 +370,31 @@
void cWeightedStdDev::collect2(double val, double weight)
{
- cStdDev::collect(weight*val);
+ // Lars Westerhoff: collect weight*val*val for sqrsum_samples for variance
+
+ if (++num_samples <= 0)
+ {
+ // FIXME: num_samples overflow: issue warning and must stop collecting!
+ ev.printf("\a\nWARNING: (%s)%s: observation count overflow!\n\n",className(),fullPath());
+ }
+ sum_samples+=weight*val;
+ sqrsum_samples+=weight*val*val;
sum_weights += weight;
+
+ if (num_samples>1)
+ {
+ if (val<min_samples)
+ min_samples=val;
+ else if (val>max_samples)
+ max_samples=val;
+ }
+ else
+ {
+ min_samples=max_samples=val;
+ }
+
+ if (transientDetectionObject()) td->collect(val); //NL
+ if (accuracyDetectionObject()) ra->collect(val); //NL
}
void cWeightedStdDev::clearResult()
@@ -382,18 +405,18 @@
double cWeightedStdDev::variance() const
{
- throw new cRuntimeError(this, "variance()/stddev() not implemented");
+ // Lars Westerhoff
-
- // if (sum_weights==0)
- // return 0.0;
- // else
- // {
- // double devsqr = (sqrsum_samples - sum_samples*sum_samples/sum_weights)/(sum_weights-1);
- // if (devsqr<=0)
- // return 0.0;
- // else
- // return devsqr;
- //}
+
+ if (sum_weights==0)
+ return 0.0;
+ else
+ {
+ double devsqr = (sqrsum_samples - sum_samples*sum_samples/sum_weights)/(sum_weights); // sum_weights-1 ???
+ if (devsqr<=0)
+ return 0.0;
+ else
+ return devsqr;
+ }
}
void cWeightedStdDev::saveToFile(FILE *f) const

View File

@ -1,11 +0,0 @@
--- src/utils/opp_makemake.in.orig 2006-10-21 16:43:59.000000000 +0200
+++ src/utils/opp_makemake.in 2008-04-06 14:33:13.000000000 +0200
@@ -254,7 +254,7 @@
-u | --userinterface)
shift
- userif=`echo $1 | tr '[a-z]' '[A-Z]'`
+ userif=`echo $1 | tr '[[:lower:]]' '[[:upper:]]'`
case "$userif" in
CMDENV | TKENV)
;;

View File

@ -1,19 +0,0 @@
OMNeT++ is a public-source, component-based, modular and
open-architecture simulation environment with strong GUI
support and an embeddable simulation kernel. Its primary
application area is the simulation of communication
networks and because of its generic and flexible
architecture, it has been successfully used in other
areas like the simulation of IT systems, queueing
networks, hardware architectures and business processes
as well. OMNeT++ is rapidly becoming a popular
simulation platform in the scientific community as well
as in industrial settings. Several open source
simulation models have been published, in the field of
internet simulations (IP, IPv6, MPLS, etc), mobility and
ad-hoc simulations and other areas.
OMNeT++ is free for academic and non-profit use;
commercial users must obtain a license from Omnest Global Inc.
WWW: http://www.omnetpp.org/

View File

@ -1,10 +0,0 @@
####################################################################
## ##
## -- Legal note -- ##
## ##
## OMNeT++ is free for academic and non-profit use; commercial ##
## users must obtain a license from Omnest Global Inc. ##
## ##
####################################################################

View File

@ -1,21 +0,0 @@
bin/gned
bin/nedtool
bin/opp_makedep
bin/opp_makemake
bin/opp_msgc
bin/opp_neddoc
bin/opp_test
bin/plove
bin/scalars
bin/seedtool
bin/splitvec
lib/libcmdenv.so.3.3
lib/libcmdenv.so
lib/libenvir.so.3.3
lib/libenvir.so
lib/libnedxml.so.3.3
lib/libnedxml.so
lib/libsim_std.so.3.3
lib/libsim_std.so
lib/libtkenv.so.3.3
lib/libtkenv.so

View File

@ -128,7 +128,6 @@
SUBDIR += kde4-windeco-dekorator
SUBDIR += kde4-windeco-nitrogen
SUBDIR += kdeartwork4
SUBDIR += lila-xfwm4
SUBDIR += linux-f10-hicolor-icon-theme
SUBDIR += linux-f10-qtcurve-gtk2
SUBDIR += linux-hicolor-icon-theme

View File

@ -1,33 +0,0 @@
# Created by: Filippo Natali <filippo@widestore.net>
# $FreeBSD$
PORTNAME= Lila-xfwm4
PORTVERSION= 0.3.2
CATEGORIES= x11-themes xfce
MASTER_SITES= SF/lila-theme/lila-xfwm/${PORTVERSION}
DISTNAME= lila-xfwm-${PORTVERSION}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= Xfce 4 Lila window decoration theme for Xfwm4
RUN_DEPENDS= xfwm4:${PORTSDIR}/x11-wm/xfce4-wm
DEPRECATED= Upstream development dead
EXPIRATION_DATE= 2013-12-04
NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_BZIP2= yes
NO_STAGE= yes
do-install:
@${MKDIR} ${PREFIX}/share/themes/Lila/xfwm4
@cd ${WRKSRC}/lila-xfwm/Lila \
&& ${COPYTREE_SHARE} . ${PREFIX}/share/themes/Lila/xfwm4
@${MKDIR} ${PREFIX}/share/themes/Lila-light/xfwm4
@cd ${WRKSRC}/lila-xfwm/Lila-light \
&& ${COPYTREE_SHARE} . ${PREFIX}/share/themes/Lila-light/xfwm4
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (xfce4/lila-xfwm-0.3.2.tar.bz2) = 3cddb6f80067d9d922172beb2a7931e32056243eba9779b8dff6a68aedad0fa7
SIZE (xfce4/lila-xfwm-0.3.2.tar.bz2) = 25330

View File

@ -1,3 +0,0 @@
Lila theme for xfwm4 window manager.
WWW: http://lila-center.info/

View File

@ -1,82 +0,0 @@
share/themes/Lila/xfwm4/bottom-active.xpm
share/themes/Lila/xfwm4/bottom-inactive.xpm
share/themes/Lila/xfwm4/bottom-left-active.xpm
share/themes/Lila/xfwm4/bottom-left-inactive.xpm
share/themes/Lila/xfwm4/bottom-right-active.xpm
share/themes/Lila/xfwm4/bottom-right-inactive.xpm
share/themes/Lila/xfwm4/close-active.xpm
share/themes/Lila/xfwm4/close-inactive.xpm
share/themes/Lila/xfwm4/close-pressed.xpm
share/themes/Lila/xfwm4/hide-active.xpm
share/themes/Lila/xfwm4/hide-inactive.xpm
share/themes/Lila/xfwm4/hide-pressed.xpm
share/themes/Lila/xfwm4/left-active.xpm
share/themes/Lila/xfwm4/left-inactive.xpm
share/themes/Lila/xfwm4/maximize-active.xpm
share/themes/Lila/xfwm4/maximize-inactive.xpm
share/themes/Lila/xfwm4/maximize-pressed.xpm
share/themes/Lila/xfwm4/menu-active.xpm
share/themes/Lila/xfwm4/menu-inactive.xpm
share/themes/Lila/xfwm4/menu-pressed.xpm
share/themes/Lila/xfwm4/right-active.xpm
share/themes/Lila/xfwm4/right-inactive.xpm
share/themes/Lila/xfwm4/themerc
share/themes/Lila/xfwm4/title-1-active.xpm
share/themes/Lila/xfwm4/title-1-inactive.xpm
share/themes/Lila/xfwm4/title-2-active.xpm
share/themes/Lila/xfwm4/title-2-inactive.xpm
share/themes/Lila/xfwm4/title-3-active.xpm
share/themes/Lila/xfwm4/title-3-inactive.xpm
share/themes/Lila/xfwm4/title-4-active.xpm
share/themes/Lila/xfwm4/title-4-inactive.xpm
share/themes/Lila/xfwm4/title-5-active.xpm
share/themes/Lila/xfwm4/title-5-inactive.xpm
share/themes/Lila/xfwm4/top-left-active.xpm
share/themes/Lila/xfwm4/top-left-inactive.xpm
share/themes/Lila/xfwm4/top-right-active.xpm
share/themes/Lila/xfwm4/top-right-inactive.xpm
share/themes/Lila-light/xfwm4/bottom-active.xpm
share/themes/Lila-light/xfwm4/bottom-inactive.xpm
share/themes/Lila-light/xfwm4/bottom-left-active.xpm
share/themes/Lila-light/xfwm4/bottom-left-inactive.xpm
share/themes/Lila-light/xfwm4/bottom-right-active.xpm
share/themes/Lila-light/xfwm4/bottom-right-inactive.xpm
share/themes/Lila-light/xfwm4/close-active.xpm
share/themes/Lila-light/xfwm4/close-inactive.xpm
share/themes/Lila-light/xfwm4/close-pressed.xpm
share/themes/Lila-light/xfwm4/hide-active.xpm
share/themes/Lila-light/xfwm4/hide-inactive.xpm
share/themes/Lila-light/xfwm4/hide-pressed.xpm
share/themes/Lila-light/xfwm4/left-active.xpm
share/themes/Lila-light/xfwm4/left-inactive.xpm
share/themes/Lila-light/xfwm4/maximize-active.xpm
share/themes/Lila-light/xfwm4/maximize-inactive.xpm
share/themes/Lila-light/xfwm4/maximize-pressed.xpm
share/themes/Lila-light/xfwm4/maximize-toggled-active.xpm
share/themes/Lila-light/xfwm4/maximize-toggled-inactive.xpm
share/themes/Lila-light/xfwm4/maximize-toggled-pressed.xpm
share/themes/Lila-light/xfwm4/menu-active.xpm
share/themes/Lila-light/xfwm4/menu-inactive.xpm
share/themes/Lila-light/xfwm4/menu-pressed.xpm
share/themes/Lila-light/xfwm4/right-active.xpm
share/themes/Lila-light/xfwm4/right-inactive.xpm
share/themes/Lila-light/xfwm4/themerc
share/themes/Lila-light/xfwm4/title-1-active.xpm
share/themes/Lila-light/xfwm4/title-1-inactive.xpm
share/themes/Lila-light/xfwm4/title-2-active.xpm
share/themes/Lila-light/xfwm4/title-2-inactive.xpm
share/themes/Lila-light/xfwm4/title-3-active.xpm
share/themes/Lila-light/xfwm4/title-3-inactive.xpm
share/themes/Lila-light/xfwm4/title-4-active.xpm
share/themes/Lila-light/xfwm4/title-4-inactive.xpm
share/themes/Lila-light/xfwm4/title-5-active.xpm
share/themes/Lila-light/xfwm4/title-5-inactive.xpm
share/themes/Lila-light/xfwm4/top-left-active.xpm
share/themes/Lila-light/xfwm4/top-left-inactive.xpm
share/themes/Lila-light/xfwm4/top-right-active.xpm
share/themes/Lila-light/xfwm4/top-right-inactive.xpm
@dirrm share/themes/Lila-light/xfwm4
@dirrmtry share/themes/Lila-light
@dirrm share/themes/Lila/xfwm4
@dirrmtry share/themes/Lila
@dirrmtry share/themes