new port of SpiralLoops 0.0.1, an experimental loop-based sampler

PR:	24522
This commit is contained in:
Trevor Johnson 2001-03-24 02:54:49 +00:00
parent 9ba9c792a9
commit e8a23d8c76
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=40304
6 changed files with 54 additions and 37 deletions

View File

@ -1,34 +1,45 @@
# New ports collection makefile for: spiralsynth
# Date created: 2000-09-05
# Whom: Trevor Johnson <trevor@jpj.net>
# New ports collection makefile for: spiralloops
# Date created: 2000-12-06
# Whom: trevor
#
# $FreeBSD$
#
PORTNAME= spiralsynth
PORTVERSION= 0.1.7
PORTNAME= spiralloops
PORTVERSION= 0.0.1
CATEGORIES= audio
MASTER_SITES= http://www.pawfal.org/SpiralSynth/dload/
DISTNAME= SpiralSynth-${PORTVERSION}
MASTER_SITES= http://www.pawfal.org/SpiralLoops/dload/
DISTNAME= SpiralLoops-${PORTVERSION}
MAINTAINER= trevor@FreeBSD.org
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
USE_X_PREFIX= yes
DOCDIR= share/doc/${PORTNAME}
DOC_FILES= CHANGES COPYING README
GNU_CONFIGURE= yes
PLIST= ${WRKDIR}/pkg-plist
USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
DOC_FILES= CHANGES COPYING README
pre-patch:
${PERL} -pi -e "s:-ldl::g" ${WRKSRC}/Makefile.in
pre-install:
${ECHO} bin/SpiralLoops > ${PLIST}
.if !defined(NOPORTDOCS)
.for i in ${DOC_FILES}
${ECHO} ${DOCDIR}/`${BASENAME} ${i}` >> ${PLIST}
.endfor
${ECHO} @dirrm ${DOCDIR} >> ${PLIST}
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/SpiralSynth ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/SpiralLoops ${PREFIX}/bin
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/spiralsynth
${MKDIR} ${PREFIX}/${DOCDIR}
.for i in ${DOC_FILES}
${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/doc/spiralsynth
${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/${DOCDIR}
.endfor
.endif
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (SpiralSynth-0.1.7.tar.gz) = fe41794cd35bd6f05d163a3c5c61bc4b
MD5 (SpiralLoops-0.0.1.tar.gz) = ecfe2b8181773b569be0bb620e2f87de

View File

@ -0,0 +1,13 @@
SpiralLoops.C:196: assignment to `char *' from `const char *' discards qualifiers
--- SpiralLoops.h.orig Sun Nov 26 07:53:44 2000
+++ SpiralLoops.h Wed Dec 6 21:55:54 2000
@@ -85,7 +85,7 @@
short *(*Run)(void);
void (*Destroy)(void);
void *handle;
- char *error;
+ const char *error;
short *m_PluginBuffer;
bool m_PluginOpen;
bool m_PluginLinked;

View File

@ -1 +1 @@
MIDI-capable synthesizer for X
Loop-based sampler

View File

@ -1,23 +1,21 @@
adapted from the Web page and the README:
from the Web page:
Spiral Synth is a physically modelled, monophonic, analogue
synthesizer. It is capable of creating the kind of sounds made by
hardware analogue synths, the noises used in electronic music.
You can also use it to make stranger sounds. MIDI is supported,
including velocity detection, mapped to the volume of the oscillators
(but you can also use the PC keyboard to play the synth). Output
is to /dev/dsp or in Microsoft RIFF (.WAV) format to a file. You
can save and recall your sounds using the 100 patch save slots.
SpiralLoops is an experimental loop-based sampler for Linux or
FreeBSD.
The PC keyboard can be used to play the synth, "q" & "z" are C,
and the keys progress from them: "2" is C#, "w" is D, etc. These
are just the defaults, and can be changed from the .Spiralrc file.
The function keys change the octave.
The idea of SpiralLoops is to provide a simple, visual tool for
looping and layering of sounds; which can be sourced from either wav
files on disk, or from sound-generating plugins.
Sample output and a detailed list of features can be found on the
home page.
SpiralLoops allows you to create loop based compositions with the
minimum feedback time between the decisions you make and your ears.
The looping mechanism is very flexible, you can lock the timing of
loops together, or offset them for creating complex sequences, such as
polyrhythms.
WWW: http://www.pawfal.org/SpiralSynth/
Instructions for using the program are on its home page.
WWW: http://www.pawfal.org/SpiralLoops/
Trevor Johnson
trevor@FreeBSD.org

View File

@ -1,5 +0,0 @@
bin/SpiralSynth
share/doc/spiralsynth/CHANGES
share/doc/spiralsynth/COPYING
share/doc/spiralsynth/README
@dirrm share/doc/spiralsynth