- Fix build with clang

- Add LICENSE

PR:		ports/185697
Submitted by:	KATO Tsuguru
This commit is contained in:
Antoine Brodin 2014-01-14 21:09:27 +00:00
parent 6c23bbf50a
commit e89e1e4f3d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=339718
2 changed files with 12 additions and 2 deletions

View File

@ -7,10 +7,11 @@ CATEGORIES= net
MASTER_SITES= SF/libsocket/${PORTNAME}-stable/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A C++ wrapper library to the sockets
COMMENT= C++ wrapper library to the sockets
LICENSE= LGPL21 # (or later)
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
.include <bsd.port.mk>

View File

@ -1,5 +1,14 @@
--- src/tcpservertest.cpp.orig 2012-12-03 14:28:35.000000000 +0100
+++ src/tcpservertest.cpp 2012-12-03 14:28:46.000000000 +0100
@@ -22,7 +22,7 @@
#include <stdio.h>
#include <stdlib.h>
-#include <iostream.h>
+#include <iostream>
#include <unistd.h>
#include <sys/wait.h>
#include <sys/types.h>
@@ -30,6 +30,7 @@
#include "tcpsocket.h"