Add upstream patch to fix build with !gcc
Submitted by: Raphael Kubo da Costa via area51
This commit is contained in:
parent
2b3a95fed8
commit
e80845eff2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=276007
13
x11/qimageblitz/files/patch-blitz-CMakeLists.txt
Normal file
13
x11/qimageblitz/files/patch-blitz-CMakeLists.txt
Normal file
@ -0,0 +1,13 @@
|
||||
Index: blitz/CMakeLists.txt
|
||||
===================================================================
|
||||
--- blitz/CMakeLists.txt (revision 1203425)
|
||||
+++ blitz/CMakeLists.txt (revision 1203426)
|
||||
@@ -33,7 +33,7 @@
|
||||
if(NOT APPLE AND NOT WIN32)
|
||||
set( blitz_LIB_SRCS ${blitz_LIB_SRCS} asm_scale.S )
|
||||
add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/asm_scale.o
|
||||
- COMMAND gcc -c ${CMAKE_CURRENT_SOURCE_DIR}/asm_scale.S
|
||||
+ COMMAND ${CMAKE_C_COMPILER} -c ${CMAKE_CURRENT_SOURCE_DIR}/asm_scale.S
|
||||
DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/asm_scale.S )
|
||||
set( blitz_LIB_EXTRA_SRCS ${CMAKE_CURRENT_BINARY_DIR}/asm_scale.o )
|
||||
set(HAVE_EXTERNAL_ASM TRUE)
|
Loading…
Reference in New Issue
Block a user