- New port: games/pingus

Pingus is a free Lemmings-like game covered under the GNU GPL. It features
currently 22 playable levels and runs under a wide variety of operating systems
(FreeBSD, Linux, Windows, etc.)

WWW:    http://pingus.seul.org/
This commit is contained in:
Jose Alonso Cardenas Marquez 2007-10-06 06:42:55 +00:00
parent ef978159f3
commit e8073f33bc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=200978
7 changed files with 91 additions and 0 deletions

View File

@ -559,6 +559,7 @@
SUBDIR += phpua-ut
SUBDIR += phpua-ut2003
SUBDIR += pinball
SUBDIR += pingus
SUBDIR += pioneers
SUBDIR += pipenightdreams
SUBDIR += pipepanic

46
games/pingus/Makefile Normal file
View File

@ -0,0 +1,46 @@
# New ports collection makefile for: pingus
# Date created: 2007-10-05
# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= pingus
PORTVERSION= 0.7.1
CATEGORIES= games
MASTER_SITES= http://pingus.seul.org/files/
MAINTAINER= acm@FreeBSD.org
COMMENT= Free Lemmings-like game
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
boost_regex.4:${PORTSDIR}/devel/boost \
physfs-1.0.1:${PORTSDIR}/devel/physfs
USE_BZIP2= yes
USE_ICONV= yes
USE_SCONS= yes
USE_SDL= sdl image mixer
PLIST= ${WRKDIR}/pkg-plist
SUB_FILES= pkg-message
pre-install:
@${RM} -f ${PLIST}
@${ECHO_CMD} "bin/${PORTNAME}" >> ${PLIST}
@cd ${WRKSRC}/data && \
${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/|' >> ${PLIST} && \
${FIND} * -type d | ${SORT} -r | ${SED} -e 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
@${ECHO_CMD} "@dirrm %%DATADIR%%" >> ${PLIST}
do-install:
@${MKDIR} ${DATADIR}
@cd ${WRKSRC}/data && \
${FIND} * -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

3
games/pingus/distinfo Normal file
View File

@ -0,0 +1,3 @@
MD5 (pingus-0.7.1.tar.bz2) = b4fcf66d0dc5e1d6148447988f87d3b1
SHA256 (pingus-0.7.1.tar.bz2) = 90772f82bc1b9655541feb6471573fcbe375a633a858fcf5798ad8160ae89fb5
SIZE (pingus-0.7.1.tar.bz2) = 10648862

View File

@ -0,0 +1,13 @@
--- SConstruct.orig 2007-10-05 10:46:32.000000000 -0500
+++ SConstruct 2007-10-05 11:09:38.000000000 -0500
@@ -337,7 +337,9 @@
if os.environ.has_key('PKG_CONFIG_PATH'):
env['ENV']['PKG_CONFIG_PATH'] = os.environ['PKG_CONFIG_PATH']
- env['CPPPATH'] += ['.', 'src/']
+
+ env['CPPPATH'] = Split(env['CPPPATH'])
+ env['LIBPATH'] = Split(env['LIBPATH'])
config_h_defines = []

View File

@ -0,0 +1,11 @@
--- src/tinygettext/iconv.cpp 2007-10-05 11:17:23.000000000 -0500
+++ src/tinygettext/iconv.cpp 2007-10-05 11:17:35.000000000 -0500
@@ -78,7 +78,7 @@
size_t in_size = text.size();
size_t out_size = 4*in_size; // Worst case scenario: ASCII -> UTF-32?
std::string result(out_size, ' ');
- ICONV_CONST char* in_str = &text[0];
+ const char* in_str = &text[0];
char* out_str = &result[0];
// Try to convert the text.

View File

@ -0,0 +1,12 @@
###############################################################################
The Pingus game was installed
1) Use the --datadir option to the correct path of pingus data
# pingus --datadir %%DATADIR%%
2) Enjoy it
###############################################################################

5
games/pingus/pkg-descr Normal file
View File

@ -0,0 +1,5 @@
Pingus is a free Lemmings-like game covered under the GNU GPL. It features
currently 22 playable levels and runs under a wide variety of operating systems
(FreeBSD, Linux, Windows, etc.)
WWW: http://pingus.seul.org/