- Update to 4.55

- Reorganize Makefile
- portlint(1)

PR:		95976
Submitted by:	maintainer
This commit is contained in:
Marcus Alves Grando 2006-04-18 14:38:28 +00:00
parent cfb09f297f
commit e7f99dda8d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=159880
4 changed files with 48 additions and 27 deletions

View File

@ -6,24 +6,26 @@
#
PORTNAME= ipplan
PORTVERSION= 4.51
PORTVERSION= 4.55
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= iptrack
DISTNAME= ${PORTNAME}-4.51
DISTNAME= ${PORTNAME}-4.55
MAINTAINER= mt@primats.org.ua
COMMENT= IP address management and tracking
USE_REINPLACE= yes
RUN_DEPENDS= nmap:${PORTSDIR}/security/nmap
USE_PERL5_RUN= yes
USE_PHP= gettext pcre xml zlib
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
IPPLANDIR?= share/${PORTNAME}
PKGMESSAGE= ${WRKDIR}/pkg-message
PLIST_SUB= IPPLANDIR=${IPPLANDIR}
USE_PHP= gettext pcre xml zlib
.if !defined(WITHOUT_MYSQL)
USE_PHP+= mysql
.endif
@ -36,21 +38,30 @@ USE_PHP+= pgsql
USE_PHP+= snmp
.endif
.include <bsd.port.pre.mk>
post-patch:
@${SED} -e 's|%IPPLANDIR%|${PREFIX}/${IPPLANDIR}|g' ${MASTERDIR}/pkg-message > ${PKGMESSAGE}
.if defined(WITH_PGSQL)
@${REINPLACE_CMD} -e 's|INSTALL|INSTALL-POSTGRESQL|g' ${PKGMESSAGE}
.endif
@${REINPLACE_CMD} -e "s|/usr/bin/perl|${PERL}|" \
-e "s|/usr/bin/xsltproc|${LOCALBASE}/bin/xsltproc|" \
${WRKSRC}/contrib/process-exports.pl
@${REINPLACE_CMD} -e "s|/usr/local/bin/php|${LOCALBASE}/bin/php|" \
${WRKSRC}/contrib/ipplan-poller.php
@${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|" \
${WRKSRC}/config.php
@${FIND} ${WRKSRC} -name '*.orig' -delete -o -name '*.bak' -delete
do-install:
@${MKDIR} ${PREFIX}/${IPPLANDIR}
@${CP} -R ${WRKSRC}/* ${PREFIX}/${IPPLANDIR}
@${FIND} ${PREFIX}/${IPPLANDIR} -name '*.orig' -delete
@${CAT} ${PKGMESSAGE}
post-install:
@${MKDIR} -m 700 /var/spool/ipplan/uploads \
/var/spool/ipplan/exportdns
@${CHOWN} -R www:www /var/spool/ipplan
@${SED} -e 's|%IPPLANDIR%|${PREFIX}/${IPPLANDIR}|g' ${MASTERDIR}/pkg-message > ${PKGMESSAGE}
.if defined(WITH_PGSQL)
@${REINPLACE_CMD} -e 's|INSTALL|INSTALL-POSTGRESQL|g' ${PKGMESSAGE}
.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (ipplan-4.51.tar.gz) = 9d45303d7dd85f4bb560f43d891b4b56
SHA256 (ipplan-4.51.tar.gz) = 3cbea32b656a6cc561abd81aed9279a1ada7859d2e66a1df0c9fd172aa00c650
SIZE (ipplan-4.51.tar.gz) = 1307160
MD5 (ipplan-4.55.tar.gz) = 3e8d140584bf908c0be53ca03bf6f5b0
SHA256 (ipplan-4.55.tar.gz) = e8c8d391b6ddcf0e6f48e972500f9f05f17ace20111f1966ac9c804e95d7a644
SIZE (ipplan-4.55.tar.gz) = 1333149

View File

@ -1,29 +1,38 @@
--- config.php.orig Sun Jun 5 09:53:19 2005
+++ config.php Fri Jun 10 15:28:16 2005
--- config.php.orig Thu Mar 16 22:16:54 2006
+++ config.php Tue Apr 18 03:56:19 2006
@@ -96,7 +96,7 @@
// see either httpd.conf User directive or ps -ef to see which user
// apache runs under, then set mode 700 on directory and change owner
// to this user
-define("UPLOADDIRECTORY", "/var/spool/ipplanuploads");
+define("UPLOADDIRECTORY", "/var/spool/ipplan/uploads");
-define("UPLOADDIRECTORY", '/var/spool/ipplanuploads');
+define("UPLOADDIRECTORY", '/var/spool/ipplan/uploads');
// default country code ("" for none)
define("DEFAULTCOUNTRY", "US");
@@ -109,7 +109,7 @@
// not work if php is running in safemode. probing and scanning may
// also be against policy for your site!
//define("NMAP", "");
-define("NMAP", "/usr/bin/nmap");
+define("NMAP", "/usr/local/bin/nmap");
//define("NMAP", '');
-define("NMAP", '/usr/bin/nmap');
+define("NMAP", '%%LOCALBASE%%/bin/nmap');
//-------------------------START OF REGISTRAR---------------------------
@@ -152,7 +152,7 @@
// helpdesk email address
define("HELPDESKEMAIL", "helpdesk@mydomain.com");
@@ -186,7 +186,7 @@
// this will usually be the user under which Apache runs. If the
// permissions are not correct, the files will be created in the
// system temp directory, usually /tmp
-define("DNSEXPORTPATH", "/tmp/dns/");
+define("DNSEXPORTPATH", "/var/spool/ipplan/exportdns/");
-define("DNSEXPORTPATH", '/tmp/dns/');
+define("DNSEXPORTPATH", '/var/spool/ipplan/dnsexport/');
// dnsslaveonly is the default setting for when creating new zones. If your
// dns server only serves as a slave for most of your zones, it's helpful
@@ -202,7 +202,7 @@
// export path where DHCP files in XML format will be output ready for
// transformation into DHCP file for various DHCP servers
-define("DHCPEXPORTPATH", '/tmp/dhcp/');
+define("DHCPEXPORTPATH", '/var/spool/ipplan/dncpexport/');
// This string identifies ip addresses that belong in the DHCP pool
define("DHCPRESERVED", "Reserved - DHCP pool");

View File

@ -529,6 +529,7 @@
%%IPPLANDIR%%/user/searchallform.php
%%IPPLANDIR%%/user/swiplib.php
%%IPPLANDIR%%/user/traceroute.php
%%IPPLANDIR%%/user/treeview.php
%%IPPLANDIR%%/user/whois.php
%%IPPLANDIR%%/xmllib.php
@dirrm %%IPPLANDIR%%/user/Net/DNS/RR