- Add OPTION to mkae it work with non-utf-8 locales,
- Add translation for russian language. - Add pkg-message tip for users with problem 'english only dialogues'. - Add working mirror for distfile. PR: ports/123301 Submitted by: Yarodin <yarodin@gmail.com>
This commit is contained in:
parent
db4fdfd1ef
commit
e7e239d19a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=212711
@ -7,8 +7,10 @@
|
||||
|
||||
PORTNAME= kgtk
|
||||
PORTVERSION= 0.9.4
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= sysutils kde
|
||||
MASTER_SITES= http://home.freeuk.com/cpdrummond/
|
||||
MASTER_SITES= http://source.antisupport.com/kgtk/ \
|
||||
http://home.freeuk.com/cpdrummond/
|
||||
DISTNAME= KGtk-${PORTVERSION}
|
||||
|
||||
MAINTAINER= citycat4@ngs.ru
|
||||
@ -16,6 +18,10 @@ COMMENT= Daemon to use KDE dialogs in GTK applications
|
||||
|
||||
BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
|
||||
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
OPTIONS= UNICODE "System locale is utf-8" off
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gtk20
|
||||
@ -26,6 +32,10 @@ CMAKE_BUILD_DIR=build3
|
||||
BUILD_WRKSRC= ${WRKSRC}/${CMAKE_BUILD_DIR}
|
||||
INSTALL_WRKSRC= ${WRKSRC}/${CMAKE_BUILD_DIR}
|
||||
|
||||
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITHOUT_NLS)
|
||||
PLIST_SUB+= NLS="@comment "
|
||||
.else
|
||||
@ -33,10 +43,14 @@ USE_GETTEXT= yes
|
||||
PLIST_SUB+= NLS=""
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_UNICODE)
|
||||
EXTRA_PATCHES+= ${PATCHDIR}/opt-patch-gtk2__kgtk2-wrapper.cmake
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's| -ldl||' ${WRKSRC}/gtk2/CMakeLists.txt ${WRKSRC}/qt3/CMakeLists.txt ${WRKSRC}/qt4/CMakeLists.txt
|
||||
@${REINPLACE_CMD} -e 's|#!/bin/bash|#!/bin/sh|' ${WRKSRC}/mangled.sh
|
||||
|
||||
@${CP} ${PATCHDIR}/ru.po ${WRKSRC}/kdialogd3/po/
|
||||
pre-configure:
|
||||
@${MKDIR} ${WRKSRC}/${CMAKE_BUILD_DIR}
|
||||
|
||||
@ -49,4 +63,6 @@ do-configure:
|
||||
-DCMAKE_EXE_LINKER_FLAGS=${PTHREAD_LIBS} \
|
||||
-DCMAKE_INSTALL_PREFIX=${PREFIX}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
.include <bsd.port.post.mk>
|
||||
|
10
sysutils/kgtk/files/opt-patch-gtk2__kgtk2-wrapper.cmake
Normal file
10
sysutils/kgtk/files/opt-patch-gtk2__kgtk2-wrapper.cmake
Normal file
@ -0,0 +1,10 @@
|
||||
--- ./gtk2/kgtk2-wrapper.cmake.orig 2007-10-31 22:33:19.000000000 +0200
|
||||
+++ ./gtk2/kgtk2-wrapper.cmake 2008-05-04 22:49:28.000000000 +0300
|
||||
@@ -11,6 +11,7 @@
|
||||
# Released under the GPL v2 or later
|
||||
# --
|
||||
#
|
||||
+export G_BROKEN_FILENAMES=1
|
||||
|
||||
app=`basename $0`
|
||||
|
10
sysutils/kgtk/files/patch-kgtk-wrapper
Normal file
10
sysutils/kgtk/files/patch-kgtk-wrapper
Normal file
@ -0,0 +1,10 @@
|
||||
--- ./kgtk-wrapper.orig 2007-10-31 22:33:19.000000000 +0200
|
||||
+++ ./kgtk-wrapper 2008-05-04 22:49:28.000000000 +0300
|
||||
@@ -14,6 +14,7 @@
|
||||
# This script attempts to determine which KGtk library (if any) should
|
||||
# be used when launching the app
|
||||
#
|
||||
+export G_BROKEN_FILENAMES=1
|
||||
|
||||
app=`basename $0`
|
||||
useApp=1
|
6
sysutils/kgtk/files/pkg-message.in
Normal file
6
sysutils/kgtk/files/pkg-message.in
Normal file
@ -0,0 +1,6 @@
|
||||
--------------------------------------------------------------------------
|
||||
|
||||
If you get KDE dialogues partially translated to your local language,
|
||||
then use correct kgtk wrapper 'kgtk2-wrapper' to start gtk applications.
|
||||
|
||||
--------------------------------------------------------------------------
|
62
sysutils/kgtk/files/ru.po
Normal file
62
sysutils/kgtk/files/ru.po
Normal file
@ -0,0 +1,62 @@
|
||||
# translation of ru.po to
|
||||
# This file is put in the public domain.
|
||||
#
|
||||
# Yarodin <yarodin@gmail.com>, 2008.
|
||||
msgid ""
|
||||
msgstr ""
|
||||
"Project-Id-Version: kdialogd3\n"
|
||||
"Report-Msgid-Bugs-To: \n"
|
||||
"POT-Creation-Date: 2007-09-21 14:40+0100\n"
|
||||
"PO-Revision-Date: 2008-05-01 19:31+0600\n"
|
||||
"Last-Translator: Yarodin <yarodin@gmail.com>\n"
|
||||
"Language-Team: Russian <kde-i18n-ru@kde.org>\n"
|
||||
"MIME-Version: 1.0\n"
|
||||
"Content-Type: text/plain; charset=UTF-8\n"
|
||||
"Content-Transfer-Encoding: 8bit\n"
|
||||
"X-Generator: KBabel 1.11.4\n"
|
||||
"Plural-Forms: nplurals=2; plural=n != 1;\n"
|
||||
|
||||
#: kdialogd.cpp:328
|
||||
msgid "Select Folder"
|
||||
msgstr "Выбор папки"
|
||||
|
||||
#: kdialogd.cpp:573
|
||||
msgid "You can only select local files."
|
||||
msgstr "Вы можете выбрать только локальные файлы."
|
||||
|
||||
#: kdialogd.cpp:574
|
||||
msgid "Remote Files Not Accepted"
|
||||
msgstr "Файлы на удаленной машине недоступны"
|
||||
|
||||
#: kdialogd.cpp:580
|
||||
msgid ""
|
||||
"File %1 exits.\n"
|
||||
"Do you want to replace it?"
|
||||
msgstr ""
|
||||
"Файл %1 уже существует.\n"
|
||||
"Хотите его перезаписать?"
|
||||
|
||||
#: kdialogd.cpp:582
|
||||
msgid "File Exists"
|
||||
msgstr "Файл существует"
|
||||
|
||||
#: kdialogd.cpp:667
|
||||
msgid "You can only select local folders."
|
||||
msgstr "Вы можете выбрать только локальные папки."
|
||||
|
||||
#: kdialogd.cpp:668
|
||||
msgid "Remote Folders Not Accepted"
|
||||
msgstr "Сетевые папки недоступны."
|
||||
|
||||
#: kdialogd.cpp:677
|
||||
msgid "KDialog Daemon"
|
||||
msgstr "KDialog-Демон"
|
||||
|
||||
#: kdialogd.cpp:678
|
||||
msgid "Use KDE dialogs from non-KDE apps."
|
||||
msgstr "Использование KDE диалогов в Не-KDE приложениях."
|
||||
|
||||
#: kdialogd.cpp:680
|
||||
msgid "(c) Craig Drummond, 2006-2007"
|
||||
msgstr "(c) Craig Drummond, 2006-2007"
|
||||
|
@ -9,6 +9,7 @@ lib/kgtk/libkqt3.so
|
||||
%%NLS%%share/locale/de/LC_MESSAGES/kdialogd3.mo
|
||||
%%NLS%%share/locale/es/LC_MESSAGES/kdialogd3.mo
|
||||
%%NLS%%share/locale/fr/LC_MESSAGES/kdialogd3.mo
|
||||
%%NLS%%share/locale/ru/LC_MESSAGES/kdialogd3.mo
|
||||
%%NLS%%share/locale/en_GB/LC_MESSAGES/kdialogd3.mo
|
||||
%%NLS%%share/locale/zh_CN/LC_MESSAGES/kdialogd3.mo
|
||||
@dirrm lib/kgtk
|
||||
|
Loading…
Reference in New Issue
Block a user