astro/wmsun: "Update" to 1.05 and return to official upstream repository

While I'm here:
* Add license information
* Sort variables a bit according to the PHB

This was initially a small patch that was meant to update the MASTER_SITES
and the WWW field. [1] On further research it came to light that the
previous version of astro/wmsun was a fork whose upstream sources are now
gone.

In the meantime there have been some recent activities regarding Window
Maker dockapps and many of those programs were collected, updated and are
maintained by the current Window Maker developers.

Therefore the intial patch has been extended a bit to point to the new
upstream location instead of using a semi-official location that could
vanish in near future. [2]

At last but not least: The program was renamed from "wmSun" to "wmsun" so
there's a bit more churn than usual.

https://github.com/window-maker/dockapps/blob/master/wmsun/ChangeLog

PR:		235526
Submitted by:	Marco Beishuzen (maintainer) [1]
Approved by:	tcberner (mentor), maintainer [2]
Differential Revision:	https://reviews.freebsd.org/D19136
This commit is contained in:
Kai Knoblich 2019-04-14 12:40:56 +00:00
parent 37756c7f1f
commit e78b938367
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=498902
6 changed files with 48 additions and 32 deletions

View File

@ -2,25 +2,30 @@
# $FreeBSD$
PORTNAME= wmsun
PORTVERSION= 1.12
PORTVERSION= 1.05
PORTEPOCH= 1
CATEGORIES= astro windowmaker
MASTER_SITES= http://linux-bsd-unix.strefa.pl/
DISTNAME= wmSun-${PORTVERSION}
MASTER_SITES= https://www.dockapps.net/download/
MAINTAINER= mbeis@xs4all.nl
COMMENT= Dockapp that displays the rise and set times of the Sun
WRKSRC_SUBDIR= wmSun
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libdockapp.so:x11-wm/libdockapp
USE_XORG= xext xpm x11
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" \
INCDIR="-I${LOCALBASE}/include" LIBDIR="-L${LOCALBASE}/lib"
MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/wmSun man/man1/wmSun.1.gz
PLIST_FILES= bin/wmsun man/man1/wmsun.1.gz
WRKSRC= ${WRKDIR}/dockapps-a1e67bd
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmSun ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/wmSun.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
${INSTALL_PROGRAM} ${WRKSRC}/wmsun ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/wmsun.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.include <bsd.port.mk>

View File

@ -1,2 +1,3 @@
SHA256 (wmSun-1.12.tar.gz) = d05fb019dd835fc33b2c7c3fb7cf1b6a8cd7fe59b62c8d3fa00ddd0f776da15d
SIZE (wmSun-1.12.tar.gz) = 147170
TIMESTAMP = 1549747586
SHA256 (wmsun-1.05.tar.gz) = 29c7d2da4c0731a20955af9ba01bde3901dc269bfa1020ff707927c62d5b83a0
SIZE (wmsun-1.05.tar.gz) = 20640

View File

@ -1,17 +1,19 @@
--- Makefile.orig 2015-04-01 21:05:45 UTC
--- Makefile.orig 2015-08-28 11:57:39 UTC
+++ Makefile
@@ -18,12 +18,12 @@ LIBS = -lXpm -lX11 -lXext -lm
OBJS = wmSun.o SunRise.o ../wmgeneral/wmgeneral.o
@@ -19,14 +19,14 @@ LIBS = -lXpm -lX11 -lXext -lm -ldockapp
OBJS = wmsun.o SunRise.o
.c.o:
- $(CC) $(COPTS) -D$(shell echo `uname -s`) -c $< -o $*.o $(INCDIR)
+ $(CC) $(CFLAGS) -D$(OPSYS) -c $< -o $@ $(INCDIR)
- $(CC) $(CPPFLAGS) $(CFLAGS) -c $< -o $*.o
+ $(CC) $(CPPFLAGS) $(CFLAGS) -c $< -o $@ $(INCDIR)
all: wmSun.o wmSun
all: wmsun.o wmsun
wmSun: $(OBJS)
- $(CC) $(COPTS) $(SYSTEM) -o wmSun $^ $(INCDIR) $(LIBDIR) $(LIBS)
+ $(CC) $(CFLAGS) $(SYSTEM) -o wmSun $(OBJS) $(LIBDIR) $(LIBS)
wmsun.o: wmSun_master.xpm wmSun_mask.xbm
wmsun: $(OBJS)
- $(CC) $(LDFLAGS) -o wmsun $^ $(LIBS)
+ $(CC) $(LDFLAGS) -o wmsun $(OBJS) $(LIBDIR) $(LIBS)
clean:
for i in $(OBJS) ; do rm -f $$i; done
for i in $(OBJS) ; do \

View File

@ -1,12 +0,0 @@
--- wmSun.c.orig 2015-04-01 21:07:58 UTC
+++ wmSun.c
@@ -76,7 +76,8 @@ int main(int argc, char *argv[]) {
int LocalDayOfMonth, DayOfMonth;
int Hours, Mins, Secs, OldSecs, digit, xoff, xsize;
int OldMins;
- long CurrentLocalTime, CurrentGMTTime, date;
+ time_t CurrentLocalTime, CurrentGMTTime;
+ long date;
double UT, val, RA, DEC, LTRise, LTSet, LocalHour, hour24();
int D, H, M, S, sgn, A, B, q;
char str[10];

View File

@ -0,0 +1,20 @@
--- wmsun.c.orig 2015-08-28 11:57:39 UTC
+++ wmsun.c
@@ -43,7 +43,6 @@
/*
* Includes
*/
-#define _POSIX_C_SOURCE 1
#include <X11/X.h> /* for ButtonPress, ButtonRelease, etc */
#include <X11/Xlib.h> /* for XEvent, ConnectionNumber, etc */
#include <math.h> /* for cos, sin */
@@ -106,7 +105,8 @@ int main(int argc, char *argv[]) {
int n;
int Year, Month;
int DayOfMonth;
- long CurrentLocalTime, CurrentGMTTime, date;
+ time_t CurrentLocalTime, CurrentGMTTime;
+ long date;
double UT, val, LTRise, LTSet, LocalHour, hour24();
int H, M;
struct timeval timeout;

View File

@ -1,3 +1,3 @@
A dockapp that displays the rise and set time of the sun.
WWW: http://linux-bsd-unix.strefa.pl/
WWW: https://www.dockapps.net/wmsun/