Add x11/evtest
evtest is a tool to print evdev kernel events. It reads directly from the kernel device and prints a device description and the events with the value and the symbolic name. WWW: https://gitlab.freedesktop.org/libevdev/evtest Differential Revision: https://reviews.freebsd.org/D27190
This commit is contained in:
parent
bd0e2549e3
commit
e75fa619c7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=554961
@ -60,6 +60,7 @@
|
||||
SUBDIR += erun
|
||||
SUBDIR += eterm
|
||||
SUBDIR += evilvte
|
||||
SUBDIR += evtest
|
||||
SUBDIR += fbdesk
|
||||
SUBDIR += fbpanel
|
||||
SUBDIR += find-cursor
|
||||
|
32
x11/evtest/Makefile
Normal file
32
x11/evtest/Makefile
Normal file
@ -0,0 +1,32 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= evtest
|
||||
DISTVERSIONPREFIX= ${PORTNAME}-
|
||||
DISTVERSION= 1.34
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= https://gitlab.freedesktop.org/libevdev/${PORTNAME}/-/archive/${PORTNAME}-${DISTVERSION}/
|
||||
|
||||
MAINTAINER= 0mp@FreeBSD.org
|
||||
COMMENT= Input device event monitor and query tool
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto
|
||||
LIB_DEPENDS= libevdev.so:devel/libevdev
|
||||
|
||||
USES= autoreconf localbase
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
CFLAGS+= -DPACKAGE_VERSION=${PKGVERSION}
|
||||
|
||||
PLIST_FILES= bin/evtest
|
||||
|
||||
OPTIONS_DEFINE= MANPAGES
|
||||
OPTIONS_DEFAULT= MANPAGES
|
||||
|
||||
MANPAGES_BUILD_DEPENDS= asciidoc:textproc/asciidoc \
|
||||
xmlto:textproc/xmlto
|
||||
MANPAGES_PLIST_FILES= man/man1/evtest.1.gz
|
||||
|
||||
.include <bsd.port.mk>
|
3
x11/evtest/distinfo
Normal file
3
x11/evtest/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1605183618
|
||||
SHA256 (evtest-evtest-1.34.tar.gz) = 0e7a2eeff380af796e5e9b21b6f48fd706c58c931162c151c2c1074bdfeb85c6
|
||||
SIZE (evtest-evtest-1.34.tar.gz) = 19954
|
44
x11/evtest/files/patch-evtest.c
Normal file
44
x11/evtest/files/patch-evtest.c
Normal file
@ -0,0 +1,44 @@
|
||||
--- evtest.c.orig 2019-08-02 18:14:30 UTC
|
||||
+++ evtest.c
|
||||
@@ -43,7 +43,7 @@
|
||||
#include <config.h>
|
||||
#endif
|
||||
|
||||
-#include <linux/version.h>
|
||||
+#include <sys/syslimits.h>
|
||||
#include <linux/input.h>
|
||||
|
||||
#include <string.h>
|
||||
@@ -875,7 +875,7 @@ static char* scan_devices(void)
|
||||
char *filename;
|
||||
int max_device = 0;
|
||||
|
||||
- ndev = scandir(DEV_INPUT_EVENT, &namelist, is_event_device, versionsort);
|
||||
+ ndev = scandir(DEV_INPUT_EVENT, &namelist, is_event_device, alphasort);
|
||||
if (ndev <= 0)
|
||||
return NULL;
|
||||
|
||||
@@ -923,7 +923,7 @@ static int version(void)
|
||||
#ifndef PACKAGE_VERSION
|
||||
#define PACKAGE_VERSION "<version undefined>"
|
||||
#endif
|
||||
- printf("%s %s\n", program_invocation_short_name, PACKAGE_VERSION);
|
||||
+ printf("%s %s\n", getprogname(), PACKAGE_VERSION);
|
||||
return EXIT_SUCCESS;
|
||||
}
|
||||
|
||||
@@ -935,12 +935,12 @@ static int usage(void)
|
||||
{
|
||||
printf("USAGE:\n");
|
||||
printf(" Capture mode:\n");
|
||||
- printf(" %s [--grab] /dev/input/eventX\n", program_invocation_short_name);
|
||||
+ printf(" %s [--grab] /dev/input/eventX\n", getprogname());
|
||||
printf(" --grab grab the device for exclusive access\n");
|
||||
printf("\n");
|
||||
printf(" Query mode: (check exit code)\n");
|
||||
printf(" %s --query /dev/input/eventX <type> <value>\n",
|
||||
- program_invocation_short_name);
|
||||
+ getprogname());
|
||||
|
||||
printf("\n");
|
||||
printf("<type> is one of: EV_KEY, EV_SW, EV_LED, EV_SND\n");
|
5
x11/evtest/pkg-descr
Normal file
5
x11/evtest/pkg-descr
Normal file
@ -0,0 +1,5 @@
|
||||
evtest is a tool to print evdev kernel events. It reads directly from the
|
||||
kernel device and prints a device description and the events with the value
|
||||
and the symbolic name.
|
||||
|
||||
WWW: https://gitlab.freedesktop.org/libevdev/evtest
|
Loading…
Reference in New Issue
Block a user