Fix build with -fno-common

While here add license, make Makefile better match current standards, and
regenerate patch files (i.e. make portlint happy).
This commit is contained in:
Stefan Eßer 2020-09-22 10:57:34 +00:00
parent b2c27e0dc5
commit e74372b1ef
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=549571
6 changed files with 40 additions and 16 deletions

View File

@ -3,20 +3,23 @@
PORTNAME= pnm2ppa
PORTVERSION= 1.13
PORTREVISION= 4
PORTREVISION= 5
CATEGORIES= print
MASTER_SITES= SF
MAINTAINER= 000.fbsd@quip.cz
COMMENT= Convert PNM images to PPA for some HP printers
OPTIONS_DEFINE= A4SIZE
A4SIZE_DESC= Set A4 (not Letter) as a default paper size
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/docs/en/LICENSE
USES= gmake ghostscript:run
GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
OPTIONS_DEFINE= A4SIZE
A4SIZE_DESC= Set A4 (not Letter) as a default paper size
.include <bsd.port.options.mk>
.if defined(A4) || !empty(PORT_OPTIONS:MA4SIZE)
RUN_DEPENDS+= enscript:print/enscript-a4
@ -46,4 +49,4 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/pnm2ppa.1 ${STAGEDIR}${PREFIX}/man/man1
${INSTALL_DATA} ${WRKSRC}/pnm2ppa.conf.sample ${STAGEDIR}${PREFIX}/etc
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,6 +1,6 @@
--- docs/en/pnm2ppa.1.orig Mon Nov 6 10:16:38 2000
+++ docs/en/pnm2ppa.1 Tue Jan 30 22:02:49 2001
@@ -51,13 +51,13 @@
--- docs/en/pnm2ppa.1.orig 2002-06-23 05:17:58 UTC
+++ docs/en/pnm2ppa.1
@@ -60,13 +60,13 @@ Econofast mode: lower print quality that is faster and
.\"{{{ -f configFile
.IP "\fB\-f \fIconfigFile\fR\fP"
Re-reads configuration from \fIconfigFile\fR (after
@ -16,7 +16,7 @@
.\"}}}
.\"{{{ --fd
@@ -161,7 +161,7 @@
@@ -170,7 +170,7 @@ Sets the y-offset \fIyoffset\fR from the top of the pa
.SH NOTES
@ -25,7 +25,7 @@
.PP
The \fB-v\fP option resets all definitions (margins, offsets, etc.) back to
the inbuilt defaults for that printer and should be used before subsequent
@@ -171,13 +171,13 @@
@@ -180,13 +180,13 @@ pnm(5), ppm(5), pbm(5)
.SH FILES

View File

@ -0,0 +1,10 @@
--- pnm2ppa.c.orig 2009-12-12 19:14:55 UTC
+++ pnm2ppa.c
@@ -40,6 +40,7 @@
#include "gamma.h"
#include "lang.h"
+char syslog_message[128];
double Gamma_R, Gamma_G, Gamma_B;
int adjust_coloffsx, adjust_coloffsy;

View File

@ -1,5 +1,5 @@
--- pnm2ppa.conf.orig Sun Nov 10 06:47:47 2002
+++ pnm2ppa.conf Mon Nov 18 21:10:36 2002
--- pnm2ppa.conf.orig 2002-11-09 21:47:47 UTC
+++ pnm2ppa.conf
@@ -1,7 +1,7 @@
# Sample configuration file
#
@ -9,7 +9,7 @@
#
# uncomment entries by removing "#" to activate them.
#
@@ -44,7 +44,7 @@
@@ -44,7 +44,7 @@ version 0 # REMOVE THIS ENTRY to make 720 the de
log_info 1 # <= COMMENT THIS OUT TO GET THE NEW DEFAULT BEHAVIOR!
# Note: the "silent 1" and "log_info" keywords are only accepted from the
@ -18,7 +18,7 @@
# files specified by users with the pnm2ppa option "-f".
#---------set the margins of the printed page-------------------
@@ -123,7 +123,7 @@
@@ -123,7 +123,7 @@ log_info 1 # <= COMMENT THIS OUT TO GET
#------------Color correct curve Gamma parameters-------------------------
# Gamma color correction values for Red, Green and Blue:
# (Note: a more effective method of color correction is to use

View File

@ -0,0 +1,11 @@
--- ppa_syslog.h.orig 2009-12-10 19:11:17 UTC
+++ ppa_syslog.h
@@ -39,7 +39,7 @@
#include <syslog.h>
#endif
-char syslog_message[128];
+extern char syslog_message[128];
extern size_t message_size ;
void wrap_syslog( int, char *, char *);

View File

@ -1,5 +1,5 @@
--- text-en.h.orig Sat Oct 14 17:35:25 2000
+++ text-en.h Tue Jan 30 21:42:43 2001
--- text-en.h.orig 2002-02-11 15:38:30 UTC
+++ text-en.h
@@ -73,7 +73,7 @@
/* 24 */ "Verbose logging to console\n",