Update to version 1.31.0. ChangeLog since 1.30.0:

20111221 - 1.31.0

[-] * Fixed compilation with latest libusb.
[-] * Improved error handling in SQL backend of SMSD.
[-] * SMSD documentation improvements.
[-] * Indonesian translation updates.

20111213 - 1.30.92

[-] * Improved vCard parser to better handle location for various fields, thanks to Vladimir Serbinenko for initial patch.
[-] * Fixed reading calls from some Nokia phones (bug #1553).
[-] * Improved text mode SMS parsing in AT driver, thanks to Vladimir Serbinenko.
[-] * Use glib's MD5 implementation if available.

20111129 - 1.30.91

[+] * Improved documentation for configuring Gammu.
[-] * Fixed parsing birthday from vCard in some cases.
[+] * Added option not to use configured logging in SMSD inject and monitor (bug #1539).
[+] * Added SMSD configuration LogFacility (bug #1539).
[-] * Fixed reading of data from OBEX phones (LP#891803).
[-] * Fixed double reply detection (bug #1544).
[-] * Increase maximal number of caller groups (bug #1541).
[-] * Cancel all calls on maketerminated call if we don't get call ID.
[-] * Fixed SMSC handling in some cases in SMSD (bug #1547).

20111107 - 1.30.90

[-] * Various documentation improvements.
[-] * Detect Alcatel style reply on CPIN response (bug #1502).
[-] * Fix build on some Win32 systems (bug #1496).
[-] * Make jadmaker handle names with spaces (Rapha\xc3\xabl Droz).
[-] * Display 8-bit messages in hex (Nicolas Pitre).
[-] * Do not use AT+CUSD=2 on some phones (bug #1508).
[-] * Fixed gammu-monitor with Windows service (bug #1515).
[-] * Cleanup of contrib directory.
[-] * Better support for Samsung AT phones (bug #1513).
[-] * Fixed handling of MMS notification SMSes (bug #1530).
[-] * Fixed CPIN reply handling (bug #1532).
[+] * SMSD checks for PIN status just after connect (bug #1532).
[-] * Fixed various MSVC compilation issues.
This commit is contained in:
Boris Samorodov 2011-12-26 11:20:09 +00:00
parent 5608277c95
commit e7397de52a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=288047
5 changed files with 45 additions and 45 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= gammu
PORTVERSION= 1.30.0
PORTVERSION= 1.31.0
CATEGORIES= comms
MASTER_SITES= http://dl.cihar.com/gammu/releases/ \
http://dl.cihar.com.nyud.net/gammu/releases/

View File

@ -1,2 +1,2 @@
SHA256 (gammu-1.30.0.tar.gz) = 7fc29a72e3bf0a185886f4aa8bd8c1a67ac0a209a16c2606534f4e5651a6eab2
SIZE (gammu-1.30.0.tar.gz) = 8048876
SHA256 (gammu-1.31.0.tar.gz) = c6331d134384d2a6569b2fb2069d911f994dbbe632b1c8c5fa8e9c01309a41ba
SIZE (gammu-1.31.0.tar.gz) = 8123548

View File

@ -1,6 +1,6 @@
--- CMakeLists.txt.orig 2011-01-19 10:33:05.000000000 +0300
+++ CMakeLists.txt 2011-01-28 13:57:29.069544083 +0300
@@ -622,7 +622,7 @@ mark_as_advanced (INSTALL_LOC_DIR)
--- CMakeLists.txt.orig 2011-12-21 17:25:37.000000000 +0400
+++ CMakeLists.txt 2011-12-23 14:57:04.447118270 +0400
@@ -656,7 +656,7 @@ mark_as_advanced (INSTALL_DATA_DIR)
set (INSTALL_DOC_DIR "share/doc/gammu" CACHE STRING "Path for documentation installation")
mark_as_advanced (INSTALL_DOC_DIR)

View File

@ -1,5 +1,5 @@
--- libgammu/device/bluetoth/bluez.c.orig 2010-07-12 15:51:05.000000000 +0400
+++ libgammu/device/bluetoth/bluez.c 2011-01-28 13:21:17.936545967 +0300
--- libgammu/device/bluetoth/bluez.c.orig 2011-12-21 17:25:37.000000000 +0400
+++ libgammu/device/bluetoth/bluez.c 2011-12-23 15:05:14.498122134 +0400
@@ -23,6 +23,8 @@
#ifdef GSM_ENABLE_BLUETOOTHDEVICE
#ifdef BLUEZ_FOUND
@ -22,45 +22,45 @@
#include "../../gsmcomon.h"
#include "../devfunc.h"
@@ -44,7 +42,7 @@
GSM_Error bluetooth_connect(GSM_StateMachine *s, int port, char *device)
{
GSM_Device_BlueToothData *d = &s->Device.Data.BlueTooth;
- struct sockaddr_rc laddr, raddr;
+ struct sockaddr_rfcomm laddr, raddr;
bdaddr_t bdaddr;
int fd;
@@ -48,7 +46,7 @@ GSM_Error bluetooth_connect(GSM_StateMac
/* Some phones need time till they are accessible after SDP browsing */
for (tries = 0; tries < 5; tries++) {
GSM_Device_BlueToothData *d = &s->Device.Data.BlueTooth;
- struct sockaddr_rc laddr, raddr;
+ struct sockaddr_rfcomm laddr, raddr;
bdaddr_t bdaddr;
int fd;
@@ -53,15 +51,15 @@ GSM_Error bluetooth_connect(GSM_StateMac
@@ -61,15 +59,15 @@ GSM_Error bluetooth_connect(GSM_StateMac
smprintf(s, "Connecting to RF channel %i\n",port);
smprintf(s, "Connecting to RF channel %i\n", port);
- fd = socket(PF_BLUETOOTH, SOCK_STREAM, BTPROTO_RFCOMM);
+ fd = socket(PF_BLUETOOTH, SOCK_STREAM, BLUETOOTH_PROTO_RFCOMM);
if (fd < 0) {
smprintf(s, "Can't create socket\n");
return ERR_DEVICENODRIVER;
}
- fd = socket(PF_BLUETOOTH, SOCK_STREAM, BTPROTO_RFCOMM);
+ fd = socket(PF_BLUETOOTH, SOCK_STREAM, BLUETOOTH_PROTO_RFCOMM);
if (fd < 0) {
smprintf(s, "Can't create socket\n");
continue;
}
- bacpy(&laddr.rc_bdaddr, BDADDR_ANY);
- laddr.rc_family = AF_BLUETOOTH;
- laddr.rc_channel = 0;
+ bacpy(&laddr.rfcomm_bdaddr, BDADDR_ANY);
+ laddr.rfcomm_family = AF_BLUETOOTH;
+ laddr.rfcomm_channel = 0;
- bacpy(&laddr.rc_bdaddr, BDADDR_ANY);
- laddr.rc_family = AF_BLUETOOTH;
- laddr.rc_channel = 0;
+ bacpy(&laddr.rfcomm_bdaddr, BDADDR_ANY);
+ laddr.rfcomm_family = AF_BLUETOOTH;
+ laddr.rfcomm_channel = 0;
if (bind(fd, (struct sockaddr *)&laddr, sizeof(laddr)) < 0) {
smprintf(s, "Can't bind socket (%d, %s)\n", errno, strerror(errno));
@@ -70,9 +68,9 @@ GSM_Error bluetooth_connect(GSM_StateMac
}
if (bind(fd, (struct sockaddr *)&laddr, sizeof(laddr)) < 0) {
smprintf(s, "Can't bind socket (%d, %s)\n", errno, strerror(errno));
@@ -78,9 +76,9 @@ GSM_Error bluetooth_connect(GSM_StateMac
}
str2ba(device, &bdaddr);
- bacpy(&raddr.rc_bdaddr, &bdaddr);
- raddr.rc_family = AF_BLUETOOTH;
- raddr.rc_channel = port;
+ bacpy(&raddr.rfcomm_bdaddr, &bdaddr);
+ raddr.rfcomm_family = AF_BLUETOOTH;
+ raddr.rfcomm_channel = port;
str2ba(device, &bdaddr);
- bacpy(&raddr.rc_bdaddr, &bdaddr);
- raddr.rc_family = AF_BLUETOOTH;
- raddr.rc_channel = port;
+ bacpy(&raddr.rfcomm_bdaddr, &bdaddr);
+ raddr.rfcomm_family = AF_BLUETOOTH;
+ raddr.rfcomm_channel = port;
if (connect(fd, (struct sockaddr *)&raddr, sizeof(raddr)) < 0) {
smprintf(s, "Can't connect (%d, %s)\n", errno, strerror(errno));
if (connect(fd, (struct sockaddr *)&raddr, sizeof(raddr)) < 0) {
smprintf(s, "Can't connect (%d, %s)\n", errno, strerror(errno));

View File

@ -36,10 +36,10 @@ libdata/pkgconfig/gammu.pc
libdata/pkgconfig/gammu-smsd.pc
lib/libGammu.so
lib/libGammu.so.7
lib/libGammu.so.7.1.30.0
lib/libGammu.so.7.1.31.0
lib/libgsmsd.so
lib/libgsmsd.so.7
lib/libgsmsd.so.7.1.30.0
lib/libgsmsd.so.7.1.31.0
share/gammu/gnapplet.ini
share/gammu/gnapplet.sis
share/gammu/series60-remote.sis