Fix for building on 3.0
This commit is contained in:
parent
11deadb428
commit
e714328231
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=14870
@ -3,7 +3,7 @@
|
||||
# Date created: 5 September 1996
|
||||
# Whom: Bill Fenner <fenner@FreeBSD.ORG>
|
||||
#
|
||||
# $Id: Makefile,v 1.11 1998/09/21 23:39:42 fenner Exp $
|
||||
# $Id: Makefile,v 1.12 1998/09/25 10:05:11 asami Exp $
|
||||
#
|
||||
|
||||
DISTNAME= nte-1.5a29
|
||||
@ -20,16 +20,6 @@ RESTRICTED= "Contains DES encryption"
|
||||
USE_GMAKE= yes
|
||||
USE_X_PREFIX= yes
|
||||
|
||||
MAKE_ENV= LOCALBASE="${LOCALBASE}"
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
||||
#DISGUSTING HACK ALERT
|
||||
#Although nte includes an hsearch.c for those who don't have it in
|
||||
# libc, there's no way to get the default Makefile to build it.
|
||||
# So we build it here.
|
||||
#This is below the .include <bsd.port.mk> since variable names in
|
||||
# targets or dependencies are evaluated when they are read so
|
||||
# bsd.port.mk must have defined ${WRKSRC} already.
|
||||
pre-build: ${WRKSRC}/freebsd/hsearch.o
|
||||
|
||||
${WRKSRC}/freebsd/hsearch.o: ${WRKSRC}/src/hsearch.c
|
||||
${CC} -I${WRKSRC}/src ${CFLAGS} -c -o $@ ${WRKSRC}/src/hsearch.c
|
||||
|
@ -6,7 +6,8 @@ CFLAGS+=-ggdb $(INCLUDES) -DFREEBSD -DPROTOTYPES -DHAVE_NO_VALUES_H -DHAVE_LIMIT
|
||||
# for search.h
|
||||
CFLAGS+=-I../src
|
||||
|
||||
OBJS+=hsearch.o
|
||||
hsearch.o: ../src/hsearch.c
|
||||
${CC} -I${WRKSRC}/src ${CFLAGS} -c -o $@ ../src/hsearch.c
|
||||
|
||||
install: all
|
||||
install -c -s -m 755 -o bin -g bin nt ${PREFIX}/bin
|
||||
install -c -s -m 755 -o bin -g bin nte ${PREFIX}/bin
|
||||
|
@ -1,6 +1,15 @@
|
||||
--- src/Makefile.template.orig Thu Oct 31 14:35:42 1996
|
||||
+++ src/Makefile.template Thu Oct 31 14:36:23 1996
|
||||
@@ -168,13 +168,13 @@
|
||||
--- src/Makefile.template.orig Fri Jul 31 07:51:31 1998
|
||||
+++ src/Makefile.template Sun Nov 22 10:28:13 1998
|
||||
@@ -3,7 +3,7 @@
|
||||
protocol.o network_write.o network_read.o ds_fns.o parse_packet.o ids.o \
|
||||
sliding_key.o rtx.o missing.o participants.o bitmaps.o \
|
||||
recent.o nt_ui.o generic_tcl.o libs.o www_ui.o www_fns.o nt_help.o \
|
||||
- save_struct.o iohandler.o libqfDES.a debug.o canvas_ext.o font_ext.o
|
||||
+ save_struct.o iohandler.o libqfDES.a debug.o canvas_ext.o font_ext.o hsearch.o
|
||||
ENCOBJS=crypt.o md5c.o random.o
|
||||
QFDES=qfDES.o qfDES-memory.o qfDES-key.o
|
||||
QFINCLUDES=-I../src/qfdes
|
||||
@@ -172,13 +172,13 @@
|
||||
$(CC) $(CFLAGS) -c libs.c
|
||||
|
||||
../src/help/blocks.ehtml: text2html ../src/help/blocks.html
|
||||
|
Loading…
Reference in New Issue
Block a user