Initial import of expat, a

XML 1.0 parser written in C.
This commit is contained in:
Dirk Froemberg 1999-08-26 13:45:48 +00:00
parent 79129066a3
commit e6e1e1046b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=20990
11 changed files with 104 additions and 0 deletions

26
textproc/expat/Makefile Normal file
View File

@ -0,0 +1,26 @@
# New ports collection makefile for: expat
# Version required: 1.1
# Date created: Thu Aug 26 14:38:07 CEST 1999
# Whom: Dirk Froemberg <dirk@FreeBSD.org>
#
# $Id$
#
DISTNAME= expat
PKGNAME= expat-1.1
CATEGORIES= textproc
MASTER_SITES= ftp://ftp.jclark.com/pub/xml/ \
http://www.physik.TU-Berlin.DE/~ibex/ports/distfiles/
MAINTAINER= dirk@FreeBSD.org
USE_ZIP= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xmlwf/xmlwf ${PREFIX}/bin
${MKDIR} ${PREFIX}/include/xml
${INSTALL_DATA} ${WRKSRC}/xmlparse/xmlparse.h ${PREFIX}/include/xml
${INSTALL_DATA} ${WRKSRC}/xmltok/xmltok.h ${PREFIX}/include/xml
${INSTALL_DATA} ${WRKSRC}/libexpat.a ${PREFIX}/lib
.include <bsd.port.mk>

1
textproc/expat/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (expat.zip) = 9111cc7764ff900229d9e51c03f4a593

View File

@ -0,0 +1 @@
XML 1.0 parser written in C

2
textproc/expat/pkg-descr Normal file
View File

@ -0,0 +1,2 @@
Expat is an XML 1.0 parser written in C. It aims to be fully
conforming. It is currently not a validating XML processor.

5
textproc/expat/pkg-plist Normal file
View File

@ -0,0 +1,5 @@
bin/xmlwf
include/xml/xmlparse.h
include/xml/xmltok.h
lib/libexpat.a
@dirrm include/xml

26
textproc/expat2/Makefile Normal file
View File

@ -0,0 +1,26 @@
# New ports collection makefile for: expat
# Version required: 1.1
# Date created: Thu Aug 26 14:38:07 CEST 1999
# Whom: Dirk Froemberg <dirk@FreeBSD.org>
#
# $Id$
#
DISTNAME= expat
PKGNAME= expat-1.1
CATEGORIES= textproc
MASTER_SITES= ftp://ftp.jclark.com/pub/xml/ \
http://www.physik.TU-Berlin.DE/~ibex/ports/distfiles/
MAINTAINER= dirk@FreeBSD.org
USE_ZIP= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xmlwf/xmlwf ${PREFIX}/bin
${MKDIR} ${PREFIX}/include/xml
${INSTALL_DATA} ${WRKSRC}/xmlparse/xmlparse.h ${PREFIX}/include/xml
${INSTALL_DATA} ${WRKSRC}/xmltok/xmltok.h ${PREFIX}/include/xml
${INSTALL_DATA} ${WRKSRC}/libexpat.a ${PREFIX}/lib
.include <bsd.port.mk>

1
textproc/expat2/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (expat.zip) = 9111cc7764ff900229d9e51c03f4a593

View File

@ -0,0 +1,34 @@
--- Makefile.orig Mon Mar 8 08:20:38 1999
+++ Makefile Thu Aug 26 14:49:24 1999
@@ -1,10 +1,9 @@
-CC=gcc
# If you know what your system's byte order is, define XML_BYTE_ORDER:
# use -DXML_BYTE_ORDER=12 for little-endian byte order;
# use -DXML_BYTE_ORDER=21 for big-endian (network) byte order.
# -DXML_NS adds support for checking of lexical aspects of XML namespaces spec
# -DXML_MIN_SIZE makes a smaller but slower parser
-CFLAGS=-O2 -Ixmltok -Ixmlparse -DXML_NS
+CFLAGS+=-Ixmltok -Ixmlparse -DXML_NS
# Use one of the next two lines; unixfilemap is better if it works.
FILEMAP_OBJ=xmlwf/unixfilemap.o
#FILEMAP_OBJ=xmlwf/readfilemap.o
@@ -18,7 +17,7 @@
$(FILEMAP_OBJ)
EXE=
-all: xmlwf/xmlwf$(EXE)
+all: xmlwf/xmlwf$(EXE) libexpat.a
xmlwf/xmlwf$(EXE): $(OBJS)
$(CC) $(CFLAGS) -o $@ $(OBJS)
@@ -34,6 +33,10 @@
$(CC) $(CFLAGS) -o $@ gennmtab/gennmtab.c
xmltok/xmltok.o: xmltok/nametab.h
+
+libexpat.a: $(OBJS)
+ ar -rc $@ $(OBJS)
+ ranlib $@
.c.o:
$(CC) $(CFLAGS) -c -o $@ $<

View File

@ -0,0 +1 @@
XML 1.0 parser written in C

View File

@ -0,0 +1,2 @@
Expat is an XML 1.0 parser written in C. It aims to be fully
conforming. It is currently not a validating XML processor.

View File

@ -0,0 +1,5 @@
bin/xmlwf
include/xml/xmlparse.h
include/xml/xmltok.h
lib/libexpat.a
@dirrm include/xml