devel/schilybase: update to 2022-09-18

- point MASTER_SITES to new upstream
 - split bosh from sysutils/schilyutils into new port shells/bosh
   - stop installing pfbosh, a SunOS-only feature
   - install jsh as jbosh to avoid a conflict
   - patch shell names in man pages
 - point WWW to subproject-specific sites if available
 - misc/schilytools: deprecate man2html component
 - devel/schilybase: add missing file to pkg-plist
 - make test suite work better
   - do not pass INS_*BASE/DESTDIR to smake tests
   - account for devel/sccs placing files in /tmp
   - make sh/tests/common/test-common find bosh after
     we patched out the hardlink to sh
   - Test suite passes on armv7 except for archivers/star.
     Will have to investigate further.
 - sysutils/schilyutils: add vctags command
   I forgot about that one when I made the port initially.
   The ctags link is not installed to avoid conflicts.

Changelog: http://fuz.su/pub/schilytools/AN-2022-09-18.txt

PR:	266475
This commit is contained in:
Robert Clausecker 2022-08-18 22:53:34 +02:00 committed by Neel Chauhan
parent ed4ae91e94
commit e69a1817a6
24 changed files with 297 additions and 104 deletions

View File

@ -2,7 +2,7 @@ PORTNAME= star
CATEGORIES= archivers
COMMENT= Unique standard tape archiver with many enhancements
WWW= https://codeberg.org/schilytools/schilytools
WWW= http://cdrtools.sourceforge.net/private/star.html
PORTDOCS= README* STARvsGNUTAR

View File

@ -2,14 +2,17 @@ PORTNAME= sccs
CATEGORIES= devel
COMMENT= Source Code Control System (SCCS)
WWW= https://codeberg.org/schilytools/schilytools
WWW= http://sccs.sourceforge.net/
TEST_DEPENDS= star:archivers/star
MASTERDIR= ${.CURDIR}/../../devel/schilybase
COMPONENTS= patch \
sccs
TESTCOMPONENTS= ${COMPONENTS:Npatch}
# these files are installed by the patch target,
# but they belong to sysutils/schilyutils
# These files are installed by the patch target,
# but they belong to sysutils/schilyutils.
post-install:
${RM} ${STAGEDIR}${PREFIX}/bin/opatch
${RM} ${STAGEDIR}${PREFIX}/bin/spatch
@ -17,4 +20,11 @@ post-install:
${RM} ${STAGEDIR}${PREFIX}/share/man/man1/patch.1
${RM} ${STAGEDIR}${PREFIX}/share/man/man1/spatch.1
# This test suite installs a temp copy of the schilytools to /tmp.
# The directories are hard-coded unfortunately.
pre-test:
@${ECHO_MSG} '=> cleaning old test files'
${RM} -r /tmp/sccstests /tmp/SCCSTEST
@${ECHO_MSG} '=> running test suite'
.include "${MASTERDIR}/Makefile.master"

View File

@ -2,7 +2,6 @@ PORTNAME= schilybase
CATEGORIES= devel
COMMENT= Support files and libraries for the schilytools
WWW= https://codeberg.org/schilytools/schilytools
NLS_USES= gettext-tools
USE_LDCONFIG= yes

View File

@ -1,10 +1,9 @@
DISTVERSION= 2021-09-18
PORTREVISION= 2
MASTER_SITES= SF/schilytools \
http://fuz.su/~fuz/distfiles/schilytools/
DISTVERSION= 2022-09-18
MASTER_SITES= http://fuz.su/pub/schilytools/
DISTNAME= schily-${DISTVERSION}
MAINTAINER= fuz@fuz.su
WWW?= https://codeberg.org/schilytools/schilytools
LICENSE= CDDL ${COMPONENTS:@c@${LICENSE.${c}}@:O:u}
LICENSE.autoconf= GPLv2
@ -13,6 +12,7 @@ LICENSE.man2html= GPLv2
LICENSE.mkisofs= GPLv2
LICENSE.libparanoia= LGPL21
LICENSE.cpp= BSD3CLAUSE
LICENSE.ctags= BSD3CLAUSE
LICENSE.libmdigest= BSD2CLAUSE
LICENSE.libfile= BSD2CLAUSE
LICENSE.patch= BSD1CLAUSE
@ -40,7 +40,7 @@ MAKE_ARGS= INS_BASE=${PREFIX} \
INS_RBASE=${PREFIX} \
LINKMODE=dynamic \
DESTDIR=${STAGEDIR} \
STRIPFLAGS=${WITH_DEBUG:D:U-s} \
STRIPFLAGS=${STRIP} \
CCOM=${COMPILER_TYPE} \
CC=${CC} \
CCC=${CXX} \
@ -54,6 +54,8 @@ PLIST= ${.CURDIR}/pkg-plist
PKGMESSAGE?= ${.CURDIR}/pkg-message
DESCR= ${.CURDIR}/pkg-descr
TESTCOMPONENTS?= ${COMPONENTS}
post-extract:
@cd ${WRKSRC}/rmt && ${MV} rmt.dfl srmt.dfl
@cd ${WRKSRC}/rmt && ${MV} default-rmt.sample default-srmt.sample
@ -81,9 +83,10 @@ do-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so.*.*
.endif
# the test suite gets moody if we set INS_BASE/INS_RBASE/DESTDIR
do-test:
.for component in ${COMPONENTS}
cd ${WRKSRC}/${component} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} tests
.for component in ${TESTCOMPONENTS}
cd ${WRKSRC}/${component} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS:NINS_*BASE=*:NDESTDIR=*} tests
.endfor
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1632527018
SHA256 (schily-2021-09-18.tar.bz2) = 7c93f43d22c6e3de0eafe018ceb26ddd5cc6c543dc301f307d1e6ca313248aa4
SIZE (schily-2021-09-18.tar.bz2) = 4952788
TIMESTAMP = 1663463867
SHA256 (schily-2022-09-18.tar.bz2) = 73aab13a15bfb4e2a418a7602365a914ed5f5bc782d8aef21580195e1e5e5b65
SIZE (schily-2022-09-18.tar.bz2) = 4878648

View File

@ -1,33 +1,6 @@
--- cdrecord/cdrecord.dfl.orig 2014-01-03 21:59:27 UTC
--- cdrecord/cdrecord.dfl.orig 2022-09-18 01:03:28 UTC
+++ cdrecord/cdrecord.dfl
@@ -3,7 +3,7 @@
# This file is /etc/default/cdrecord
# It contains defaults that are used if no command line option
# or environment is present.
-#
+#
# The default device, if not specified elswhere
# Note that since Sommer 2006, cdrecord by default searches for a
# single CD-ROM device. You should set CDR_DEVICE= together with
@@ -11,15 +11,14 @@
# one CR-ROM drive in your system.
#
#CDR_DEVICE=yamaha
-#CDR_DEVICE=default
-#
+#
# The default speed (speed=), if not specified elswhere
#
# Note that newer cdrecord versions do not default
# to speed=1. For MMC compliant drives, the default
# is to write at maximum speed, so it in general does
-# not make sense to set up a default speed in /etc/default/cdrecord
+# not make sense to set up a default speed in /etc/default/cdrecord
#
#CDR_SPEED=40
@@ -34,7 +33,7 @@
@@ -34,7 +34,7 @@
# Linux and Solaris have problems with bigger transfer sizes.
# If you are on FreeBSD, it is recommened to set CDR_TRANSFERSIZE=126k
#
@ -36,29 +9,3 @@
#
# The following definitions allow abstract device names.
@@ -56,14 +55,14 @@
#
# drive name device speed fifosize driveropts transfersize
#
-my-default= 1,0,0 -1 -1 burnfree 63k
-sol-default= USCSI:1,0,0 -1 -1 burnfree
-ricoh-u= USCSI:0,2,0 -1 -1 burnfree
-teac= 1,3,0 -1 -1 ""
-teac-max-ts= 1,3,0 -1 -1 "" 32k
-panasonic= 1,4,0 -1 -1 ""
-plextor= 1,4,0 -1 -1 ""
-sanyo= 1,4,0 -1 -1 burnfree
-yamaha= 1,5,0 -1 -1 ""
-cdrom= 0,6,0 2 1m ""
-remote= REMOTE:rscsi@somehost:1,0,0 16 16m burnfree
+#my-default= 1,0,0 -1 -1 burnfree 63k
+#sol-default= USCSI:1,0,0 -1 -1 burnfree
+#ricoh-u= USCSI:0,2,0 -1 -1 burnfree
+#teac= 1,3,0 -1 -1 ""
+#teac-max-ts= 1,3,0 -1 -1 "" 32k
+#panasonic= 1,4,0 -1 -1 ""
+#plextor= 1,4,0 -1 -1 ""
+#sanyo= 1,4,0 -1 -1 burnfree
+#yamaha= 1,5,0 -1 -1 ""
+#cdrom= 0,6,0 2 1m ""
+#remote= REMOTE:rscsi@somehost:1,0,0 16 16m burnfree

View File

@ -0,0 +1,10 @@
--- ctags/Makefile.orig 2022-09-10 14:28:08 UTC
+++ ctags/Makefile
@@ -7,7 +7,6 @@ include $(SRCROOT)/$(RULESDIR)/rules.top
INSDIR= bin
TARGET= vctags
-SYMLINKS += ctags
CPPOPTS += -DUSE_LARGEFILES
CPPOPTS += -DVED_STATS

View File

@ -1,13 +1,24 @@
--- sh/Makefile.orig 2021-06-04 17:19:38 UTC
--- sh/Makefile.orig 2022-08-18 18:38:26 UTC
+++ sh/Makefile
@@ -7,9 +7,8 @@ include $(SRCROOT)/$(RULESDIR)/rules.top
@@ -7,10 +7,8 @@ include $(SRCROOT)/$(RULESDIR)/rules.top
INSDIR= bin
# Shell
-TARGET= sh
+TARGET= bosh
SYMLINKS= pfsh # Profile Bourne Shell
-SYMLINKS= pfsh # Profile Bourne Shell
-SYMLINKS += bosh # Bourne Shell
SYMLINKS += jsh # Job control Bourne Shell
-SYMLINKS += jsh # Job control Bourne Shell
+TARGET= bosh
+SYMLINKS += jbosh # Job control Bourne Shell
HARDLINKS += ../xpg4/bin/sh # POSIX Bourne Shell
##CPPOPTS += -DNO_USER_MALLOC # Do not use our own malloc()
@@ -196,7 +194,7 @@ LIBS= $(LIB_SECDB) -lshedit -lxtermcap -lgetopt \
$(LIB_ACL_TEST) \
$(LIB_INTL) $(LIB_DL)
#LIBS= -lgen -lsecdb
-XMK_FILE= Makefile.dot Makefile.man bosh.mk1 jsh.mk1 pfsh.mk1
+XMK_FILE= Makefile.dot Makefile.man bosh.mk1 jsh.mk1
signames.c abbrev.c abbrev.h:
@echo " ==> MAKING SYMLINKS in ."; sh ./MKLINKS

View File

@ -0,0 +1,11 @@
--- sh/jsh.mk1.orig 2022-09-11 13:08:33 UTC
+++ sh/jsh.mk1
@@ -8,7 +8,7 @@ include $(SRCROOT)/$(RULESDIR)/rules.top
###########################################################################
MANDIR= man
-TARGETMAN= jsh
+TARGETMAN= jbosh
MANSECT= $(MANSECT_CMD)
MANSUFFIX= $(MANSUFF_CMD)
MANFILE= jsh.1

View File

@ -0,0 +1,143 @@
--- sh/sh.1.orig 2022-09-18 01:03:28 UTC
+++ sh/sh.1
@@ -61,32 +61,25 @@
.if n .ds s sz
.TH sh 1 "2022/09/11" "Schily Bourne Shell" "User Commands"
.SH NAME
-sh, bosh, jsh \- standard and job control shell and command interpreter
+sh, bosh, jbosh \- standard and job control shell and command interpreter
.SH SYNOPSIS
.LP
.nf
-.B /usr/bin/sh\c
-.RB " [" \(miabCcefhikmnprstuvxP "] ["\c
-.IR argument ]...
-.fi
-
-.LP
-.nf
-.B /usr/bin/bosh\c
+.B bosh\c
.RB " [" \(miabCcefhikmnprstuvxP "] ["\c
.IR argument ]...
.fi
.LP
.nf
-.B /usr/bin/pbosh\c
+.B pbosh\c
.RB " [" \(miabCcefhikmnprstuvxP "] ["\c
.IR argument ]...
.fi
.LP
.nf
-.B /usr/bin/jsh\c
+.B jbosh\c
.RB " [" \(miabCcefhikmnprstuvxP "] ["\c
.IR argument ]...
.fi
@@ -95,18 +88,18 @@ sh, bosh, jsh \- standard and job control shell and co
.sp
.LP
The
-.B /usr/bin/sh
+.B bosh
utility is a command programming language that
executes commands read from a terminal or a file.
.LP
The name
.B bosh
permits to call this implementation even when
-.B /usr/bin/sh
+.B sh
has been linked to another shell.
.LP
The
-.B jsh
+.B jbosh
utility is an interface to the shell that provides all of the
functionality of
.B sh
@@ -121,7 +114,7 @@ or
Since
.B POSIX
requires that job control is auto-enabled for interactive shells,
-.B jsh
+.B jbosh
can be seen as an artefact from the historic Bourne Shell, but is kept for
compatibility.
.LP
@@ -180,7 +173,7 @@ if the file exists (by default this is the file
.BR $HOME/.shrc ).
Thereafter, commands are read as described below, which is also the case
when the shell is invoked as
-.BR /usr/bin/sh .
+.BR bosh .
.SH OPTIONS
The options below are
@@ -5827,7 +5820,7 @@ those that precede the command name.
Switch job control mode on.
All jobs are run in their own process groups.
See section
-.B "Job Control (jsh)"
+.B "Job Control (jbosh)"
below.
On systems with job control, this flag is turned on automatically
for interactive shells.
@@ -7516,7 +7509,7 @@ termination status.
The process identifier
.I n
may either be a UNIX process id or a shell job id. See
-.B "Job Control (jsh)"
+.B "Job Control (jbosh)"
section below for information on shell job ids.
.sp
The return code of
@@ -7544,11 +7537,11 @@ in the section
.B Parameter Substitution
above.
-.SS "Job Control (jsh)"
+.SS "Job Control (jbosh)"
.sp
.LP
When the shell is invoked as
-.BR jsh ,
+.BR jbosh ,
when the shell is invoked as interactive shell
or after
.B set -m
@@ -8362,7 +8355,7 @@ See
for an extended description of the behavior of
.B sh
and
-.B jsh
+.B jbosh
when encountering files greater than or equal to 2 Gbyte ( 2^31 bytes).
.SH EXIT STATUS
.sp
@@ -8373,11 +8366,11 @@ execution of the shell file is abandoned. Otherwise, t
exit status of the last command executed (see also the
.B exit
command above).
-.SS "jsh Only"
+.SS "jbosh Only"
.sp
.LP
If the shell is invoked as
-.B jsh
+.B jbosh
and an attempt is made to exit the
shell while there are stopped jobs, the shell issues one warning:
.sp
@@ -8476,7 +8469,7 @@ The location of the restricted Bourne Shell binary.
See
.BR attributes (5)
for descriptions of the following attributes:
-.SS "/usr/bin/sh, /usr/bin/jsh"
+.SS "sh, jbosh"
.sp
.sp

View File

@ -0,0 +1,17 @@
--- sh/tests/common/test-common.orig 2022-08-19 19:43:40 UTC
+++ sh/tests/common/test-common
@@ -19,10 +19,10 @@ powerpc-aix-*)
;;
esac
-if [ -f ../../../OBJ/$OARCH/sh ]; then
- shell=${shell:=../../../OBJ/$OARCH/sh}
-elif [ -f ../../OBJ/$OARCH/sh ]; then
- shell=${shell:=../../OBJ/$OARCH/sh}
+if [ -f ../../../OBJ/$OARCH/bosh ]; then
+ shell=${shell:=../../../OBJ/$OARCH/bosh}
+elif [ -f ../../OBJ/$OARCH/bosh ]; then
+ shell=${shell:=../../OBJ/$OARCH/bosh}
fi
SHELL="$shell"
export SHELL

View File

@ -20,6 +20,7 @@ include/schily/alloca.h
include/schily/archdefs.h
include/schily/assert.h
include/schily/avoffset.h
include/schily/blake2.h
include/schily/btorder.h
include/schily/ccomdefs.h
include/schily/checkerr.h

View File

@ -2,7 +2,6 @@ PORTNAME= smake
CATEGORIES= devel
COMMENT= Portable make program with automake features
WWW= https://codeberg.org/schilytools/schilytools
MASTERDIR= ${.CURDIR}/../../devel/schilybase
BOOTSTRAP_SMAKE?= yes

View File

@ -2,7 +2,7 @@ PORTNAME= sunpromake
CATEGORIES= devel parallel
COMMENT= Parallel-execution enabled SunOS make program, enhanced to fit POSIX
WWW= https://codeberg.org/schilytools/schilytools
WWW= http://schilytools.sourceforge.net/sunpromake.html
USE_LDCONFIG= yes

View File

@ -2,7 +2,7 @@ PORTNAME= ved
CATEGORIES= editors
COMMENT= Visual editor (easy to learn, fast, and lean)
WWW= https://codeberg.org/schilytools/schilytools
WWW= http://schilytools.sourceforge.net/ved.html
OPTIONS_DEFINE= DOCS

View File

@ -1,12 +1,13 @@
PORTNAME= schilytools
DISTVERSION= 1
DISTVERSION= 2
CATEGORIES= misc
MAINTAINER= fuz@fuz.su
COMMENT= Collection of tools and libraries by J. Schilling (metaport)
WWW= https://codeberg.org/schilytools/schilytools
RUN_DEPENDS= schilybase>=2021.05.19:devel/schilybase \
RUN_DEPENDS= bosh>=2022.08.18.b:shells/bosh \
schilybase>=2021.05.19:devel/schilybase \
schilyutils>=2021.05.19:sysutils/schilyutils \
star>=2021.05.19:archivers/star \
sccs>=2021.05.19:devel/sccs \
@ -14,9 +15,12 @@ RUN_DEPENDS= schilybase>=2021.05.19:devel/schilybase \
sunpromake>=2021.05.19:devel/sunpromake \
ved>=2021.05.19:editors/ved \
cdrtools>=2021.05.19:sysutils/cdrtools \
rscsi>=2021.05.19:net/rscsi \
man2html:textproc/man2html
rscsi>=2021.05.19:net/rscsi
USES= metaport
OPTIONS_DEFINE= DEPRECATED
DEPRECATED_DESC= include deprecated utilities
DEPRECATED_RUN_DEPENDS= man2html:textproc/man2html
.include <bsd.port.mk>

View File

@ -2,9 +2,7 @@ PORTNAME= rscsi
CATEGORIES= net
COMMENT= Remote SCSI transport server program (daemon)
WWW= https://codeberg.org/schilytools/schilytools
CONFLICTS= cdrtools-devel
WWW= http://cdrtools.sourceforge.net/private/cdrecord.html
USERS= rscsi
GROUPS= rscsi

View File

@ -9,6 +9,7 @@
SUBDIR += bash-static
SUBDIR += bashc
SUBDIR += bicon
SUBDIR += bosh
SUBDIR += ch
SUBDIR += dash
SUBDIR += elvish

16
shells/bosh/Makefile Normal file
View File

@ -0,0 +1,16 @@
PORTNAME= bosh
CATEGORIES= shells
COMMENT= Bourne Shell extended by J. Schilling
MAINTAINER= fuz@fuz.su
WWW= http://schilytools.sourceforge.net/bosh.html
# bin/bosh
CONFLICTS_INSTALL= bosh-cli
MASTERDIR= ${.CURDIR}/../../devel/schilybase
COMPONENTS= obosh \
pbosh \
sh
.include "${MASTERDIR}/Makefile.master"

23
shells/bosh/pkg-descr Normal file
View File

@ -0,0 +1,23 @@
The Schily Bourne Shell was derived from the Bourne Shell sources from
OpenSolaris. The Schily Bourne Shell is actively maintained and
enhanced on a regular base. It can be compiled into three variants:
Non-POSIX SVr4/OpenSolaris variant (obosh)
The portable but not extended variant obosh allows script
portability testing. Most scripts that run in the old Schily
Bourne Shell will run with any Unix shell that is still in use
since 1990.
Minimal POSIX compliant variant (pbosh)
This version implements the minimal set of POSIX features and
this version is always in strict POSIX mode. The features are
similar to the features in dash, but since pbosh supports multi
byte characters, it is really POSIX compliant. The pbosh
variant allows script portability testing aginst the POSIX
feature set.
The POSIX compliant extended variant (bosh)
This version has been verified to work as the system shell on
Gentoo Linux and OpenSolaris (SchilliX). The enhanced Schily
Bourne Shell (bosh) implements many features that are missing
in the OpenSolaris Bourne Shell listed above.

11
shells/bosh/pkg-plist Normal file
View File

@ -0,0 +1,11 @@
@shell bin/bosh
@shell bin/jbosh
@shell bin/obosh
@shell bin/pbosh
%%DOCSDIR%%/dotfiles.tar.bz2
share/man/man1/bosh.1.gz
share/man/man1/jbosh.1.gz
share/man/man1/obosh.1.gz
share/man/man1/pbosh.1.gz
@shell xpg4/bin/bosh
@shell xpg4/bin/sh

View File

@ -2,7 +2,7 @@ PORTNAME= cdrtools
CATEGORIES= sysutils audio
COMMENT= Tools for ripping from and recording to CDs and DVDs
WWW= https://codeberg.org/schilytools/schilytools
WWW= http://cdrtools.sourceforge.net/private/cdrecord.html
LAME_RUN_DEPENDS= lame:audio/lame
VORBIS_RUN_DEPENDS= oggenc:audio/vorbis-tools

View File

@ -2,13 +2,15 @@ PORTNAME= schilyutils
CATEGORIES= sysutils converters deskutils textproc shells
COMMENT= Collection of utilities from J. Schilling
WWW= https://codeberg.org/schilytools/schilytools
WWW= http://schilytools.sourceforge.net/
USES+= perl5 shebangfix
USE_PERL5= run
SHEBANG_FILES= man2html/man2html cstyle/cstyle.pl
CONFLICTS_INSTALL= bosh-cli bsh calc clusterit deforaos-browser heirloom-sh latte-integrale p5-Math-SigFigs radmind # bin/bosh bin/bsh bin/calc bin/copy bin/count bin/fsdiff bin/jsh
# bin/bsh bin/calc bin/copy bin/count bin/fsdiff
CONFLICTS_INSTALL= bsh calc deforaos-browser \
latte-integrale p5-Math-SigFigs radmind
MASTERDIR= ${.CURDIR}/../../devel/schilybase
COMPONENTS= bsh \
@ -22,6 +24,7 @@ COMPONENTS= bsh \
count \
cpp \
cstyle \
ctags \
cut \
fifo \
label \
@ -29,17 +32,14 @@ COMPONENTS= bsh \
lndir \
match \
mdigest \
obosh \
p \
paste \
patch \
pbosh \
printf \
sdd \
sfind \
sformat \
sgrow \
sh \
termcap \
translit \
udiff

View File

@ -1,5 +1,4 @@
bin/Cstyle
@shell bin/bosh
@shell bin/bsh
bin/btcflash
bin/calc
@ -12,18 +11,14 @@ bin/fdiff
bin/fifo
bin/fsdiff
bin/hdump
@shell bin/jsh
bin/krcpp
bin/label
bin/lndir
bin/match
bin/mdigest
@shell bin/obosh
bin/opatch
bin/p
bin/pbosh
bin/pfbsh
bin/pfsh
bin/scal
bin/scompare
bin/scut
@ -38,12 +33,11 @@ bin/sprintf
bin/termcap
bin/translit
bin/udiff
bin/vctags
etc/sformat.dat
lib/cpp
share/doc/bosh/dotfiles.tar.bz2
share/doc/bsh/dotfiles.tar.bz2
share/man/de/man1/sdd.1.gz
share/man/man1/bosh.1.gz
share/man/man1/bsh.1.gz
share/man/man1/btcflash.1.gz
share/man/man1/calc.1.gz
@ -56,19 +50,15 @@ share/man/man1/fdiff.1.gz
share/man/man1/fifo.1.gz
share/man/man1/fsdiff.1.gz
share/man/man1/hdump.1.gz
share/man/man1/jsh.1.gz
share/man/man1/krcpp.1.gz
share/man/man1/label.1.gz
share/man/man1/lndir.1.gz
share/man/man1/match.1.gz
share/man/man1/mdigest.1.gz
share/man/man1/obosh.1.gz
share/man/man1/opatch.1.gz
share/man/man1/p.1.gz
share/man/man1/patch.1.gz
share/man/man1/pbosh.1.gz
share/man/man1/pfbsh.1.gz
share/man/man1/pfsh.1.gz
share/man/man1/scal.1.gz
share/man/man1/scompare.1.gz
share/man/man1/scut.1.gz
@ -82,7 +72,6 @@ share/man/man1/sprintf.1.gz
share/man/man1/termcap.1.gz
share/man/man1/translit.1.gz
share/man/man1/udiff.1.gz
share/man/man1/vctags.1.gz
share/man/man8/sformat.8.gz
xpg4/bin/bosh
xpg4/bin/od
@shell xpg4/bin/sh