x11-wm/phoc: update to 0.11.0

Changes:	https://gitlab.gnome.org/World/Phosh/phoc/-/releases/v0.11.0
Reported by:	Repology
This commit is contained in:
Jan Beich 2021-12-15 20:15:55 +00:00
parent c7dbfbd90d
commit e63ef2b931
4 changed files with 15 additions and 14 deletions

View File

@ -1,6 +1,6 @@
PORTNAME= phoc
DISTVERSIONPREFIX= v
DISTVERSION= 0.10.0
DISTVERSION= 0.11.0
CATEGORIES= x11-wm
MAINTAINER= jbeich@FreeBSD.org
@ -10,7 +10,7 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
wlroots>=0.12.0<0.13.0:x11-toolkits/wlroots
wlroots>=0.14.1<0.15.0:x11-toolkits/wlroots
LIB_DEPENDS= libwayland-server.so:graphics/wayland \
libwlroots.so:x11-toolkits/wlroots \
libinput.so:x11/libinput \
@ -24,7 +24,7 @@ USE_GNOME= gnomedesktop3
USE_XORG= pixman xcb
GL_SITE= https://gitlab.gnome.org
GL_ACCOUNT= World/Phosh
GL_COMMIT= d5fc37eb6aad998013c066febc9a794ad77a27ac
GL_COMMIT= 9e8cc69eabb9fc14292a3af59282765cd86ff728
SHEBANG_FILES= build-aux/post_install.py
CFLAGS+= -Wno-error=format-nonliteral # clang
PLIST_FILES= bin/${PORTNAME}

View File

@ -1,14 +1,15 @@
# https://gitlab.gnome.org/World/Phosh/phoc/-/merge_requests/241
BUILD_DEPENDS:= ${BUILD_DEPENDS:N*wlroots*}
BUILD_DEPENDS:= ${BUILD_DEPENDS:N*wlroots*} \
xwayland-devel>0:x11-servers/xwayland-devel
LIB_DEPENDS:= ${LIB_DEPENDS:N*wlroots*} \
libudev.so:devel/libudev-devd \
libdrm.so:graphics/libdrm \
libseat.so:sysutils/seatd \
libxcb-errors.so:x11/xcb-util-errors \
libxcb-render-util.so:x11/xcb-util-renderutil \
libxcb-icccm.so:x11/xcb-util-wm
RUN_DEPENDS+= xwayland-devel>0:x11-servers/xwayland-devel
USE_GL+= gbm egl
USE_XORG+= x11
GL_TUPLE+= https://source.puri.sm:Librem5:wlroots:5413b1ec61c6e3390929db595c0ec92f92ea2594:wlroots/subprojects/wlroots
GL_TUPLE+= https://source.puri.sm:Librem5:wlroots:2fce64d30d378d7009a5770b2472231a0e535ada:wlroots/subprojects/wlroots
MESON_ARGS+= -Dwlroots:default_library=static
PLIST_FILES+= "@comment libdata/pkgconfig/wlroots.pc"

View File

@ -1,5 +1,5 @@
TIMESTAMP = 1639596892
SHA256 (World/Phosh-phoc-d5fc37eb6aad998013c066febc9a794ad77a27ac_GL0.tar.gz) = 4690898bd298af0534532a4ac9933cd1a45177f8a25af9401c908420ddd14841
SIZE (World/Phosh-phoc-d5fc37eb6aad998013c066febc9a794ad77a27ac_GL0.tar.gz) = 165533
SHA256 (Librem5-wlroots-5413b1ec61c6e3390929db595c0ec92f92ea2594_GL0.tar.gz) = 48950a5a45feb46957f172afaaa7a096945b36ca4b32b2e5e259fa6c32c1f737
SIZE (Librem5-wlroots-5413b1ec61c6e3390929db595c0ec92f92ea2594_GL0.tar.gz) = 477754
TIMESTAMP = 1639599355
SHA256 (World/Phosh-phoc-9e8cc69eabb9fc14292a3af59282765cd86ff728_GL0.tar.gz) = 9a29d73adf9a00aa385b4105f3204cf4861e134aa3d55e87585c69dbd2bf51ec
SIZE (World/Phosh-phoc-9e8cc69eabb9fc14292a3af59282765cd86ff728_GL0.tar.gz) = 161336
SHA256 (Librem5-wlroots-2fce64d30d378d7009a5770b2472231a0e535ada_GL0.tar.gz) = 33261e862963b790c967b39ace715ba54f33c396d32cc407e3951d2a39ffd313
SIZE (Librem5-wlroots-2fce64d30d378d7009a5770b2472231a0e535ada_GL0.tar.gz) = 506577

View File

@ -22,14 +22,14 @@ private to phoc package for now.
+if not meson.is_subproject()
install_headers(conf_h, ver_h, subdir: 'wlr')
+endif
--- subprojects/wlroots/meson.build.orig 2021-08-20 08:28:34 UTC
--- subprojects/wlroots/meson.build.orig 2021-09-12 16:57:08 UTC
+++ subprojects/wlroots/meson.build
@@ -161,7 +161,7 @@ lib_wlr = library(
@@ -147,7 +147,7 @@ lib_wlr = library(
soversion: soversion,
dependencies: wlr_deps,
include_directories: [wlr_inc, proto_inc],
- install: true,
+ install: not meson.is_subproject(),
link_args : symbols_flag,
link_args: symbols_flag,
link_depends: symbols_file,
)