Initial import of Cgraph version 2.04.
A PostScript plotting library in C. PR: 8051 Submitted by: Anton Berezin <tobez@plab.ku.dk>
This commit is contained in:
parent
16a24fb1cd
commit
e615b3dbed
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=15565
41
graphics/Cgraph/Makefile
Normal file
41
graphics/Cgraph/Makefile
Normal file
@ -0,0 +1,41 @@
|
||||
# New ports collection makefile for: cgraph
|
||||
# Version required: 2.04
|
||||
# Date created: 25 September 1998
|
||||
# Whom: Anton Berezin <tobez@plab.ku.dk>
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= Cgraph2.04
|
||||
PKGNAME= Cgraph-2.04
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ftp://pinoko.berkeley.edu/pub/software/
|
||||
|
||||
MAINTAINER= tobez@plab.ku.dk
|
||||
|
||||
WRKSRC= ${WRKDIR}/Cgraph/source
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-extract:
|
||||
@${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}/Makefile
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${PREFIX}/share/doc/cgraph
|
||||
@${INSTALL_DATA} ${WRKSRC}/../docs/cgraph.ps ${PREFIX}/share/doc/cgraph
|
||||
.endif
|
||||
.if !defined(NOPORTEXAMPLES)
|
||||
@${MKDIR} ${PREFIX}/share/examples/cgraph
|
||||
@${INSTALL_DATA} ${WRKSRC}/../examples/minimal/CGminimal.c ${PREFIX}/share/examples/cgraph
|
||||
@${INSTALL_DATA} ${WRKSRC}/../examples/dash/dashlist.c ${PREFIX}/share/examples/cgraph
|
||||
@${INSTALL_DATA} ${WRKSRC}/../examples/marker/markerlist.c ${PREFIX}/share/examples/cgraph
|
||||
@${INSTALL_DATA} ${WRKSRC}/../examples/loglog/TFopt-lrLog.c ${PREFIX}/share/examples/cgraph
|
||||
@${INSTALL_DATA} ${WRKSRC}/../examples/loglog/TFampspect.dat ${PREFIX}/share/examples/cgraph
|
||||
.endif
|
||||
.if ${PORTOBJFORMAT} == "aout"
|
||||
@${LN} -sf libcgraph.so.2.4 ${PREFIX}/lib/libcgraph.so
|
||||
.endif
|
||||
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
|
||||
|
||||
.include <bsd.port.post.mk>
|
1
graphics/Cgraph/distinfo
Normal file
1
graphics/Cgraph/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (Cgraph2.04.tar.gz) = abd35dddd307a693467e59c518d80b97
|
20
graphics/Cgraph/files/Makefile.lib
Normal file
20
graphics/Cgraph/files/Makefile.lib
Normal file
@ -0,0 +1,20 @@
|
||||
# makefile for Cgraph sources
|
||||
|
||||
LIBDIR = ${PREFIX}/lib
|
||||
|
||||
SHLIB_MAJOR= 2
|
||||
SHLIB_MINOR= 4
|
||||
LIB= cgraph
|
||||
|
||||
SRCS= bgdash.c bginit.c bgshow.c bgstart.c\
|
||||
glcmp.c gxaxs.c gxlog.c gyaxs.c gylog.c\
|
||||
gfont.c gcord.c gmlin.c gorig.c gprim.c\
|
||||
grmle.c grset.c gmark.c ggraycolor.c gstrk.c\
|
||||
gaxlabel.c gbott.c cgsave.c cgprint.c\
|
||||
gtext.c gtrnc.c gmesh.c gstyl.c gwdth.c\
|
||||
cg_newfuncs.c
|
||||
|
||||
beforeinstall:
|
||||
${INSTALL} -C -o ${BINOWN} -g ${BINGRP} -m 444 ${.CURDIR}/cgraph.h ${PREFIX}/include
|
||||
|
||||
.include <bsd.lib.mk>
|
11
graphics/Cgraph/files/patch-aa
Normal file
11
graphics/Cgraph/files/patch-aa
Normal file
@ -0,0 +1,11 @@
|
||||
--- gfont.c.orig Fri Sep 25 17:49:17 1998
|
||||
+++ gfont.c Fri Sep 25 17:49:30 1998
|
||||
@@ -5,7 +5,7 @@
|
||||
/* 9-09-87 starting */
|
||||
/******************************************************************/
|
||||
|
||||
-/* Modified on 5/13/92 to work on NeXt's
|
||||
+/* Modified on 5/13/92 to work on NeXt's */
|
||||
|
||||
|
||||
#include <string.h>
|
10
graphics/Cgraph/files/patch-ee
Normal file
10
graphics/Cgraph/files/patch-ee
Normal file
@ -0,0 +1,10 @@
|
||||
--- ../examples/loglog/TFopt-lrLog.c.orig Fri Sep 25 18:05:29 1998
|
||||
+++ ../examples/loglog/TFopt-lrLog.c Fri Sep 25 18:05:38 1998
|
||||
@@ -14,7 +14,6 @@
|
||||
#include <stdio.h>
|
||||
#include <math.h>
|
||||
#include <string.h>
|
||||
-#include <streams/streams.h>
|
||||
#include <cgraph.h>
|
||||
|
||||
#define PI 3.141592654
|
1
graphics/Cgraph/pkg-comment
Normal file
1
graphics/Cgraph/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A PostScript plotting library in C
|
7
graphics/Cgraph/pkg-descr
Normal file
7
graphics/Cgraph/pkg-descr
Normal file
@ -0,0 +1,7 @@
|
||||
Cgraph: PostScript plotting library in C
|
||||
|
||||
This is a C source code library that contains a set of C functions
|
||||
that generate PostScript for publication quality scientific plots.
|
||||
If you have a PostScript previewer, it is possible to launch the
|
||||
viewer automatically on generated PS/EPS files. The Cgraph Library
|
||||
source code, examples, and documentation are in the public domain.
|
15
graphics/Cgraph/pkg-plist
Normal file
15
graphics/Cgraph/pkg-plist
Normal file
@ -0,0 +1,15 @@
|
||||
include/cgraph.h
|
||||
lib/libcgraph.a
|
||||
lib/libcgraph_p.a
|
||||
lib/libcgraph.so
|
||||
lib/libcgraph.so.2.4
|
||||
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
|
||||
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
|
||||
share/doc/cgraph/cgraph.ps
|
||||
share/examples/cgraph/CGminimal.c
|
||||
share/examples/cgraph/dashlist.c
|
||||
share/examples/cgraph/markerlist.c
|
||||
share/examples/cgraph/TFopt-lrLog.c
|
||||
share/examples/cgraph/TFampspect.dat
|
||||
@dirrm share/doc/cgraph
|
||||
@dirrm share/examples/cgraph
|
Loading…
Reference in New Issue
Block a user