- Add patch which fixes build under certain configurations
PR: ports/38124 Submitted by: Leland Wang <llwang@infor.org> - Fix build for -current and add WITH_NE2000 knob PR: ports/38759 Submitted by: anholt
This commit is contained in:
parent
b7caa7d18f
commit
e60efd8dfc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=61536
@ -29,7 +29,7 @@ RUN_DEPENDS+= mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
|
||||
USE_XLIB= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_AUTOCONF= yes
|
||||
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ARGS= --enable-cdrom \
|
||||
--disable-split-hd
|
||||
@ -63,6 +63,10 @@ CONFIGURE_ARGS+= --enable-debugger --enable-disasm
|
||||
CONFIGURE_ARGS+= --enable-x86-debugger
|
||||
.endif
|
||||
|
||||
.if defined(WITH_NE2000)
|
||||
CONFIGURE_ARGS+= --enable-ne2000
|
||||
.endif
|
||||
|
||||
.if defined(WITH_SOUND)
|
||||
CONFIGURE_ARGS+= --enable-sb16=linux
|
||||
.endif
|
||||
@ -109,6 +113,11 @@ pre-everything::
|
||||
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_X86_DEBUGGER=yes\""
|
||||
@${ECHO_MSG}
|
||||
.endif
|
||||
.if !defined(WITH_NE2000)
|
||||
@${ECHO_MSG} "If you want to compile with networking (ne2000) support."
|
||||
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_NE2000=yes\""
|
||||
@${ECHO_MSG}
|
||||
.endif
|
||||
.if !defined(WITH_SOUND)
|
||||
@${ECHO_MSG} "If you want to compile with sound (blaster 16) support."
|
||||
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_SOUND=yes\""
|
||||
|
21
emulators/bochs/files/patch-configure.in
Normal file
21
emulators/bochs/files/patch-configure.in
Normal file
@ -0,0 +1,21 @@
|
||||
--- configure.in.orig Wed Mar 27 17:20:32 2002
|
||||
+++ configure.in Thu May 30 21:32:01 2002
|
||||
@@ -101,8 +101,16 @@
|
||||
AC_CHECK_FUNCS(usleep, AC_DEFINE(BX_HAVE_USLEEP))
|
||||
AC_CHECK_FUNCS(nanosleep, AC_DEFINE(BX_HAVE_NANOSLEEP))
|
||||
AC_CHECK_FUNCS(abort, AC_DEFINE(BX_HAVE_ABORT))
|
||||
-AC_CHECK_TYPE(socklen_t, AC_DEFINE(BX_HAVE_SOCKLEN_T), , [#include <sys/socket.h>])
|
||||
-
|
||||
+AC_MSG_CHECKING(for socklen_t)
|
||||
+AC_TRY_COMPILE([#include <sys/types.h>
|
||||
+ #include <sys/socket.h>],
|
||||
+ [socklen_t x],
|
||||
+ [
|
||||
+ AC_DEFINE(BX_HAVE_SOCKLEN_T)
|
||||
+ AC_MSG_RESULT(yes)
|
||||
+ ],
|
||||
+ AC_MSG_RESULT(no)
|
||||
+ )
|
||||
AC_MSG_CHECKING(for struct timeval)
|
||||
AC_TRY_COMPILE([#include <sys/time.h>],
|
||||
[struct timeval x;],
|
11
emulators/bochs/files/patch-main.cc
Normal file
11
emulators/bochs/files/patch-main.cc
Normal file
@ -0,0 +1,11 @@
|
||||
--- main.cc.orig Thu May 16 04:26:43 2002
|
||||
+++ main.cc Thu May 16 04:26:55 2002
|
||||
@@ -1174,7 +1174,7 @@
|
||||
BX_MEM(0)->load_ROM(bx_options.vgarom.Opath->getptr (), 0xc0000);
|
||||
BX_CPU(0)->init (BX_MEM(0));
|
||||
#if BX_SUPPORT_APIC
|
||||
- BX_CPU(0)->local_apic.set_id (i);
|
||||
+ BX_CPU(0)->local_apic.set_id (0);
|
||||
#endif
|
||||
BX_CPU(0)->reset(BX_RESET_HARDWARE);
|
||||
#else
|
Loading…
Reference in New Issue
Block a user