Update to 2.0.39.

Sponsored by:	Absolight
This commit is contained in:
Mathieu Arnold 2018-08-06 12:20:47 +00:00
parent 623b8232b7
commit e5aefe4e80
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=476509
9 changed files with 82 additions and 118 deletions

View File

@ -18,7 +18,7 @@ USES= gmake perl5 cpe
.include "${.CURDIR}/../munin-common/munin.mk"
ALL_TARGET= build-common-prime
ALL_TARGET= build-common
INSTALL_TARGET= install-common
NO_ARCH= yes

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1530519300
SHA256 (munin-2.0.38.tar.gz) = ee44c8c5e0a0a08c0378a7bd324b3bfa50bf84eef77760d2c20c21059fdb3099
SIZE (munin-2.0.38.tar.gz) = 2246848
TIMESTAMP = 1533554476
SHA256 (munin-2.0.39.tar.gz) = f2d5a84152f8d10b9694ed70efbdacb9312b79e8ef272ea3e669ae356749fb96
SIZE (munin-2.0.39.tar.gz) = 2249240

View File

@ -1,6 +1,6 @@
--- Makefile.orig 2018-06-29 00:50:01 UTC
--- Makefile.orig 2018-07-24 11:34:38 UTC
+++ Makefile
@@ -68,60 +68,47 @@ install: install-master-prime install-co
@@ -93,60 +93,47 @@ install: install-master-prime install-co
install-pre: Makefile Makefile.config
@$(CHECKUSER)
@ -88,7 +88,7 @@
# Not ready to be installed yet
# $(INSTALL) -m 0755 build/master/_bin/munin-gather $(LIBDIR)/
@@ -131,36 +118,30 @@ install-node-plugins: install-plugins-pr
@@ -156,36 +143,30 @@ install-node-plugins: install-plugins-pr
install-plugins-prime: install-plugins build $(PLUGINS) Makefile Makefile.config
@$(CHECKGROUP)
@ -108,14 +108,14 @@
@# Process the OS specific plugins at the end. Otherwise they would be overridden by the
@# generic ones.
for p in build/plugins/node.d/* build/plugins/node.d.$(OSTYPE)/* ; do \
if test -f "$$p" ; then \
echo Installing $$p; \
- $(INSTALL) -m 0755 $$p $(LIBDIR)/plugins/; \
+ $(INSTALL) -m 0755 $$p $(DESTDIR)$(LIBDIR)/plugins/; \
fi \
if test -f "$$p"; then \
echo Installing $$p; \
- $(INSTALL) -m 0755 $$p $(LIBDIR)/plugins/; \
+ $(INSTALL) -m 0755 $$p $(DESTDIR)$(LIBDIR)/plugins/; \
fi \
done
- @# Some HP-UX plugins need *.adv support files in LIBDIR
- if [ "$(OSTYPE)" = "hp-ux" ]; then mv $(LIBDIR)/plugins/*.adv $(LIBDIR); done
- if [ "$(OSTYPE)" = "hp-ux" ]; then mv $(LIBDIR)/plugins/*.adv $(LIBDIR); fi
- $(INSTALL) -m 0644 build/plugins/plugins.history $(LIBDIR)/plugins/
- $(INSTALL) -m 0644 build/plugins/plugin.sh $(LIBDIR)/plugins/
+ $(INSTALL) -m 0644 build/plugins/plugins.history $(DESTDIR)$(LIBDIR)/plugins/
@ -128,15 +128,15 @@
+ mkdir -p $(DESTDIR)$(JAVALIBDIR)
+ $(INSTALL) -m 0644 build/plugins/javalib/munin-jmx-plugins.jar $(DESTDIR)$(JAVALIBDIR)/
+ mkdir -p $(DESTDIR)$(LIBDIR)/plugins
for p in build/plugins/node.d.java/*; do \
if test -f "$$p" ; then \
echo Installing $$p; \
- $(INSTALL) -m 0755 $$p $(LIBDIR)/plugins/; \
+ $(INSTALL) -m 0755 $$p $(DESTDIR)$(LIBDIR)/plugins/; \
fi \
for p in build/plugins/node.d.java/*; do \
if test -f "$$p"; then \
echo Installing $$p; \
- $(INSTALL) -m 0755 $$p $(LIBDIR)/plugins/; \
+ $(INSTALL) -m 0755 $$p $(DESTDIR)$(LIBDIR)/plugins/; \
fi \
done
@@ -171,14 +152,14 @@ install-plugins-java: build-plugins-java
@@ -196,14 +177,14 @@ install-plugins-java: build-plugins-java
install-async-prime: install-async
install-async:
@ -155,7 +155,7 @@
install-common-prime: build-common install-common
@@ -444,7 +425,7 @@ t/install:
@@ -491,7 +472,7 @@ t/install:
# This builds */Build from Build.PL
%/Build: %/Build.PL
@ -164,11 +164,11 @@
build-%: %/Build
cd $* && $(PERL) Build
@@ -461,6 +442,7 @@ install-%: %/Build
--install_path sbin=$(SBINDIR) \
--install_path bindoc=$(MANDIR)/man1 \
--install_path libdoc=$(MANDIR)/man3 \
+ --destdir=$(DESTDIR)
@@ -507,6 +488,7 @@ install-%: %/Build
--install_path script=$(BINDIR) \
--install_path sbin=$(SBINDIR) \
--install_path bindoc=$(MANDIR)/man1 \
+ --destdir=$(DESTDIR) \
--install_path libdoc=$(MANDIR)/man3
test-%: %/Build
cd $* && $(PERL) Build test --verbose=0 || true

View File

@ -1,4 +1,4 @@
--- Makefile.config.orig 2014-11-24 21:46:24 UTC
--- Makefile.config.orig 2018-07-24 11:34:38 UTC
+++ Makefile.config
@@ -17,62 +17,62 @@
#
@ -90,8 +90,8 @@
+BASH := /usr/local/bin/bash
# Server only - Where to install the perl libraries
PERLSITELIB := $(shell $(PERL) -V:sitelib | cut -d"'" -f2)
@@ -129,9 +129,8 @@ CGIUSER := nobody
PERLLIB = $(DESTDIR)$(shell $(PERL) -V:sitelib | cut -d"'" -f2)
@@ -128,9 +128,8 @@ CGIUSER := nobody
# Which command to use to check if the USER and GROUP to run Munin as, exists.
# These will work on most modern OSes:
#

View File

@ -1,8 +1,8 @@
--- plugins/node.d/multiping.in.orig 2014-11-24 21:46:24 UTC
--- plugins/node.d/multiping.in.orig 2018-07-24 11:34:38 UTC
+++ plugins/node.d/multiping.in
@@ -59,6 +59,7 @@ if [ -z "$host" ]; then
host=${host:-${file_host:-www.google.com}}
fi
@@ -58,6 +58,7 @@ Foundation, Inc., 51 Franklin Street, Fi
host=${host:-www.google.com}
+site=0
if [ "$1" = "config" ]; then

View File

@ -1,11 +1,11 @@
--- plugins/node.d/multips_memory.in.orig 2017-01-18 20:25:20 UTC
--- plugins/node.d/multips_memory.in.orig 2018-07-24 11:34:38 UTC
+++ plugins/node.d/multips_memory.in
@@ -137,7 +137,7 @@ fi
for name in $names; do
fieldname="$(clean_fieldname "$name")"
- ps -eo $monitor,comm | gawk '
+ ps -eo $monitor,comm | awk '
- ps -eo "$monitor,comm" | gawk '
+ ps -eo "$monitor,comm" | awk '
BEGIN { total = "U"; } # U = Unknown.
/grep/ { next; }
$2 ~ /^'"$name"'$/ { total = total + ($1*1024); }

View File

@ -1,8 +1,8 @@
--- plugins/node.d/nutups_.in.orig 2014-11-24 21:46:24 UTC
--- plugins/node.d/nutups_.in.orig 2018-07-24 11:34:38 UTC
+++ plugins/node.d/nutups_.in
@@ -7,20 +7,25 @@
@@ -7,21 +7,25 @@
#
# usage: ups_upsid_function
# usage: nutups_upsid_function
#
+# env.upsc <command> (default: "/bin/upsc")
+# env.upsconf <filename> (default: "/etc/nut/ups.conf")
@ -10,58 +10,22 @@
#%# family=contrib
#%# capabilities=autoconf suggest
UPS=$(basename $0 | cut -d_ -f2)
FUNCTION=$(basename $0 | cut -d_ -f3)
+UPSC=${upsc:-/bin/upsc}
UPS=$(basename "$0" | cut -d_ -f2)
FUNCTION=$(basename "$0" | cut -d_ -f3)
UPSC=$(command -v upsc)
+UPSCONF=${upsconf:-/etc/nut/ups.conf}
if [ "$1" = "autoconf" ]; then
- [ -x /bin/upsc ] && [ -r /etc/nut/ups.conf ] && echo yes && exit 0
- echo "no (/bin/upsc or /etc/nut/ups.conf not found)"
+ [ -x $UPSC ] && [ -r $UPSCONF ] && echo yes && exit 0
- [ -x "$UPSC" ] && [ -r /etc/nut/ups.conf ] && echo yes && exit 0
- echo "no (upsc or /etc/nut/ups.conf not found)"
+ [ -x "$UPSC" ] && [ -r "$UPSCONF" ] && echo yes && exit 0
+ echo "no ($UPSC or $UPSCONF not found)"
exit 0
fi
if [ "$1" = "suggest" ]; then
- grep '^\[[^]]*\]$' /etc/nut/ups.conf \
+ grep '^\[[^]]*\]$' $UPSCONF \
+ grep '^\[[^]]*\]$' "$UPSCONF" \
| tr -d '][' \
| while read ups; do
| while read -r ups; do
for i in voltages freq charge current; do
@@ -42,7 +47,7 @@ voltages() {
echo "${i}.min 0"
done
else
- upsc $UPS | sed -n '/volt/{
+ $UPSC $UPS | sed -n '/volt/{
s/://
/nominal/s/.* /nominal.value /
/voltage/s/\.[^ ]*/.value/
@@ -64,7 +69,7 @@ charge() {
echo "${i}.min 0"
done
else
- upsc $UPS | sed -n '/charge/{
+ $UPSC $UPS | sed -n '/charge/{
s/^[^:]*\.//g
s/:/.value/
p
@@ -87,7 +92,7 @@ frequency() {
echo "acfreq.max 100"
echo "acfreq.min 5"
else
- upsc $UPS | sed -n '/freq/{s/.*:/acfreq.value/;p}'
+ $UPSC $UPS | sed -n '/freq/{s/.*:/acfreq.value/;p}'
fi
}
@@ -102,7 +107,7 @@ current() {
echo "current.max 100"
echo "current.min 0"
else
- upsc $UPS | sed -n '/current/{s/.*:/current.value/;p}'
+ $UPSC $UPS | sed -n '/current/{s/.*:/current.value/;p}'
fi
}

View File

@ -1,38 +1,38 @@
--- plugins/node.d/squeezebox_.in.orig 2018-03-25 14:01:24 UTC
--- plugins/node.d/squeezebox_.in.orig 2018-07-24 11:34:38 UTC
+++ plugins/node.d/squeezebox_.in
@@ -157,7 +157,7 @@ if [ "$CMD" = "years" ]; then
@@ -152,7 +152,7 @@ if [ "$CMD" = "years" ]; then
printf "graph_order y"
echo $years_array | sed 's/ / y/g'
echo "${years_array// / y}"
- for i in `seq 0 $no_of_years`; do
+ for i in `jot - 0 $no_of_years`; do
year=$(echo ${arr1[$i]})
if [ $year = 0 ]; then
echo y0.label No year
@@ -172,7 +172,7 @@ if [ "$CMD" = "years" ]; then
done
exit 0
fi
- for i in `seq 0 $no_of_years`; do
+ for i in `jot - 0 $no_of_years`; do
year=$(echo ${arr1[$i]})
printf "y%s.value " ${year}
printf "%b" "albums 0 0 year:${year}\nexit\n" | $NC $HOST $PORT | sed 's/%3A/:/g' | cut -d ':' -f 3
@@ -183,7 +183,7 @@ elif [ "$CMD" = "signalstrength" -o "$CM
echo "graph_category radio"
COUNT=$(printf "%b" "player count ?\nexit\n" | $NC $HOST $PORT | cut -d " " -f 3)
(( COUNT-- ))
- for ID in $(seq 0 $COUNT); do
+ for ID in $(jot - 0 $COUNT); do
MAC=$(printf "%b" "player id $ID ?\nexit\n" | $NC $HOST $PORT | cut -d " " -f 4 | sed 's/%3A/:/g')
NAME=$(printf "%b" "player name $MAC ?\nexit\n" | $NC $HOST $PORT | cut -d " " -f 4 | sed 's/%20/ /g')
MAC2=$(echo $MAC | sed 's/://g; s/\./_/g')
@@ -193,7 +193,7 @@ elif [ "$CMD" = "signalstrength" -o "$CM
- for i in $(seq 0 "$no_of_years"); do
+ for i in $(jot - 0 "$no_of_years"); do
year=${arr1[$i]}
if [ "$year" = 0 ]; then
echo "y0.label No year"
@@ -167,7 +167,7 @@ if [ "$CMD" = "years" ]; then
done
exit 0
fi
COUNT=$(printf "%b" "player count ?\nexit\n" | $NC $HOST $PORT | cut -d " " -f 3)
- for i in $(seq 0 "$no_of_years"); do
+ for i in $(jot - 0 "$no_of_years"); do
year=${arr1[$i]}
printf "y%s.value " "$year"
printf "%b" "albums 0 0 year:${year}\\nexit\\n" | "$NC" "$HOST" "$PORT" | sed 's/%3A/:/g' | cut -d ':' -f 3
@@ -178,7 +178,7 @@ elif [ "$CMD" = "signalstrength" ] || [
echo "graph_category radio"
COUNT=$(printf "%b" 'player count ?\nexit\n' | "$NC" "$HOST" "$PORT" | cut -d " " -f 3)
(( COUNT-- ))
- for ID in $(seq 0 "$COUNT"); do
+ for ID in $(jot - 0 "$COUNT"); do
MAC=$(printf "%b" "player id $ID ?\\nexit\\n" | "$NC" "$HOST" "$PORT" | cut -d " " -f 4 | sed 's/%3A/:/g')
NAME=$(printf "%b" "player name $MAC ?\\nexit\\n" | "$NC" "$HOST" "$PORT" | cut -d " " -f 4 | sed 's/%20/ /g')
MAC2=${MAC//:/}
@@ -189,7 +189,7 @@ elif [ "$CMD" = "signalstrength" ] || [
fi
COUNT=$(printf "%b" 'player count ?\nexit\n' | "$NC" "$HOST" "$PORT" | cut -d " " -f 3)
(( COUNT-- ))
- for ID in $(seq 0 $COUNT); do
+ for ID in $(jot - 0 $COUNT); do
MAC=$(printf "%b" "player id $ID ?\nexit\n" | $NC $HOST $PORT | cut -d " " -f 4 | sed 's/%3A/:/g')
VAL=$(printf "%b" "$MAC $CMD ?\nexit\n"| $NC $HOST $PORT | cut -d " " -f 2- | sed "s/$CMD //")
MAC2=$(echo $MAC| sed 's/://g')
- for ID in $(seq 0 "$COUNT"); do
+ for ID in $(jot - 0 "$COUNT"); do
MAC=$(printf "%b" "player id $ID ?\\nexit\\n" | "$NC" "$HOST" "$PORT" | cut -d " " -f 4 | sed 's/%3A/:/g')
VAL=$(printf "%b" "$MAC $CMD ?\\nexit\\n"| "$NC" "$HOST" "$PORT" | cut -d " " -f 2- | sed "s/$CMD //")
MAC2=${MAC//:/}

View File

@ -1,6 +1,6 @@
LICENSE= GPLv2
MUNIN_VERSION= 2.0.38
MUNIN_VERSION= 2.0.39
MUNIN_SITES= http://downloads.munin-monitoring.org/munin/stable/${MUNIN_VERSION}/
DISTINFO_FILE= ${.CURDIR}/../../sysutils/munin-common/distinfo
PATCHDIR= ${.CURDIR}/../../sysutils/munin-common/files