1) Revert change supporting for shared library build/installation

due to uncertainty: there are too many unsharable global variables.
Pointed out by Alexander Leidinger.
2) Due the last, revert to previous state without static library
installation
3) Revert patch template to patch-aa revision 1.7
4) Unique change that is not reverse related: update MASTER_SITES
using MASTER_SITE_SOURCEFORGE (joseph@randomnetworks.com)
5) PORTREVISION bump.

I am reverting this for I won't be around to discuss this for the
time being. :)

If anyone wants to, please contact the submitter.

Submitted by:	Alexander Leidinger <Alexander@leidinger.net>,
		Joseph Scott <joseph@randomnetworks.com>
This commit is contained in:
Mario Sergio Fujikawa Ferreira 2001-01-08 00:54:30 +00:00
parent ff5cd969e5
commit e5accf3361
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=36913
3 changed files with 31 additions and 22 deletions

View File

@ -7,21 +7,18 @@
PORTNAME= lame
PORTVERSION= 3.70
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://lame.sourceforge.net/download/beta/
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://lame.sourceforge.net/pub/
MASTER_SITE_SUBDIR= lame/src
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= yoshiaki@kt.rim.or.jp
EXTRA_PATCHES= ${WRKDIR}/patch-lib_version
USE_GMAKE= yes
WANT_GTK= yes
ALL_TARGET= lame
INSTALLS_SHLIB= yes
PLIST_SUB= LIB_VERSION="${LIB_VERSION}"
LIB_VERSION= 1
MAN1= lame.1
@ -31,15 +28,7 @@ MAN1= lame.1
USE_GTK= yes
.endif
pre-patch:
@${SED} "s!%%LIB_VERSION%%!${LIB_VERSION}!g" \
${FILESDIR}/template-extra-patch-lib_version \
> ${WRKDIR}/patch-lib_version
do-install:
@${INSTALL_DATA} ${WRKSRC}/libmp3lame.a ${PREFIX}/lib
@${INSTALL_DATA} ${WRKSRC}/libmp3lame.so.${LIB_VERSION} ${PREFIX}/lib
@${INSTALL_DATA} ${WRKSRC}/lame.h ${PREFIX}/include
@${INSTALL_PROGRAM} ${WRKSRC}/lame ${PREFIX}/bin
@${INSTALL_MAN} ${WRKSRC}/doc/man/lame.1 ${PREFIX}/man/man1
.if !defined(NOPORTDOCS)
@ -48,7 +37,4 @@ do-install:
${WRKSRC}/doc/html/*.css ${PREFIX}/share/doc/lame
.endif
post-install:
@${LN} -sf libmp3lame.so.${LIB_VERSION} ${PREFIX}/lib/libmp3lame.so
.include <bsd.port.post.mk>

27
audio/lame/files/patch-aa Normal file
View File

@ -0,0 +1,27 @@
--- Makefile.orig Sat Jul 1 15:31:35 2000
+++ Makefile Sat Jul 1 15:36:07 2000
@@ -11,8 +11,8 @@
# defaults:
PGM = lame
-CC = gcc
-CC_OPTS = -O
+CC ?= gcc
+CC_OPTS = ${CFLAGS}
GTK =
GTKLIBS =
SNDLIB = -DLAMESNDFILE
@@ -136,8 +136,10 @@
##########################################################################
ifeq ($(UNAME),FreeBSD)
# remove if you do not have GTK or do not want the GTK frame analyzer
- GTK = -DHAVEGTK `gtk12-config --cflags`
- GTKLIBS = `gtk12-config --libs`
+ifdef HAVE_GTK
+ GTK = -DHAVEGTK `$(GTK_CONFIG) --cflags`
+ GTKLIBS = `$(GTK_CONFIG) --libs`
+endif
# Comment out next 2 lines if you want to remove VBR histogram capability
BRHIST_SWITCH = -DBRHIST
LIBTERMCAP = -lncurses

View File

@ -1,8 +1,4 @@
bin/lame
include/lame.h
lib/libmp3lame.a
lib/libmp3lame.so
lib/libmp3lame.so.%%LIB_VERSION%%
share/doc/lame/contributors.html
share/doc/lame/examples.html
share/doc/lame/history.html