Update to upstream version 1.2.0

Detailed maintainer log:
- Runtime feature:
  - Backend library has been changed from libav to ffmpeg-4.1.
    Vulnerabilities of libav have been solved.
  - libx265 has been updated to 2.9.
  - Speex audio codec has been added for decode.
- Buildtime change:
  - Assembler has been changed from yasm to nasm.
  - Clang compiler has been supported.
    USE_GCC is omitted.
    We no longer need libc++ link option.
  - BUILD_DEPENDS on binutils have been omitted.
    Our ld(1) has --exclude-libs option on all supported versions of FreeBSD.
  - Configure script respects $(CC) envrionment variable.
    We no longer need to patch config.py.
  - Configure script looks up python2 from $PATH.
    We no longer need to fix shebang.
  - Provides port specific patches by $(CP).
    To avoid patch of patches.

PR:		234322
Submitted by:	naito.yuichiro@gmail.com (maintainer)
This commit is contained in:
Thomas Zander 2018-12-26 13:23:59 +00:00
parent f7af43abad
commit e53d64f58c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=488386
11 changed files with 55 additions and 65 deletions

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= handbrake
DISTVERSION= 1.1.2
PORTREVISION= 1
DISTVERSION= 1.2.0
CATEGORIES= multimedia
DIST_SUBDIR= ${PORTNAME}
@ -17,7 +16,7 @@ ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= invokes x86 assembler
BUILD_DEPENDS= bash:shells/bash \
yasm:devel/yasm \
nasm:devel/nasm \
cmake:devel/cmake
LIB_DEPENDS= libdbus-1.so:devel/dbus \
libharfbuzz.so:print/harfbuzz \
@ -26,6 +25,7 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libfribidi.so:converters/fribidi \
libxml2.so:textproc/libxml2 \
libass.so:multimedia/libass \
libspeex.so:audio/speex \
libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis \
libvorbisenc.so:audio/libvorbis \
@ -38,12 +38,12 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libjansson.so:devel/jansson
CONTRIB_FILES= fdk-aac-0.1.5.tar.gz \
libav-12.3.tar.gz \
ffmpeg-4.1.tar.bz2 \
libbluray-1.0.2.tar.bz2 \
libdvdnav-6.0.0.tar.bz2 \
libdvdread-6.0.0.tar.bz2 \
libvpx-1.7.0.tar.gz \
x265_2.6.tar.gz
x265_2.9.tar.gz
MASTER_SITES+= https://download.handbrake.fr/contrib/:contrib
DISTFILES+= ${CONTRIB_FILES:S/$/:contrib/}
@ -61,8 +61,6 @@ USE_GITHUB= yes
GH_ACCOUNT= HandBrake
GH_PROJECT= HandBrake
USE_GCC= yes
CONFIGURE_ARGS= --force --enable-x265
CONFIGURE_TARGET= build
@ -77,9 +75,6 @@ NOPRECIOUSMAKEVARS= yes # for ffmpeg and x264
# Enforce linking to bundled libraries instead of system libraries
LDFLAGS+= -L${BUILD_WRKSRC}/contrib/lib
# Enforce linking to the system c++ standard lib
LDFLAGS+= -l${COMPILER_FEATURES:Mlib*c++:S/lib//}
OPTIONS_DEFINE= FDK_AAC X11
OPTIONS_DEFAULT= X11
@ -94,16 +89,13 @@ LICENSE_NAME_FDK_AAC= Software License for The Fraunhofer FDK AAC Codec Library
LICENSE_FILE_FDK_AAC= ${WRKDIR}/${DISTFILES:Mfdk*:R:R}/NOTICE
LICENSE_PERMS_FDK_AAC= dist-mirror pkg-mirror auto-accept
# Recent GNU binutils are required to handle inline SSSE3 asm (in x264), and
# to support --exclude-libs option for ld(1) when building GUI program
X11_CONFIGURE_ENV= COMPILER_PATH=${LOCALBASE}/bin
X11_MAKE_ENV= COMPILER_PATH=${LOCALBASE}/bin
X11_CONFIGURE_ON= --disable-gtk-update-checks
X11_CONFIGURE_OFF= --disable-gtk
X11_BUILD_DEPENDS= ${LOCALBASE}/bin/ld:devel/binutils
X11_LIB_DEPENDS= libvpx.so:multimedia/libvpx \
libnotify.so:devel/libnotify
X11_USES= gettext desktop-file-utils
X11_USES= gettext desktop-file-utils gnome
X11_USE= gstreamer1=gdkpixbuf,libav \
gnome=gtk30,intltool,cairo,gdkpixbuf2
@ -114,10 +106,11 @@ post-extract: .SILENT
.for f in ${CONTRIB_FILES}
${CP} ${DISTDIR}/${DIST_SUBDIR}/${f} ${WRKSRC}/download
.endfor
post-patch:
@${REINPLACE_CMD} 's@python2 @${PYTHON_CMD} @' \
${WRKSRC}/gtk/src/Makefile.am
# Install version information.
${CP} ${FILESDIR}/version.txt ${WRKSRC}
# Following patches reduces warnings with clang.
${CP} ${FILESDIR}/P00-freebsd-libavutil-x86-asm-h.patch ${WRKSRC}/contrib/ffmpeg
${CP} ${FILESDIR}/P01-freebsd-ifo_types.h.patch ${WRKSRC}/contrib/libdvdread
post-install-X11-on:
${LN} -sf ghb ${STAGEDIR}${PREFIX}/bin/HandBrake

View File

@ -1,8 +1,8 @@
TIMESTAMP = 1536199029
TIMESTAMP = 1545096793
SHA256 (handbrake/fdk-aac-0.1.5.tar.gz) = 2164592a67b467e5b20fdcdaf5bd4c50685199067391c6fcad4fa5521c9b4dd7
SIZE (handbrake/fdk-aac-0.1.5.tar.gz) = 2091081
SHA256 (handbrake/libav-12.3.tar.gz) = 115b659022dd387f662e26fbc5bc0cc14ec18daa100003ffd34f4da0479b272e
SIZE (handbrake/libav-12.3.tar.gz) = 7582844
SHA256 (handbrake/ffmpeg-4.1.tar.bz2) = b684fb43244a5c4caae652af9022ed5d85ce15210835bce054a33fb26033a1a5
SIZE (handbrake/ffmpeg-4.1.tar.bz2) = 10687291
SHA256 (handbrake/libbluray-1.0.2.tar.bz2) = 6d9e7c4e416f664c330d9fa5a05ad79a3fb39b95adfc3fd6910cbed503b7aeff
SIZE (handbrake/libbluray-1.0.2.tar.bz2) = 733058
SHA256 (handbrake/libdvdnav-6.0.0.tar.bz2) = f0a2711b08a021759792f8eb14bb82ff8a3c929bf88c33b64ffcddaa27935618
@ -11,7 +11,7 @@ SHA256 (handbrake/libdvdread-6.0.0.tar.bz2) = b33b1953b4860545b75f6efc06e01d9849
SIZE (handbrake/libdvdread-6.0.0.tar.bz2) = 394627
SHA256 (handbrake/libvpx-1.7.0.tar.gz) = 1fec931eb5c94279ad219a5b6e0202358e94a93a90cfb1603578c326abfc1238
SIZE (handbrake/libvpx-1.7.0.tar.gz) = 2679797
SHA256 (handbrake/x265_2.6.tar.gz) = 1bf0036415996af841884802161065b9e6be74f5f6808ac04831363e2549cdbf
SIZE (handbrake/x265_2.6.tar.gz) = 1271976
SHA256 (handbrake/HandBrake-HandBrake-1.1.2_GH0.tar.gz) = fa66152d295dcd07c7c631fe5b3ccad8e4fef5fb0e367c8682fdc0a141ce62c3
SIZE (handbrake/HandBrake-HandBrake-1.1.2_GH0.tar.gz) = 15880248
SHA256 (handbrake/x265_2.9.tar.gz) = ebae687c84a39f54b995417c52a2fdde65a4e2e7ebac5730d251471304b91024
SIZE (handbrake/x265_2.9.tar.gz) = 1385848
SHA256 (handbrake/HandBrake-HandBrake-1.2.0_GH0.tar.gz) = fcf69f7642a278cd17b9a3fb9f299800962b2fa559e02e0cd798aa5e5e83b82c
SIZE (handbrake/HandBrake-HandBrake-1.2.0_GH0.tar.gz) = 18489017

View File

@ -0,0 +1,11 @@
--- a/libavutil/x86/asm.h.orig 2018-04-14 08:34:28.000000000 +0900
+++ b/libavutil/x86/asm.h 2018-06-23 22:34:29.258291000 +0900
@@ -72,7 +72,7 @@
typedef int x86_reg;
#endif
-#define HAVE_7REGS (ARCH_X86_64 || (HAVE_EBX_AVAILABLE && HAVE_EBP_AVAILABLE))
+#define HAVE_7REGS (ARCH_X86_64 || (HAVE_EBX_AVAILABLE && HAVE_EBP_AVAILABLE && !defined(__clang__)))
#define HAVE_6REGS (ARCH_X86_64 || (HAVE_EBX_AVAILABLE || HAVE_EBP_AVAILABLE))
#if ARCH_X86_64 && defined(PIC)

View File

@ -0,0 +1,11 @@
--- a/src/dvdread/ifo_types.h.orig 2015-06-27 19:35:59.043370000 +0200
+++ b/src/dvdread/ifo_types.h 2015-06-27 19:37:10.885577000 +0200
@@ -32,7 +32,7 @@
#if defined(__GNUC__)
#if __GNUC__ > 2 || (__GNUC__ == 2 && __GNUC_MINOR__ >= 95)
-#if __GNUC__ > 3 || (__GNUC__ == 3 && __GNUC_MINOR__ >= 4)
+#if (__GNUC__ > 3 || (__GNUC__ == 3 && __GNUC_MINOR__ >= 4)) && !defined(__clang__)
#define ATTRIBUTE_PACKED __attribute__ ((packed,gcc_struct))
#else
#define ATTRIBUTE_PACKED __attribute__ ((packed))

View File

@ -1,4 +1,4 @@
--- contrib/x265_10bit/module.defs.orig 2017-12-24 00:33:48 UTC
--- contrib/x265_10bit/module.defs.orig 2018-06-17 04:23:34 UTC
+++ contrib/x265_10bit/module.defs
@@ -19,6 +19,10 @@ X265_10.CONFIGURE.static =
X265_10.CONFIGURE.shared = -DENABLE_SHARED=OFF
@ -10,4 +10,4 @@
+
ifneq (none,$(X265_10.GCC.g))
X265_10.CONFIGURE.extra += -DCMAKE_BUILD_TYPE=Debug
endif
else

View File

@ -1,4 +1,4 @@
--- contrib/x265_12bit/module.defs.orig 2017-12-24 00:33:48 UTC
--- contrib/x265_12bit/module.defs.orig 2018-06-17 04:23:34 UTC
+++ contrib/x265_12bit/module.defs
@@ -19,6 +19,10 @@ X265_12.CONFIGURE.static =
X265_12.CONFIGURE.shared = -DENABLE_SHARED=OFF
@ -10,4 +10,4 @@
+
ifneq (none,$(X265_12.GCC.g))
X265_12.CONFIGURE.extra += -DCMAKE_BUILD_TYPE=Debug
endif
else

View File

@ -1,11 +0,0 @@
--- libhb/module.defs.orig 2018-01-13 05:30:25 UTC
+++ libhb/module.defs
@@ -49,7 +49,7 @@ LIBHB.GCC.D += __LIBHB__ USE_PTHREAD
LIBHB.GCC.I += $(LIBHB.build/) $(CONTRIB.build/)include
ifeq ($(BUILD.system),freebsd)
- LIBHB.GCC.I += /usr/local/include/libxml2
+ LIBHB.GCC.I += $(LOCALBASE)/include/libxml2
else ifneq (,$(filter $(BUILD.system),darwin cygwin mingw))
LIBHB.GCC.I += $(CONTRIB.build/)include/libxml2
else

View File

@ -1,6 +1,6 @@
--- libhb/nlmeans.c.orig 2017-10-05 21:17:34 UTC
--- libhb/nlmeans.c.orig 2018-06-17 04:23:34 UTC
+++ libhb/nlmeans.c
@@ -787,7 +787,7 @@ static int nlmeans_init(hb_filter_object
@@ -898,7 +898,7 @@ static int nlmeans_init(hb_filter_object_t *filter,
NLMeansFunctions *functions = &pv->functions;
functions->build_integral = build_integral_scalar;

View File

@ -1,11 +0,0 @@
--- make/configure.py.orig 2018-01-13 05:30:25 UTC
+++ make/configure.py
@@ -1515,7 +1515,7 @@ try:
class Tools:
ar = ToolProbe( 'AR.exe', 'ar' )
cp = ToolProbe( 'CP.exe', 'cp' )
- gcc = ToolProbe( 'GCC.gcc', 'gcc', IfHost( 'gcc-4', '*-*-cygwin*' ))
+ gcc = ToolProbe( 'GCC.gcc', 'gcc', IfHost( os.environ['CC'], '*-*-freebsd*' ), IfHost( 'gcc-4', '*-*-cygwin*' ))
if host.match( '*-*-darwin*' ):
gmake = ToolProbe( 'GMAKE.exe', 'make', 'gmake' )

View File

@ -1,12 +0,0 @@
--- version.txt.orig 2017-04-11 00:36:21 UTC
+++ version.txt
@@ -0,0 +1,9 @@
+URL=https://github.com/HandBrake/HandBrake.git
+HASH=df6c26fa261423237ee2bec0bf784c32cbfda3fa
+SHORTHASH=df6c26fa2
+TAG=1.1.2
+TAG_HASH=df6c26fa261423237ee2bec0bf784c32cbfda3fa
+REV=0
+BRANCH=
+REMOTE=https://github.com/HandBrake/HandBrake.git
+DATE=2018-09-04 15:35:01 -0400

View File

@ -0,0 +1,9 @@
URL=https://github.com/HandBrake/HandBrake.git
HASH=23bc08b55d58308862e940c97f2d1aeb0f07544b
SHORTHASH=23bc08b55
TAG=1.2.0
TAG_HASH=23bc08b55d58308862e940c97f2d1aeb0f07544b
REV=0
BRANCH=heads/1.2.0
REMOTE=https://github.com/HandBrake/HandBrake.git
DATE=2018-12-16 17:16:51 +0000