graphics/py-pyx: Update to 0.16
- Update WWW - Strip shared library Changes: https://github.com/pyx-project/pyx/releases https://github.com/pyx-project/pyx/blob/master/CHANGES
This commit is contained in:
parent
601f99ea56
commit
e4fcbc5dd3
@ -1,5 +1,5 @@
|
||||
PORTNAME= pyx
|
||||
PORTVERSION= 0.15
|
||||
PORTVERSION= 0.16
|
||||
CATEGORIES= graphics python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
@ -7,7 +7,8 @@ DISTNAME= PyX-${PORTVERSION}
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= Python package for creating encapsulated PostScript figures
|
||||
WWW= https://pyx-project.org/
|
||||
WWW= https://pyx-project.org/ \
|
||||
https://github.com/pyx-project/pyx
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
@ -23,12 +24,20 @@ T1CODE_DESC= Fast t1 font encoding/decoding
|
||||
|
||||
KPATHSEA_CFLAGS= -I${LOCALBASE}/include
|
||||
KPATHSEA_LDFLAGS= -L${LOCALBASE}/lib
|
||||
KPATHSEA_LIB_DEPENDS= libkpathsea.so:devel/tex-kpathsea
|
||||
KPATHSEA_VARS= KPATHSEA=1
|
||||
KPATHSEA_VARS_OFF= KPATHSEA=0
|
||||
T1CODE_CFLAGS= -I${LOCALBASE}/include
|
||||
T1CODE_VARS= T1CODE=1
|
||||
T1CODE_VARS_OFF= T1CODE=0
|
||||
|
||||
post-patch-KPATHSEA-on:
|
||||
@${REINPLACE_CMD} -e 's|build_pykpathsea=0|build_pykpathsea=1|' ${WRKSRC}/setup.cfg
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%KPATHSEA%%|${KPATHSEA}|; s|%%T1CODE%%|${T1CODE}|' ${WRKSRC}/setup.cfg
|
||||
|
||||
post-patch-T1CODE-on:
|
||||
@${REINPLACE_CMD} -e 's|build_t1code=0|build_t1code=1|' ${WRKSRC}/setup.cfg
|
||||
post-install-KPATHSEA-on:
|
||||
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
|
||||
|
||||
post-install-T1CODE-on:
|
||||
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1581963845
|
||||
SHA256 (PyX-0.15.tar.gz) = 0fc3b00c5e7fb6f4aefbf63b95f624297dde47700a82b8b5ad6ebb346b5e4977
|
||||
SIZE (PyX-0.15.tar.gz) = 2559840
|
||||
TIMESTAMP = 1669057893
|
||||
SHA256 (PyX-0.16.tar.gz) = 4d8e3e471cd3e9a9bd13d5086cdf7c0af1b0c3f3e195e74f5f63318dc40a66d8
|
||||
SIZE (PyX-0.16.tar.gz) = 626703
|
||||
|
11
graphics/py-pyx/files/patch-setup.cfg
Normal file
11
graphics/py-pyx/files/patch-setup.cfg
Normal file
@ -0,0 +1,11 @@
|
||||
--- setup.cfg.orig 2022-10-16 12:38:35 UTC
|
||||
+++ setup.cfg
|
||||
@@ -1,6 +1,6 @@
|
||||
[PyX]
|
||||
-build_t1code = 0
|
||||
-build_pykpathsea = 0
|
||||
+build_t1code = %%T1CODE%%
|
||||
+build_pykpathsea = %%KPATHSEA%%
|
||||
|
||||
[build_ext]
|
||||
|
Loading…
Reference in New Issue
Block a user