Use the MAN1 variable. Add the other half of patch-aa that causes
this port to respect BINOWN and MANOWN.
This commit is contained in:
parent
249efab97e
commit
e4be841dab
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=12714
@ -3,19 +3,18 @@
|
||||
# Date created: 8 July 1997
|
||||
# Whom: Antti Kaipila <anttik@iki.fi>
|
||||
#
|
||||
# $Id: Makefile,v 1.2 1998/01/05 17:12:11 vanilla Exp $
|
||||
# $Id: Makefile,v 1.3 1998/06/27 05:34:55 hoek Exp $
|
||||
#
|
||||
|
||||
DISTNAME= cdplay-0.92
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ftp://ftp.one.sci.fi/pub/cdplay/
|
||||
|
||||
MAINTAINER= anttik@iki.fi
|
||||
MAINTAINER= anttik@iki.fi
|
||||
|
||||
MAN1= cdplay.1
|
||||
|
||||
pre-patch:
|
||||
@${GUNZIP_CMD} ${WRKSRC}/cdplay.1.gz
|
||||
|
||||
post-patch:
|
||||
@${GZIP_CMD} ${WRKSRC}/cdplay.1
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,6 +1,5 @@
|
||||
diff -ur ../cdplay-0.92.orig/Makefile ./Makefile
|
||||
--- ../cdplay-0.92.orig/Makefile Fri Nov 7 19:32:07 1997
|
||||
+++ ./Makefile Sat Jun 27 00:36:45 1998
|
||||
--- Makefile.orig Fri Nov 7 16:32:07 1997
|
||||
+++ Makefile Fri Aug 21 22:57:43 1998
|
||||
@@ -26,11 +26,11 @@
|
||||
BIN=cdplay
|
||||
CDDEVICE=\"/dev/rcd0c\"
|
||||
@ -16,3 +15,12 @@ diff -ur ../cdplay-0.92.orig/Makefile ./Makefile
|
||||
|
||||
all: main term cd sound link
|
||||
|
||||
@@ -56,6 +56,6 @@
|
||||
@rm cdplay
|
||||
install:
|
||||
@echo Installing binary
|
||||
- @install -c -o root -g wheel -m 755 cdplay $(BINPATH)
|
||||
+ @$(BSD_INSTALL_PROGRAM) cdplay $(BINPATH)
|
||||
@echo Installing manpage
|
||||
- @install -c -o root -g wheel -m 755 cdplay.1.gz $(MANPATH)
|
||||
+ @$(BSD_INSTALL_MAN) cdplay.1 $(MANPATH)
|
||||
|
@ -1,2 +1 @@
|
||||
man/man1/cdplay.1.gz
|
||||
bin/cdplay
|
||||
|
Loading…
Reference in New Issue
Block a user