www/minio: create port
Minio is an object storage server built for cloud application developers and devops. WWW: https://minio.io/
This commit is contained in:
parent
84b9758ad8
commit
e4be3e244f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=424767
@ -403,6 +403,7 @@
|
||||
SUBDIR += midori
|
||||
SUBDIR += mimetex
|
||||
SUBDIR += mini_httpd
|
||||
SUBDIR += minio
|
||||
SUBDIR += mitmproxy
|
||||
SUBDIR += mkapachepw
|
||||
SUBDIR += mknmz-wwwoffle
|
||||
|
26
www/minio/Makefile
Normal file
26
www/minio/Makefile
Normal file
@ -0,0 +1,26 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= minio
|
||||
PORTVERSION= 2016.10.24.21.23.47
|
||||
CATEGORIES= www
|
||||
|
||||
MAINTAINER= swills@FreeBSD.org
|
||||
COMMENT= Amazon S3 compatible object storage server
|
||||
|
||||
BUILD_DEPENDS= go>=1.6:lang/go \
|
||||
bash:shells/bash
|
||||
|
||||
USES= gmake
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_TAGNAME= RELEASE.2016-10-24T21-23-47Z
|
||||
GH_SUBDIR= src/github.com/${GH_ACCOUNT}/${PORTNAME}
|
||||
MAKE_ENV= GOPATH=${WRKSRC} GOROOT=${LOCALBASE}/go
|
||||
|
||||
STRIP= # stripping can break go binaries
|
||||
PLIST_FILES= bin/minio
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
|
||||
|
||||
.include <bsd.port.mk>
|
3
www/minio/distinfo
Normal file
3
www/minio/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1477484969
|
||||
SHA256 (minio-minio-2016.10.24.21.23.47-RELEASE.2016-10-24T21-23-47Z_GH0.tar.gz) = 1c70f7c9964cc7e67dee479ca6e24952a1756b30182e8ad012e8f32dd4d3c547
|
||||
SIZE (minio-minio-2016.10.24.21.23.47-RELEASE.2016-10-24T21-23-47Z_GH0.tar.gz) = 1441818
|
24
www/minio/files/patch-Makefile
Normal file
24
www/minio/files/patch-Makefile
Normal file
@ -0,0 +1,24 @@
|
||||
--- Makefile.orig 2016-10-24 20:34:01 UTC
|
||||
+++ Makefile
|
||||
@@ -95,7 +95,7 @@ cyclo:
|
||||
@GO15VENDOREXPERIMENT=1 ${GOPATH}/bin/gocyclo -over 65 cmd
|
||||
@GO15VENDOREXPERIMENT=1 ${GOPATH}/bin/gocyclo -over 65 pkg
|
||||
|
||||
-build: getdeps verifiers $(UI_ASSETS)
|
||||
+build: $(UI_ASSETS)
|
||||
|
||||
deadcode:
|
||||
@GO15VENDOREXPERIMENT=1 ${GOPATH}/bin/deadcode
|
||||
@@ -131,10 +131,10 @@ pkg-list:
|
||||
|
||||
install: gomake-all
|
||||
|
||||
-release: verifiers
|
||||
+release:
|
||||
@MINIO_RELEASE=RELEASE ./buildscripts/build.sh
|
||||
|
||||
-experimental: verifiers
|
||||
+experimental:
|
||||
@MINIO_RELEASE=EXPERIMENTAL ./buildscripts/build.sh
|
||||
|
||||
clean:
|
28
www/minio/files/patch-buildscripts_gen-ldflags.go
Normal file
28
www/minio/files/patch-buildscripts_gen-ldflags.go
Normal file
@ -0,0 +1,28 @@
|
||||
--- buildscripts/gen-ldflags.go.orig 2016-10-24 20:34:01 UTC
|
||||
+++ buildscripts/gen-ldflags.go
|
||||
@@ -23,15 +23,13 @@ import (
|
||||
"os"
|
||||
"os/exec"
|
||||
"strings"
|
||||
- "time"
|
||||
)
|
||||
|
||||
func genLDFlags(version string) string {
|
||||
var ldflagsStr string
|
||||
- ldflagsStr = "-X github.com/minio/minio/cmd.Version=" + version
|
||||
- ldflagsStr += " -X github.com/minio/minio/cmd.ReleaseTag=" + releaseTag(version)
|
||||
- ldflagsStr += " -X github.com/minio/minio/cmd.CommitID=" + commitID()
|
||||
- ldflagsStr += " -X github.com/minio/minio/cmd.ShortCommitID=" + commitID()[:12]
|
||||
+ ldflagsStr = "-X github.com/minio/minio/cmd.Version=2016-10-24T21:23:47Z"
|
||||
+ ldflagsStr += " -X github.com/minio/minio/cmd.ReleaseTag=RELEASE.2016-10-24T21-23-47Z"
|
||||
+ ldflagsStr += " -X github.com/minio/minio/cmd.CommitID=048af5e5cdc1344e83231c09079828a3d289e6df"
|
||||
ldflagsStr += " -X github.com/minio/minio/cmd.GOPATH=" + os.Getenv("GOPATH")
|
||||
return ldflagsStr
|
||||
}
|
||||
@@ -67,5 +65,5 @@ func commitID() string {
|
||||
}
|
||||
|
||||
func main() {
|
||||
- fmt.Println(genLDFlags(time.Now().UTC().Format(time.RFC3339)))
|
||||
+ fmt.Println(genLDFlags("2016-10-24T21:23:47Z"))
|
||||
}
|
4
www/minio/pkg-descr
Normal file
4
www/minio/pkg-descr
Normal file
@ -0,0 +1,4 @@
|
||||
Minio is an object storage server built for cloud application developers and
|
||||
devops.
|
||||
|
||||
WWW: https://minio.io/
|
Loading…
Reference in New Issue
Block a user