Netscape 4.07 and 4.08 have multiple published security holes.

Please use Netscape 4.80 instead.
This commit is contained in:
Trevor Johnson 2002-10-17 10:14:05 +00:00
parent ea117cbd34
commit e48ad0f9da
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=68196
19 changed files with 0 additions and 835 deletions

View File

@ -137,7 +137,6 @@
SUBDIR += linux-flashplugin
SUBDIR += linux-lesstif-ns
SUBDIR += linux-mozilla
SUBDIR += linux-netscape4
SUBDIR += linux-netscape47-communicator
SUBDIR += linux-netscape47-navigator
SUBDIR += linux-opera
@ -227,7 +226,6 @@
SUBDIR += netscape3
SUBDIR += netscape3-gold
SUBDIR += netscape4-communicator
SUBDIR += netscape4-communicator.us
SUBDIR += netscape4-navigator
SUBDIR += netscape47-communicator
SUBDIR += netscape47-navigator

View File

@ -1,45 +0,0 @@
# New ports collection makefile for: linux-netscape4
# Date created: 24 Feb 1997
# Whom: ache
#
# $FreeBSD$
#
PORTNAME= linux-netscape
PORTVERSION= 4.08
CATEGORIES= www linux
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= tom
DISTNAME= communicator-v408-export.x86-unknown-linux2.0_libc5
MAINTAINER= ports@FreeBSD.org
# This should have been marked FORBIDDEN long ago. - nectar 2002/02/10
FORBIDDEN= "Multiple vulnerabilities: see http://www.securityfocus.com/bid/2637, http://www.securityfocus.com/bid/1726"
RUN_DEPENDS= /compat/linux/lib/ld.so:${PORTSDIR}/emulators/linux_base \
netscape:${PORTSDIR}/www/netscape-wrapper
ONLY_FOR_ARCHS= i386
WRKSRC= ${WRKDIR}/communicator-v408.x86-unknown-linux2.0
NO_BUILD= Yes
NDIR= ${PREFIX}/lib/netscape
BINDIR= ${PREFIX}/bin
do-install:
cd ${WRKSRC} && yes "" | \
LC_TIME=C MOZILLA_HOME="${NDIR}" ./ns-install
${MV} -f ${NDIR}/netscape ${NDIR}/netscape.bin
${INSTALL_SCRIPT} ${WRKSRC}/netscape ${BINDIR}/netscape.run
if [ ! -f ${NDIR}/mailcap ] ; then \
${INSTALL_DATA} ${FILESDIR}/mailcap ${NDIR}; \
fi
${RM} -rf ${NDIR}/nls ${NDIR}/movemail-src ${NDIR}/XKeysymDB
${CHOWN} -R ${BINOWN}:${BINGRP} ${NDIR}
post-install:
@${CAT} ${DESCR}
.include <bsd.port.mk>

View File

@ -1 +0,0 @@
MD5 (communicator-v408-export.x86-unknown-linux2.0_libc5.tar.gz) = 1e3b92b821c898d213b587e8a2908daa

View File

@ -1,69 +0,0 @@
# Example .mailcap file for FreeBSD machines
#
# First a note about syntax:
# The first token in a configuration line represents a mime type.
# A mime type is of the form "SubGroup/Item" and either token
# can be replaced by the wildcard character "*"
#
# the second token is the command that you would run
# when the specified mime type is encountered. An example
# would be "xv %s" where %s will be replaced by a filename
#
# remaining tokens represent name value pairs.
#
# the "test=<SOME TEST COMMAND>" pair invokes the test command
# specified and checks the UNIX shell return code to see if the
# test passed. If the test passes the mime mapping is made, otherwise
# the mapping is not made.
#
# the "stream-buffer-size=<NUMBER>" pair tells the application
# to use a popen command to invoke the program specified and to
# pipe all data into the command. Only programs that can handle
# piped input can use this method. When this method is used
# a "%s" should not be included in the command. You should
# make sure that the program you wish to use can accept piped
# data by trying something like this before using it:
# cat "YOUR_DATA_FILE_HERE" | COMMAND_TO_TEST
#
# You may continue lines by using the backslash character "\"
# FreeBSD doesn't seem to support `sfplay' yet, but if a port comes
# along then the following should be enabled.
#
# plays AIFF files
#audio/x-aiff; sfplay %s
# plays AIFC files
#audio/x-aifc; sfplay %s
# FreeBSD has no wavplay utility either, but if someone
# would care to port one then this can also be used.
# plays WAV files
#audio/x-wav; wavplay %s > /dev/null 2>&1
# FreeBSD /dev/audio is sun compliant
audio/basic; cat %s > /dev/audio
# use this to play MPEG audio if you have maplay installed
audio/x-mpeg; maplay -; stream-buffer-size=2000
# use this to play MPEG video files if you have mpeg_play installed
video/mpeg; mpeg_play -quiet %s
# All other anims go well with xanim (if installed)
video/*; xanim %s > /dev/null 2>&1
# use this to display postscript files
application/postscript; ghostview %s
# use this to display pdf files
application/pdf; xpdf %s 2>/dev/null
# this is the default for non GIF or JPEG images
image/*; xv %s
# if you would prefer an external viewer for GIF and JPEG images
# uncomment the following lines for XV to act as your external viewer.
#image/gif; xv %s
#image/jpg; xv %s
#image/jpeg; xv %s

View File

@ -1,7 +0,0 @@
#!/bin/sh
export XKEYSYMDB ; XKEYSYMDB=@X11BASE@/lib/X11/XKeysymDB
export XNLSPATH ; XNLSPATH=@X11BASE@/lib/X11/nls
export XAPPLRESDIR ; XAPPLRESDIR=@X11BASE@/lib/X11/app-defaults
export MOZILLA_HOME; MOZILLA_HOME=${MOZILLA_HOME:=@PREFIX@/lib/netscape}
export CLASSPATH ; CLASSPATH=.:$MOZILLA_HOME
exec $MOZILLA_HOME/netscape.bin $*

View File

@ -1,57 +0,0 @@
--- ns-install.orig Tue Nov 3 22:27:09 1998
+++ ns-install Wed Jan 27 18:16:33 1999
@@ -120,6 +120,7 @@
# Even though the user has already used gzip to extract the file (or
# we wouldn't be here), make sure we can find it.
#
+unset GZIP
GZIP="gzip"
flag=1
while test ${flag} -eq 1
@@ -294,10 +295,10 @@
# avoid users having to set MOZILLA_JAVA_FONT_PROPERTY_PATH, or
# just assuming Java font-handling is broken.
#
- if test ! -z "`ls /bin/uname`"
+ if test ! -z "`ls /usr/bin/uname`"
then
MOVE_FONTS="TRUE"
- case `/bin/uname` in
+ case `/usr/bin/uname` in
AIX)
PLATFORM="aix"
;;
@@ -324,14 +325,6 @@
# Is this a virgin install? If so, create the .netscape dir
# and put the default bookmark file in it.
#
- if test ! -d ${HOME}/.netscape
- then
- # New install, or upgrade from 0.x or 1.x.
- mkdir ${HOME}/.netscape
- cp ${TARGET}/bookmark.htm ${HOME}/.netscape/bookmarks.html
- chmod 644 ${HOME}/.netscape/bookmarks.html
- echo "${HOME}/.netscape/bookmarks.html" >> ${LOGFILE}
- fi
fi
echo ""
@@ -393,18 +386,6 @@
then
echo "ERROR: Installation completed, but unable to update/create the product"
echo " version registry."
- echo ""
- echo " If you are installing ${PRODUCT} from a platform other than"
- echo " that for which this package is intended, 'vreg' will not be"
- echo " able to run. If this is the case, you may run 'vreg' manually"
- echo " (to enable ASD) on the appropriate platform using the following"
- echo " commands:"
- echo ""
- awk '{printf("\techo \"%s\" >>/tmp/infile\n", $0)}' ${REG_INFILE}
- echo " ${TARGET}/vreg ${TARGET}/${VREGISTRY} /tmp/infile"
- echo ""
- /bin/rm -f ns-install ${PACKAGE} ${REG_INFILE} core
- exit 3
fi
echo ""

View File

@ -1 +0,0 @@
Linux version of Netscape Communicator

View File

@ -1,5 +0,0 @@
This is the Linux version of Netscape Communicator. You might wish
to use this version if you wish to run Linux plugins, for example.
Please read the file "/usr/local/lib/netscape/LICENSE" for
the licensing terms.

View File

@ -1,199 +0,0 @@
bin/netscape.run
lib/netscape/LICENSE
lib/netscape/Netscape.ad
lib/netscape/README
lib/netscape/bookmark.htm
lib/netscape/dynfonts/libTrueDoc.so
lib/netscape/java/classes/aix/font.properties
lib/netscape/java/classes/aix/font.properties.cs
lib/netscape/java/classes/aix/font.properties.hu
lib/netscape/java/classes/aix/font.properties.ja
lib/netscape/java/classes/aix/font.properties.ko
lib/netscape/java/classes/aix/font.properties.pl
lib/netscape/java/classes/aix/font.properties.ru
lib/netscape/java/classes/aix/font.properties.zh
lib/netscape/java/classes/aix/font.properties.zh_TW
lib/netscape/java/classes/awt.properties
lib/netscape/java/classes/font.properties
lib/netscape/java/classes/font.properties.cs
lib/netscape/java/classes/font.properties.el
lib/netscape/java/classes/font.properties.hu
lib/netscape/java/classes/font.properties.ja
lib/netscape/java/classes/font.properties.ko
lib/netscape/java/classes/font.properties.lt
lib/netscape/java/classes/font.properties.lv
lib/netscape/java/classes/font.properties.pl
lib/netscape/java/classes/font.properties.ru
lib/netscape/java/classes/font.properties.tr
lib/netscape/java/classes/font.properties.zh
lib/netscape/java/classes/font.properties.zh_GB2312
lib/netscape/java/classes/font.properties.zh_TW
lib/netscape/java/classes/font.properties.zh_TW_Big5
lib/netscape/java/classes/font.properties.zh_TW_CNS11643
lib/netscape/java/classes/hpux/font.properties
lib/netscape/java/classes/hpux/font.properties.bg
lib/netscape/java/classes/hpux/font.properties.cs
lib/netscape/java/classes/hpux/font.properties.el
lib/netscape/java/classes/hpux/font.properties.hr
lib/netscape/java/classes/hpux/font.properties.hu
lib/netscape/java/classes/hpux/font.properties.ja
lib/netscape/java/classes/hpux/font.properties.ko
lib/netscape/java/classes/hpux/font.properties.pl
lib/netscape/java/classes/hpux/font.properties.ro
lib/netscape/java/classes/hpux/font.properties.ru
lib/netscape/java/classes/hpux/font.properties.sk
lib/netscape/java/classes/hpux/font.properties.sl
lib/netscape/java/classes/hpux/font.properties.tr
lib/netscape/java/classes/hpux/font.properties.zh_GB2312
lib/netscape/java/classes/hpux/font.properties.zh_TW_Big5
lib/netscape/java/classes/hpux/font.properties.zh_TW_CNS11643
lib/netscape/java/classes/ifc11.jar
lib/netscape/java/classes/iiop10.jar
lib/netscape/java/classes/irix/font.properties
lib/netscape/java/classes/irix/font.properties.cs
lib/netscape/java/classes/irix/font.properties.el
lib/netscape/java/classes/irix/font.properties.hu
lib/netscape/java/classes/irix/font.properties.ja
lib/netscape/java/classes/irix/font.properties.ko
lib/netscape/java/classes/irix/font.properties.zh_GB2312
lib/netscape/java/classes/irix/font.properties.zh_TW_Big5
lib/netscape/java/classes/irix/font.properties.zh_TW_CNS11643
lib/netscape/java/classes/jae40.jar
lib/netscape/java/classes/java40.jar
lib/netscape/java/classes/jio40.jar
lib/netscape/java/classes/jsd10.jar
lib/netscape/java/classes/ldap10.jar
lib/netscape/java/classes/scd10.jar
lib/netscape/libjsd.so
lib/netscape/libnullplugin-dynMotif.so
lib/netscape/mailcap
lib/netscape/movemail
lib/netscape/nethelp/Back_dep.gif
lib/netscape/nethelp/Back_dis.gif
lib/netscape/nethelp/Back_sel.gif
lib/netscape/nethelp/Back_up.gif
lib/netscape/nethelp/Blank.htm
lib/netscape/nethelp/Button.js
lib/netscape/nethelp/CntData.js
lib/netscape/nethelp/CntTool.htm
lib/netscape/nethelp/CntTool.js
lib/netscape/nethelp/Exit_dep.gif
lib/netscape/nethelp/Exit_sel.gif
lib/netscape/nethelp/Exit_up.gif
lib/netscape/nethelp/Forw_dep.gif
lib/netscape/nethelp/Forw_dis.gif
lib/netscape/nethelp/Forw_sel.gif
lib/netscape/nethelp/Forw_up.gif
lib/netscape/nethelp/Header.js
lib/netscape/nethelp/IdxData.js
lib/netscape/nethelp/IdxFill.htm
lib/netscape/nethelp/IdxKey.htm
lib/netscape/nethelp/IdxTool.htm
lib/netscape/nethelp/IdxTopic.htm
lib/netscape/nethelp/Local-1.js
lib/netscape/nethelp/NSHIfrm.htm
lib/netscape/nethelp/NavUI.htm
lib/netscape/nethelp/NoJSerr.htm
lib/netscape/nethelp/Prnt_dep.gif
lib/netscape/nethelp/Prnt_sel.gif
lib/netscape/nethelp/Prnt_up.gif
lib/netscape/nethelp/Stack.js
lib/netscape/nethelp/Status.htm
lib/netscape/nethelp/System.htm
lib/netscape/nethelp/System.js
lib/netscape/nethelp/ToolUI.htm
lib/netscape/nethelp/Tool_dep.gif
lib/netscape/nethelp/Tool_sel.gif
lib/netscape/nethelp/Tool_up.gif
lib/netscape/nethelp/Topic.js
lib/netscape/nethelp/Utility.js
lib/netscape/nethelp/Wait.gif
lib/netscape/nethelp/netscape/collabra/coll.htm
lib/netscape/nethelp/netscape/collabra/collHdr.htm
lib/netscape/nethelp/netscape/collabra/collabra.gif
lib/netscape/nethelp/netscape/collabra/discgrps.gif
lib/netscape/nethelp/netscape/collabra/help.hpf
lib/netscape/nethelp/netscape/composer/comp.htm
lib/netscape/nethelp/netscape/composer/compHdr.htm
lib/netscape/nethelp/netscape/composer/composer.gif
lib/netscape/nethelp/netscape/composer/comtlbr2.gif
lib/netscape/nethelp/netscape/composer/fmtlbr3.gif
lib/netscape/nethelp/netscape/composer/help.hpf
lib/netscape/nethelp/netscape/composer/tagicon2.gif
lib/netscape/nethelp/netscape/confernc/brws2.gif
lib/netscape/nethelp/netscape/confernc/chat2.gif
lib/netscape/nethelp/netscape/confernc/circle2.gif
lib/netscape/nethelp/netscape/confernc/conf.htm
lib/netscape/nethelp/netscape/confernc/confHdr.htm
lib/netscape/nethelp/netscape/confernc/confernc.gif
lib/netscape/nethelp/netscape/confernc/eraser2.gif
lib/netscape/nethelp/netscape/confernc/fhndtl2.gif
lib/netscape/nethelp/netscape/confernc/filex2.gif
lib/netscape/nethelp/netscape/confernc/help.hpf
lib/netscape/nethelp/netscape/confernc/horline2.gif
lib/netscape/nethelp/netscape/confernc/line2.gif
lib/netscape/nethelp/netscape/confernc/pointer2.gif
lib/netscape/nethelp/netscape/confernc/rect2.gif
lib/netscape/nethelp/netscape/confernc/txttool2.gif
lib/netscape/nethelp/netscape/confernc/whtbd2.gif
lib/netscape/nethelp/netscape/home/help.hpf
lib/netscape/nethelp/netscape/home/home.gif
lib/netscape/nethelp/netscape/home/home.htm
lib/netscape/nethelp/netscape/home/homeHdr.htm
lib/netscape/nethelp/netscape/messengr/help.hpf
lib/netscape/nethelp/netscape/messengr/mailbox.gif
lib/netscape/nethelp/netscape/messengr/mess.htm
lib/netscape/nethelp/netscape/messengr/messHdr.htm
lib/netscape/nethelp/netscape/messengr/messengr.gif
lib/netscape/nethelp/netscape/messengr/mpctrl.gif
lib/netscape/nethelp/netscape/navigatr/help.hpf
lib/netscape/nethelp/netscape/navigatr/nav.htm
lib/netscape/nethelp/netscape/navigatr/navHdr.htm
lib/netscape/nethelp/netscape/navigatr/navigatr.gif
lib/netscape/nethelp/netscape/netcastr/help.hpf
lib/netscape/nethelp/netscape/netcastr/net.htm
lib/netscape/nethelp/netscape/netcastr/netHdr.htm
lib/netscape/nethelp/netscape/netcastr/netcastr.gif
lib/netscape/nethelp/netscape/nscal/index.html
lib/netscape/nethelp/netscape/shared/Contents.htm
lib/netscape/nethelp/netscape/shared/NetHelp1.css
lib/netscape/nethelp/netscape/shared/admnIcon.gif
lib/netscape/nethelp/netscape/shared/calIcon.gif
lib/netscape/nethelp/netscape/shared/collIcon.gif
lib/netscape/nethelp/netscape/shared/commIcon.gif
lib/netscape/nethelp/netscape/shared/compIcon.gif
lib/netscape/nethelp/netscape/shared/confIcon.gif
lib/netscape/nethelp/netscape/shared/ibmIcon.gif
lib/netscape/nethelp/netscape/shared/messIcon.gif
lib/netscape/nethelp/netscape/shared/navIcon.gif
lib/netscape/nethelp/netscape/shared/netIcon.gif
lib/netscape/nethelp/netwatch.gif
lib/netscape/nethelp/picsfail.htm
lib/netscape/nethelp/picsfail.jar
lib/netscape/netscape-dynMotif
lib/netscape/netscape.bin
lib/netscape/plugins/libnullplugin.so
lib/netscape/registry
lib/netscape/spell/netscape.dic
lib/netscape/spell/pen4s324.dat
lib/netscape/vreg
@dirrm lib/netscape/spell
@dirrm lib/netscape/plugins
@dirrm lib/netscape/nethelp/netscape/shared
@dirrm lib/netscape/nethelp/netscape/nscal
@dirrm lib/netscape/nethelp/netscape/netcastr
@dirrm lib/netscape/nethelp/netscape/navigatr
@dirrm lib/netscape/nethelp/netscape/messengr
@dirrm lib/netscape/nethelp/netscape/home
@dirrm lib/netscape/nethelp/netscape/confernc
@dirrm lib/netscape/nethelp/netscape/composer
@dirrm lib/netscape/nethelp/netscape/collabra
@dirrm lib/netscape/nethelp/netscape
@dirrm lib/netscape/nethelp
@dirrm lib/netscape/java/classes/irix
@dirrm lib/netscape/java/classes/hpux
@dirrm lib/netscape/java/classes/aix
@dirrm lib/netscape/java/classes
@dirrm lib/netscape/java
@dirrm lib/netscape/dynfonts
@dirrm lib/netscape

View File

@ -1,6 +0,0 @@
#!/bin/sh
sed -e "s;@X11BASE@;${X11BASE};g" -e "s;@PREFIX@;${PREFIX};g" \
${FILESDIR}/netscape.sh >${WRKSRC}/netscape
chmod +x ${WRKSRC}/netscape

View File

@ -1,75 +0,0 @@
# ex:ts=8
# Ports collection makefile for: netscape (full communicator version)
# Date created: 14 Feb 1998
# Whom: obrien@cs.ucdavis.edu
#
# $FreeBSD$
#
PORTNAME= netscape-communicator
PORTVERSION= 4.07.us
CATEGORIES= www linux
DISTNAME= communicator-v407-us.x86-unknown-linux2.0_libc5
MAINTAINER= ports@FreeBSD.org
RUN_DEPENDS= /compat/linux/lib/ld-linux.so.1:${PORTSDIR}/emulators/linux_base
FORBIDDEN= "Has a serious security hole, use 4.77 or later instead"
NO_LATEST_LINK= yes
ONLY_FOR_ARCHS= i386
NO_FETCH= yes
NO_BUILD= Yes
WRKSRC= ${WRKDIR}/communicator-v407.x86-unknown-linux2.0
NDIR= ${PREFIX}/lib/netscape.us
BINDIR= ${PREFIX}/bin
.include <bsd.port.pre.mk>
# Need to define USA_RESIDENT to YES or NO
.if !defined(USA_RESIDENT) || (${USA_RESIDENT} != YES && ${USA_RESIDENT} != yes && ${USA_RESIDENT} != NO && ${USA_RESIDENT} != no)
pre-fetch:
@${ECHO}
@${ECHO} You must set variable USA_RESIDENT to YES, if you are USA or
@${ECHO} Canadian resident, in order to build this package.
@${ECHO} There is no version of this port for NON-USA and NON-Canadian users.
@${ECHO}
@${FALSE}
#
.elif defined(USA_RESIDENT)
.if ${USA_RESIDENT} == YES || ${USA_RESIDENT} == yes
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE='You must manually obtain ${DISTNAME}${EXTRACT_SUFX} distribution and place it in ${DISTDIR}.'
.endif
.else
pre-fetch:
@${ECHO}
@${ECHO} There is no version of this port for NON-USA and NON-Canadian users.
@${ECHO}
@${FALSE}
.endif
.endif
do-install:
cd ${WRKSRC} && \
yes "" | LC_TIME=C MOZILLA_HOME="${NDIR}" ./ns-install
${MV} -f ${NDIR}/netscape ${NDIR}/communicator-4.07.us.bin
${INSTALL_SCRIPT} ${WRKSRC}/netscape ${BINDIR}/communicator-4.07.us
${LN} -sf communicator-4.07.us ${BINDIR}/communicator-4.us
${LN} -sf communicator-4.07.us ${BINDIR}/netscape.us
if [ ! -f ${NDIR}/mailcap ] ; then \
${INSTALL_DATA} ${FILESDIR}/mailcap ${NDIR}; \
fi
${RM} -rf ${NDIR}/netscape-dynMotif
${RM} -rf ${NDIR}/libnullplugin-dynMotif.so
${RM} -rf ${NDIR}/movemail-src
${CHOWN} -R ${BINOWN}:${BINGRP} ${NDIR}
post-install:
@${CAT} ${DESCR}
.include <bsd.port.post.mk>

View File

@ -1 +0,0 @@
MD5 (communicator-v407-us.x86-unknown-linux2.0_libc5.tar.gz) = e3b8fe597e9ed539e97ff1e6bbd5fb35

View File

@ -1,69 +0,0 @@
# Example .mailcap file for FreeBSD machines
#
# First a note about syntax:
# The first token in a configuration line represents a mime type.
# A mime type is of the form "SubGroup/Item" and either token
# can be replaced by the wildcard character "*"
#
# the second token is the command that you would run
# when the specified mime type is encountered. An example
# would be "xv %s" where %s will be replaced by a filename
#
# remaining tokens represent name value pairs.
#
# the "test=<SOME TEST COMMAND>" pair invokes the test command
# specified and checks the UNIX shell return code to see if the
# test passed. If the test passes the mime mapping is made, otherwise
# the mapping is not made.
#
# the "stream-buffer-size=<NUMBER>" pair tells the application
# to use a popen command to invoke the program specified and to
# pipe all data into the command. Only programs that can handle
# piped input can use this method. When this method is used
# a "%s" should not be included in the command. You should
# make sure that the program you wish to use can accept piped
# data by trying something like this before using it:
# cat "YOUR_DATA_FILE_HERE" | COMMAND_TO_TEST
#
# You may continue lines by using the backslash character "\"
# FreeBSD doesn't seem to support `sfplay' yet, but if a port comes
# along then the following should be enabled.
#
# plays AIFF files
#audio/x-aiff; sfplay %s
# plays AIFC files
#audio/x-aifc; sfplay %s
# FreeBSD has no wavplay utility either, but if someone
# would care to port one then this can also be used.
# plays WAV files
#audio/x-wav; wavplay %s > /dev/null 2>&1
# FreeBSD /dev/audio is sun compliant
audio/basic; cat %s > /dev/audio
# use this to play MPEG audio if you have maplay installed
audio/x-mpeg; maplay -; stream-buffer-size=2000
# use this to play MPEG video files if you have mpeg_play installed
video/mpeg; mpeg_play -quiet %s
# All other anims go well with xanim (if installed)
video/*; xanim %s > /dev/null 2>&1
# use this to display postscript files
application/postscript; ghostview %s
# use this to display pdf files
application/pdf; xpdf %s 2>/dev/null
# this is the default for non GIF or JPEG images
image/*; xv %s
# if you would prefer an external viewer for GIF and JPEG images
# uncomment the following lines for XV to act as your external viewer.
#image/gif; xv %s
#image/jpg; xv %s
#image/jpeg; xv %s

View File

@ -1,5 +0,0 @@
#!/bin/sh
export MOZILLA_HOME; MOZILLA_HOME=${MOZILLA_HOME:=@PREFIX@/lib/netscape.us}
export CLASSPATH ; CLASSPATH=.:$MOZILLA_HOME
export XCMSDB; XCMSDB=/dev/null
exec $MOZILLA_HOME/communicator-4.07.us.bin $*

View File

@ -1,77 +0,0 @@
--- ns-install.orig Tue Sep 29 20:59:31 1998
+++ ns-install Wed Oct 7 06:11:53 1998
@@ -120,6 +120,7 @@
# Even though the user has already used gzip to extract the file (or
# we wouldn't be here), make sure we can find it.
#
+unset GZIP
GZIP="gzip"
flag=1
while test ${flag} -eq 1
@@ -288,10 +289,10 @@
# avoid users having to set MOZILLA_JAVA_FONT_PROPERTY_PATH, or
# just assuming Java font-handling is broken.
#
- if test ! -z "`ls /bin/uname`"
+ if test ! -z "`ls /usr/bin/uname`"
then
MOVE_FONTS="TRUE"
- case `/bin/uname` in
+ case `/usr/bin/uname` in
AIX)
PLATFORM="aix"
;;
@@ -318,14 +319,14 @@
# Is this a virgin install? If so, create the .netscape dir
# and put the default bookmark file in it.
#
- if test ! -d ${HOME}/.netscape
- then
- # New install, or upgrade from 0.x or 1.x.
- mkdir ${HOME}/.netscape
- cp ${TARGET}/bookmark.htm ${HOME}/.netscape/bookmarks.html
- chmod 644 ${HOME}/.netscape/bookmarks.html
- echo "${HOME}/.netscape/bookmarks.html" >> ${LOGFILE}
- fi
+# if test ! -d ${HOME}/.netscape
+# then
+# # New install, or upgrade from 0.x or 1.x.
+# mkdir ${HOME}/.netscape
+# cp ${TARGET}/bookmark.htm ${HOME}/.netscape/bookmarks.html
+# chmod 644 ${HOME}/.netscape/bookmarks.html
+# echo "${HOME}/.netscape/bookmarks.html" >> ${LOGFILE}
+# fi
fi
echo ""
@@ -387,18 +388,18 @@
then
echo "ERROR: Installation completed, but unable to update/create the product"
echo " version registry."
- echo ""
- echo " If you are installing ${PRODUCT} from a platform other than"
- echo " that for which this package is intended, 'vreg' will not be"
- echo " able to run. If this is the case, you may run 'vreg' manually"
- echo " (to enable ASD) on the appropriate platform using the following"
- echo " commands:"
- echo ""
- awk '{printf("\techo \"%s\" >>/tmp/infile\n", $0)}' ${REG_INFILE}
- echo " ${TARGET}/vreg ${TARGET}/${VREGISTRY} /tmp/infile"
- echo ""
- /bin/rm -f ns-install ${PACKAGE} ${REG_INFILE} core
- exit 3
+# echo ""
+# echo " If you are installing ${PRODUCT} from a platform other than"
+# echo " that for which this package is intended, 'vreg' will not be"
+# echo " able to run. If this is the case, you may run 'vreg' manually"
+# echo " (to enable ASD) on the appropriate platform using the following"
+# echo " commands:"
+# echo ""
+# awk '{printf("\techo \"%s\" >>/tmp/infile\n", $0)}' ${REG_INFILE}
+# echo " ${TARGET}/vreg ${TARGET}/${VREGISTRY} /tmp/infile"
+# echo ""
+# /bin/rm -f ns-install ${PACKAGE} ${REG_INFILE} core
+# exit 3
fi
echo ""

View File

@ -1 +0,0 @@
Netscape ver 4 communicator w/US strong encryption

View File

@ -1,10 +0,0 @@
This is the Linux version of the netscape web-surfboard with strong
encryption.
Please read the file "/usr/local/lib/netscape.us/LICENSE" for the licensing
terms.
Note: If Java applets fail to display. Type this as root:
cd /usr/X11R6/lib/X11/fonts/misc
/usr/X11R6/bin/mkfontdir
chmod 444 fonts.dir
And then exit and restart your X server.

View File

@ -1,199 +0,0 @@
bin/communicator-4.07.us
@exec ln -sf %f %B/communicator-4.us
@exec ln -sf communicator-4.us %B/netscape.us
@unexec rm -f %B/communicator-4.us
@unexec rm -f %B/netscape.us
lib/netscape.us/LICENSE
lib/netscape.us/Netscape.ad
lib/netscape.us/README
lib/netscape.us/XKeysymDB
lib/netscape.us/bookmark.htm
lib/netscape.us/communicator-4.07.us.bin
lib/netscape.us/dynfonts/libTrueDoc.so
lib/netscape.us/java/classes/aix/font.properties
lib/netscape.us/java/classes/aix/font.properties.cs
lib/netscape.us/java/classes/aix/font.properties.hu
lib/netscape.us/java/classes/aix/font.properties.ja
lib/netscape.us/java/classes/aix/font.properties.ko
lib/netscape.us/java/classes/aix/font.properties.pl
lib/netscape.us/java/classes/aix/font.properties.ru
lib/netscape.us/java/classes/aix/font.properties.zh
lib/netscape.us/java/classes/aix/font.properties.zh_TW
lib/netscape.us/java/classes/awt.properties
lib/netscape.us/java/classes/font.properties
lib/netscape.us/java/classes/font.properties.cs
lib/netscape.us/java/classes/font.properties.el
lib/netscape.us/java/classes/font.properties.hu
lib/netscape.us/java/classes/font.properties.ja
lib/netscape.us/java/classes/font.properties.ko
lib/netscape.us/java/classes/font.properties.lt
lib/netscape.us/java/classes/font.properties.lv
lib/netscape.us/java/classes/font.properties.pl
lib/netscape.us/java/classes/font.properties.ru
lib/netscape.us/java/classes/font.properties.tr
lib/netscape.us/java/classes/font.properties.zh
lib/netscape.us/java/classes/font.properties.zh_GB2312
lib/netscape.us/java/classes/font.properties.zh_TW
lib/netscape.us/java/classes/font.properties.zh_TW_Big5
lib/netscape.us/java/classes/font.properties.zh_TW_CNS11643
lib/netscape.us/java/classes/hpux/font.properties
lib/netscape.us/java/classes/hpux/font.properties.bg
lib/netscape.us/java/classes/hpux/font.properties.cs
lib/netscape.us/java/classes/hpux/font.properties.el
lib/netscape.us/java/classes/hpux/font.properties.hr
lib/netscape.us/java/classes/hpux/font.properties.hu
lib/netscape.us/java/classes/hpux/font.properties.ja
lib/netscape.us/java/classes/hpux/font.properties.ko
lib/netscape.us/java/classes/hpux/font.properties.pl
lib/netscape.us/java/classes/hpux/font.properties.ro
lib/netscape.us/java/classes/hpux/font.properties.ru
lib/netscape.us/java/classes/hpux/font.properties.sk
lib/netscape.us/java/classes/hpux/font.properties.sl
lib/netscape.us/java/classes/hpux/font.properties.tr
lib/netscape.us/java/classes/hpux/font.properties.zh_GB2312
lib/netscape.us/java/classes/hpux/font.properties.zh_TW_Big5
lib/netscape.us/java/classes/hpux/font.properties.zh_TW_CNS11643
lib/netscape.us/java/classes/ifc11.jar
lib/netscape.us/java/classes/iiop10.jar
lib/netscape.us/java/classes/irix/font.properties
lib/netscape.us/java/classes/irix/font.properties.cs
lib/netscape.us/java/classes/irix/font.properties.el
lib/netscape.us/java/classes/irix/font.properties.hu
lib/netscape.us/java/classes/irix/font.properties.ja
lib/netscape.us/java/classes/irix/font.properties.ko
lib/netscape.us/java/classes/irix/font.properties.zh_GB2312
lib/netscape.us/java/classes/irix/font.properties.zh_TW_Big5
lib/netscape.us/java/classes/irix/font.properties.zh_TW_CNS11643
lib/netscape.us/java/classes/jae40.jar
lib/netscape.us/java/classes/java40.jar
lib/netscape.us/java/classes/jio40.jar
lib/netscape.us/java/classes/jsd10.jar
lib/netscape.us/java/classes/ldap10.jar
lib/netscape.us/java/classes/scd10.jar
lib/netscape.us/libjsd.so
lib/netscape.us/mailcap
lib/netscape.us/movemail
lib/netscape.us/nethelp/Back_dep.gif
lib/netscape.us/nethelp/Back_dis.gif
lib/netscape.us/nethelp/Back_sel.gif
lib/netscape.us/nethelp/Back_up.gif
lib/netscape.us/nethelp/Blank.htm
lib/netscape.us/nethelp/Button.js
lib/netscape.us/nethelp/CntData.js
lib/netscape.us/nethelp/CntTool.htm
lib/netscape.us/nethelp/CntTool.js
lib/netscape.us/nethelp/Exit_dep.gif
lib/netscape.us/nethelp/Exit_sel.gif
lib/netscape.us/nethelp/Exit_up.gif
lib/netscape.us/nethelp/Forw_dep.gif
lib/netscape.us/nethelp/Forw_dis.gif
lib/netscape.us/nethelp/Forw_sel.gif
lib/netscape.us/nethelp/Forw_up.gif
lib/netscape.us/nethelp/Header.js
lib/netscape.us/nethelp/IdxData.js
lib/netscape.us/nethelp/IdxFill.htm
lib/netscape.us/nethelp/IdxKey.htm
lib/netscape.us/nethelp/IdxTool.htm
lib/netscape.us/nethelp/IdxTopic.htm
lib/netscape.us/nethelp/Local-1.js
lib/netscape.us/nethelp/NSHIfrm.htm
lib/netscape.us/nethelp/NavUI.htm
lib/netscape.us/nethelp/NoJSerr.htm
lib/netscape.us/nethelp/Prnt_dep.gif
lib/netscape.us/nethelp/Prnt_sel.gif
lib/netscape.us/nethelp/Prnt_up.gif
lib/netscape.us/nethelp/Stack.js
lib/netscape.us/nethelp/Status.htm
lib/netscape.us/nethelp/System.htm
lib/netscape.us/nethelp/System.js
lib/netscape.us/nethelp/ToolUI.htm
lib/netscape.us/nethelp/Tool_dep.gif
lib/netscape.us/nethelp/Tool_sel.gif
lib/netscape.us/nethelp/Tool_up.gif
lib/netscape.us/nethelp/Topic.js
lib/netscape.us/nethelp/Utility.js
lib/netscape.us/nethelp/Wait.gif
lib/netscape.us/nethelp/netscape/collabra/coll.htm
lib/netscape.us/nethelp/netscape/collabra/collHdr.htm
lib/netscape.us/nethelp/netscape/collabra/collabra.gif
lib/netscape.us/nethelp/netscape/collabra/discgrps.gif
lib/netscape.us/nethelp/netscape/collabra/help.hpf
lib/netscape.us/nethelp/netscape/composer/comp.htm
lib/netscape.us/nethelp/netscape/composer/compHdr.htm
lib/netscape.us/nethelp/netscape/composer/composer.gif
lib/netscape.us/nethelp/netscape/composer/comtlbr2.gif
lib/netscape.us/nethelp/netscape/composer/fmtlbr3.gif
lib/netscape.us/nethelp/netscape/composer/help.hpf
lib/netscape.us/nethelp/netscape/composer/tagicon2.gif
lib/netscape.us/nethelp/netscape/confernc/brws2.gif
lib/netscape.us/nethelp/netscape/confernc/chat2.gif
lib/netscape.us/nethelp/netscape/confernc/circle2.gif
lib/netscape.us/nethelp/netscape/confernc/conf.htm
lib/netscape.us/nethelp/netscape/confernc/confHdr.htm
lib/netscape.us/nethelp/netscape/confernc/confernc.gif
lib/netscape.us/nethelp/netscape/confernc/eraser2.gif
lib/netscape.us/nethelp/netscape/confernc/fhndtl2.gif
lib/netscape.us/nethelp/netscape/confernc/filex2.gif
lib/netscape.us/nethelp/netscape/confernc/help.hpf
lib/netscape.us/nethelp/netscape/confernc/horline2.gif
lib/netscape.us/nethelp/netscape/confernc/line2.gif
lib/netscape.us/nethelp/netscape/confernc/pointer2.gif
lib/netscape.us/nethelp/netscape/confernc/rect2.gif
lib/netscape.us/nethelp/netscape/confernc/txttool2.gif
lib/netscape.us/nethelp/netscape/confernc/whtbd2.gif
lib/netscape.us/nethelp/netscape/home/help.hpf
lib/netscape.us/nethelp/netscape/home/home.gif
lib/netscape.us/nethelp/netscape/home/home.htm
lib/netscape.us/nethelp/netscape/home/homeHdr.htm
lib/netscape.us/nethelp/netscape/messengr/help.hpf
lib/netscape.us/nethelp/netscape/messengr/mailbox.gif
lib/netscape.us/nethelp/netscape/messengr/mess.htm
lib/netscape.us/nethelp/netscape/messengr/messHdr.htm
lib/netscape.us/nethelp/netscape/messengr/messengr.gif
lib/netscape.us/nethelp/netscape/messengr/mpctrl.gif
lib/netscape.us/nethelp/netscape/navigatr/help.hpf
lib/netscape.us/nethelp/netscape/navigatr/nav.htm
lib/netscape.us/nethelp/netscape/navigatr/navHdr.htm
lib/netscape.us/nethelp/netscape/navigatr/navigatr.gif
lib/netscape.us/nethelp/netscape/netcastr/help.hpf
lib/netscape.us/nethelp/netscape/netcastr/net.htm
lib/netscape.us/nethelp/netscape/netcastr/netHdr.htm
lib/netscape.us/nethelp/netscape/netcastr/netcastr.gif
lib/netscape.us/nethelp/netscape/nscal/index.html
lib/netscape.us/nethelp/netscape/shared/Contents.htm
lib/netscape.us/nethelp/netscape/shared/NetHelp1.css
lib/netscape.us/nethelp/netscape/shared/admnIcon.gif
lib/netscape.us/nethelp/netscape/shared/calIcon.gif
lib/netscape.us/nethelp/netscape/shared/collIcon.gif
lib/netscape.us/nethelp/netscape/shared/commIcon.gif
lib/netscape.us/nethelp/netscape/shared/compIcon.gif
lib/netscape.us/nethelp/netscape/shared/confIcon.gif
lib/netscape.us/nethelp/netscape/shared/ibmIcon.gif
lib/netscape.us/nethelp/netscape/shared/messIcon.gif
lib/netscape.us/nethelp/netscape/shared/navIcon.gif
lib/netscape.us/nethelp/netscape/shared/netIcon.gif
lib/netscape.us/nethelp/netwatch.gif
lib/netscape.us/nethelp/picsfail.htm
lib/netscape.us/nethelp/picsfail.jar
lib/netscape.us/plugins/libnullplugin.so
lib/netscape.us/registry
lib/netscape.us/spell/netscape.dic
lib/netscape.us/spell/pen4s324.dat
lib/netscape.us/vreg
@dirrm lib/netscape.us/dynfonts
@dirrm lib/netscape.us/java/classes
@dirrm lib/netscape.us/java
@dirrm lib/netscape.us/nethelp/netscape/collabra
@dirrm lib/netscape.us/nethelp/netscape/composer
@dirrm lib/netscape.us/nethelp/netscape/confernc
@dirrm lib/netscape.us/nethelp/netscape/home
@dirrm lib/netscape.us/nethelp/netscape/messengr
@dirrm lib/netscape.us/nethelp/netscape/navigatr
@dirrm lib/netscape.us/nethelp/netscape/netcastr
@dirrm lib/netscape.us/nethelp/netscape/nscal
@dirrm lib/netscape.us/nethelp/netscape/shared
@dirrm lib/netscape.us/nethelp/netscape
@dirrm lib/netscape.us/nethelp
@dirrm lib/netscape.us/plugins
@dirrm lib/netscape.us/spell
@dirrm lib/netscape.us

View File

@ -1,6 +0,0 @@
#!/bin/sh
sed -e "s;@X11BASE@;${X11BASE};g" -e "s;@PREFIX@;${PREFIX};g" \
${FILESDIR}/netscape.sh >${WRKSRC}/netscape
chmod +x ${WRKSRC}/netscape