9e - a simple Plan9 distribution unpacker

PR:		ports/19459
Submitted by:	Jerry Hicks <jhix@mindspring.com>
This commit is contained in:
Wes Peters 2000-06-27 03:55:27 +00:00
parent 54f8f282be
commit e44dc6976a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=29900
7 changed files with 94 additions and 0 deletions

21
archivers/9e/Makefile Normal file
View File

@ -0,0 +1,21 @@
# New ports collection makefile for: 9e
# Date created: 17 Mar 1999
# Whom: Jerry Hicks
#
# $FreeBSD$
#
PORTNAME= 9e
PORTVERSION= 1.0
CATEGORIES= archivers
MASTER_SITES= http://www.eecs.harvard.edu/~wkj/Software/9e/
DISTNAME= 9e
MAINTAINER= jhix@mindspring.com
WWW= http://www.eecs.harvard.edu/~wkj/Software/9e/
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/9e ${PREFIX}/bin
.include <bsd.port.mk>

1
archivers/9e/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (9e.tar.gz) = ffb6c9963c6bb61ddfc456fd29f96073

View File

@ -0,0 +1,27 @@
--- Makefile.orig Thu Jun 22 18:59:41 2000
+++ Makefile Thu Jun 22 19:04:02 2000
@@ -1,14 +1,9 @@
# Makefile for 9e
-CC = gcc
-
-CFLAGS = -g3 -ggdb
+CFLAGS = -O
.PHONY: all clean distclean
-LIBS = -lefence
-
-HDRS = 9a.h
SRCS = 9e.c
OBJS = 9e.o
@@ -17,7 +12,7 @@
all: $(BINARIES)
9e: $(OBJS)
- $(CC) -o 9e 9e.o $(LIBS)
+ $(CC) -o 9e 9e.o
clean:
rm -f *.o *~ a.out

View File

@ -0,0 +1,23 @@
--- 9e.c.orig Thu Jun 15 13:40:52 2000
+++ 9e.c Fri Jun 23 04:16:00 2000
@@ -139,17 +139,16 @@
}
if(Hdrs) {
- fprintf(stderr, "%s %lo %s %s %ld %ld\n", namebuf, mode,
+ fprintf(stderr, "%s %lo %s %s %ld %ld\n", name, mode,
owner, group, mtime, size);
fout = NULL;
} else {
if (Verbose)
- fprintf(stderr, "%s %d\n", namebuf, size);
+ fprintf(stderr, "%s\n", name);
if(mode & CHDIR) {
assert(size == 0);
/* Give ourselves read, write, and execute permission */
- if(mkdir(name, (mode & ~CHDIR) | 0700) < 0)
- warn("mkdir(2) failed for", name);
+ mkdir(name, (mode & ~CHDIR) | 0700);
continue;
}
if((fout=fopen(name, "w+b")) == NULL)

1
archivers/9e/pkg-comment Normal file
View File

@ -0,0 +1 @@
Explode Plan9 archives

20
archivers/9e/pkg-descr Normal file
View File

@ -0,0 +1,20 @@
9e is a program to explose Plan9 archives. You can do whatever you
like with the source so long as you clearly indicate all modifications
and the author responsible for each.
Usage Summary:
$9e [options] <file> ...
Options:
-h: dump headers only
-v: dump file names and sizes while extracting
-r: specify alternate root directory
-?: help
If no file is named on the command line, standard input is assumed.
Note that the input file must be a decompressed archive (decompress
with gzip).
WWW: http://www.eecs.harvard.edu/~wkj/Software/9e/

1
archivers/9e/pkg-plist Normal file
View File

@ -0,0 +1 @@
bin/9e