Upgrade to version 5.3.6.

Pending issues:

   - Support for long doubles was disabled (does not build on 9.x.)

   - Using readline/rep causes a core dump on SIGWINCH.

   - Calls to (find-seconds 0 0 0 1 5 1970 #f) fail, so a bit of
     documentation was cut out as it broke the build by using this
     specific call.
This commit is contained in:
Jimmy Olgeni 2013-10-07 13:11:03 +00:00
parent 6418503dcc
commit e44105a5bb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=329701
9 changed files with 27492 additions and 25362 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= racket-textual
PORTVERSION= 5.3.1
PORTVERSION= 5.3.6
CATEGORIES= lang scheme
MASTER_SITES= http://download.racket-lang.org/installers/${PORTVERSION}/${PORTNAME}/ \
http://www.eecs.northwestern.edu/racket/${PORTVERSION}/${PORTNAME}/ \
@ -30,7 +30,6 @@ CONFIGURE_ARGS= --enable-shared --enable-pthread \
--enable-lt=${LIBTOOL}
CONFIGURE_SCRIPT=../configure
NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${ARCH} == "i386"
@ -54,11 +53,9 @@ USES+= iconv
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:env
MAN1= mzc.1 mzscheme.1 racket.1 raco.1 setup-plt.1
ONLY_FOR_ARCHS= i386 amd64
PLIST_SUB+= ARCH=${ARCH}
RACKET_PLIST= ${WRKDIR}/pkg-plist
.include <bsd.port.pre.mk>

View File

@ -1,2 +1,2 @@
SHA256 (racket-textual/5.3.1/racket-textual-5.3.1-src-unix.tgz) = 10386a01d1c666a4215a11bb8410b8af7a6f18d75fd9bc63c4780591751f4f14
SIZE (racket-textual/5.3.1/racket-textual-5.3.1-src-unix.tgz) = 6134415
SHA256 (racket-textual/5.3.6/racket-textual-5.3.6-src-unix.tgz) = 7561f68c2c39d2c8d2b20521c25be7e6a3ae6941d658531abec8a8dff0607790
SIZE (racket-textual/5.3.6/racket-textual-5.3.6-src-unix.tgz) = 6266358

View File

@ -0,0 +1,17 @@
$FreeBSD$
--- ../racket/include/scheme.h.orig
+++ ../racket/include/scheme.h
@@ -63,11 +63,6 @@
# define MZ_USE_SINGLE_FLOATS
#endif
-/* gcc defines __SSE_MATH__ when SSE floating point is enabled: */
-#ifdef __SSE_MATH__
-# define C_COMPILER_USES_SSE 1
-#endif
-
#ifdef C_COMPILER_USES_SSE
# if defined(MZ_TRY_EXTFLONUMS) && !defined(MZ_NO_EXTFLONUMS)
# define MZ_LONG_DOUBLE

File diff suppressed because it is too large Load Diff

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= racket
PORTVERSION= 5.3.1
PORTVERSION= 5.3.6
CATEGORIES= lang scheme
MASTER_SITES= http://download.racket-lang.org/installers/${PORTVERSION}/${PORTNAME}/ \
http://www.eecs.northwestern.edu/racket/${PORTVERSION}/${PORTNAME}/ \
@ -30,7 +30,6 @@ CONFIGURE_ARGS= --enable-shared --enable-pthread \
--enable-lt=${LIBTOOL}
CONFIGURE_SCRIPT=../configure
NO_STAGE= yes
.include <bsd.port.options.mk>
.if defined(WITHOUT_X11)
@ -41,8 +40,6 @@ IGNORE= requires X11; use lang/racket-textual instead
MANUAL_PACKAGE_BUILD= i386 requires kern.maxdsiz="640M" to build
.endif
USE_GNOME= pango
LIB_DEPENDS+= ffi:${PORTSDIR}/devel/libffi \
cairo:${PORTSDIR}/graphics/cairo \
jpeg:${PORTSDIR}/graphics/jpeg \
@ -60,15 +57,14 @@ CPPFLAGS+= -I${LOCALBASE}/include
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src/build
USES+= iconv
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:env
MAN1= drracket.1 gracket.1 mred.1 mzc.1 mzscheme.1 plt-help.1 \
racket.1 raco.1 setup-plt.1
USE_GNOME= pango
USE_LDCONFIG= yes
USE_SQLITE= 3
ONLY_FOR_ARCHS= i386 amd64
PLIST_SUB+= ARCH=${ARCH}
RACKET_PLIST= ${WRKDIR}/pkg-plist
.include <bsd.port.pre.mk>
@ -80,6 +76,6 @@ pre-patch:
@${MKDIR} ${WRKSRC}
post-patch:
@${FIND} ${WRKDIR} -name *.orig -delete
@${FIND} ${WRKSRC} -name *.orig -delete
.include <bsd.port.post.mk>

View File

@ -1,2 +1,2 @@
SHA256 (racket/5.3.1/racket-5.3.1-src-unix.tgz) = 2abfcd4edf39db9eafcc8a456ccf216fe486cb718e1f70210f902cc6b1d418c3
SIZE (racket/5.3.1/racket-5.3.1-src-unix.tgz) = 18296513
SHA256 (racket/5.3.6/racket-5.3.6-src-unix.tgz) = 7fe0ffc1231f888cd481f175e428f0217257dd136d2513bde73954af5a7cfb8a
SIZE (racket/5.3.6/racket-5.3.6-src-unix.tgz) = 19278914

View File

@ -0,0 +1,28 @@
$FreeBSD$
--- ../../collects/plot/scribblings/ticks.scrbl.orig
+++ ../../collects/plot/scribblings/ticks.scrbl
@@ -182,22 +182,6 @@
@doc-apply[plot-y-far-ticks]
@doc-apply[plot-z-ticks]
@doc-apply[plot-z-far-ticks]{
-@examples[#:eval plot-eval
- (parameterize ([plot-x-label "Near x axis"]
- [plot-y-label "Near y axis"]
- [plot-z-label "Near z axis"]
- [plot-x-ticks (date-ticks)]
- [plot-y-ticks (time-ticks)]
- [plot-z-ticks (fraction-ticks)]
- [plot-x-far-label "Far x axis"]
- [plot-y-far-label "Far y axis"]
- [plot-z-far-label "Far z axis"]
- [plot-x-far-ticks (linear-ticks)]
- [plot-y-far-ticks (currency-ticks)]
- [plot-z-far-ticks (log-ticks #:base 2)])
- (plot3d (lines3d '(#(1 1 1) #(40000000 4 4)) #:style 'transparent)
- #:angle 45 #:altitude 50
- #:title "Axis Names and Tick Locations"))]
At any @racket[#:angle], the far @italic{x} and @italic{y} ticks are behind the plot, and the far @italic{z} ticks are on the right.
Far ticks are drawn, but not labeled, if they are identical to their corresponding near ticks.
They are always identical by default.

View File

@ -0,0 +1,17 @@
$FreeBSD$
--- ../racket/include/scheme.h.orig
+++ ../racket/include/scheme.h
@@ -63,11 +63,6 @@
# define MZ_USE_SINGLE_FLOATS
#endif
-/* gcc defines __SSE_MATH__ when SSE floating point is enabled: */
-#ifdef __SSE_MATH__
-# define C_COMPILER_USES_SSE 1
-#endif
-
#ifdef C_COMPILER_USES_SSE
# if defined(MZ_TRY_EXTFLONUMS) && !defined(MZ_NO_EXTFLONUMS)
# define MZ_LONG_DOUBLE

File diff suppressed because it is too large Load Diff