Update to 1.21.

The project is now hosted on GitLab, which is better than Google Drive from
a porting perspective. We can now drop a few workarounds and patches that
have been upstreamed.

Unfortunately this release is being fetched directly from GitLab and thus we
need to run gtkdocize and autoreconf ourselves as there is no actual release
tarball.

Submitted by:	Tobias Berner <tcberner@gmail.com>
This commit is contained in:
Raphael Kubo da Costa 2016-04-08 13:06:18 +00:00
parent 70cb9a0736
commit e432a3366d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=412745
4 changed files with 19 additions and 41 deletions

View File

@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= libaccounts-glib
PORTVERSION= 1.18
PORTREVISION= 1
PORTVERSION= 1.21
CATEGORIES= net-im
MASTER_SITES= https://drive.google.com/uc?export=download&id=0B8fX9XOwH_g4U1NzNmg0cWoxNGM&dummy= \
MASTER_SITES= https://gitlab.com/${GL_ACCOUNT}/${GL_PROJECT}/repository/archive${EXTRACT_SUFX}?ref=VERSION_${GL_TAGNAME}&num;/ \
LOCAL/rakuco
DISTNAME= ${GL_PROJECT}-VERSION_${GL_TAGNAME}-${GL_COMMIT}
MAINTAINER= kde@FreeBSD.org
COMMENT= Accounts and SSO framework for Linux and POSIX based platforms
@ -14,25 +14,24 @@ COMMENT= Accounts and SSO framework for Linux and POSIX based platforms
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libsqlite3.so:databases/sqlite3
FETCH_BEFORE_ARGS= -o ${DISTFILES}
BUILD_DEPENDS= gtkdocize:textproc/gtk-doc
LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib
GNU_CONFIGURE= YES
# The line below is a hack required when the port is configure either without
# devel/libcheck installed or with --disable-tests.
# A proper fix has been submitted upstream:
# https://gitlab.com/accounts-sso/libaccounts-glib/merge_requests/1
CONFIGURE_ENV= HAVE_GCOV_FALSE='\#'
CONFIGURE_ARGS= --disable-tests
CONFIGURE_ARGS= --disable-tests --enable-gtk-doc
INSTALL_TARGET= install-strip
USES= gmake libtool pathfix pkgconfig python
USES= autoreconf gmake libtool pathfix pkgconfig python sqlite:3
USE_GNOME= pygobject3 introspection libxml2
PATHFIX_MAKEFILEIN=Makefile.am
post-patch:
@${REINPLACE_CMD} -e 's|-Werror||g' \
${WRKSRC}/libaccounts-glib/Makefile.in
# GitLab variables.
GL_ACCOUNT= accounts-sso
GL_PROJECT= ${PORTNAME}
GL_TAGNAME= ${PORTVERSION}
GL_COMMIT= 00254a604a7c7bd38c41794a80ad8930e90f21aa
pre-configure:
cd ${WRKSRC} && gtkdocize --copy --flavour no-tmpl
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (libaccounts-glib-1.18.tar.gz) = 7aab9ec2ba3ae2548125f4bb330ed433e8066c672e32101a339cbb7f4657ff56
SIZE (libaccounts-glib-1.18.tar.gz) = 579435
SHA256 (libaccounts-glib-VERSION_1.21-00254a604a7c7bd38c41794a80ad8930e90f21aa.tar.gz) = 27cb75f3f2f0ce736b77f0fd0432f8d565297f0735846a2862577eadaec92488
SIZE (libaccounts-glib-VERSION_1.21-00254a604a7c7bd38c41794a80ad8930e90f21aa.tar.gz) = 127061

View File

@ -1,21 +0,0 @@
Fixes the following build error with clang:
ag-manager.c:503:16: error: implicit conversion from enumeration type 'AgAccountsError' to different enumeration type 'AgError' [-Werror,-Wenum-conversion]
code = AG_ACCOUNTS_ERROR_DB_LOCKED;
~ ^~~~~~~~~~~~~~~~~~~~~~~~~~~
ag-manager.c:508:16: error: implicit conversion from enumeration type 'AgAccountsError' to different enumeration type 'AgError' [-Werror,-Wenum-conversion]
code = AG_ACCOUNTS_ERROR_DB;
~ ^~~~~~~~~~~~~~~~~~~~
Sent upstream: https://gitlab.com/accounts-sso/libaccounts-glib/merge_requests/3
--- libaccounts-glib/ag-manager.c
+++ libaccounts-glib/ag-manager.c
@@ -490,7 +490,7 @@ static void
set_error_from_db (AgManager *manager)
{
AgManagerPrivate *priv = manager->priv;
- AgError code;
+ AgAccountsError code;
GError *error;
switch (sqlite3_errcode (priv->db))

View File

@ -15,10 +15,10 @@ lib/girepository-1.0/Accounts-1.0.typelib
lib/libaccounts-glib.so
lib/libaccounts-glib.so.0
lib/libaccounts-glib.so.0.1.3
libdata/pkgconfig/libaccounts-glib.pc
%%PYTHON_SITELIBDIR%%/gi/overrides/Accounts.py
%%PYTHON_SITELIBDIR%%/gi/overrides/Accounts.pyc
%%PYTHON_SITELIBDIR%%/gi/overrides/Accounts.pyo
libdata/pkgconfig/libaccounts-glib.pc
share/backup-framework/applications/accounts.conf
share/dbus-1/interfaces/com.google.code.AccountsSSO.Accounts.Manager.xml
share/gir-1.0/Accounts-1.0.gir