lang/fpc: update to 3.2.2

* Add new unit devel/fpc-tplylib
* Remove COMPAT10 dependency  [PR/254481]
PR:		254481
Reported by:	jbeich
This commit is contained in:
Jose Alonso Cardenas Marquez 2021-07-31 20:52:39 -05:00
parent 0372ca28f2
commit e40d870fc3
41 changed files with 117 additions and 74 deletions

View File

@ -76,8 +76,8 @@ _FPC_ALL_UNITS= a52 aspell bfd bzip2 cairo chm dblib dbus dts fastcgi \
mysql ncurses newt numlib odata odbc oggvorbis openal opengl openssl \
oracle pasjpeg pastojs pcap postgres proj4 pthreads pxlib \
regexpr rexx rsvg rtl-console rtl-extra rtl-generics rtl-objpas \
rtl-unicode sdl sqlite svgalib symbolic syslog unzip users utmp \
uuid vcl-compat webidl x11 xforms zlib
rtl-unicode sdl sqlite svgalib symbolic syslog tplylib unzip \
users utmp uuid vcl-compat webidl x11 xforms zlib
.if ${fpc_ARGS:Mbase}
USE_FPC= gdbint graph httpd22 httpd24 ibase mysql odbc oracle pasjpeg \
@ -191,6 +191,7 @@ sdl_UNIT= devel/fpc-sdl
svgalib_UNIT= graphics/fpc-svgalib
symbolic_UNIT= devel/fpc-symbolic
syslog_UNIT= sysutils/fpc-syslog
tplylib_UNIT= devel/fpc-tplylib
unzip_UNIT= archivers/fpc-unzip
users_UNIT= sysutils/fpc-users
utmp_UNIT= sysutils/fpc-utmp

View File

@ -43,8 +43,8 @@ COROSYNC_DEFAULT?= 2
FIREBIRD_DEFAULT?= 2.5
# Possible values: flang (experimental), gfortran
FORTRAN_DEFAULT?= gfortran
# Possible values: 3.2.0
FPC_DEFAULT?= 3.2.0
# Possible values: 3.2.2
FPC_DEFAULT?= 3.2.2
# Possible values: 8 (last to support powerpcspe), 9, 10, 11
# (Any other version is completely unsupported and not meant for general use.)
.if ${ARCH} == "powerpcspe"

View File

@ -3,7 +3,7 @@
@@ -17,7 +17,7 @@
P.Directory:=ADirectory;
{$endif ALLPACKAGES}
P.Version:='3.2.0';
P.Version:='3.2.2';
- P.OSes := [linux,win32,win64,wii];
+ P.OSes := [linux,win32,win64,wii,dragonfly,freebsd];
P.SourcePath.Add('src');

View File

@ -3,7 +3,7 @@
@@ -17,7 +17,7 @@
P.Directory:=ADirectory;
{$endif ALLPACKAGES}
P.Version:='3.2.0';
P.Version:='3.2.2';
- P.OSes := [linux];
+ P.OSes := [linux,dragonfly,freebsd];
P.SourcePath.Add('src');

View File

@ -17,6 +17,8 @@ lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fpindexer/ireadertxt.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fpindexer/memindexdb.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fpindexer/memindexdb.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fpindexer/memindexdb.rsj
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fpindexer/pgindexdb.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fpindexer/pgindexdb.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fpindexer/sqldbindexdb.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fpindexer/sqldbindexdb.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fpindexer/sqliteindexdb.o

View File

@ -1,6 +1,5 @@
# Created by: John Merryweather Cooper
PORTREVISION= 2
CATEGORIES= databases lang
PKGNAMESUFFIX= -mysql

View File

@ -53,3 +53,6 @@ lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/mysql/mysql56dyn.rsj
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/mysql/mysql57dyn.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/mysql/mysql57dyn.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/mysql/mysql57dyn.rsj
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/mysql/mysql80dyn.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/mysql/mysql80dyn.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/mysql/mysql80dyn.rsj

View File

@ -1,4 +1,3 @@
PORTREVISION= 2
CATEGORIES= databases lang
PKGNAMESUFFIX= -sqlite

View File

@ -708,6 +708,7 @@
SUBDIR += fpc-regexpr
SUBDIR += fpc-sdl
SUBDIR += fpc-symbolic
SUBDIR += fpc-tplylib
SUBDIR += fpc-zlib
SUBDIR += fpp
SUBDIR += frama-c

View File

@ -1,3 +1,6 @@
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/dbus.fpm
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/dbus/dbus.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/dbus/dbus.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/dbus/dbuscomp.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/dbus/dbuscomp.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/dbus/dbuscomp.rsj

View File

@ -4,7 +4,7 @@ PKGNAMESUFFIX= -fcl-base
COMMENT= Free Pascal Component Library base
USES= fpc
USE_FPC= fcl-res rtl-objpas
USE_FPC= rtl-objpas
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}

View File

@ -33,9 +33,6 @@ lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-base/custapp.rsj
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-base/eventlog.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-base/eventlog.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-base/eventlog.rsj
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-base/fileinfo.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-base/fileinfo.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-base/fileinfo.rsj
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-base/fpexprpars.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-base/fpexprpars.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-base/fpexprpars.rsj

View File

@ -1,4 +1,3 @@
PORTREVISION= 2
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-db

View File

@ -1,3 +1,4 @@
/you/have/to/check/what/makeplist/gives/you
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/fcl-db.fpm
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/bufdataset.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/bufdataset.ppu
@ -112,6 +113,8 @@ lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/fpddmysql56.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/fpddmysql56.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/fpddmysql57.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/fpddmysql57.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/fpddmysql80.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/fpddmysql80.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/fpddodbc.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/fpddodbc.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/fpddoracle.o
@ -189,6 +192,9 @@ lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/mysql56conn.rsj
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/mysql57conn.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/mysql57conn.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/mysql57conn.rsj
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/mysql80conn.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/mysql80conn.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/mysql80conn.rsj
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/odbcconn.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/odbcconn.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-db/oracleconnection.o

View File

@ -4,7 +4,7 @@ PKGNAMESUFFIX= -fcl-extra
COMMENT= Free Pascal extra libraries (FCL)
USES= fpc
USE_FPC= fcl-base fcl-res rtl-objpas
USE_FPC= fcl-base fcl-res rtl-objpas tplylib
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}

View File

@ -2,3 +2,6 @@ lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/fcl-extra.fpm
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-extra/daemonapp.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-extra/daemonapp.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-extra/daemonapp.rsj
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-extra/fileinfo.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-extra/fileinfo.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-extra/fileinfo.rsj

View File

@ -1,4 +1,3 @@
PORTREVISION= 2
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-fpcunit

View File

@ -1,4 +1,3 @@
PORTREVISION= 2
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-passrc

View File

@ -3,11 +3,15 @@ lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-pdf/fpfonttextmapping.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-pdf/fpfonttextmapping.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-pdf/fpparsettf.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-pdf/fpparsettf.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-pdf/fpparsettf.rsj
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-pdf/fppdf.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-pdf/fppdf.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-pdf/fppdf.rsj
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-pdf/fpttf.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-pdf/fpttf.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-pdf/fpttf.rsj
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-pdf/fpttfencodings.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-pdf/fpttfencodings.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-pdf/fpttfsubsetter.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-pdf/fpttfsubsetter.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-pdf/fpttfsubsetter.rsj

View File

@ -6,6 +6,7 @@ PKGNAMESUFFIX= -fcl-res
COMMENT= Free Pascal resource handlers (FCL)
USES= fpc
USE_FPC= rtl-objpas fcl-base tplylib
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}

View File

@ -44,6 +44,10 @@ lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-res/machotypes.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-res/machotypes.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-res/machowriter.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-res/machowriter.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-res/rcparser.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-res/rcparser.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-res/rcreader.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-res/rcreader.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-res/resdatastream.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-res/resdatastream.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fcl-res/resfactory.o

View File

@ -1,6 +1,5 @@
# Created by: John Merryweather Cooper et al
PORTREVISION= 1
CATEGORIES= devel lang
PKGNAMESUFFIX= -regexpr

View File

@ -0,0 +1,12 @@
CATEGORIES= devel lang
PKGNAMESUFFIX= -tplylib
COMMENT= Unit for a compiler generator for Turbo Pascal and compatibles
USES= fpc
MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
EXTRACTUNITDIR= ${WRKUNITDIR}
.include "${MASTERDIR}/Makefile"

View File

@ -0,0 +1,5 @@
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/tplylib.fpm
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/tplylib/lexlib.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/tplylib/lexlib.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/tplylib/yacclib.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/tplylib/yacclib.ppu

View File

@ -1,8 +1,7 @@
# Created by: John Merryweather Cooper <coop9211@uidaho.edu>
PORTNAME= base
PORTVERSION= 3.2.0
PORTREVISION= 1
PORTVERSION= 3.2.2
CATEGORIES= lang
PKGNAMEPREFIX= fpc-

View File

@ -1,7 +1,7 @@
# Created by: John Merryweather Cooper
PORTNAME= docs
PORTVERSION= 3.2.0
PORTVERSION= 3.2.2
CATEGORIES= lang
MASTER_SITES= ftp://ftp.freepascal.org/pub/fpc/dist/${PORTVERSION}/docs/ \
ftp://freepascal.stack.nl/pub/fpc/dist/${PORTVERSION}/docs/

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1601823528
SHA256 (freepascal/3.2.0/doc-pdf.tar.gz) = 5c4efe4709c387182d6da214bdd159f503ae9aa65c5c3e47c299cd7a03ed8de1
SIZE (freepascal/3.2.0/doc-pdf.tar.gz) = 9644753
TIMESTAMP = 1627716992
SHA256 (freepascal/3.2.2/doc-pdf.tar.gz) = 4dccbd4210995a94b76d1624a796c0abcf5118c0b92c487ab35a9d5a8bc68138
SIZE (freepascal/3.2.2/doc-pdf.tar.gz) = 9762841

View File

@ -1,14 +0,0 @@
--- packages/pastojs/fpmake.pp 2020-10-04 00:18:21.474418000 -0500
+++ packages/pastojs/fpmake.pp 2020-10-04 00:18:32.337561000 -0500
@@ -57,6 +57,11 @@
T:=P.Targets.AddUnit('pas2jspparser.pp');
T:=P.Targets.AddUnit('pas2jsuseanalyzer.pp');
T:=P.Targets.AddUnit('pas2jscompiler.pp');
+ T:=P.Targets.AddUnit('pas2jsresstrfile.pp');
+ T.ResourceStrings := True;
+ T:=P.Targets.AddUnit('pas2jsresources.pp');
+ T:=P.Targets.AddUnit('pas2jshtmlresources.pp');
+ T:=P.Targets.AddUnit('pas2jsjsresources.pp');
T:=P.Targets.AddUnit('pas2jsfscompiler.pp');
T.Dependencies.AddUnit('pas2jscompiler');
T:=P.Targets.AddUnit('pas2jspcucompiler.pp');

View File

@ -1,4 +1,3 @@
PORTREVISION= 2
CATEGORIES= lang
PKGNAMESUFFIX= -rtl-extra

View File

@ -1,4 +1,3 @@
PORTREVISION= 2
CATEGORIES= lang
PKGNAMESUFFIX= -rtl-objpas

View File

@ -5,6 +5,7 @@ lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/rtl-objpas/dateutils.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/rtl-objpas/dateutils.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/rtl-objpas/fmtbcd.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/rtl-objpas/fmtbcd.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/rtl-objpas/nullable.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/rtl-objpas/rtti.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/rtl-objpas/rtti.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/rtl-objpas/rtti.rsj

View File

@ -1,5 +1,5 @@
PORTNAME= fpc
PORTVERSION= 3.2.0
PORTVERSION= 3.2.2
DISTVERSIONSUFFIX=.source
CATEGORIES= lang
MASTER_SITES= ftp://ftp.freepascal.org/pub/fpc/dist/${PORTVERSION}/source/ \

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1601823640
SHA256 (freepascal/fpc-3.2.0.source.tar.gz) = d595b72de7ed9e53299694ee15534e5046a62efa57908314efa02d5cc3b1cf75
SIZE (freepascal/fpc-3.2.0.source.tar.gz) = 52028183
TIMESTAMP = 1627716934
SHA256 (freepascal/fpc-3.2.2.source.tar.gz) = d542e349de246843d4f164829953d1f5b864126c5b62fd17c9b45b33e23d2f44
SIZE (freepascal/fpc-3.2.2.source.tar.gz) = 52240052

View File

@ -1,6 +1,5 @@
PORTNAME= units
PORTVERSION= 3.2.0
PORTREVISION= 1
PORTVERSION= 3.2.2
CATEGORIES= lang
PKGNAMEPREFIX= fpc-
@ -22,8 +21,8 @@ ALL_OPTIONS= A52 ASPELL BFD BZIP2 CAIRO CHM DBLIB DBUS DTS FASTCGI \
LIBVLC LUA MAD MODPLUG NCURSES NEWT NUMLIB ODATA OGGVORBIS \
OPENAL OPENGL OPENSSL PASJPEG PASTOJS PCAP PROJ4 PXLIB RSVG \
REXX RTL_CONSOLE RTL_EXTRA RTL-GENERICS RTL_OBJPAS RTL_UNICODE \
SDL SVGALIB SYMBOLIC SYSLOG UNZIP USERS UTMP UUID VCL-COMPAT \
WEBIDL X11 XFORMS ZLIB
SDL SVGALIB SYMBOLIC SYSLOG TPLYLIB UNZIP USERS UTMP UUID \
VCL-COMPAT WEBIDL X11 XFORMS ZLIB
OPTIONS_DEFINE:= ${ALL_OPTIONS}
OPTIONS_DEFAULT:= ${ALL_OPTIONS}
@ -107,6 +106,7 @@ SDL_DESC= Interface to SDL library
SVGALIB_DESC= Interface to svgalib library
SYMBOLIC_DESC= Simple expression parsing and evaluating
SYSLOG_DESC= Interface to system logger
TPLYLIB_DESC= Compiler generator unit for Turbo Pascal and compatibles
UNZIP_DESC= Routines for unzipping zip files
USERS_DESC= Interface to manipulate users
UTMP_DESC= Gather information from the utmp file

View File

@ -1,4 +1,3 @@
PORTREVISION= 1
CATEGORIES= lang
PKGNAMESUFFIX= -utils

View File

@ -38,10 +38,6 @@ bin/unitdiff.rsj
bin/webidl2pas
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/utils-lexyacc.fpm
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/utils-pas2js.fpm
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/utils-lexyacc/lexlib.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/utils-lexyacc/lexlib.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/utils-lexyacc/yacclib.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/utils-lexyacc/yacclib.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/utils-pas2js/dirwatch.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/utils-pas2js/dirwatch.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/utils-pas2js/httpcompiler.o

View File

@ -1,8 +1,8 @@
# Created by: John Merryweather Cooper et al
PORTNAME= fpc
PORTVERSION= 3.2.0
PORTREVISION?= 1
PORTVERSION= 3.2.2
PORTREVISION?= 0
CATEGORIES?= lang
MASTER_SITES= ftp://ftp.freepascal.org/pub/fpc/dist/${PORTVERSION}/source/:source \
ftp://planetmirror.com/pub/fpc/dist/${PORTVERSION}/source/:source \
@ -102,6 +102,7 @@ do-extract:
${FPCSRCDIR}/packages/libtar \
${FPCSRCDIR}/packages/paszlib \
${FPCSRCDIR}/packages/rtl-objpas \
${FPCSRCDIR}/packages/tplylib \
${FPCSRCDIR}/utils/fpcm)
post-patch:
@ -136,7 +137,7 @@ do-build:
(cd ${WRKDIR}/${FPCSRCDIR}/packages/fpmkunit && ${SETENV} \
${MAKE_ENV} ${MAKE_CMD} bootstrap ${MAKE_ARGS} ${NEWPPC})
@${ECHO_MSG} "##### COMPLETE BOOTSTRAP FPMKUNIT #####"
.for component in fcl-res rtl-objpas fcl-base
.for component in rtl-objpas fcl-base tplylib fcl-res
@${ECHO_MSG} "##### STARTING ${component:tu} #####"
(cd ${WRKDIR}/${FPCSRCDIR}/packages/${component} && \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${NEWPPC})

View File

@ -1,9 +1,7 @@
TIMESTAMP = 1606173579
SHA256 (freepascal/fpc-3.2.0.source.tar.gz) = d595b72de7ed9e53299694ee15534e5046a62efa57908314efa02d5cc3b1cf75
SIZE (freepascal/fpc-3.2.0.source.tar.gz) = 52028183
SHA256 (freepascal/ppc386-3.0.4-freebsd.tar.gz) = 3f5fa4b24abde00a1dcfe7e28938e8b7bf908c7d6633182521916e2191ae867d
SIZE (freepascal/ppc386-3.0.4-freebsd.tar.gz) = 1121653
TIMESTAMP = 1627713160
SHA256 (freepascal/fpc-3.2.2.source.tar.gz) = d542e349de246843d4f164829953d1f5b864126c5b62fd17c9b45b33e23d2f44
SIZE (freepascal/fpc-3.2.2.source.tar.gz) = 52240052
SHA256 (freepascal/ppcx64-3.0.4-freebsd.tar.gz) = fb57c418ec374ed99cd7914a4daa5fc6afccfbf41595a886c361e3fef8bbdbb3
SIZE (freepascal/ppcx64-3.0.4-freebsd.tar.gz) = 1198576
SHA256 (freepascal/fpc-3.2.0.man.tar.gz) = d510a75642cfb87ed18c3e4d533ffcc3b9c5e7219ca914ebe7cdab47eefb3398
SIZE (freepascal/fpc-3.2.0.man.tar.gz) = 47338
SHA256 (freepascal/fpc-3.2.2.man.tar.gz) = 4b7d7d50922531fa01e00d0bc913abb40426ba3001579240bf3db3f4ad640584
SIZE (freepascal/fpc-3.2.2.man.tar.gz) = 47334

View File

@ -1,15 +1,44 @@
--- rtl/bsd/bunxsysc.inc 2015-08-04 04:31:09.000000000 -0500
+++ rtl/bsd/bunxsysc.inc 2020-02-21 18:30:23.409088000 -0500
@@ -379,10 +379,10 @@
{$if defined(freebsd) or defined (dragonfly)}
{$define PIPE_RESULT_IN_EAX_AND_EDX}
{$endif}
--- rtl/bsd/bunxsysc.inc.orig 2015-07-14 16:58:27.000000000 -0500
+++ rtl/bsd/bunxsysc.inc 2021-07-31 02:57:36.924782000 -0500
@@ -374,39 +374,11 @@
FPutime:=do_syscall(syscall_nr_utimes,TSysParam(path),TSysParam(tvp));
end;
-function __pipe_call(sysnr:TSysParam):TSysResult; {$ifdef cpui386}oldfpccall{$endif} external name 'FPC_DOSYS0';
+function FPpipe(var fildes : tfildes; flags:cint):cint;
-{$if defined(freebsd) or defined (dragonfly)}
- {$define PIPE_RESULT_IN_EAX_AND_EDX}
-{$endif}
-Function FPpipe(var fildes : tfildes):cint;
+Function FPpipe(var fildes : tfildes; flags:cint):cint;
{$ifndef PIPE_RESULT_IN_EAX_AND_EDX}
-{$ifndef PIPE_RESULT_IN_EAX_AND_EDX}
begin
- fppipe:=do_syscall(syscall_nr_pipe,TSysParam(@fildes));
+ fppipe:=do_syscall(syscall_nr_pipe2,TSysParam(@fildes), TSysParam(flags));
end;
{$else}
var
-{$else}
-var
- a, b: cInt;
-begin
- asm
- {$ifdef CPUi386}
- pushl syscall_nr_pipe
- call __pipe_call
- movl %eax, a
- movl %edx, b
- {$else}
- movq syscall_nr_pipe, %rdi
- call __pipe_call
- movl %eax, a
- movl %edx, b
- {$endif}
- end;
-
- fpPipe := a; // eax is in a, no matter if it worked or not
- fildes[0] := a;
- fildes[1] := b;
-end;
-{$endif}
function FPfcntl(fildes:cint;Cmd:cint;Arg:cint):cint;

View File

@ -7,7 +7,7 @@
+ flags : cint;
begin
- assignPipe:=fppipe(pip);
+ assignPipe:=fppipe(pip, flags);
+ assignPipe:=fppipe(pip, 0);
pipe_in:=pip[0];
pipe_out:=pip[1];
end;

View File

@ -7,7 +7,7 @@
- P.OSes := [win32, win64, linux, freebsd];
+ P.OSes := [win32, win64, linux, dragonfly, freebsd];
P.Dependencies.Add('fcl-base');
P.Version:='3.2.0';
P.Version:='3.2.2';
P.License := 'LGPL with modification';
P.HomepageURL := 'www.freepascal.org';
P.Email := 'michael@freepascal.org';