- Update to 5.6.

This commit is contained in:
Stephen Montgomery-Smith 2013-01-24 13:33:06 +00:00
parent 78fd81a07b
commit e3fe361370
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=310930
10 changed files with 9 additions and 1573 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= sage
PORTVERSION= 5.5
PORTVERSION= 5.6
CATEGORIES= math
MASTER_SITES= http://boxen.math.washington.edu/home/sagemath/sage-mirror/src/ \
http://mirrors.xmission.com/sage/src/ \

View File

@ -1,2 +1,2 @@
SHA256 (sage-5.5.tar) = 6b89765a4918f910250146edae30d40207903fc08719d6aacd21e756f0276b6d
SIZE (sage-5.5.tar) = 316641280
SHA256 (sage-5.6.tar) = db033b194089fc161cd4d65f9e0a3c496c3ddd076b588b0477e61d0c4a104e39
SIZE (sage-5.6.tar) = 319508480

File diff suppressed because it is too large Load Diff

View File

@ -1,74 +0,0 @@
--- gap-4.4.12.p6/patches/sysfiles.c.orig 2010-04-29 01:30:00.000000000 +1000
+++ gap-4.4.12.p8/patches/sysfiles.c 2010-07-26 05:25:58.334562226 +1000
@@ -1524,7 +1524,7 @@
** to cooked mode before stopping GAP and back to raw mode when continueing.
*/
-#if !SYS_IS_DARWIN && (SYS_BSD || SYS_MACH || HAVE_SGTTY_H)
+#if !SYS_IS_DARWIN && (SYS_BSD || SYS_MACH || HAVE_SGTTY_H) && !HAVE_TERMIOS_H
#ifndef SYS_SGTTY_H /* terminal control functions */
# include <sgtty.h>
@@ -2073,7 +2073,7 @@
**
*f syStopraw( <fid> ) . . . . . . . . . . . . . . . . . . . . . . BSD/MACH
*/
-#if !SYS_IS_DARWIN && (SYS_BSD || SYS_MACH || HAVE_SGTTY_H)
+#if !SYS_IS_DARWIN && (SYS_BSD || SYS_MACH || HAVE_SGTTY_H) && !HAVE_TERMIOS_H
void syStopraw (
Int fid )
@@ -2760,7 +2760,7 @@
**
*f syEchoch( <ch>, <fid> ) . . . . . . . . . . . . . . . . . . . . BSD/MACH
*/
-#if SYS_BSD || SYS_MACH || HAVE_SGTTY_H
+#if (SYS_BSD || SYS_MACH || HAVE_SGTTY_H) && !HAVE_TERMIOS_H
void syEchoch (
Int ch,
@@ -2786,7 +2786,7 @@
**
*f syEchoch( <ch>, <fid> ) . . . . . . . . . . . . . . . . . . . . . . . USG
*/
-#if SYS_USG || HAVE_TERMIO_H
+#if SYS_USG || HAVE_TERMIO_H || HAVE_TERMIOS_H
void syEchoch (
Int ch,
@@ -2974,7 +2974,7 @@
**
*f syEchos( <ch>, <fid> ) . . . . . . . . . . . . . . . . . . . . BSD/MACH
*/
-#if SYS_BSD || SYS_MACH || HAVE_SGTTY_H
+#if (SYS_BSD || SYS_MACH || HAVE_SGTTY_H) && !HAVE_TERMIOS_H
void syEchos (
Char * str,
@@ -2996,7 +2996,7 @@
**
*f syEchos( <ch>, <fid> ) . . . . . . . . . . . . . . . . . . . . . . . USG
*/
-#if SYS_USG || HAVE_TERMIO_H
+#if SYS_USG || HAVE_TERMIO_H || HAVE_TERMIOS_H
void syEchos (
Char * str,
@@ -3149,7 +3149,7 @@
**
*f SyFputs( <line>, <fid> ) . . . . . . . BSD/MACH/USG/OS2 EMX/VMS/MAC MPW
*/
-#if SYS_BSD||SYS_MACH||SYS_USG||SYS_OS2_EMX||SYS_VMS||SYS_MAC_MPW||HAVE_SGTTY_H||HAVE_TERMIO_H
+#if SYS_BSD||SYS_MACH||SYS_USG||SYS_OS2_EMX||SYS_VMS||SYS_MAC_MPW||HAVE_SGTTY_H||HAVE_TERMIO_H||HAVE_TERMIOS_H
void SyFputs (
Char * line,
@@ -3476,7 +3476,7 @@
** that return odd things rather than waiting for a key
**
*/
-#if SYS_BSD || SYS_MACH || HAVE_SGTTY_H ||SYS_USG || HAVE_TERMIO_H
+#if SYS_BSD || SYS_MACH || HAVE_SGTTY_H ||SYS_USG || HAVE_TERMIO_H || HAVE_TERMIOS_H
/* In the cygwin environment it is not predictable if text files get the
* '\r' in their line ends filtered out *before* GAP sees them. This leads

View File

@ -1,5 +1,5 @@
--- python-2.7.3.p0/src/Doc/library/fcntl.rst.orig 2011-06-11 15:46:23.000000000 +0000
+++ python-2.7.3.p2/src/Doc/library/fcntl.rst 2012-04-22 00:31:48.000000000 +0000
+++ python-2.7.3.p3/src/Doc/library/fcntl.rst 2012-04-22 00:31:48.000000000 +0000
@@ -50,8 +50,6 @@
operations are typically defined in the library module :mod:`termios` and the
argument handling is even more complicated.

View File

@ -1,5 +1,5 @@
--- python-2.7.3.p0/src/Modules/_ctypes/libffi/configure.orig 2011-06-11 15:46:26.000000000 +0000
+++ python-2.7.3.p2/src/Modules/_ctypes/libffi/configure 2012-04-22 00:23:14.000000000 +0000
+++ python-2.7.3.p3/src/Modules/_ctypes/libffi/configure 2012-04-22 00:23:14.000000000 +0000
@@ -6289,7 +6289,7 @@
rm -rf conftest*
;;

View File

@ -1,5 +1,5 @@
--- python-2.7.3.p0/src/Modules/fcntlmodule.c.orig 2011-06-11 15:46:27.000000000 +0000
+++ python-2.7.3.p2/src/Modules/fcntlmodule.c 2012-04-22 00:23:34.000000000 +0000
+++ python-2.7.3.p3/src/Modules/fcntlmodule.c 2012-04-22 00:23:34.000000000 +0000
@@ -97,20 +97,15 @@
{
#define IOCTL_BUFSZ 1024

View File

@ -1,5 +1,5 @@
--- python-2.7.3.p0/src/Python/thread_pthread.h.orig 2011-06-11 15:46:28.000000000 +0000
+++ python-2.7.3.p2/src/Python/thread_pthread.h 2012-04-22 00:23:46.000000000 +0000
+++ python-2.7.3.p3/src/Python/thread_pthread.h 2012-04-22 00:23:46.000000000 +0000
@@ -38,13 +38,18 @@
#endif
#endif

View File

@ -1,5 +1,5 @@
--- python-2.7.3.p0/src/setup.py-orig 2012-04-22 00:04:08.000000000 +0000
+++ python-2.7.3.p2/src/setup.py 2012-04-22 00:10:25.000000000 +0000
+++ python-2.7.3.p3/src/setup.py 2012-04-22 00:10:25.000000000 +0000
@@ -1432,10 +1432,24 @@
macros = dict()
libraries = []

View File

@ -1,5 +1,5 @@
--- sage-5.0.beta13/sage/misc/getusage.py-orig 2012-04-11 00:14:47.000000000 +0000
+++ sage-5.5/sage/misc/getusage.py 2012-04-11 00:47:03.000000000 +0000
+++ sage-5.6/sage/misc/getusage.py 2012-04-11 00:47:03.000000000 +0000
@@ -20,6 +20,8 @@
"""
Return the 'top' or 'prstat' line that contains this running Sage