Fix build with llvm11 (duplicate symbol errors)

While here, re-generate patches using 'makepatch' target
This commit is contained in:
Ganael LAPLANCHE 2020-09-08 14:15:58 +00:00
parent ca5384416a
commit e3fcd7359a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=547983
21 changed files with 168 additions and 62 deletions

View File

@ -1,7 +1,7 @@
Disable doc installation (handled by the port's Makefile)
--- doc/CMakeLists.txt.orig 2017-02-18 22:40:07.000000000 +0100
+++ doc/CMakeLists.txt 2018-06-08 22:33:26.240772000 +0200
--- doc/CMakeLists.txt.orig 2017-02-18 21:40:07 UTC
+++ doc/CMakeLists.txt
@@ -1,8 +1,8 @@
-install(FILES pcsxr.1 DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man1)
-install(FILES keys.txt DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/pcsxr)

View File

@ -1,6 +1,6 @@
--- gui/CMakeLists.txt.orig 2018-06-07 22:06:27.348220000 +0200
+++ gui/CMakeLists.txt 2018-06-07 22:08:23.025836000 +0200
@@ -17,6 +17,11 @@
--- gui/CMakeLists.txt.orig 2017-02-18 21:40:07 UTC
+++ gui/CMakeLists.txt
@@ -17,6 +17,11 @@ endif(NOT GTK3_FOUND)
include_directories(${GTK3_INCLUDE_DIRS})
set(GTK_LIBRARIES ${GTK3_LIBRARY} ${GDK3_LIBRARY} ${GDKPixbuf_LIBRARY} ${Pango_LIBRARY} ${Cairo_LIBRARY} ${GObject_LIBRARY} ${GLib_LIBRARY} ${GIO_LIBRARY})
@ -12,7 +12,7 @@
find_package(Threads REQUIRED)
find_package(ZLIB REQUIRED)
include_directories(${ZLIB_INCLUDE_DIRS})
@@ -89,7 +94,7 @@
@@ -89,7 +94,7 @@ compile_gresources(RESOURCE_FILE
add_custom_target(resource DEPENDS ${RESOURCE_FILE})
add_executable(pcsxr ${SRCS} ${RESOURCE_FILE} )
add_dependencies(pcsxr resource)

View File

@ -0,0 +1,13 @@
--- gui/Linux.h.orig 2020-09-07 22:26:22 UTC
+++ gui/Linux.h
@@ -43,8 +43,8 @@
extern gboolean UseGui;
extern int StatesC;
-char cfgfile[MAXPATHLEN]; /* ADB Comment this out - make a local var, or at least use gchar funcs */
-char cfgfile_basename[MAXPATHLEN]; /* ADB Comment this out - make a local var, or at least use gchar funcs */
+extern char cfgfile[MAXPATHLEN]; /* ADB Comment this out - make a local var, or at least use gchar funcs */
+extern char cfgfile_basename[MAXPATHLEN]; /* ADB Comment this out - make a local var, or at least use gchar funcs */
int LoadConfig();
void SaveConfig();

View File

@ -1,6 +1,16 @@
--- gui/LnxMain.c.orig 2010-06-01 07:51:28.324517082 +0000
+++ gui/LnxMain.c 2010-06-01 08:01:34.204348317 +0000
@@ -186,6 +186,9 @@
--- gui/LnxMain.c.orig 2020-09-07 22:26:22 UTC
+++ gui/LnxMain.c
@@ -42,6 +42,9 @@
#include <X11/extensions/XTest.h>
+char cfgfile[MAXPATHLEN];
+char cfgfile_basename[MAXPATHLEN];
+
enum {
RUN = 0,
RUN_CD,
@@ -187,6 +190,9 @@ static void ScanAllPlugins (void) {
gchar *currentdir;
// scan some default locations to find plugins
@ -10,7 +20,7 @@
ScanPlugins("/usr/lib/games/psemu/");
ScanPlugins("/usr/lib/games/psemu/lib/");
ScanPlugins("/usr/lib/games/psemu/config/");
@@ -211,6 +214,8 @@
@@ -212,6 +218,8 @@ static void ScanAllPlugins (void) {
ScanPlugins(DEF_PLUGIN_DIR "/config");
// scan some default locations to find bioses

View File

@ -1,5 +1,5 @@
--- gui/po/CMakeLists.txt.orig 2018-06-08 22:12:44.486045000 +0200
+++ gui/po/CMakeLists.txt 2018-06-08 22:14:13.363502000 +0200
--- gui/po/CMakeLists.txt.orig 2017-02-18 21:40:07 UTC
+++ gui/po/CMakeLists.txt
@@ -1,6 +1,9 @@
-message("Configuring langs")
-include(Gettext)

View File

@ -1,6 +1,6 @@
--- libpcsxcore/CMakeLists.txt.orig 2017-02-18 22:40:07.000000000 +0100
+++ libpcsxcore/CMakeLists.txt 2018-06-07 22:13:45.312645000 +0200
@@ -18,6 +18,12 @@
--- libpcsxcore/CMakeLists.txt.orig 2017-02-18 21:40:07 UTC
+++ libpcsxcore/CMakeLists.txt
@@ -18,6 +18,12 @@ if (USE_LIBARCHIVE)
add_definitions(-DHAVE_LIBARCHIVE)
endif()
@ -13,12 +13,12 @@
# Architecture detection and arch specific settings
message(${CMAKE_SYSTEM_PROCESSOR})
if (${CMAKE_SYSTEM_PROCESSOR} MATCHES "^powerpc")
@@ -26,6 +32,8 @@
@@ -25,6 +31,8 @@ if (${CMAKE_SYSTEM_PROCESSOR} MATCHES "^powerpc")
elseif(${CMAKE_SYSTEM_PROCESSOR} MATCHES "^i.86")
set(_ARCH_32 1)
elseif(${CMAKE_SYSTEM_PROCESSOR} MATCHES "^x86_64")
set(_ARCH_64 1)
+elseif(${CMAKE_SYSTEM_PROCESSOR} MATCHES "^amd64")
+ set(_ARCH_64 1)
+elseif(${CMAKE_SYSTEM_PROCESSOR} MATCHES "^amd64")
set(_ARCH_64 1)
else()
message("Unsupported arch. Will not build dynarec")
add_definitions(-DNOPSXREC)

View File

@ -1,6 +1,6 @@
--- libpcsxcore/ix86_64/ix86_cpudetect.c.orig 2018-06-07 22:29:16.208468000 +0200
+++ libpcsxcore/ix86_64/ix86_cpudetect.c 2018-06-07 22:31:35.845538000 +0200
@@ -145,7 +145,7 @@
--- libpcsxcore/ix86_64/ix86_cpudetect.c.orig 2020-09-07 22:26:22 UTC
+++ libpcsxcore/ix86_64/ix86_cpudetect.c
@@ -145,7 +145,7 @@ u64 GetCPUTick( void )
#endif
}

View File

@ -1,6 +1,6 @@
--- libpcsxcore/psxcommon.h.orig 2018-06-07 22:26:55.136610000 +0200
+++ libpcsxcore/psxcommon.h 2018-06-07 22:27:17.357957000 +0200
@@ -71,7 +71,7 @@
--- libpcsxcore/psxcommon.h.orig 2020-09-07 22:26:22 UTC
+++ libpcsxcore/psxcommon.h
@@ -71,7 +71,7 @@ typedef uint8_t boolean;
#include "system.h"
#include "debug.h"

View File

@ -1,6 +1,6 @@
--- plugins/bladesio1/CMakeLists.txt.orig 2017-02-18 22:40:07.000000000 +0100
+++ plugins/bladesio1/CMakeLists.txt 2018-06-07 22:01:58.035345000 +0200
@@ -17,6 +17,11 @@
--- plugins/bladesio1/CMakeLists.txt.orig 2017-02-18 21:40:07 UTC
+++ plugins/bladesio1/CMakeLists.txt
@@ -17,6 +17,11 @@ endif(NOT GTK3_FOUND)
include_directories(${GTK3_INCLUDE_DIRS})
set(GTK_LIBRARIES ${GTK3_LIBRARY} ${GDK3_LIBRARY} ${GDKPixbuf_LIBRARY} ${Pango_LIBRARY} ${Cairo_LIBRARY} ${GObject_LIBRARY} ${GLib_LIBRARY} ${GIO_LIBRARY})
@ -12,7 +12,7 @@
#defs
add_definitions(-DLOCALE_DIR="${CMAKE_INSTALL_FULL_DATAROOTDIR}/locale/" -DPSEMU_DATA_DIR="${CMAKE_INSTALL_FULL_DATAROOTDIR}/psemu" -DDEF_PLUGIN_DIR="${CMAKE_INSTALL_FULL_LIBDIR}/games/psemu")
@@ -55,7 +60,7 @@
@@ -55,7 +60,7 @@ add_library(BladeSio1 MODULE ${PLUGIN_SRCS})
add_executable(cfgBladeSio1 ${GUI_SRCS} ${RESOURCE_FILE})
add_dependencies(cfgBladeSio1 bladesio1_resource)

View File

@ -1,5 +1,5 @@
--- plugins/bladesio1/gui.c.orig 2013-09-10 15:56:22.000000000 +0200
+++ plugins/bladesio1/gui.c 2013-09-10 15:59:32.000000000 +0200
--- plugins/bladesio1/gui.c.orig 2020-09-07 22:26:23 UTC
+++ plugins/bladesio1/gui.c
@@ -26,8 +26,6 @@
#include <gtk/gtk.h>
@ -21,10 +21,11 @@
#define MAXINTERFACES 16
void sockGetIP(char *IPAddress) {
@@ -67,6 +70,22 @@
@@ -66,6 +69,22 @@ void sockGetIP(char *IPAddress) {
close(fd);
}
}
+
+#else
+
+void sockGetIP(char *IPAddress) {
@ -40,7 +41,6 @@
+}
+
+#endif
+
void cfgSysMessage(const char *fmt, ...) {
GtkWidget *MsgDlg;
va_list list;

View File

@ -0,0 +1,11 @@
--- plugins/bladesio1/sio1.c.orig 2020-09-07 22:26:23 UTC
+++ plugins/bladesio1/sio1.c
@@ -55,8 +55,6 @@ static const unsigned char build = 1;
static void (CALLBACK *irqCallback)() = 0;
-Settings settings;
-
/* sio status flags.
*/
enum {

View File

@ -1,6 +1,6 @@
--- plugins/dfcdrom/CMakeLists.txt.orig 2017-02-18 22:40:07.000000000 +0100
+++ plugins/dfcdrom/CMakeLists.txt 2018-06-07 22:20:24.492042000 +0200
@@ -27,6 +27,12 @@
--- plugins/dfcdrom/CMakeLists.txt.orig 2017-02-18 21:40:07 UTC
+++ plugins/dfcdrom/CMakeLists.txt
@@ -27,6 +27,12 @@ set(GTK_LIBRARIES ${GTK3_LIBRARY} ${GDK3_LIBRARY} ${GD
find_package(Threads REQUIRED)
@ -13,7 +13,7 @@
#defs
add_definitions(-DLOCALE_DIR="${CMAKE_INSTALL_FULL_DATAROOTDIR}/locale/" -DPSEMU_DATA_DIR="${CMAKE_INSTALL_FULL_DATAROOTDIR}/psemu" -DDEF_PLUGIN_DIR="${CMAKE_INSTALL_FULL_LIBDIR}/games/psemu")
@@ -66,7 +72,7 @@
@@ -66,7 +72,7 @@ target_link_libraries(DFCdrom ${CDIO_LIBRARIES} ${CMAK
add_executable(cfgDFCdrom ${GUI_SRCS} ${RESOURCE_FILE})
add_dependencies(cfgDFCdrom dfcdrom_resource)

View File

@ -1,6 +1,6 @@
--- plugins/dfcdrom/cdr.h.orig 2011-01-27 06:48:33.209766794 +0100
+++ plugins/dfcdrom/cdr.h 2011-01-27 06:52:51.789416162 +0100
@@ -78,7 +78,7 @@
--- plugins/dfcdrom/cdr.h.orig 2017-02-18 21:40:07 UTC
+++ plugins/dfcdrom/cdr.h
@@ -104,7 +104,7 @@ struct cdrom_msf {
#define CD_FRAMESIZE_SUB 96
#if defined (__FreeBSD__)

View File

@ -1,6 +1,6 @@
--- plugins/dfinput/CMakeLists.txt.orig 2018-06-07 22:36:37.371859000 +0200
+++ plugins/dfinput/CMakeLists.txt 2018-06-07 22:37:27.408684000 +0200
@@ -17,6 +17,12 @@
--- plugins/dfinput/CMakeLists.txt.orig 2017-02-18 21:40:07 UTC
+++ plugins/dfinput/CMakeLists.txt
@@ -17,6 +17,12 @@ endif(NOT GTK3_FOUND)
include_directories(${GTK3_INCLUDE_DIRS})
set(GTK_LIBRARIES ${GTK3_LIBRARY} ${GDK3_LIBRARY} ${GDKPixbuf_LIBRARY} ${Pango_LIBRARY} ${Cairo_LIBRARY} ${GObject_LIBRARY} ${GLib_LIBRARY} ${GIO_LIBRARY})
@ -13,7 +13,7 @@
set(USE_SDL2 0)
find_package(SDL2)
if(NOT SDL2_FOUND)
@@ -76,7 +82,7 @@
@@ -76,7 +82,7 @@ target_link_libraries(DFInput ${SDL_LIBRARY} ${SDL2_LI
add_executable(cfgDFInput ${GUI_SRCS} ${RESOURCE_FILE})
add_dependencies(cfgDFInput dfinput_resource)

View File

@ -0,0 +1,11 @@
--- plugins/dfinput/pad.h.orig 2020-09-07 22:26:22 UTC
+++ plugins/dfinput/pad.h
@@ -151,7 +151,7 @@ typedef struct tagKeyDef {
enum { ANALOG_XP = 0, ANALOG_XM, ANALOG_YP, ANALOG_YM };
#if SDL_VERSION_ATLEAST(2,0,0)
-SDL_GameControllerButton controllerMap[DKEY_TOTAL];
+extern SDL_GameControllerButton controllerMap[DKEY_TOTAL];
#endif
typedef struct tagPadDef {

View File

@ -1,6 +1,6 @@
--- plugins/dfnet/CMakeLists.txt.orig 2017-02-18 22:40:07.000000000 +0100
+++ plugins/dfnet/CMakeLists.txt 2018-06-07 22:34:06.729573000 +0200
@@ -17,6 +17,11 @@
--- plugins/dfnet/CMakeLists.txt.orig 2017-02-18 21:40:07 UTC
+++ plugins/dfnet/CMakeLists.txt
@@ -17,6 +17,11 @@ endif(NOT GTK3_FOUND)
include_directories(${GTK3_INCLUDE_DIRS})
set(GTK_LIBRARIES ${GTK3_LIBRARY} ${GDK3_LIBRARY} ${GDKPixbuf_LIBRARY} ${Pango_LIBRARY} ${Cairo_LIBRARY} ${GObject_LIBRARY} ${GLib_LIBRARY} ${GIO_LIBRARY})
@ -12,7 +12,7 @@
#defs
add_definitions(-DLOCALE_DIR="${CMAKE_INSTALL_FULL_DATAROOTDIR}/locale/" -DPSEMU_DATA_DIR="${CMAKE_INSTALL_FULL_DATAROOTDIR}/psemu" -DDEF_PLUGIN_DIR="${CMAKE_INSTALL_FULL_LIBDIR}/games/psemu")
@@ -54,7 +59,7 @@
@@ -54,7 +59,7 @@ add_library(DFNet MODULE ${PLUGIN_SRCS})
add_executable(cfgDFNet ${GUI_SRCS} ${RESOURCE_FILE})
add_dependencies(cfgDFNet dfnet_resource)

View File

@ -0,0 +1,11 @@
--- plugins/dfnet/cfg.c.orig 2020-09-07 22:26:23 UTC
+++ plugins/dfnet/cfg.c
@@ -13,6 +13,8 @@
#define CFG_FILENAME "dfnet.cfg"
+Config conf;
+
void SaveConf() {
FILE *f;

View File

@ -0,0 +1,50 @@
--- plugins/dfnet/dfnet.h.orig 2020-09-07 22:26:23 UTC
+++ plugins/dfnet/dfnet.h
@@ -56,7 +56,7 @@ __private_extern char* PLUGLOC(char* toloc);
typedef void* HWND;
-struct timeval tm;
+extern struct timeval tm;
#define CALLBACK
@@ -70,24 +70,24 @@ typedef struct {
char ipAddress[32];
} Config;
-Config conf;
+extern Config conf;
void LoadConf();
void SaveConf();
-int sock;
-char *PadSendData;
-char *PadRecvData;
-char PadSendSize;
-char PadRecvSize;
-char PadSize[2];
-int PadCount;
-int PadCountMax;
-int PadInit;
-int Ping;
-volatile int WaitCancel;
-fd_set rset;
-fd_set wset;
+extern int sock;
+extern char *PadSendData;
+extern char *PadRecvData;
+extern char PadSendSize;
+extern char PadRecvSize;
+extern char PadSize[2];
+extern int PadCount;
+extern int PadCountMax;
+extern int PadInit;
+extern int Ping;
+extern volatile int WaitCancel;
+extern fd_set rset;
+extern fd_set wset;
long sockInit();
long sockShutdown();

View File

@ -1,6 +1,6 @@
--- plugins/dfsound/CMakeLists.txt.orig 2017-02-18 22:40:07.000000000 +0100
+++ plugins/dfsound/CMakeLists.txt 2018-06-07 22:32:10.505879000 +0200
@@ -20,6 +20,11 @@
--- plugins/dfsound/CMakeLists.txt.orig 2017-02-18 21:40:07 UTC
+++ plugins/dfsound/CMakeLists.txt
@@ -20,6 +20,11 @@ endif(NOT GTK3_FOUND)
include_directories(${GTK3_INCLUDE_DIRS})
set(GTK_LIBRARIES ${GTK3_LIBRARY} ${GDK3_LIBRARY} ${GDKPixbuf_LIBRARY} ${Pango_LIBRARY} ${Cairo_LIBRARY} ${GObject_LIBRARY} ${GLib_LIBRARY} ${GIO_LIBRARY})
@ -12,7 +12,7 @@
if (${SND_BACKEND} STREQUAL "oss")
find_package(OSS REQUIRED)
@@ -129,7 +134,7 @@
@@ -129,7 +134,7 @@ endif()
add_executable(cfgDFSound ${GUI_SRCS} ${RESOURCE_FILE})
add_dependencies(cfgDFSound dfsound_resource)

View File

@ -1,6 +1,6 @@
--- plugins/dfxvideo/CMakeLists.txt.orig 2017-02-18 22:40:07.000000000 +0100
+++ plugins/dfxvideo/CMakeLists.txt 2018-06-06 22:18:56.790161000 +0200
@@ -20,6 +20,12 @@
--- plugins/dfxvideo/CMakeLists.txt.orig 2017-02-18 21:40:07 UTC
+++ plugins/dfxvideo/CMakeLists.txt
@@ -20,6 +20,12 @@ set(GTK_LIBRARIES ${GTK3_LIBRARY} ${GDK3_LIBRARY} ${GD
find_package(X11 REQUIRED)
@ -13,7 +13,7 @@
#defs
add_definitions(-DLOCALE_DIR="${CMAKE_INSTALL_FULL_DATAROOTDIR}/locale/" -DPSEMU_DATA_DIR="${CMAKE_INSTALL_FULL_DATAROOTDIR}/psemu" -DDEF_PLUGIN_DIR="${CMAKE_INSTALL_FULL_LIBDIR}/games/psemu")
@@ -63,7 +69,7 @@
@@ -63,7 +69,7 @@ target_link_libraries(DFXVideo ${X11_LIBRARIES} ${X11_
add_executable(cfgDFXVideo ${GUI_SRCS} ${RESOURCE_FILE})
add_dependencies(cfgDFXVideo dfxvideo_resource)

View File

@ -1,6 +1,6 @@
--- plugins/peopsxgl/CMakeLists.txt.orig 2018-06-07 22:22:14.308996000 +0200
+++ plugins/peopsxgl/CMakeLists.txt 2018-06-07 22:24:14.627266000 +0200
@@ -17,6 +17,12 @@
--- plugins/peopsxgl/CMakeLists.txt.orig 2017-02-18 21:40:07 UTC
+++ plugins/peopsxgl/CMakeLists.txt
@@ -17,6 +17,12 @@ endif(NOT GTK3_FOUND)
include_directories(${GTK3_INCLUDE_DIRS})
set(GTK_LIBRARIES ${GTK3_LIBRARY} ${GDK3_LIBRARY} ${GDKPixbuf_LIBRARY} ${Pango_LIBRARY} ${Cairo_LIBRARY} ${GObject_LIBRARY} ${GLib_LIBRARY} ${GIO_LIBRARY})
@ -13,7 +13,7 @@
find_package(X11 REQUIRED)
find_package(OpenGL REQUIRED)
@@ -69,7 +75,7 @@
@@ -69,7 +75,7 @@ target_link_libraries(peopsxgl ${X11_LIBRARIES} ${X11_
add_executable(cfgpeopsxgl ${GUI_SRCS} ${RESOURCE_FILE})
add_dependencies(cfgpeopsxgl dfinput_resource)