Update PyQt and its dependencies.

* PyQt4 has been updated to 4.11.3.
* QScintilla has been updated to 2.8.4.
* SIP has been updated to 4.16.5.

This update is much smaller than the previous one, as there has been no
further need for clean ups in the ports infrastructure.

Pretty much the entire patch set has been originally contributed by Tobias
Berner, who sent it to the KDE on FreeBSD mailing list. Thanks a lot!

PR:		198016
Submitted by:	Tobias Berner <tcberner@gmail.com>
This commit is contained in:
Raphael Kubo da Costa 2015-03-04 23:20:47 +00:00
parent fe98e4cc80
commit e3dad0e904
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=380454
35 changed files with 43 additions and 64 deletions

View File

@ -2,7 +2,6 @@
# $FreeBSD$
PORTNAME= sql
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= databases devel python

View File

@ -2,7 +2,6 @@
# $FreeBSD$
PORTNAME= assistant
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel python

View File

@ -2,7 +2,6 @@
# $FreeBSD$
PORTNAME= core
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel python

View File

@ -195,26 +195,6 @@
if opts.designer_plugin and "QtDesigner" in pyqt_modules:
py_major = sipcfg.py_version >> 16
@@ -975,9 +965,6 @@
# include the ABI information.
abi = ""
else:
- dynamic_pylib = "--enable-shared" in config_args
-
- if dynamic_pylib:
if glob.glob("%s/lib/libpython%d.%d*" % (ducfg["exec_prefix"], py_major, py_minor)):
lib_dir_flag = quote("-L%s/lib" % ducfg["exec_prefix"])
elif 'MULTIARCH' in ducfg and glob.glob('%s/lib/%s/libpython%d.%d*' % (ducfg['exec_prefix'], ducfg['MULTIARCH'], py_major, py_minor)):
@@ -990,9 +977,6 @@
opts.designer_plugin = False
link = "%s -lpython%d.%d%s" % (lib_dir_flag, py_major, py_minor, abi)
- else:
- sipconfig.inform("Qt Designer plugin disabled because Python library is static")
- opts.designer_plugin = False
pysh_lib = ducfg.get("LDLIBRARY", "")
@@ -2301,9 +2285,9 @@
installs=[(pyqt.module_installs(), pyqt_modroot)]

View File

@ -2,7 +2,6 @@
# $FreeBSD$
PORTNAME= dbus
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel python

View File

@ -1,7 +1,6 @@
# $FreeBSD$
PORTNAME= dbussupport
PORTREVISION= 1
CATEGORIES= devel python
MAINTAINER= kde@FreeBSD.org

View File

@ -1,7 +1,6 @@
# $FreeBSD$
PORTNAME= declarative
PORTREVISION= 1
CATEGORIES= devel python
MAINTAINER= kde@FreeBSD.org

View File

@ -2,7 +2,6 @@
# $FreeBSD$
PORTNAME= designer
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel python

View File

@ -2,7 +2,6 @@
# $FreeBSD$
PORTNAME= designerplugin
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel python
@ -23,5 +22,7 @@ USE_QT4= gui xml designer moc_build qmake_build
OPTIONS_DEFINE= DEBUG
DEBUG_CONFIGURE_ON= --debug --trace
PLIST_FILES= %%QT_PLUGINDIR%%/designer/libpyqt4.so
.include "${.CURDIR}/../py-qt4/bsd.pyqt.mk"
.include <bsd.port.mk>

View File

@ -1 +0,0 @@
%%QT_PLUGINDIR%%/designer/libpyqt4.so

View File

@ -1,7 +1,6 @@
# $FreeBSD$
PORTNAME= help
PORTREVISION= 1
CATEGORIES= devel python
MAINTAINER= kde@FreeBSD.org

View File

@ -3,7 +3,6 @@
PORTNAME= qscintilla2
PORTVERSION= ${QSCI2_VERSION}
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITES_QSCI2}

View File

@ -2,7 +2,6 @@
# $FreeBSD$
PORTNAME= script
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel python

View File

@ -1,7 +1,6 @@
# $FreeBSD$
PORTNAME= scripttools
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel python

View File

@ -2,7 +2,6 @@
# $FreeBSD$
PORTNAME= test
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel python

View File

@ -3,7 +3,6 @@
PORTNAME= qt4
PORTVERSION= ${PYQT4_VERSION}
PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= # empty
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

View File

@ -19,9 +19,9 @@ MASTER_SITES_PYQT4= SF/pyqt/PyQt4/PyQt-${PORTVERSION} \
MASTER_SITES_QSCI2= SF/pyqt/QScintilla2/QScintilla-${PORTVERSION} \
${MASTER_SITE_GENTOO:S,%SUBDIR%,distfiles,}
SIP_VERSION= 4.16.2
PYQT4_VERSION= 4.11.1
QSCI2_VERSION= 2.8.3
SIP_VERSION= 4.16.5
PYQT4_VERSION= 4.11.3
QSCI2_VERSION= 2.8.4
SIP_DISTNAME= sip-${SIP_VERSION}
PYQT4_DISTNAME= PyQt-x11-gpl-${PYQT4_VERSION}

View File

@ -1,2 +1,2 @@
SHA256 (PyQt-x11-gpl-4.11.1.tar.gz) = df9d7358d70748efa5b84fa3fe9e182a80c39ac590157daaabcc2618df176da3
SIZE (PyQt-x11-gpl-4.11.1.tar.gz) = 11118850
SHA256 (PyQt-x11-gpl-4.11.3.tar.gz) = 853780dcdbe2e6ba785d703d059b096e1fc49369d3e8d41a060be874b8745686
SIZE (PyQt-x11-gpl-4.11.3.tar.gz) = 11120237

View File

@ -1,2 +1,2 @@
SHA256 (sip-4.16.2.tar.gz) = a55a2324a46ab42e42ae57c52ef06583b17d25c987973fe2e7ff2e8a649294ce
SIZE (sip-4.16.2.tar.gz) = 793663
SHA256 (sip-4.16.5.tar.gz) = a00ba34c30bedc0f61916eb10bd12867b4754910a766647e3e58f88bd00f1e87
SIZE (sip-4.16.5.tar.gz) = 859672

View File

@ -0,0 +1,28 @@
sip 4.16.5 has switched the Makefile lines that invoke the moc utility from
an invocation with an explicit source file name to "$<".
This works with GNU make, but not make(1), where it $< evaluates to nothing
in this context.
Switch back to the previous version to avoid having to depend on devel/gmake
(figuring out which ports need it is not trivial).
--- siputils.py
+++ siputils.py
@@ -1683,7 +1683,7 @@
cpp = "moc_" + root + ".cpp"
mfile.write("\n%s: %s\n" % (cpp, mf))
- mfile.write("\t$(MOC) -o %s $<\n" % cpp)
+ mfile.write("\t$(MOC) -o %s %s\n" % (cpp, mf))
mfile.write("\n$(TARGET): $(OFILES)\n")
@@ -1980,7 +1980,7 @@
mf = os.path.join(self._src_dir, mf)
mfile.write("\n%s: %s\n" % (cpp, mf))
- mfile.write("\t$(MOC) -o %s $<\n" % cpp)
+ mfile.write("\t$(MOC) -o %s %s\n" % (cpp, mf))
mfile.write("\n$(TARGET): $(OFILES)\n")

View File

@ -3,7 +3,6 @@
PORTNAME= designerplugin
PORTVERSION= ${QSCI2_VERSION}
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITES_QSCI2}
@ -22,6 +21,8 @@ HAS_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/designer-Qt4Qt5
PLIST_FILES= %%QT_PLUGINDIR%%/designer/libqscintillaplugin.so
.include "${.CURDIR}/../py-qt4/bsd.pyqt.mk"
pre-configure:

View File

@ -1 +0,0 @@
%%QT_PLUGINDIR%%/designer/libqscintillaplugin.so

View File

@ -3,7 +3,6 @@
PORTNAME= qscintilla2
PORTVERSION= ${QSCI2_VERSION}
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITES_QSCI2}

View File

@ -1,2 +1,2 @@
SHA256 (QScintilla-gpl-2.8.3.tar.gz) = fb94e6d61c3ccd4bf167d5f092629e619f7069d42207469458998b761a7cf505
SIZE (QScintilla-gpl-2.8.3.tar.gz) = 3028154
SHA256 (QScintilla-gpl-2.8.4.tar.gz) = 9b7b2d7440cc39736bbe937b853506b3bd218af3b79095d4f710cccb0fabe80f
SIZE (QScintilla-gpl-2.8.4.tar.gz) = 3031919

View File

@ -50,8 +50,8 @@
%%QT_INCDIR%%/Qsci/qscistyledtext.h
%%QT_LIBDIR%%/libqscintilla2.so
%%QT_LIBDIR%%/libqscintilla2.so.11
%%QT_LIBDIR%%/libqscintilla2.so.11.2
%%QT_LIBDIR%%/libqscintilla2.so.11.2.0
%%QT_LIBDIR%%/libqscintilla2.so.11.3
%%QT_LIBDIR%%/libqscintilla2.so.11.3.0
%%QT_MKSPECDIR%%/features/qscintilla2.prf
share/qt4/qsci/api/python/Python-2.4.api
share/qt4/qsci/api/python/Python-2.5.api

View File

@ -2,7 +2,6 @@
# $FreeBSD$
PORTNAME= svg
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics devel python

View File

@ -24,12 +24,6 @@ EXAMPLESDIR= ${PREFIX}/share/examples/py-qt4
PYQT4_RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}qt4-${component}>=0:${PORTSDIR}/${${component}_PORT}
.endfor
# Remove some empty __pycache__/ directories that are wrongly part of the
# tarball and cause check-plist failures.
post-patch:
${RMDIR} ${WRKSRC}/examples/opengl/textures/__pycache__
${RMDIR} ${WRKSRC}/examples/widgets/stylesheet/__pycache__
do-build:
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/examples

View File

@ -2,7 +2,6 @@
# $FreeBSD$
PORTNAME= multimedia
PORTREVISION= 1
CATEGORIES= multimedia devel python
MAINTAINER= kde@FreeBSD.org

View File

@ -1,7 +1,6 @@
# $FreeBSD$
PORTNAME= phonon
PORTREVISION= 1
CATEGORIES= multimedia devel python
MAINTAINER= kde@FreeBSD.org

View File

@ -2,7 +2,6 @@
# $FreeBSD$
PORTNAME= network
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net devel python

View File

@ -2,7 +2,6 @@
# $FreeBSD$
PORTNAME= xml
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= textproc devel python

View File

@ -2,7 +2,6 @@
# $FreeBSD$
PORTNAME= xmlpatterns
PORTREVISION= 1
CATEGORIES= textproc devel python
MAINTAINER= kde@FreeBSD.org

View File

@ -2,7 +2,6 @@
# $FreeBSD$
PORTNAME= webkit
PORTREVISION= 1
CATEGORIES= www devel python
MAINTAINER= kde@FreeBSD.org

View File

@ -2,7 +2,6 @@
# $FreeBSD$
PORTNAME= gui
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= x11-toolkits devel python

View File

@ -2,7 +2,6 @@
# $FreeBSD$
PORTNAME= opengl
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= x11 devel python