A long player, random picking front end to xmms. Uses QT3.
This commit is contained in:
parent
61f1991e6e
commit
e3da4f3432
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=72006
@ -125,6 +125,7 @@
|
||||
SUBDIR += linux-libaudiofile
|
||||
SUBDIR += linux-vsound
|
||||
SUBDIR += lopster
|
||||
SUBDIR += lplayer
|
||||
SUBDIR += mad
|
||||
SUBDIR += maplay
|
||||
SUBDIR += mhwaveedit
|
||||
|
60
audio/lplayer/Makefile
Normal file
60
audio/lplayer/Makefile
Normal file
@ -0,0 +1,60 @@
|
||||
# ex:ts=8 -*-mode: makefile-*-
|
||||
#
|
||||
# New ports collection makefile for: longplayer
|
||||
# Date created: 2002-12-16
|
||||
# Whom: Alan Eldridge <alane@geeksrus.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= lplayer
|
||||
PORTVERSION= 0.98.1
|
||||
PORTREVISION= 0
|
||||
#PORTEPOCH=
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
DISTNAME= ${PORTNAME}_${PORTVERSION}_src
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= alane@FreeBSD.org
|
||||
|
||||
USE_QT_VER= 3
|
||||
USE_GMAKE= yes
|
||||
USE_REINPLACE= yes
|
||||
HAS_CONFIGURE= yes
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
|
||||
MAKE_ENV+= QTDIR=${QT_PREFIX}
|
||||
CONFIGURE_ENV= ${MAKE_ENV}
|
||||
|
||||
do-configure:
|
||||
cd ${WRKSRC}; \
|
||||
XMMSLIBS=$$(xmms-config --libs); \
|
||||
XMMSINCS=$$(xmms-config --cflags | sed 's|-I||g'); \
|
||||
${REINPLACE_CMD} -e "s|@X11BASE@|${X11BASE}|g" \
|
||||
-e "s|@LOCALBASE@|${LOCALBASE}|g" \
|
||||
-e "s|@XMMSLIBS@|$$XMMSLIBS|" \
|
||||
-e "s|@XMMSINCS@|$$XMMSINCS|" lp.pro; \
|
||||
${SETENV} ${CONFIGURE_ENV} qmake -makefile -o Makefile -unix lp.pro
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
DOCS_SUBDIR= ${DOCSDIR:S|^${PREFIX}/||}
|
||||
EXAMPLES_SUBDIR= ${EXAMPLESDIR:S|^${PREFIX}/||}
|
||||
|
||||
BINDIR= ${PREFIX}/bin
|
||||
BIN_SUBDIR= ${BINDIR:S|^${PREFIX}/||}
|
||||
LIBDIR= ${PREFIX}/lib
|
||||
LIB_SUBDIR= ${LIBDIR:S|^${PREFIX}/||}
|
||||
PKGLIBDIR= ${LIBDIR}/${PORTNAME}
|
||||
PKGLIB_SUBDIR= ${PKGLIBDIR:S|^${PREFIX}/||}
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${BINDIR} ${PKGLIBDIR}
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}-bin ${PKGLIBDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/../gnu/lplayerdir/*.png ${PKGLIBDIR}
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/lplayer ${BINDIR}
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
||||
#EOF
|
1
audio/lplayer/distinfo
Normal file
1
audio/lplayer/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (lplayer_0.98.1_src.tgz) = 9b6549068ff8af469d266bebbae7fb6c
|
41
audio/lplayer/files/lplayer
Normal file
41
audio/lplayer/files/lplayer
Normal file
@ -0,0 +1,41 @@
|
||||
#!/bin/sh
|
||||
# -*-mode: shell-script-*-
|
||||
#
|
||||
# lplayer
|
||||
#
|
||||
# 2002-12-16 Alan Eldridge <alane@freebsd.org>
|
||||
#
|
||||
|
||||
run_lplayer() {
|
||||
./lplayer-bin ${1:+"$@"} &
|
||||
exit 0
|
||||
}
|
||||
|
||||
INFOPID=0
|
||||
XDIALOG=/usr/X11R6/bin/Xdialog
|
||||
if test -x $XDIALOG; then
|
||||
$XDIALOG --title LongPlayer --backtitle "Please wait ..." \
|
||||
--no-buttons --infobox "Backing up DB ..." 15 50 5000 &
|
||||
INFOPID=$!
|
||||
fi # test -x $XDIALOG ...
|
||||
|
||||
DBFILE=$HOME/.lptable.lp2
|
||||
PLISTS=$HOME/.lpplaylists.xml
|
||||
SETTINGS=$HOME/.lpsettings.xml
|
||||
SUFFIX=.save
|
||||
LPLAYERDIR=/usr/local/lib/lplayer
|
||||
|
||||
for i in $DBFILE $PLISTS $SETTINGS; do
|
||||
if test -f $i; then
|
||||
test -f $i$SUFFIX && cmp -s $i $i$SUFFIX && continue
|
||||
rm -f $i$SUFFIX 2>/dev/null; cp -pf $i $i$SUFFIX
|
||||
fi
|
||||
done
|
||||
|
||||
test $INFOPID -gt 0 && wait $INFOPID
|
||||
|
||||
cd $LPLAYERDIR
|
||||
run_lplayer ${1:+"$@"} &
|
||||
|
||||
exit 0
|
||||
#EOF
|
14
audio/lplayer/files/patch-lp.pro
Normal file
14
audio/lplayer/files/patch-lp.pro
Normal file
@ -0,0 +1,14 @@
|
||||
--- lp.pro.orig Wed Nov 13 05:39:16 2002
|
||||
+++ lp.pro Mon Dec 16 06:31:17 2002
|
||||
@@ -82,9 +82,8 @@
|
||||
#Qt only
|
||||
#==============================================================================
|
||||
#works most of the time
|
||||
-TMAKE_LIBS = -lxmms -L/sw/lib -lglib
|
||||
-INCLUDEPATH = /usr/include/xmms /usr/lib/glib/include /usr/include/glib-1.2\
|
||||
- /sw/include/xmms /sw/lib/glib/include /sw/include/glib-1.2
|
||||
+TMAKE_LIBS = -L@X11BASE@/lib -L@LOCALBASE@/lib @XMMSLIBS@
|
||||
+INCLUDEPATH = @X11BASE@/include @X11BASE@/include @XMMSINCS@
|
||||
|
||||
#mac os x using fink
|
||||
#TMAKE_LIBS = -lxmms -L/sw/lib -lglib
|
1
audio/lplayer/pkg-comment
Normal file
1
audio/lplayer/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A QT program to queue lots of MP3s for random XMMS play
|
6
audio/lplayer/pkg-descr
Normal file
6
audio/lplayer/pkg-descr
Normal file
@ -0,0 +1,6 @@
|
||||
Longplayer is a QT program to queue lots of MP3s for random XMMS play.
|
||||
According to the web page, it's "a matter of outqueuing them...".
|
||||
|
||||
WWW: http://lplayer.sourceforge.net/
|
||||
|
||||
-- AlanE <alane@freebsd.org>
|
17
audio/lplayer/pkg-plist
Normal file
17
audio/lplayer/pkg-plist
Normal file
@ -0,0 +1,17 @@
|
||||
bin/lplayer
|
||||
lib/lplayer/go.png
|
||||
lib/lplayer/go32.png
|
||||
lib/lplayer/lplayer-bin
|
||||
lib/lplayer/lplayericon.png
|
||||
lib/lplayer/lplayerlogo.png
|
||||
lib/lplayer/lplayerlogo2.png
|
||||
lib/lplayer/lplayerlogo3.png
|
||||
lib/lplayer/next.png
|
||||
lib/lplayer/play.png
|
||||
lib/lplayer/previous.png
|
||||
lib/lplayer/ratedown.png
|
||||
lib/lplayer/ratedown32.png
|
||||
lib/lplayer/rateup.png
|
||||
lib/lplayer/rateup32.png
|
||||
lib/lplayer/stop.png
|
||||
@dirrm lib/lplayer
|
Loading…
Reference in New Issue
Block a user