Update port to 1.4

Add WWW

PR:		17645
Submitted by:	tkato@prontomail.ne.jp
This commit is contained in:
Chris D. Faulhaber 2000-03-30 03:28:07 +00:00
parent c34aa86301
commit e3bbb3138e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=27135
10 changed files with 130 additions and 125 deletions

View File

@ -1,16 +1,17 @@
# New ports collection makefile for: nas (formerly netaudio)
# Version required: 1.2p1
# Version required: 1.4
# Date created: 03 Nov 1994
# Whom: jkh
#
# $FreeBSD$
#
DISTNAME= nas-1.2p5
PKGNAME= nas-1.2.5
DISTNAME= nas-1.4
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITES= ${MASTER_SITE_XCONTRIB} \
http://radscan.com/nas/
MASTER_SITE_SUBDIR= audio/nas
EXTRACT_SUFX= .src.tar.gz
MAINTAINER= ports@FreeBSD.org
@ -19,10 +20,9 @@ ALL_TARGET= World
# no need to "xmkmf -a" and create the Makefiles twice -- see above
XMKMF= xmkmf
MAN1= AUVoxConfig.1 auconvert.1 auctl.1 audemo.1 audial.1 auedit.1 auinfo.1 \
aupanel.1 auphone.1 auplay.1 aurecord.1 auscope.1 auserver.1 autool.1 \
auvoxware.1 auwave.1 checkmail.1 issndfile.1 nas.1 playbucket.1 \
soundtoh.1
MAN1= auconvert.1 auctl.1 audemo.1 audial.1 auedit.1 auinfo.1 aupanel.1 \
auphone.1 auplay.1 aurecord.1 auscope.1 autool.1 auvoxware.1 auwave.1 \
checkmail.1 issndfile.1 nas.1 playbucket.1 soundtoh.1
MAN3= AuAnyEvent.3 AuBucketAttributes.3 AuCloseServer.3 \
AuConvertDataToShort.3 AuConvertShortToData.3 AuCreateBucket.3 \
AuCreateFlow.3 AuDataFormats.3 AuDataTypes.3 AuDefineToFormat.3 \
@ -69,4 +69,12 @@ MAN3= AuAnyEvent.3 AuBucketAttributes.3 AuCloseServer.3 \
SoundReadFile.3 SoundRewindFile.3 SoundSeekFile.3 \
SoundStringToFileFormat.3 SoundTellFile.3 SoundWriteFile.3
post-patch:
@find ${WRKSRC} -name '*.[ch]' | xargs \
${PERL} -pi -e "s|<malloc.h>|<stdlib.h>|g"
post-install:
${LDCONFIG} -m ${PREFIX}/lib
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (nas-1.2p5.tar.gz) = 27c7118347dd71dd32a7f27d7e6d44bc
MD5 (nas-1.4.src.tar.gz) = 8b9280377d0ad404afbaa5a93f213bc5

View File

@ -1,16 +1,38 @@
*** server/dda/voxware/auvoxware.c.orig Thu Nov 3 11:24:11 1994
--- server/dda/voxware/auvoxware.c Thu Nov 3 11:24:50 1994
***************
*** 755,760 ****
--- 755,765 ----
/*
* Setup soundcard at maximum audio quality.
*/
+
+ #ifdef __FreeBSD__
+ #define NO_16_BIT_SAMPLING
+ #endif
+
static void setupSoundcard(sndStatPtr)
SndStat* sndStatPtr;
{
--- server/dda/voxware/auvoxware.c.orig Sun Mar 5 11:40:55 2000
+++ server/dda/voxware/auvoxware.c Sat Mar 25 15:18:36 2000
@@ -610,7 +610,11 @@
if(sndStatOut.fd == -1)
{
+#ifdef __FreeBSD__
+ while ((sndStatOut.fd = open(sndStatOut.device, O_RDWR)) == -1 && wait)
+#else
while ((sndStatOut.fd = open(sndStatOut.device, O_RDWR|O_SYNC)) == -1 && wait)
+#endif
{
osLogMsg("openDevice: waiting on output device\n");
sleep(1);
@@ -1230,6 +1234,11 @@
/*
* Setup soundcard at maximum audio quality.
*/
+
+#ifdef __FreeBSD__
+#define NO_16_BIT_SAMPLING
+#endif
+
static void setupSoundcard(sndStatPtr)
SndStat* sndStatPtr;
{
@@ -1380,7 +1389,11 @@
AL_initialized = AuTrue;
+#ifdef __FreeBSD__
+ if ((fd = open(sndStatOut.device, O_RDWR, 0)) == -1) {
+#else
if ((fd = open(sndStatOut.device, O_RDWR|O_SYNC, 0)) == -1) {
+#endif
UNIDENTMSG;
return AuFalse;
}

View File

@ -1,12 +1,12 @@
*** ./lib/audio/Astreams.c.orig Thu Nov 3 11:58:30 1994
--- ./lib/audio/Astreams.c Thu Nov 3 11:58:52 1994
***************
*** 52,58 ****
#include <sys/stropts.h>
extern int errno;
- extern char *sys_errlist[];
/* stolen from <X11/Xproto.h> */
typedef struct {
--- 52,57 ----
--- lib/audio/Astreams.c.orig Sun May 9 10:10:05 1999
+++ lib/audio/Astreams.c Sat Mar 25 15:20:42 2000
@@ -52,7 +52,9 @@
#include <sys/stropts.h>
extern int errno;
+#if !defined(BSD)
extern char *sys_errlist[];
+#endif
/* stolen from <X11/Xproto.h> */
typedef struct {

View File

@ -1,55 +1,11 @@
*** clients/audio/auedit/Graph.c.orig Wed Dec 6 10:11:03 1995
--- clients/audio/auedit/Graph.c Sat Oct 5 11:37:52 1996
***************
*** 28,34 ****
*/
#ifndef WIN32
! #include <values.h>
#else /* WIN32 */
#define MAXSHORT 0x7fff
#endif /* WIN32 */
--- 28,34 ----
*/
#ifndef WIN32
! #include <limits.h>
#else /* WIN32 */
#define MAXSHORT 0x7fff
#endif /* WIN32 */
***************
*** 322,329 ****
for (x = 0; x < (int) w->core.width; x++)
{
! minY = MAXSHORT;
! maxY = -MAXSHORT;
for (; (int) k == x && p < end; k += w->graph.hscale)
{
--- 322,329 ----
for (x = 0; x < (int) w->core.width; x++)
{
! minY = SHRT_MAX;
! maxY = SHRT_MIN;
for (; (int) k == x && p < end; k += w->graph.hscale)
{
***************
*** 391,397 ****
GraphWidget w;
{
w->graph.vscale = (float) w->core.height / w->graph.numTracks /
! (MAXSHORT - -MAXSHORT + 1);
w->graph.hscale = (float) ((int) w->core.width - 1) /
(w->graph.end - w->graph.start);
--- 391,397 ----
GraphWidget w;
{
w->graph.vscale = (float) w->core.height / w->graph.numTracks /
! (SHRT_MAX - SHRT_MIN + 1);
w->graph.hscale = (float) ((int) w->core.width - 1) /
(w->graph.end - w->graph.start);
--- clients/audio/auedit/Graph.c.orig Mon Oct 25 02:24:08 1999
+++ clients/audio/auedit/Graph.c Sat Mar 25 14:56:23 2000
@@ -28,7 +28,7 @@
*/
#ifndef WIN32
-# ifdef __NetBSD__
+# if defined(__NetBSD__) || defined(__FreeBSD__)
# include <limits.h>
# define MAXSHORT SHRT_MAX
# define MINSHORT SHRT_MIN

View File

@ -1,25 +1,19 @@
*** lib/audio/Imakefile Tue Feb 13 12:18:13 1996
--- lib/audio/Imakefile Tue Feb 13 10:21:19 1996
***************
*** 66,73 ****
#endif /* ProjectX < 5 */
EDB_DEFINES = -DERRORDB=\"$(LIBDIR)/AuErrorDB\"
DEFINES = $(MALLOC_DEFINES) $(SYSV_DEFINES)
! CONN_DEFINES = ConnectionFlags
INSTALLFLAGS += $(INSTINCFLAGS)
--- 66,78 ----
#endif /* ProjectX < 5 */
+ #if HasBSD44Sockets
+ SOCK_DEFINES = -DBSD44SOCKETS
+ #endif
+
+
EDB_DEFINES = -DERRORDB=\"$(LIBDIR)/AuErrorDB\"
DEFINES = $(MALLOC_DEFINES) $(SYSV_DEFINES)
! CONN_DEFINES = ConnectionFlags $(SOCK_DEFINES)
INSTALLFLAGS += $(INSTINCFLAGS)
--- lib/audio/Imakefile.orig Sat Jan 1 18:28:13 2000
+++ lib/audio/Imakefile Sat Mar 25 14:56:19 2000
@@ -64,10 +64,15 @@
COMPAT_OBJS = AuGetBest.o
#endif /* ProjectX < 5 */
+#if HasBSD44Sockets
+ SOCK_DEFINES = -DBSD44SOCKETS
+#endif
+
+
EDB_DEFINES = -DERRORDB=\"$(LIBDIR)/AuErrorDB\"
DEFINES = $(MALLOC_DEFINES) $(SYSV_DEFINES)
- CONN_DEFINES = ConnectionFlags
+ CONN_DEFINES = ConnectionFlags $(SOCK_DEFINES)
HEADERS = Alibint.h Alibnet.h Xtutil.h audiolib.h audioutil.h snd.h wave.h \
voc.h aiff.h sound.h soundlib.h fileutil.h 8svx.h Astreams.h \

9
audio/nas/files/patch-af Normal file
View File

@ -0,0 +1,9 @@
--- config/NetAudio.def.orig Sun Feb 13 05:31:14 2000
+++ config/NetAudio.def Fri Mar 24 04:55:49 2000
@@ -8,5 +8,5 @@
XCOMM Directory where NAS will look for it's config file(s)
#ifndef NasConfigSearchPath
-#define NasConfigSearchPath /etc/nas/
+#define NasConfigSearchPath $(PROJECTROOT)/etc
#endif

View File

@ -1,5 +1,7 @@
The Network Audio System is designed for playing,
recording, and manipulating audio data over a network.
Like the X Window System, it uses the client/server model to
separate applications from the specific drivers that control
audio input and output devices.
The Network Audio System is designed for playing,
recording, and manipulating audio data over a network.
Like the X Window System, it uses the client/server model to
separate applications from the specific drivers that control
audio input and output devices.
WWW: http://radscan.com/nas.html

11
audio/nas/pkg-message Normal file
View File

@ -0,0 +1,11 @@
**************************************************
**************************************************
NOTE:
Be sure to create a /usr/X11R6/etc/nasd.conf file; use
/usr/X11R6/etc/nasd.conf.eg as a starting point.
It should work fine as is.
**************************************************
**************************************************

View File

@ -1,4 +1,3 @@
bin/au
bin/auconvert
bin/auctl
bin/audemo
@ -11,12 +10,13 @@ bin/auplay
bin/aurecord
bin/auscope
bin/autool
bin/auvoxware
bin/auwave
bin/checkmail
bin/issndfile
bin/nasd
bin/playbucket
bin/soundtoh
etc/nasd.conf.eg
include/audio/8svx.h
include/audio/Afuncproto.h
include/audio/Afuncs.h
@ -38,7 +38,10 @@ include/audio/sound.h
include/audio/soundlib.h
include/audio/voc.h
include/audio/wave.h
lib/AUVoxConfig.eg
lib/X11/AuErrorDB
lib/libaudio.a
lib/libaudio.so
lib/libaudio.so.1
@exec /sbin/ldconfig -m %B
@unexec /sbin/ldconfig -R
@dirrm include/audio