net-mgmt/kismet: fix build on 12 with OpenSSL 1.1.1

PR:		232140
Submitted by:	Nathan <ndowens@yahoo.com>
This commit is contained in:
Kurt Jaeger 2018-10-29 19:12:28 +00:00
parent e404b4361e
commit e39c2ee38d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=483399
3 changed files with 76 additions and 13 deletions

View File

@ -3,7 +3,7 @@
PORTNAME= kismet
DISTVERSION= 2016-07-R1
PORTREVISION= 1
PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= http://www.kismetwireless.net/code/
@ -13,8 +13,9 @@ COMMENT= 802.11 layer2 wireless network detector, sniffer, and IDS
LICENSE= GPLv2
GNU_CONFIGURE= yes
USES= gmake tar:xz
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@ -63,6 +64,12 @@ PLIST_SUB+= PLUGINS=""
PLIST_SUB+= PLUGINS="@comment "
.endif
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200000
EXTRA_PATCHES=${FILESDIR}/extra-patch-restricted-plugin-ptw_aircrack-crypto.cc
.endif
post-patch:
@${REINPLACE_CMD} -e "/gps=/s/true/false/" \
-e "/ouifile=/{/wireshark/d;s|/etc|${DOCSDIR}|;}" \
@ -99,4 +106,4 @@ post-install:
${MV} ${STAGEDIR}${PREFIX}/etc/kismet_drone.conf \
${STAGEDIR}${PREFIX}/etc/kismet_drone.conf.sample
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -0,0 +1,66 @@
--- restricted-plugin-ptw/aircrack-crypto.cc.orig 2018-10-10 00:29:38 UTC
+++ restricted-plugin-ptw/aircrack-crypto.cc
@@ -232,7 +232,7 @@ void calc_pmk( char *key, char *essid_pre, uchar pmk[4
// void calc_ptk (struct WPA_hdsk *wpa, unsigned char bssid[6], unsigned char pmk[32], unsigned char ptk[80]) {
// int i;
// uchar pke[100];
-// HMAC_CTX ctx;
+// HMAC_CTX *ctx;
//
// memcpy( pke, "Pairwise key expansion", 23 );
//
@@ -258,23 +258,23 @@ void calc_pmk( char *key, char *essid_pre, uchar pmk[4
// memcpy( pke + 67, wpa->snonce, 32 );
// }
//
-// HMAC_CTX_init(&ctx);
-// HMAC_Init_ex(&ctx, pmk, 32, EVP_sha1(), NULL);
+// ctx = HMAC_CTX_new();
+// HMAC_Init_ex(ctx, pmk, 32, EVP_sha1(), NULL);
// for(i = 0; i < 4; i++ )
// {
// pke[99] = i;
// //HMAC(EVP_sha1(), values[0], 32, pke, 100, ptk + i * 20, NULL);
-// HMAC_Init_ex(&ctx, 0, 0, 0, 0);
-// HMAC_Update(&ctx, pke, 100);
-// HMAC_Final(&ctx, ptk + i*20, NULL);
+// HMAC_Init_ex(ctx, 0, 0, 0, 0);
+// HMAC_Update(ctx, pke, 100);
+// HMAC_Final(ctx, ptk + i*20, NULL);
// }
-// HMAC_CTX_cleanup(&ctx);
+// HMAC_CTX_free(ctx);
// }
void calc_mic (struct AP_info *ap, unsigned char pmk[32], unsigned char ptk[80], unsigned char mic[20]) {
int i;
uchar pke[100];
- HMAC_CTX ctx;
+ HMAC_CTX *ctx;
memcpy( pke, "Pairwise key expansion", 23 );
@@ -300,17 +300,17 @@ void calc_mic (struct AP_info *ap, unsigned char pmk[3
memcpy( pke + 67, ap->wpa.snonce, 32 );
}
- HMAC_CTX_init(&ctx);
- HMAC_Init_ex(&ctx, pmk, 32, EVP_sha1(), NULL);
+ ctx = HMAC_CTX_new();
+ HMAC_Init_ex(ctx, pmk, 32, EVP_sha1(), NULL);
for(i = 0; i < 4; i++ )
{
pke[99] = i;
//HMAC(EVP_sha1(), values[0], 32, pke, 100, ptk + i * 20, NULL);
- HMAC_Init_ex(&ctx, 0, 0, 0, 0);
- HMAC_Update(&ctx, pke, 100);
- HMAC_Final(&ctx, ptk + i*20, NULL);
+ HMAC_Init_ex(ctx, 0, 0, 0, 0);
+ HMAC_Update(ctx, pke, 100);
+ HMAC_Final(ctx, ptk + i*20, NULL);
}
- HMAC_CTX_cleanup(&ctx);
+ HMAC_CTX_free(ctx);
if( ap->wpa.keyver == 1 )
{

View File

@ -1,10 +0,0 @@
--- restricted-plugin-ptw/aircrack-crypto.cc.orig 2016-07-02 18:06:10 UTC
+++ restricted-plugin-ptw/aircrack-crypto.cc
@@ -21,6 +21,7 @@
#include <string.h>
#include <arpa/inet.h>
#include <assert.h>
+#include <stdint.h>
#include "aircrack-crypto.h"
#include "aircrack-crctable.h"
#include "aircrack-ptw2-lib.h"