science/py-dwave-preprocessing: Update 0.5.2 -> 0.5.4

Reported by:	portscout
This commit is contained in:
Yuri Victorovich 2022-12-24 23:57:47 -08:00
parent 2e3f93c2b5
commit e37c411b1a
3 changed files with 18 additions and 7 deletions

View File

@ -1,5 +1,5 @@
PORTNAME= dwave-preprocessing
DISTVERSION= 0.5.2
DISTVERSION= 0.5.4
CATEGORIES= science python # quantum-computing
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -10,14 +10,15 @@ WWW= https://github.com/dwavesystems/dwave-preprocessing
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dimod>0:science/py-dimod@${PY_FLAVOR} \
PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dimod>=0.12.2:science/py-dimod@${PY_FLAVOR} \
${PYNUMPY}
BUILD_DEPENDS= ${PY_DEPENDS} \
${PYTHON_PKGNAMEPREFIX}wheel>=0.30.0:devel/py-wheel@${PY_FLAVOR}
LIB_DEPENDS= libspdlog.so:devel/spdlog
RUN_DEPENDS= ${PY_DEPENDS}
USES= python:3.7+
USE_PYTHON= distutils cython unittest
USES= localbase:ldflags python:3.7+
USE_PYTHON= distutils cython unittest # 1 test fails, see https://github.com/dwavesystems/dwave-preprocessing/issues/74
USE_GITHUB= yes
GH_ACCOUNT= dwavesystems

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1668294419
SHA256 (dwavesystems-dwave-preprocessing-0.5.2_GH0.tar.gz) = 07f80f4e8ede2f22d65a94711ca98fc41ce76c2825a917b0f70b8c6eeb569db7
SIZE (dwavesystems-dwave-preprocessing-0.5.2_GH0.tar.gz) = 101675
TIMESTAMP = 1671954380
SHA256 (dwavesystems-dwave-preprocessing-0.5.4_GH0.tar.gz) = 864ec18a8f14a83f0439d3cb6a9006c0d9577012f2cab14b622dc715bac17b24
SIZE (dwavesystems-dwave-preprocessing-0.5.4_GH0.tar.gz) = 104138

View File

@ -0,0 +1,10 @@
--- setup.py.orig 2022-12-25 07:50:44 UTC
+++ setup.py
@@ -26,6 +26,7 @@ extra_compile_args = {
'msvc': ['/std:c++17', '/EHsc'],
'unix': [
'-std=c++17',
+ '-DSPDLOG_FMT_EXTERNAL=1',
],
}