MFH: r497487
Fix the issue tigervnc-server and -viewer cannot be installed together when DOCS=on because both ports install LICENSE_FILE into the same place. Also, following changes are made. net/tigervnc-{server,viewer}: - bump PORTREVISION due to plist & dependency change - do not build tests, it introduces unnecessary dependencies on fltk net/tigervnc-server: - add missing dependency on devel/m4 - remove unnecessary dependency on x11-toolkits/fltk Approved by: portmgr (miwi)
This commit is contained in:
parent
8166eb4d21
commit
e37492ce84
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2019Q2/; revision=497801
@ -1,5 +1,6 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTREVISION= 1
|
||||
PKGNAMESUFFIX= -server
|
||||
CATEGORIES= net x11-servers
|
||||
|
||||
@ -8,7 +9,7 @@ COMMENT= TigerVNC Server
|
||||
PATCH_DEPENDS+= ${NONEXISTENT}:x11-servers/xorg-server:patch
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/include/GL/internal/dri_interface.h:graphics/mesa-dri \
|
||||
${LOCALBASE}/libdata/pkgconfig/fontutil.pc:x11-fonts/font-util \
|
||||
${LOCALBASE}/include/FL/Fl.H:x11-toolkits/fltk \
|
||||
gm4:devel/m4 \
|
||||
bash:shells/bash
|
||||
LIB_DEPENDS= libxshmfence.so:x11/libxshmfence
|
||||
# almost equivalent to x11-servers/xorg-server's
|
||||
@ -60,6 +61,8 @@ pre-patch:
|
||||
@${CP} -R $$(${XORG_WRKSRC})/ ${WRKSRC}/unix/xserver/
|
||||
|
||||
post-patch:
|
||||
# do not build tests
|
||||
@${REINPLACE_CMD} -e 's|add_subdirectory(tests)||' ${WRKSRC}/CMakeLists.txt
|
||||
@cd ${WRKSRC}/unix/xserver/ && ${PATCH} -p1 < ${WRKSRC}/unix/xserver$$(${TIGERVNC_XORG_PATCH_VER}).patch
|
||||
|
||||
post-configure:
|
||||
|
@ -9,5 +9,5 @@ man/man1/vncconfig.1.gz
|
||||
man/man1/vncpasswd.1.gz
|
||||
man/man1/vncserver.1.gz
|
||||
man/man1/x0vncserver.1.gz
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENCE.TXT
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.rst
|
||||
%%PORTDOCS%%%%DOCSDIR%%/%%TIGERVNC_COMPONENT%%LICENCE.TXT
|
||||
%%PORTDOCS%%%%DOCSDIR%%/%%TIGERVNC_COMPONENT%%README.rst
|
||||
|
@ -1,5 +1,6 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTREVISION= 1
|
||||
PKGNAMESUFFIX= -viewer
|
||||
CATEGORIES= net
|
||||
|
||||
@ -29,8 +30,11 @@ DESKTOP_ENTRIES= "TigerVNC viewer" "Connect to VNC server and display remote des
|
||||
"${PORTNAME}" "vncviewer" "Network;" false
|
||||
|
||||
post-patch:
|
||||
# do not build server components
|
||||
@${REINPLACE_CMD} -e 's|add_subdirectory(unix)||' ${WRKSRC}/CMakeLists.txt
|
||||
# do not build server components and tests
|
||||
@${REINPLACE_CMD} \
|
||||
-e 's|add_subdirectory(unix)||' \
|
||||
-e 's|add_subdirectory(tests)||' \
|
||||
${WRKSRC}/CMakeLists.txt
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../tigervnc
|
||||
.include "${MASTERDIR}/Makefile.common.mk"
|
||||
|
@ -30,5 +30,5 @@ share/icons/hicolor/scalable/apps/tigervnc.svg
|
||||
%%NLS%%share/locale/uk/LC_MESSAGES/tigervnc.mo
|
||||
%%NLS%%share/locale/vi/LC_MESSAGES/tigervnc.mo
|
||||
%%NLS%%share/locale/zh_CN/LC_MESSAGES/tigervnc.mo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENCE.TXT
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.rst
|
||||
%%PORTDOCS%%%%DOCSDIR%%/%%TIGERVNC_COMPONENT%%LICENCE.TXT
|
||||
%%PORTDOCS%%%%DOCSDIR%%/%%TIGERVNC_COMPONENT%%README.rst
|
||||
|
@ -14,14 +14,22 @@ USES+= cmake:insource,noninja
|
||||
USE_GITHUB= yes
|
||||
|
||||
GH_ACCOUNT= TigerVNC
|
||||
|
||||
CONFLICTS= tightvnc-[0-9]*
|
||||
PLIST_SUB+= TIGERVNC_COMPONENT=${PORTNAME}${PKGNAMESUFFIX}-
|
||||
|
||||
CMAKE_ARGS+= -G "Unix Makefiles"
|
||||
MAKE_ARGS+= TIGERVNC_SRCDIR=${WRKSRC}
|
||||
|
||||
DOCS= LICENCE.TXT README.rst
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
PLIST= ${.CURDIR}/pkg-plist
|
||||
|
||||
do-install-DOCS-on:
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for f in ${DOCS}
|
||||
(cd ${WRKSRC} && ${INSTALL_DATA} ${f} ${STAGEDIR}${DOCSDIR}/${PORTNAME}${PKGNAMESUFFIX}-${f})
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,10 +1,8 @@
|
||||
--- cmake/BuildPackages.cmake.orig 2017-04-19 13:27:31 UTC
|
||||
--- cmake/BuildPackages.cmake.orig 2018-07-16 14:08:55 UTC
|
||||
+++ cmake/BuildPackages.cmake
|
||||
@@ -86,5 +86,5 @@ endif() #UNIX
|
||||
@@ -86,5 +86,3 @@ endif() #UNIX
|
||||
# Common
|
||||
#
|
||||
|
||||
-install(FILES ${CMAKE_SOURCE_DIR}/LICENCE.TXT DESTINATION ${DOC_DIR})
|
||||
-install(FILES ${CMAKE_SOURCE_DIR}/README.rst DESTINATION ${DOC_DIR})
|
||||
+install(FILES ${CMAKE_SOURCE_DIR}/LICENCE.TXT DESTINATION share/doc/tigervnc)
|
||||
+install(FILES ${CMAKE_SOURCE_DIR}/README.rst DESTINATION share/doc/tigervnc)
|
||||
|
Loading…
Reference in New Issue
Block a user