Move devel/autoconf->devel/autoconf253 and devel/automake->devel/automake15

All autotools ports are now truly versioned and do not conflict with each
other.

This marks the end of "Phase 1" of the autotools updates.
This commit is contained in:
Ade Lovett 2004-08-03 22:36:52 +00:00
parent 99fb36c32d
commit e32a824579
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=115365
38 changed files with 142 additions and 430 deletions

View File

@ -10,6 +10,14 @@ in the release notes.
All ports committers are allowed to commit to this file.
20040803:
AUTHOR: ade@FreeBSD.org
As part of the ongoing autotools cleanup, devel/autoconf has been
replaced with devel/autoconf253, and devel/automake with devel/automake15.
Consumers of the various autotools knobs from bsd.autotools.mk should not
notice any differences. This update completes the transition of autotools
to true versioned packages (cf: tcl/tk)
20040723:
AUTHOR: anholt@FreeBSD.org
The XFREE86_VERSION variable is replaced by the X_WINDOW_SYSTEM variable.

2
MOVED
View File

@ -1216,3 +1216,5 @@ net/zebra-devel||2004-07-27|The same as net/zebra for some time
mail/pear-mailparse|mail/pecl-mailparse|2004-07-30|Renamed
security/lcrzo|net/netwib|2004-08-01|The project has been renamed and port moved to better category
security/lcrzoex|net/netwox|2004-08-01|The project has been renamed and port moved to better category
devel/autoconf|devel/autoconf253|2004-08-03|autotools cleanup
devel/automake|devel/automake15|2004-08-03|autotools cleanup

View File

@ -116,12 +116,6 @@ Autotools_Include_MAINTAINER= ade@FreeBSD.org
# the configuration steps.
#
# Things to do:
# - Move both autoconf and automake to true versioned ports
# (devel/autoconf253 and devel/automake14 respectively). This is
# likely to break a number of ports that make assumptions about
# "autoconf", "automake", et al. but is required if we are to move
# to strictly-versioned autotools.
#
# - Work on killing off as many "old" autotools ports as possible
#
# - Bring back the installation of libtool .la files by default, removing
@ -153,15 +147,7 @@ GNU_CONFIGURE?= yes
.endif
.if defined(WANT_AUTOMAKE_VER)
# XXX: hackery to handle non-versioned "legacy" ports
# destined to die
#
. if ${WANT_AUTOMAKE_VER} == 15
AUTOMAKE_SUFFIX= # empty
. else
AUTOMAKE_SUFFIX= ${WANT_AUTOMAKE_VER}
. endif
# Make sure we specified a legal version of automake
#
@ -220,15 +206,7 @@ BROKEN= "Incompatible autoheader ${WANT_AUTOHEADER_VER} and autoconf ${WANT_AUTO
.endif
.if defined(WANT_AUTOCONF_VER)
# XXX: hackery to handle non-versioned "legacy" ports
# destined to die
#
. if ${WANT_AUTOCONF_VER} == 253
AUTOCONF_SUFFIX= # empty
. else
AUTOCONF_SUFFIX= ${WANT_AUTOCONF_VER}
. endif
# Make sure we specified a legal version of autoconf
#
@ -277,9 +255,6 @@ GNU_CONFIGURE?= yes
WANT_LIBTOOL_VER?= ${USE_INC_LIBTOOL_VER}
.endif
# Note that there aren't any non-versioned libtools, so we can skip
# a little bit of cruft that exists in automake/autoconf above
#
.if defined(WANT_LIBTOOL_VER)
LIBTOOL_SUFFIX= ${WANT_LIBTOOL_VER}

View File

@ -33,9 +33,9 @@ pre-patch: build-depends
post-patch:
@${ECHO_CMD} "" >>${WRKSRC}/libfaac/psych.h
@cd ${WRKSRC}; ${ACLOCAL} -I .; \
@cd ${WRKSRC}; ${SETENV} ${AUTOMAKE_ENV} ${ACLOCAL} -I .; \
${SETENV} ${SCRIPTS_ENV} ${LIBTOOLIZE} --automake
@${REINPLACE_CMD} -e 's|$$lt_target|$$host|' \
${REINPLACE_CMD} -e 's|$$lt_target|$$host|' \
${WRKSRC}/aclocal.m4
.include <bsd.port.mk>

View File

@ -0,0 +1,7 @@
--- configure.orig Sat Oct 18 20:10:50 2003
+++ configure Wed Jul 7 21:43:37 2004
@@ -5,3 +5,3 @@
echo "Running autoconf..."
- autoconf
+ ${AUTOCONF}
test "x$1" = "x--regenerate" && shift

View File

@ -0,0 +1,7 @@
--- configure.orig Sat Oct 18 20:10:50 2003
+++ configure Wed Jul 7 21:43:37 2004
@@ -5,3 +5,3 @@
echo "Running autoconf..."
- autoconf
+ ${AUTOCONF}
test "x$1" = "x--regenerate" && shift

View File

@ -55,13 +55,13 @@
SUBDIR += atlas
SUBDIR += aunit
SUBDIR += autobook
SUBDIR += autoconf
SUBDIR += autoconf213
SUBDIR += autoconf253
SUBDIR += autoconf259
SUBDIR += autodia
SUBDIR += autogen
SUBDIR += automake
SUBDIR += automake14
SUBDIR += automake15
SUBDIR += automake18
SUBDIR += avalon-framework
SUBDIR += avarice

View File

@ -1,55 +0,0 @@
# New ports collection makefile for: autoconf
# Date created: 7 October 1995
# Whom: torstenb@FreeBSD.org
#
# $FreeBSD$
#
PORTNAME= autoconf
PORTVERSION= 2.53
PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= ade/gnu
MAINTAINER= ade@FreeBSD.org
COMMENT= Automatically configure source code on many Un*x platforms
DEPRECATED= Please use devel/autoconf259 instead
EXPIRATION_DATE=31st December 2004
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
help2man:${PORTSDIR}/misc/help2man
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
LATEST_LINK= autoconf
USE_BZIP2= yes
USE_PERL5_RUN= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CONFIG_SHELL=${SH} M4=${LOCALBASE}/bin/gm4
CONFIGURE_ARGS= --without-lispdir
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
GENERIC_TOOLS= config.guess config.sub elisp-comp install-sh mdate-sh \
missing mkinstalldirs
MAN1= autoconf.1 autoheader.1 autom4te.1 autoreconf.1 autoscan.1 \
autoupdate.1 config.guess.1 config.sub.1 ifnames.1
.if defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
pre-everything::
@${ECHO} ===========================================================
@${ECHO} "You have 'USE_AUTOCONF' or 'USE_AUTOCONF_VER' variables"
@${ECHO} "defined either in environment or in make(1) arguments."
@${ECHO} "Please undefine them and try again."
@${ECHO} ===========================================================
@${FALSE}
.endif # defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
post-install:
.for FILE in ${GENERIC_TOOLS}
${INSTALL_SCRIPT} ${WRKSRC}/config/${FILE} ${PREFIX}/share/autoconf
.endfor
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
MD5 (autoconf-2.53.tar.bz2) = c121b003f51e293c2bf5a6105c721388
SIZE (autoconf-2.53.tar.bz2) = 756398

View File

@ -1,15 +0,0 @@
--- bin/autoscan.in.orig Fri Mar 8 06:52:41 2002
+++ bin/autoscan.in Mon Sep 16 03:56:50 2002
@@ -192,7 +192,11 @@
sub used ($$;$)
{
my ($kind, $word, $where) = @_;
- $where ||= "$File::Find::name:$.";
+ my $lineno = 0;
+ if (defined($.)) {
+ $lineno = $.;
+ }
+ $where ||= "$File::Find::name:$lineno";
push (@{$used{$kind}{$word}}, $where);
}

View File

@ -1,9 +0,0 @@
Autoconf is an extensible package of m4 macros that produce shell
scripts to automatically configure software source code packages.
These scripts can adapt the packages to many kinds of UNIX-like
systems without manual user intervention. Autoconf creates a
configuration script for a package from a template file that lists the
operating system features that the package can use, in the form of m4
macro calls.
WWW: http://www.gnu.org/software/autoconf/

View File

@ -1,62 +0,0 @@
bin/autoconf
bin/autoheader
bin/autom4te
bin/autoreconf
bin/autoscan
bin/autoupdate
bin/ifnames
share/autoconf/Autom4te/General.pm
share/autoconf/Autom4te/Struct.pm
share/autoconf/Autom4te/XFile.pm
share/autoconf/INSTALL
share/autoconf/autoconf/autoconf.m4
share/autoconf/autoconf/autoconf.m4f
share/autoconf/autoconf/autoheader.m4
share/autoconf/autoconf/autotest.m4
share/autoconf/autoconf/autoupdate.m4
share/autoconf/autoconf/c.m4
share/autoconf/autoconf/fortran.m4
share/autoconf/autoconf/functions.m4
share/autoconf/autoconf/general.m4
share/autoconf/autoconf/headers.m4
share/autoconf/autoconf/lang.m4
share/autoconf/autoconf/libs.m4
share/autoconf/autoconf/oldnames.m4
share/autoconf/autoconf/programs.m4
share/autoconf/autoconf/specific.m4
share/autoconf/autoconf/status.m4
share/autoconf/autoconf/types.m4
share/autoconf/autom4te.cfg
share/autoconf/autoscan/functions
share/autoconf/autoscan/headers
share/autoconf/autoscan/identifiers
share/autoconf/autoscan/libraries
share/autoconf/autoscan/makevars
share/autoconf/autoscan/programs
share/autoconf/autotest/autotest.m4
share/autoconf/autotest/autotest.m4f
share/autoconf/autotest/general.m4
share/autoconf/config.guess
share/autoconf/config.sub
share/autoconf/elisp-comp
share/autoconf/install-sh
share/autoconf/m4sugar/m4sh.m4
share/autoconf/m4sugar/m4sh.m4f
share/autoconf/m4sugar/m4sugar.m4
share/autoconf/m4sugar/m4sugar.m4f
share/autoconf/m4sugar/version.m4
share/autoconf/mdate-sh
share/autoconf/missing
share/autoconf/mkinstalldirs
@dirrm share/autoconf/m4sugar
@dirrm share/autoconf/autotest
@dirrm share/autoconf/autoscan
@dirrm share/autoconf/autoconf
@dirrm share/autoconf/Autom4te
@dirrm share/autoconf
@unexec install-info --delete %D/info/autoconf.info %D/info/dir
@unexec install-info --delete %D/info/standards.info %D/info/dir
info/autoconf.info
info/standards.info
@exec install-info %D/info/autoconf.info %D/info/dir
@exec install-info %D/info/standards.info %D/info/dir

View File

@ -1,44 +0,0 @@
# New ports collection makefile for: automake
# Date created: 15 March 1997
# Whom: FUJIMOTO Kensaku <fujimoto@oscar.elec.waseda.ac.jp>
#
# $FreeBSD$
#
PORTNAME= automake
PORTVERSION= 1.5
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= automake
MAINTAINER= ade@FreeBSD.org
COMMENT= GNU Standards-compliant Makefile generator
DEPRECATED= Please use devel/automake18 instead
EXPIRATION_DATE=31st December 2004
LATEST_LINK= automake
GNU_CONFIGURE= yes
CONFIGURE_ENV= PERL=${PERL5}
USE_PERL5= yes
STRIP= # none
.if defined(USE_AUTOMAKE) || defined(USE_AUTOMAKE_VER)
pre-everything::
@${ECHO} ===========================================================
@${ECHO} "You have 'USE_AUTOMAKE' or 'USE_AUTOMAKE_VER' variables"
@${ECHO} "defined either in environment or in make(1) arguments."
@${ECHO} "Please undefine them and try again."
@${ECHO} ===========================================================
@${FALSE}
.endif # defined(USE_AUTOMAKE) || defined(USE_AUTOMAKE_VER)
pre-configure:
${PERL} -pi -e "s^%%X11BASE%%^${X11BASE}^" ${WRKSRC}/aclocal.in
post-install:
@install-info ${PREFIX}/info/automake.info ${PREFIX}/info/dir
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
MD5 (automake-1.5.tar.gz) = 74a22ac0581378e807ecb334a55c5bab
SIZE (automake-1.5.tar.gz) = 526934

View File

@ -1,11 +0,0 @@
--- Makefile.in.orig Sun Sep 9 11:42:15 2001
+++ Makefile.in Sun Sep 9 11:42:51 2001
@@ -180,7 +180,7 @@
.texi.info:
@cd $(srcdir) && rm -f $@ $@-[0-9] $@-[0-9][0-9]
cd $(srcdir) \
- && $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) \
+ && $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) --no-split \
`echo $< | sed 's,.*/,,'`
.texi.dvi:

View File

@ -1,48 +0,0 @@
--- aclocal.in.orig Sun Sep 9 11:31:39 2001
+++ aclocal.in Sun Sep 9 11:37:54 2001
@@ -34,6 +34,8 @@
# Note that this isn't pkgdatadir, but a separate directory.
$acdir = "@datadir@/aclocal";
+$acdir_x11 = '%%X11BASE%%/share/aclocal';
+
# Some globals.
# Exit status.
@@ -115,6 +117,9 @@
local (@dirlist) = &parse_arguments (@ARGV);
+
+unshift @dirlist, $acdir_x11 if -d "$acdir_x11/.";
+
&scan_m4_files (@dirlist);
&scan_configure;
if (! $exit_status)
@@ -299,11 +304,13 @@
$file_contents{'acinclude.m4'} = &scan_file ('acinclude.m4');
}
+ local (@skipinolist) = ();
local ($m4dir);
foreach $m4dir (@dirlist)
{
opendir (DIR, $m4dir)
|| die "aclocal: couldn't open directory `$m4dir': $!\n";
+ local ($file, $fullfile, $expr);
local ($file, $fullfile);
foreach $file (sort grep (! /^\./, readdir (DIR)))
{
@@ -314,6 +321,12 @@
next if $file eq 'aclocal.m4';
$fullfile = $m4dir . '/' . $file;
+
+ # Do not scan a file more than once.
+ $ino = (stat($fullfile))[1];
+ next if grep($ino eq $_, @skipinolist);
+ push @skipinolist, $ino;
+
$file_contents{$fullfile} = &scan_file ($fullfile);
}
closedir (DIR);

View File

@ -1,25 +0,0 @@
--- automake.texi.orig Sat Apr 4 04:04:07 1998
+++ automake.texi Wed Sep 23 23:34:15 1998
@@ -1,6 +1,7 @@
\input texinfo @c -*-texinfo-*-
@c %**start of header
@setfilename automake.info
+@dircategory Programming & development tools
@settitle automake
@setchapternewpage off
@c %**end of header
@@ -9,12 +10,12 @@
@dircategory GNU admin
@direntry
-* automake: (automake). Making Makefile.in's
+* Automake: (automake). Making Makefile.in's
@end direntry
@dircategory Individual utilities
@direntry
-* aclocal: (automake)Invoking aclocal. Generating aclocal.m4
+* Aclocal: (automake) Invoking aclocal. Generating aclocal.m4
@end direntry
@ifinfo

View File

@ -1,8 +0,0 @@
Automake is an experimental Makefile generator. It was inspired by
the 4.4BSD make and include files, but aims to be portable and to
conform to the GNU standards for Makefile variables and targets.
Automake assumes the project uses autoconf. If you want automatic
dependency tracking support, the use of GNU make is also required.
WWW: http://sources.redhat.com/automake/

View File

@ -1,93 +0,0 @@
bin/aclocal
bin/automake
@unexec install-info --delete %D/info/automake.info %D/info/dir
info/automake.info
@exec install-info %D/info/automake.info %D/info/dir
share/aclocal/as.m4
share/aclocal/auxdir.m4
share/aclocal/ccstdc.m4
share/aclocal/cond.m4
share/aclocal/depend.m4
share/aclocal/depout.m4
share/aclocal/dmalloc.m4
share/aclocal/error.m4
share/aclocal/gcj.m4
share/aclocal/header.m4
share/aclocal/init.m4
share/aclocal/install-sh.m4
share/aclocal/lex.m4
share/aclocal/lispdir.m4
share/aclocal/maintainer.m4
share/aclocal/make.m4
share/aclocal/minuso.m4
share/aclocal/missing.m4
share/aclocal/multi.m4
share/aclocal/obstack.m4
share/aclocal/protos.m4
share/aclocal/ptrdiff.m4
share/aclocal/python.m4
share/aclocal/regex.m4
share/aclocal/sanity.m4
share/aclocal/strip.m4
share/aclocal/strtod.m4
share/aclocal/termios.m4
share/aclocal/winsz.m4
share/automake/Automake/Struct.pm
share/automake/COPYING
share/automake/INSTALL
share/automake/acinstall
share/automake/am/ansi2knr.am
share/automake/am/check.am
share/automake/am/clean-hdr.am
share/automake/am/clean.am
share/automake/am/compile.am
share/automake/am/configure.am
share/automake/am/data.am
share/automake/am/dejagnu.am
share/automake/am/depend.am
share/automake/am/depend2.am
share/automake/am/distdir.am
share/automake/am/footer.am
share/automake/am/header-vars.am
share/automake/am/header.am
share/automake/am/install.am
share/automake/am/java.am
share/automake/am/lang-compile.am
share/automake/am/lex.am
share/automake/am/library.am
share/automake/am/libs.am
share/automake/am/libtool.am
share/automake/am/lisp.am
share/automake/am/ltlib.am
share/automake/am/ltlibrary.am
share/automake/am/mans-vars.am
share/automake/am/mans.am
share/automake/am/multilib.am
share/automake/am/program.am
share/automake/am/progs.am
share/automake/am/python.am
share/automake/am/remake-hdr.am
share/automake/am/scripts.am
share/automake/am/subdirs.am
share/automake/am/tags.am
share/automake/am/texi-vers.am
share/automake/am/texibuild.am
share/automake/am/texinfos.am
share/automake/am/yacc.am
share/automake/ansi2knr.1
share/automake/ansi2knr.c
share/automake/compile
share/automake/config.guess
share/automake/config.sub
share/automake/depcomp
share/automake/elisp-comp
share/automake/install-sh
share/automake/mdate-sh
share/automake/missing
share/automake/mkinstalldirs
share/automake/py-compile
share/automake/texinfo.tex
share/automake/ylwrap
@dirrm share/automake/am
@dirrm share/automake/Automake
@dirrm share/automake

View File

@ -19,7 +19,7 @@ COMMENT= GNU Standards-compliant Makefile generator (version 1.5)
DEPRECATED= Please use devel/automake18 instead
EXPIRATION_DATE=31st December 2004
WANT_AUTOCONF_VER=253
WANT_AUTOCONF_VER=yes
WANT_AUTOCONF_RUN=253
BUILD_VERSION= 15
PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}

View File

@ -0,0 +1,12 @@
--- gcc/Makefile.in.orig Thu Jan 25 14:02:58 2001
+++ gcc/Makefile.in Wed Jul 7 20:48:46 2004
@@ -805,3 +805,3 @@
$(srcdir)/configure: $(srcdir)/configure.in
- cd $(srcdir); autoconf
+ cd $(srcdir); autoconf253
@@ -818,3 +818,3 @@
$(srcdir)/cstamp-h.in: $(srcdir)/configure.in $(srcdir)/acconfig.h
- cd $(srcdir) && autoheader
+ cd $(srcdir) && autoheader253
@rm -f $(srcdir)/cstamp-h.in

View File

@ -0,0 +1,15 @@
--- admin/detect-autoconf.sh.orig Sun May 25 13:51:54 2003
+++ admin/detect-autoconf.sh Wed Jul 7 05:36:58 2004
@@ -3,7 +3,7 @@
# Global variables...
-AUTOCONF="autoconf"
-AUTOHEADER="autoheader"
-AUTOM4TE="autom4te"
-AUTOMAKE="automake"
-ACLOCAL="aclocal"
+AUTOCONF="autoconf253"
+AUTOHEADER="autoheader253"
+AUTOM4TE="autom4te253"
+AUTOMAKE="automake15"
+ACLOCAL="aclocal15"

View File

@ -4,7 +4,7 @@ libexec/emacs/%%EMACS_VER%%/%%EMACS_ARCH%%/canna.so
%%LISPDIR%%/canna/canna.elc
%%LISPDIR%%/canna/canna-leim.el
%%LISPDIR%%/canna/canna-leim.elc
%%DOCDIR%%/README.ja
%%DOCDIR%%/ChangeLog
%%PORTDOCS%%%%DOCDIR%%/README.ja
%%PORTDOCS%%%%DOCDIR%%/ChangeLog
@dirrm %%LISPDIR%%/canna
@dirrm %%DOCDIR%%
%%PORTDOCS%%@dirrm %%DOCDIR%%

View File

@ -37,6 +37,6 @@ share/emacs/site-lisp/egg/its/zhuyin.el
share/emacs/site-lisp/egg/its/zhuyin.elc
@dirrm share/emacs/site-lisp/egg/its
@dirrm share/emacs/site-lisp/egg
%%DOCDIR%%/README.ja
%%DOCDIR%%/ChangeLog
@dirrm %%DOCDIR%%
%%PORTDOCS%%%%DOCDIR%%/README.ja
%%PORTDOCS%%%%DOCDIR%%/ChangeLog
%%PORTDOCS%%@dirrm %%DOCDIR%%

View File

@ -1,11 +1,16 @@
--- scripts/phpize.in.orig Fri Jun 25 12:51:38 2004
+++ scripts/phpize.in Fri Jun 25 12:52:14 2004
@@ -64,7 +64,7 @@
echo
exit 1
--- scripts/phpize.in.orig Fri Nov 14 03:21:15 2003
+++ scripts/phpize.in Wed Jul 7 01:34:05 2004
@@ -56,5 +56,5 @@
-aclocal || exit 1
-autoconf || exit 1
-autoheader || exit 1
+aclocal15 || exit 1
+autoconf253 || exit 1
+autoheader253 || exit 1
test -x $builddir/build/shtool || chmod +x $builddir/build/shtool
@@ -66,3 +66,3 @@
fi
-libtoolize=`$builddir/build/shtool path glibtoolize libtoolize`
+libtoolize=`$builddir/build/shtool path libtoolize13`
$libtoolize -f -c || exit 1
# dumping API NOs:

View File

@ -13,8 +13,6 @@ CATEGORIES= net
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Ncurses-based console plugin for Licq
#USE_AUTOCONF_VER= 254
#USE_AUTOMAKE_VER= 15
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" \
LIBS="${PTHREAD_LIBS}"
LICQ_PORT?= net/licq

View File

@ -0,0 +1,20 @@
--- autogen.orig Tue Mar 18 15:47:57 2003
+++ autogen Wed Jul 7 17:45:10 2004
@@ -14,12 +14,12 @@
else
- libtoolize --automake
+ libtoolize13 --automake
fi
echo "aclocal..."
-aclocal
+aclocal15
echo "autoheader..."
-autoheader
+autoheader253
echo "automake..."
-automake --add-missing
+automake15 --add-missing
echo "autoconf..."
-autoconf
+autoconf253

View File

@ -13,8 +13,6 @@ CATEGORIES= net
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Ncurses-based console plugin for Licq
#USE_AUTOCONF_VER= 254
#USE_AUTOMAKE_VER= 15
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" \
LIBS="${PTHREAD_LIBS}"
LICQ_PORT?= net/licq

View File

@ -21,7 +21,7 @@ USE_GMAKE= yes
USE_PERL5= yes
USE_BZIP2= yes
WANT_AUTOMAKE_VER= 15
USE_AUTOCONF_VER= 213
USE_AUTOCONF_VER= 253
GNU_CONFIGURE= yes
NO_CHECKSUM= yes # the tarball is created on the fly from CVS
CONFIGURE_ARGS= --prefix=${PREFIX}
@ -69,8 +69,8 @@ do-fetch:
exit 1; \
fi
pre-configure:
@cd ${WRKSRC} && ./make_configure
#pre-configure:
# @cd ${WRKSRC} && ${SETENV} ${SCRIPTS_ENV} ./make_configure
post-build:
@${CHMOD} +x ${WRKSRC}/mkinstalldirs

View File

@ -0,0 +1,10 @@
--- make_configure.orig Fri Oct 11 01:16:34 2002
+++ make_configure Wed Jul 7 18:23:05 2004
@@ -1,3 +1,3 @@
-aclocal
-autoconf
-perl -p -i -e "s=\#include <xmlversion.h>=\#include <libxml/xmlversion.h>=g" configure
\ No newline at end of file
+aclocal15
+autoconf253
+perl -p -i -e "s=\#include <xmlversion.h>=\#include <libxml/xmlversion.h>=g" configure

View File

@ -20,6 +20,7 @@ LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2 \
apr-0.9:${PORTSDIR}/devel/apr
USE_AUTOCONF_VER= 253
WANT_LIBTOOL_VER= 15
CONFIGURE_ARGS= --disable-shared
CONFIGURE_ENV= LDFLAGS="-L${PREFIX}/lib"
USE_GMAKE= yes

View File

@ -0,0 +1,7 @@
--- configure.in.orig Sat Sep 6 03:06:11 2003
+++ configure.in Wed Jul 7 00:38:40 2004
@@ -125,3 +125,3 @@
LDFLAGS="$LDFLAGS `$apr_config --ldflags`"
-LIBTOOL="`$apr_config --apr-libtool`"
+LIBTOOL="$LIBTOOL"
LIBTOOL_LIBS="$LIBTOOL_LIBS `$apr_config --link-libtool --libs`"

View File

@ -17,7 +17,7 @@ DIST_SUBDIR= mod_webapp
MAINTAINER= asachs@uunet.co.za
COMMENT= Apache module mounts Tomcat web applications
BUILD_DEPENDS= ${NONEXISTANT}:${PORTSDIR}/devel/apr:extract
BUILD_DEPENDS= ${NONEXISTANT}:${PORTSDIR}/devel/apr:configure
USE_APACHE= yes
WANT_AUTOCONF_VER=253

View File

@ -99,6 +99,7 @@ pre-configure:
.for FILE in ${PIC2FIX}
@${REINPLACE_CMD} -e "s|-prefer-pic|${CFLAGS}|g" ${WRKSRC}/${FILE}
.endfor
@${REINPLACE_CMD} -e "s|/bin/sh|/bin/sh -x|" ${WRKSRC}/configure
post-install:
.if !defined(NOPORTDOCS)

View File

@ -0,0 +1,11 @@
--- build2/build2.mk.orig Thu Apr 11 02:19:45 2002
+++ build2/build2.mk Wed Jul 7 01:51:27 2004
@@ -9,3 +9,3 @@
@echo rebuilding $@
- @autoconf
+ @autoconf253
@@ -19,2 +19,2 @@
@rm -f $@
- @autoheader
+ @autoconf253

View File

@ -99,6 +99,7 @@ pre-configure:
.for FILE in ${PIC2FIX}
@${REINPLACE_CMD} -e "s|-prefer-pic|${CFLAGS}|g" ${WRKSRC}/${FILE}
.endfor
@${REINPLACE_CMD} -e "s|/bin/sh|/bin/sh -x|" ${WRKSRC}/configure
post-install:
.if !defined(NOPORTDOCS)

View File

@ -0,0 +1,11 @@
--- build2/build2.mk.orig Thu Apr 11 02:19:45 2002
+++ build2/build2.mk Wed Jul 7 01:51:27 2004
@@ -9,3 +9,3 @@
@echo rebuilding $@
- @autoconf
+ @autoconf253
@@ -19,2 +19,2 @@
@rm -f $@
- @autoheader
+ @autoconf253

View File

@ -19,10 +19,7 @@ DISTNAME= libvk-Apr19-2243
MAINTAINER= peterho@ned.dem.csiro.au
COMMENT= ViewKit workalike from Hungry Programmers
BUILD_DEPENDS= ${AUTOCONFIG}:${PORTSDIR}/devel/${AUTOCONFIG}
AUTOCONFIG= autoconf
WANT_AUTOCONF_VER= 253
MOTIFPACKAGE?= open-motif
USE_X_PREFIX= yes
USE_MOTIF = yes
@ -36,6 +33,6 @@ BROKEN= "Does not compile (bad C++ code)"
.endif
pre-configure:
@cd ${WRKSRC}; ${CHMOD} +w configure; ${AUTOCONFIG}
@cd ${WRKSRC}; ${CHMOD} +w configure; ${AUTOCONF}
.include <bsd.port.post.mk>