Add a port of Meta-CVS, a more capable version control system than CVS,

built around CVS.

PR:		48258
Submitted by:	Johannes Groedem <johs@copyleft.no>
This commit is contained in:
Greg Lewis 2003-02-28 16:49:54 +00:00
parent ce31c2c6f7
commit e31eae8acf
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=76649
9 changed files with 218 additions and 0 deletions

View File

@ -363,6 +363,7 @@
SUBDIR += makedepend
SUBDIR += makeplus
SUBDIR += memcheck
SUBDIR += meta-cvs
SUBDIR += mico
SUBDIR += mime
SUBDIR += mingw

32
devel/meta-cvs/Makefile Normal file
View File

@ -0,0 +1,32 @@
# New ports collection makefile for: meta-cvs
# Date created: 13 February 2003
# Whom: johs
#
# $FreeBSD$
#
PORTNAME= meta-cvs
PORTVERSION= 1.0.5
CATEGORIES= devel
MASTER_SITES= http://users.footprints.net/~kaz/
DISTNAME= mcvs-${PORTVERSION}
MAINTAINER= johs@copyleft.no
COMMENT= A more capable version control system than CVS, built around CVS
BUILD_DEPENDS= clisp:${PORTSDIR}/lang/clisp
pre-build:
${CP} ${FILESDIR}/Makefile ${WRKSRC}/Makefile
${CP} ${FILESDIR}/build.sh ${WRKSRC}/code
post-install:
${SED} 's:PREFIX:${PREFIX}:g' ${FILESDIR}/mcvs.tmpl > ${WRKDIR}/mcvs
${INSTALL_SCRIPT} ${WRKDIR}/mcvs ${PREFIX}/bin
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/Meta-CVS-PAPER ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/QUICK-GUIDE ${DOCSDIR}
.endif
.include <bsd.port.mk>

1
devel/meta-cvs/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (mcvs-1.0.5.tar.gz) = 106f352a8ff12a94d989b1f826376599

View File

@ -0,0 +1,9 @@
# $FreeBSD$
all: meta-cvs
meta-cvs:
(cd code; /bin/sh build.sh)
install:
(cd code; /bin/sh install.sh ${PREFIX})

View File

@ -0,0 +1,24 @@
#!/bin/sh
#
# $FreeBSD$
CLISP_LIB=$(clisp -q -norc -x '(progn (princ *lib-directory*) (values))')
LINKSET=unix-bindings-linking-set
if [ ! -e $LINKSET ] ; then
export CLISP_LINKKIT="${CLISP_LIB}linkkit"
sh "${CLISP_LIB}clisp-link" add-module-set unix-bindings \
"${CLISP_LIB}base" $LINKSET
fi
LISPRUN=$LINKSET/lisp.run
if ! $LISPRUN -M $LINKSET/lispinit.mem -q -c mcvs-main ; then
echo "There were compilation errors."
exit 1
fi
$LISPRUN -M $LINKSET/lispinit.mem -q -i mcvs-main -x '(ext:saveinitmem "mcvs.mem" :quiet t)'
exit 0

View File

@ -0,0 +1,2 @@
#!PREFIX/lib/clisp/meta-cvs/lisp.run -MPREFIX/lib/clisp/meta-cvs/lispinit.mem
(mcvs)

View File

@ -0,0 +1,124 @@
$FreeBSD$
--- code/install.sh.orig Thu Feb 13 19:30:54 2003
+++ code/install.sh Thu Feb 13 19:31:01 2003
@@ -51,12 +51,6 @@
exit 1
fi
-if [ ! -e $LINKSET ] ; then
- export CLISP_LINKKIT="${CLISP_LIB}linkkit"
- sh "${CLISP_LIB}clisp-link" add-module-set unix-bindings \
- "${CLISP_LIB}base" $LINKSET
-fi
-
LISPRUN=$LINKSET/lisp
if [ -f $LISPRUN.run ] ; then
@@ -65,18 +59,8 @@
elif [ -f $LISPRUN.exe ] ; then
LISPRUN=$LISPRUN.exe
LISPEXE=.exe
-else
- echo "linking set failed to build."
- exit 1
-fi
-
-if ! $LISPRUN -M $LINKSET/lispinit.mem -q -c mcvs-main ; then
- echo "There were compilation errors."
- exit 1
fi
-$LISPRUN -M $LINKSET/lispinit.mem -q -i mcvs-main -x '(ext:saveinitmem "mcvs.mem" :quiet t)'
-
if ! cp mcvs.mem $TARGET_LIB/lispinit.mem; then
echo "Unable to copy to $TARGET_LIB."
exit 1
@@ -84,87 +68,6 @@
if ! cp $LISPRUN $TARGET_LIB; then
echo "Unable to copy to $TARGET_LIB."
- exit 1
-fi
-
-if ! cat > $TARGET_BIN/mcvs <<END
-#!$TARGET_LIB/lisp$LISPEXE -M$TARGET_LIB/lispinit.mem
-(mcvs)
-END
-then
- echo "Could not create mcvs script in $TARGET."
- exit 1
-fi
-
-if ! chmod a+x "$TARGET_BIN/mcvs" ; then
- echo "Could not set permissions of mcvs script in $TARGET."
- exit 1
-fi
-
-if ! cat > $TARGET_BIN/mcvs-upgrade <<END
-#!/bin/sh
-TARGET_LIB="$TARGET_LIB"
-LISPRUN="\$TARGET_LIB/lisp.run -M \$TARGET_LIB/lispinit.mem"
-
-if [ \$# != 1 ] ; then
- echo
- echo "Syntax:"
- echo
- echo " mcvs-upgrade <path-to-source>"
- echo
- echo "The path specifies the directory which holds unpacked Meta-CVS source,"
- echo "the place where the file mcvs-main.lisp is located."
- echo
- echo "This upgrade mechanism is intended to make it possible to use a"
- echo "newer version of Meta-CVS without having to obtain a complete binary"
- echo "distribution that includes the Lisp executable, and without having"
- echo "to install the Lisp development environment to build the sources."
- echo
- echo "Note that it's not possible to upgrade if the newer Meta-CVS sources"
- echo "rely on new C functions being linked into the Lisp system; get a"
- echo "new binary distribution, or set up CLISP and compile Meta-CVS from"
- echo "the sources using its install.sh script"
- echo
- echo "Ignore the copious compiler warnings about objects and functions"
- echo "being redefined; this is what we want."
- echo
- exit 1
-fi
-
-SOURCE_PATH="\$1"
-
-if ! cd "\$SOURCE_PATH" ; then
- echo "unable to change to \$SOURCE_PATH"
- exit 1
-fi
-
-if ! \$LISPRUN -c mcvs-main ; then
- echo "unable to compile"
- exit 1
-fi
-
-if ! \$LISPRUN -q -i mcvs-main -x '(ext:saveinitmem "mcvs.mem" :quiet t)' ; then
- echo "unable to load and generate memory image"
- exit 1
-fi
-
-if ! cp mcvs.mem \$TARGET_LIB/lispinit.mem ; then
- echo "unable to copy new Meta-CVS image to \$TARGET_LIB directory."
- exit 1
-fi
-
-echo
-echo "It appears that Meta-CVS has been re-generated from the given sources."
-echo
-
-END
-then
- echo "Could not create mcvs script in $TARGET."
- exit 1
-fi
-
-if ! chmod a+x "$TARGET_BIN/mcvs-upgrade" ; then
- echo "Could not set permissions of mcvs script in $TARGET."
exit 1
fi

18
devel/meta-cvs/pkg-descr Normal file
View File

@ -0,0 +1,18 @@
This is a port of Meta-CVS, a version control system built around CVS.
Although it retains most of the features of CVS, including all of the
networking support, it is more capable than CVS, and easier to use.
Its main features are:
* Directory structure versioning.
* Support for a promotion model.
* User-friendly file type handling.
* Sane corner cases.
* Simple branching and merging.
* Support for symbolic links and metadata.
* Tracking of third party code containing moves and renames.
* Ease of deployment.
WWW: http://users.footprints.net/~kaz/mcvs.html
- Johannes Groedem
johs@copyleft.no

7
devel/meta-cvs/pkg-plist Normal file
View File

@ -0,0 +1,7 @@
bin/mcvs
lib/clisp/meta-cvs/lispinit.mem
lib/clisp/meta-cvs/lisp.run
@dirrm lib/clisp/meta-cvs
%%PORTDOCS%%%%DOCSDIR%%/Meta-CVS-PAPER
%%PORTDOCS%%%%DOCSDIR%%/QUICK-GUIDE
%%PORTDOCS%%@dirrm %%DOCSDIR%%