textproc/libstaroffice: update to 0.0.7 release
This commit is contained in:
parent
282afd895f
commit
e2ff699318
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=545097
@ -1,8 +1,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libstaroffice
|
||||
PORTVERSION= 0.0.6
|
||||
PORTREVISION= 8
|
||||
PORTVERSION= 0.0.7
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= LODEV
|
||||
MASTER_SITE_SUBDIR= #
|
||||
@ -24,4 +23,7 @@ USE_LDCONFIG= yes
|
||||
CONFIGURE_ARGS= --without-docs
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
|
||||
LIBVERSION= ${PORTVERSION}
|
||||
PLIST_SUB+= LIBVERSION=${LIBVERSION}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1524783443
|
||||
SHA256 (libstaroffice-0.0.6.tar.xz) = 6b00e1ed8194e6072be4441025d1b888e39365727ed5b23e0e8c92c4009d1ec4
|
||||
SIZE (libstaroffice-0.0.6.tar.xz) = 706324
|
||||
TIMESTAMP = 1594860260
|
||||
SHA256 (libstaroffice-0.0.7.tar.xz) = f94fb0ad8216f97127bedef163a45886b43c62deac5e5b0f5e628e234220c8db
|
||||
SIZE (libstaroffice-0.0.7.tar.xz) = 707920
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- src/lib/STOFFOLEParser.cxx.orig 2018-01-30 09:10:08 UTC
|
||||
+++ src/lib/STOFFOLEParser.cxx
|
||||
@@ -506,7 +506,7 @@ bool STOFFOLEParser::readSummaryInformation(STOFFInput
|
||||
ascii.addPos(pos);
|
||||
ascii.addNote(f.str().c_str());
|
||||
|
||||
- for (auto const posToType : posToTypeMap) {
|
||||
+ for (auto const &posToType : posToTypeMap) {
|
||||
pos=posToType.first;
|
||||
input->seek(pos, librevenge::RVNG_SEEK_SET);
|
||||
f.str("");
|
@ -1,11 +0,0 @@
|
||||
--- src/lib/STOFFSpreadsheetListener.hxx.orig 2018-04-25 09:25:45 UTC
|
||||
+++ src/lib/STOFFSpreadsheetListener.hxx
|
||||
@@ -61,7 +61,7 @@ struct State;
|
||||
}
|
||||
|
||||
/** This class contents the main functions needed to create a spreadsheet processing Document */
|
||||
-class STOFFSpreadsheetListener : public STOFFListener
|
||||
+class STOFFSpreadsheetListener final : public STOFFListener
|
||||
{
|
||||
public:
|
||||
/** constructor */
|
@ -1,20 +0,0 @@
|
||||
--- src/lib/StarObjectSmallGraphic.cxx.orig 2018-04-25 11:44:09 UTC
|
||||
+++ src/lib/StarObjectSmallGraphic.cxx
|
||||
@@ -1389,7 +1389,7 @@ bool SdrGraphicPath::send(STOFFListenerPtr &listener,
|
||||
else {
|
||||
shape.m_command=STOFFGraphicShape::C_Path;
|
||||
librevenge::RVNGPropertyListVector path;
|
||||
- for (auto const poly : m_pathPolygons)
|
||||
+ for (auto const &poly : m_pathPolygons)
|
||||
poly.addToPath(path, isClosed, state.m_global->m_relativeUnit, state.m_global->m_offset);
|
||||
shape.m_propertyList.insert("svg:d", path);
|
||||
}
|
||||
@@ -1402,7 +1402,7 @@ bool SdrGraphicPath::send(STOFFListenerPtr &listener,
|
||||
|
||||
////////////////////////////////////////
|
||||
//! Internal: virtual class to store a Sdr graphic uno
|
||||
-class SdrGraphicUno : public SdrGraphicRect
|
||||
+class SdrGraphicUno final : public SdrGraphicRect
|
||||
{
|
||||
public:
|
||||
//! constructor
|
@ -7,5 +7,5 @@ include/libstaroffice-0.0/libstaroffice/STOFFDocument.hxx
|
||||
include/libstaroffice-0.0/libstaroffice/libstaroffice.hxx
|
||||
lib/libstaroffice-0.0.so
|
||||
lib/libstaroffice-0.0.so.0
|
||||
lib/libstaroffice-0.0.so.0.0.6
|
||||
lib/libstaroffice-0.0.so.%%LIBVERSION%%
|
||||
libdata/pkgconfig/libstaroffice-0.0.pc
|
||||
|
Loading…
Reference in New Issue
Block a user