- Respect PTHREAD_CFLAGS[LIBS]
- Correct pkg-descr PR: ports/65549 Submitted by: maintainer
This commit is contained in:
parent
80df8d5a98
commit
e2f45169cc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=107075
@ -25,6 +25,8 @@ CONFIGURE_ARGS= --quiet
|
||||
INSTALL_TARGET= install install-man
|
||||
MAN8= arpwatch.8 arpsnmp.8
|
||||
|
||||
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}"
|
||||
|
||||
post-install:
|
||||
if [ ! -d ${PREFIX}/arpwatch ]; then \
|
||||
${MKDIR} ${PREFIX}/arpwatch; \
|
||||
|
@ -1,14 +1,25 @@
|
||||
--- ../arpwatch.orig/Makefile.in Wed Jun 14 20:39:55 2000
|
||||
+++ ./Makefile.in Mon Sep 15 14:31:33 2003
|
||||
@@ -45,7 +45,7 @@
|
||||
--- Makefile.in.orig Wed Jun 14 20:39:55 2000
|
||||
+++ Makefile.in Wed Apr 14 15:16:06 2004
|
||||
@@ -45,15 +45,15 @@
|
||||
PROG = arpwatch
|
||||
CCOPT = @V_CCOPT@
|
||||
INCLS = -I. @V_INCLS@
|
||||
-DEFS = -DDEBUG @DEFS@ -DARPDIR=\"$(ARPDIR)\" -DPATH_SENDMAIL=\"$(SENDMAIL)\"
|
||||
+DEFS = @DEFS@ -pthread -DARPDIR=\"$(ARPDIR)\" -DPATH_SENDMAIL=\"$(SENDMAIL)\"
|
||||
+DEFS = @DEFS@ -DARPDIR=\"$(ARPDIR)\" -DPATH_SENDMAIL=\"$(SENDMAIL)\"
|
||||
|
||||
# Standard CFLAGS
|
||||
CFLAGS = $(CCOPT) $(DEFS) $(INCLS)
|
||||
-CFLAGS = $(CCOPT) $(DEFS) $(INCLS)
|
||||
+CFLAGS = $(CCOPT) $(PTHREAD_CFLAGS) $(DEFS) $(INCLS)
|
||||
|
||||
# Standard LIBS
|
||||
-LIBS = @LIBS@
|
||||
+LIBS = @LIBS@ $(PTHREAD_LIBS)
|
||||
# Standard LIBS without libpcap.a
|
||||
-SLIBS = @LBL_LIBS@
|
||||
+SLIBS = @LBL_LIBS@ $(PTHREAD_LIBS)
|
||||
|
||||
INSTALL = @INSTALL@
|
||||
SENDMAIL = @V_SENDMAIL@
|
||||
@@ -110,8 +110,8 @@
|
||||
$(CC) $(CFLAGS) -o $@ zap.o intoa.o -lutil
|
||||
|
||||
|
@ -5,6 +5,6 @@ maintained by the program, and an alert is issued should a device
|
||||
move between interfaces. In addition, event processing has been
|
||||
refactored, and some bugs have been fixed.
|
||||
|
||||
see net/arpwatch/pkg-descr for more information about arpwatch 2.x
|
||||
see net-mgmt/arpwatch/pkg-descr for more information about arpwatch 2.x
|
||||
|
||||
Matthew George <mdg@secureworks.net>
|
||||
|
Loading…
Reference in New Issue
Block a user