Update to version 2.0

PR:		7514
Submitted by:	maintainer
This commit is contained in:
Steve Price 1998-08-09 00:54:34 +00:00
parent b046b62fed
commit e2bb7c1fed
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=12360
5 changed files with 43 additions and 84 deletions

View File

@ -1,72 +1,22 @@
# New ports collection makefile for: h2ps-1.0
# Version required: 1.0
# New ports collection makefile for: h2ps-2.0
# Version required: 2.0
# Date created: 20 May 1997
# Whom: Choi Jun Ho <junker@jazz.snu.ac.kr>
# Whom: CHOI Junho <junker@jazz.snu.ac.kr>
#
# $Id: Makefile,v 1.2 1997/09/22 16:21:39 max Exp $
# $Id: Makefile,v 1.3 1997/11/22 01:17:55 asami Exp $
#
DISTNAME= h2ps-1.0
PKGNAME= ko-h2ps-${PAPERSIZE}-1.0
DISTNAME= h2ps-2.00
PKGNAME= ko-h2ps-a4-2.0
CATEGORIES= korean print
MASTER_SITES= ftp://cglab.snu.ac.kr/pub/hangul/n3f/applications/
MASTER_SITES= ftp://cglab.snu.ac.kr/pub/hangul/n3f/tar/
MAINTAINER= junker@jazz.snu.ac.kr
MANUAL_PACKAGE_BUILD= PAPERSIZE has to be set to letter a4
MAKE_FLAGS?= WIDTH=${WIDTH} HEIGHT=${HEIGHT} A4_PAPERSIZE=${A4_PAPERSIZE} -f
MAN1= h2ps.1
pre-build:
@(cd ${WRKSRC}; make clean)
letter::
${MAKE} PAPERSIZE=letter
letter-install::
${MAKE} PAPERSIZE=letter install
a4::
${MAKE} PAPERSIZE=a4
a4-install::
${MAKE} PAPERSIZE=a4 install
.if !defined(PAPERSIZE)
PAPERSIZE=a4
WIDTH=8.27
HEIGHT=11.64
A4_PAPERSIZE=1
PAPERSIZE_UNSPECIFIED= yes
.elif ${PAPERSIZE} == A4 || ${PAPERSIZE} == a4
PAPERSIZE=a4
WIDTH=8.27
HEIGHT=11.64
A4_PAPERSIZE=1
.elif ${PAPERSIZE} == letter || ${PAPERSIZE} == LETTER
PAPERSIZE=letter
WIDTH=8.5
HEIGHT=11.0
A4_PAPERSIZE=0
.else
PAPERSIZE_INVALID= yes
.endif # not defined PAPERSIZE
pre-fetch:
.if defined(PAPERSIZE_UNSPECIFIED)
@echo "Defaulting to ${PAPERSIZE} sized paper."
@echo ""
@echo "Set the environment variable PAPERSIZE if you want to use other sizes."
@echo "Possible values are: A4 (default) or letter"
.elif defined(PAPERSIZE_INVALID)
@echo "Error: invalid value for PAPERSIZE: \"${PAPERSIZE}\""
@echo "Possible values are: A4 (default) or letter"
@/usr/bin/false
.endif
pre-install:
@(cd ${WRKSRC}; make install.man)
post-install:
strip ${PREFIX}/bin/h2ps
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/h2ps ${PREFIX}/bin
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (h2ps-1.0.tar.gz) = bfa63e61e7beb35f387c224679e5e7e4
MD5 (h2ps-2.00.tar.gz) = 529c4243512f04984762d32584f513a8

View File

@ -1,15 +1,20 @@
diff -c -r ../h2ps-1.0-orig/h2ps.1 ./h2ps.1
*** ../h2ps-1.0-orig/h2ps.1 Wed Mar 19 21:29:14 1997
--- ./h2ps.1 Wed Mar 19 21:42:46 1997
***************
*** 156,161 ****
--- 156,164 ----
is the number of copies desired of each file named. By default, you get
only one copy.
.TP 0.6i
+ .B -a
+ Use the American paper size (8.5" x 11") as the basis for all calculations.
+ .TP 0.6i
.B -d
Print the current date and time at the bottom of the page. This option
is affected by the no surrounding border and the no header options.
--- h2ps.c.orig Fri Aug 7 01:41:12 1998
+++ h2ps.c Sat Aug 8 09:54:44 1998
@@ -9,6 +9,7 @@
#include <stdlib.h>
#include <sys/types.h>
#include <time.h>
+#include <unistd.h>
#include "ncode.h"
#include "npsr.h"
@@ -177,6 +178,9 @@
fputs("%%Creator: h2ps\n", out);
fprintf(out, "%%%%CreationDate: %s\n", date_str);
fputs("%%Pages: (atend)\n", out);
+ fputs("%%PageOrder: Ascend\n", out);
+ fputs("%%DocumentData: Clean8Bit\n", out);
+ fputs("%%DocumentPaperSizes: A4\n", out);
fputs("%%EndComments\n", out);
npsr_insert_resource(out, NPSR_FONT, "n3f-5");

View File

@ -1,11 +1,16 @@
h2ps
----
h2ps formats each named file for printing in a postscript printer with
embedded PS hangul fonts; if no file is given, h2ps reads from the
standard input. The format used is nice and compact: normally two pages
on each physical page, borders surrounding pages, headers with useful
information (page number, printing date, file name or supplied header),
line numbering, etc. This is very useful for making archive listings of
programs.
standard input. The format used is nice and compact: n(1 to 10) pages
on each physical page, headers with useful information (page number,
printing date), etc. This is very useful for making simple listings of
Korean text.
It is relatively compat when comparing with nh2ps, and no need to another
It is relatively compact when comparing with nh2ps, and no need to another
fonts or ghostscript. It can be printed with any PostScript printer only
with english fonts because its fonts are embedded with output.
--
Ports by CHOI Junho <junker@jazz.snu.ac.kr>

View File

@ -1,2 +1 @@
bin/h2ps
man/man1/h2ps.1.gz