Plugger is a multimedia plugin for Unix Netscape that handles

all types of formats.  It is a very small plugin because it
uses external programs to show/play the different formats.

PR:	10103
Submitted by:Jay Sachs <sachs@cs.williams.edu>
This commit is contained in:
Chris Piazza 1999-06-25 22:14:30 +00:00
parent 28395826e9
commit e2a1e8f670
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=19780
7 changed files with 85 additions and 0 deletions

34
www/plugger/Makefile Normal file
View File

@ -0,0 +1,34 @@
# New ports collection makefile for: plugger
# Version required: 3.0
# Date created: 11 Februrary 1999
# Whom: Jay Sachs <sachs@cs.williams.edu>
#
# $Id$
#
DISTNAME= plugger-3.0
CATEGORIES= www
MASTER_SITES= http://www.hubbe.net/~hubbe/plugger/ \
ftp://ftp.netscape.com/pub/sdk/plugin/unix/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} unix-sdk-3.0b5.tar.Z
MAINTAINER= sachs@cs.williams.edu
RUN_DEPENDS= ${LOCALBASE}/lib/netscape/plugins:${PORTSDIR}/www/netscape46-navigator
MAN7= plugger.7
MANCOMPRESSED= no
post-patch:
${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.old
${SED} \
-e 's#/usr/local/#${PREFIX}/#' \
-e 's#/usr/X11/#${X11BASE}/#' \
-e 's#/etc/pluggerrc#${PREFIX}/etc/pluggerrc.sample#' \
-e 's# /etc/ # ${PREFIX}/etc/pluggerrc.sample #' \
${WRKSRC}/Makefile.old > ${WRKSRC}/Makefile
post-install:
@${CAT} ${PKGMESSAGE} | ${SED} -e 's:/usr/local:${PREFIX}:'
.include <bsd.port.mk>

2
www/plugger/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (plugger-3.0.tar.gz) = 98f073487375d398b1cd0b657fcfce63
MD5 (unix-sdk-3.0b5.tar.Z) = 1e43785d5697c60937e8d6236e7d7d7e

View File

@ -0,0 +1,18 @@
--- Makefile.orig Mon Feb 15 10:14:46 1999
+++ Makefile Mon Feb 15 10:14:24 1999
@@ -1,5 +1,5 @@
# Where is your Plugin Source Development Kit from Netscape?
-SDK=/home/hubbe/src/PluginSDK30b5
+SDK=../PluginSDK30b5
# Where is your Xwindows located?
X11=/usr/X11/
@@ -40,6 +40,8 @@
DEFINES=$(STREAM) -DVERSION=\"$(VERSION)\" # -DDEBUG # -DPLUGIN_TRACE
CFLAGS=-O -I$(SDK)/include -I$(X11)/include -DXP_UNIX $(DEFINES)
+
+all: $(BIN_FILES)
plugger.so: plugger.o common.o
$(LD) -o plugger.so plugger.o common.o

1
www/plugger/pkg-comment Normal file
View File

@ -0,0 +1 @@
A multimedia front-end plugin for Netscape

12
www/plugger/pkg-descr Normal file
View File

@ -0,0 +1,12 @@
Plugger is a multimedia plugin for Unix Netscape 3.0 or later that
handles Quicktime, MPEG, MP2, AVI, SGI-movie, Tiff, DL, IFF-anim,
MIDI, Soundtracker, AU, WAV and Commodore 64 audio files. And now,
with Plugger 3.0, MPEG audio and video can be played streaming.
Plugger is a very small plugin, because plugger uses external programs
to show/play the different formats.
WWW: http://www.hubbe.net/~hubbe/plugger.html
-Jay
sachs@cs.williams.edu

15
www/plugger/pkg-message Normal file
View File

@ -0,0 +1,15 @@
**************************************************
**************************************************
NOTE:
Be sure to create a /usr/local/etc/pluggerrc file; use
/usr/local/etc/pluggerrc.sample as a starting point.
It should work fine as is.
Also note that you will need the various external viewers
(splay, xanim, etc) in order to view embedded web content.
**************************************************
**************************************************

3
www/plugger/pkg-plist Normal file
View File

@ -0,0 +1,3 @@
lib/netscape/plugins/plugger.so
etc/pluggerrc.sample