Add clanbomber - a bomberman-like multiplayer game written using clanlib.

This commit is contained in:
Maxim Sobolev 2000-09-25 07:09:11 +00:00
parent 78d89936e2
commit e29c060b2d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=33084
7 changed files with 83 additions and 0 deletions

View File

@ -31,6 +31,7 @@
SUBDIR += CaribbeanStud
SUBDIR += bzflag
SUBDIR += cgoban
SUBDIR += clanbomber
SUBDIR += columns
SUBDIR += connect4
SUBDIR += corewars

23
games/clanbomber/Makefile Normal file
View File

@ -0,0 +1,23 @@
# New ports collection makefile for: clanbomber
# Date created: 10 May 2000
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= clanbomber
PORTVERSION= 1.01
CATEGORIES= games
MASTER_SITES= http://www.clanbomber.de/files/
MAINTAINER= sobomax@FreeBSD.org
LIB_DEPENDS= clanCore.0:${PORTSDIR}/devel/clanlib
USE_XLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-pthread -L${LOCALBASE}/lib" \
CPPFLAGS="-I${LOCALBASE}/include"
CFLAGS+= -fpermissive -g3
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (clanbomber-1.01.tar.gz) = 5df0045983d205b9fe59c0d8b4c4d889

View File

@ -0,0 +1,11 @@
--- configure.orig Fri May 19 12:12:53 2000
+++ configure Fri May 19 12:13:21 2000
@@ -779,7 +779,7 @@
-CXXFLAGS="-O6"
+#CXXFLAGS="-O6"
for ac_prog in $CCC c++ g++ gcc CC cxx cc++ cl
do

View File

@ -0,0 +1 @@
A bomberman-like multiplayer game

View File

@ -0,0 +1,8 @@
ClanBomber is a free (GPL) Bomberman-like multiplayer game that uses ClanLib, a
free multi platform C++ game SDK. First "ClanBomber" was only a working title
for a small game started in September 1998, that has only been started to learn
how to use ClanLib. But the ClanBomber project has grown into a real game. It
is fully playable and features Computer controlled bombers, however, it is
recommended to play ClanBomber with friends (3-8 players are really fun).
WWW: http://www.clanbomber.de/

View File

@ -0,0 +1,38 @@
bin/clanbomber
share/clanbomber/bud.mod
share/clanbomber/clanbomber.dat
share/clanbomber/clanbomber.scr
share/clanbomber/maps/Arena.map
share/clanbomber/maps/Big_Block.map
share/clanbomber/maps/Big_Standard.map
share/clanbomber/maps/Blast_Matrix.map
share/clanbomber/maps/Bloody_Ring.map
share/clanbomber/maps/Boiling_Egg.map
share/clanbomber/maps/Bomb_Attack.map
share/clanbomber/maps/Crammed.map
share/clanbomber/maps/Death_Corridor.map
share/clanbomber/maps/Dilemma.map
share/clanbomber/maps/FearCircle.map
share/clanbomber/maps/FearCircle_Remix.map
share/clanbomber/maps/FireWheels.map
share/clanbomber/maps/Football.map
share/clanbomber/maps/Four_Instance.map
share/clanbomber/maps/Ghostbear.map
share/clanbomber/maps/Hard_Work.map
share/clanbomber/maps/Hole_Run.map
share/clanbomber/maps/Huge_Standard.map
share/clanbomber/maps/Juicy_Lucy.map
share/clanbomber/maps/Kitchen.map
share/clanbomber/maps/Meeting.map
share/clanbomber/maps/MungoBane.map
share/clanbomber/maps/Obstacle_Race.map
share/clanbomber/maps/Overkill.map
share/clanbomber/maps/Prison_Cells.map
share/clanbomber/maps/Redirection.map
share/clanbomber/maps/Sixty_Nine.map
share/clanbomber/maps/Small_Standard.map
share/clanbomber/maps/Snake_Race.map
share/clanbomber/maps/Tiny_Standard.map
share/clanbomber/maps/Whole_Mess.map
@dirrm share/clanbomber/maps
@dirrm share/clanbomber