- Update to 20020217

- Pass the maintainership wand to submitter

PR:		35162
Submitted by:	Erik Greenwald <erik@smluc.org>
This commit is contained in:
Patrick Li 2002-02-21 01:26:32 +00:00
parent 4125c6d213
commit e29128b955
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=55010
9 changed files with 136 additions and 107 deletions

View File

@ -6,20 +6,23 @@
#
PORTNAME= openal
PORTVERSION= 20000908
PORTVERSION= 20020217
CATEGORIES= audio
MASTER_SITES= ftp://ftp.openal.org/pub/openal/
MAINTAINER= ports@FreeBSD.org
MAINTAINER= erik@smluc.org
WRKSRC= ${WRKDIR}/${PORTNAME}/linux
WRKSRC= ${WRKDIR}/tmp/${PORTNAME}/linux
USE_GMAKE= yes
USE_AUTOCONF= yes
INSTALLS_SHLIB= yes
post-patch:
@find ${WRKSRC} -name 'Makefile.in' | xargs ${PERL} -pi -e 's/-g -c/-c/g'
@${PERL} -pi -e 's|autoconf|${AUTOCONF}|; \
s|autoheader|${AUTOHEADER}|' ${WRKSRC}/autogen.sh
pre-configure:
@cd ${WRKSRC} && ${SH} autogen.sh
post-install:
${INSTALL_DATA} ${WRKSRC}/doc/openal.info ${PREFIX}/info

View File

@ -1 +1 @@
MD5 (openal-20000908.tar.gz) = f8940f253b738a4c29f2d3dc09fb4936
MD5 (openal-20020217.tar.gz) = d8664ed879cf878a740fe9721e91fca4

View File

@ -1,42 +0,0 @@
--- Makefile.in.orig Sun Sep 3 17:40:32 2000
+++ Makefile.in Fri Oct 13 05:50:01 2000
@@ -1,4 +1,5 @@
INSTALL=@INSTALL@
+INSTALL_DATA=@INSTALL_DATA@
LN_S=@LN_S@
DESTDIR=@prefix@/
DESTINC=$(DESTDIR)include
@@ -38,20 +39,19 @@
$(INSTALL) -d -m 755 $(DESTINC)
$(INSTALL) -d -m 755 $(DESTINC)/AL
$(INSTALL) -d -m 755 $(DESTLIB)
- $(INSTALL) -m 755 src/libopenal.a $(DESTLIB)
- $(INSTALL) -m 755 src/libopenal.so.$(VERSION) $(DESTLIB)
- $(LN_S) -f $(DESTLIB)/libopenal.so.$(VERSION) $(DESTLIB)/libopenal.so.$(MAJOR_VERSION)
- $(LN_S) -f $(DESTLIB)/libopenal.so.$(VERSION) $(DESTLIB)/libopenal.so
- $(INSTALL) -m 444 ../include/AL/al.h $(DESTINC)/AL
- $(INSTALL) -m 444 ../include/AL/alc.h $(DESTINC)/AL
- $(INSTALL) -m 444 ../include/AL/alu.h $(DESTINC)/AL
- $(INSTALL) -m 444 ../include/AL/alut.h $(DESTINC)/AL
- $(INSTALL) -m 444 ../include/AL/altypes.h $(DESTINC)/AL
- $(INSTALL) -m 444 ../include/AL/alctypes.h $(DESTINC)/AL
- $(INSTALL) -m 444 ../include/AL/alutypes.h $(DESTINC)/AL
- $(INSTALL) -m 444 ../include/AL/aluttypes.h $(DESTINC)/AL
- $(INSTALL) -m 444 include/AL/alkludge.h $(DESTINC)/AL
- $(INSTALL) -m 444 include/AL/alkludgetypes.h $(DESTINC)/AL
+ $(INSTALL_DATA) src/libopenal.a $(DESTLIB)
+ $(INSTALL_DATA) src/libopenal.so.$(MAJOR_VERSION) $(DESTLIB)
+ $(LN_S) -f $(DESTLIB)/libopenal.so.$(MAJOR_VERSION) $(DESTLIB)/libopenal.so
+ $(INSTALL_DATA) ../include/AL/al.h $(DESTINC)/AL
+ $(INSTALL_DATA) ../include/AL/alc.h $(DESTINC)/AL
+ $(INSTALL_DATA) ../include/AL/alu.h $(DESTINC)/AL
+ $(INSTALL_DATA) ../include/AL/alut.h $(DESTINC)/AL
+ $(INSTALL_DATA) ../include/AL/altypes.h $(DESTINC)/AL
+ $(INSTALL_DATA) ../include/AL/alctypes.h $(DESTINC)/AL
+ $(INSTALL_DATA) ../include/AL/alutypes.h $(DESTINC)/AL
+ $(INSTALL_DATA) ../include/AL/aluttypes.h $(DESTINC)/AL
+ $(INSTALL_DATA) include/AL/alkludge.h $(DESTINC)/AL
+ $(INSTALL_DATA) include/AL/alkludgetypes.h $(DESTINC)/AL
configure: configure.in
@echo "configure.in newer than configure...Please re-./configure"

View File

@ -1,11 +1,11 @@
--- configure.in~ Sat Sep 9 00:15:48 2000
+++ configure.in Mon Sep 25 18:53:56 2000
@@ -111,7 +111,7 @@
AC_CHECK_LIB(m, sin, LIBS="$LIBS -lm", echo "I'm afraid you'll need libm."; exit 1)
--- configure.in.orig Wed Feb 20 11:40:35 2002
+++ configure.in Wed Feb 20 11:40:46 2002
@@ -734,7 +734,7 @@
dnl Should be allow dlopen of extensions?
-AC_CHECK_LIB(dl, dlopen, LIBS="$LIBS -ldl", AC_DEFINE(NODLOPEN) echo "Can't dlopen extensions." )
+AC_CHECK_FUNC(dlopen, [], AC_CHECK_LIB(dl, dlopen, LIBS="$LIBS -ldl", AC_DEFINE(NODLOPEN) echo "Can't dlopen extensions." ))
dnl Should we use turn warnings into errors?
if test x$SHOULD_USE_WERROR = xyes; then
- WFLAGS="$WFLAGS -Werror -pedantic-errors"
+ WFLAGS="$WFLAGS"
fi
dnl Special OS objs for target systems
case "$target" in
dnl if we are forced to live with redundant decls, turn off those errors

View File

@ -0,0 +1,101 @@
--- src/arch/bsd/bsd_dsp.c.orig Thu Apr 12 15:59:49 2001
+++ src/arch/bsd/bsd_dsp.c Wed Feb 20 14:27:54 2002
@@ -8,12 +8,16 @@
*
*/
#include "al_siteconfig.h"
+#include "al_config.h"
+#include "al_main.h"
+#include "al_debug.h"
+#include "alc/alc_context.h"
+#include "arch/interface/interface_sound.h"
+#include "arch/bsd/bsd_dsp.h"
#include <AL/altypes.h>
-#include <AL/alkludge.h>
-
-#include "al_siteconfig.h"
+#include <errno.h>
#include <fcntl.h>
#include <machine/soundcard.h>
#include <stdio.h>
@@ -26,12 +30,6 @@
#include <sys/types.h>
#include <unistd.h>
-#include "arch/interface/interface_sound.h"
-#include "arch/bsd/bsd_dsp.h"
-
-#include "al_main.h"
-#include "al_debug.h"
-#include "alc/alc_context.h"
static int alcChannel_to_dsp_channel(ALuint alcc);
@@ -101,9 +99,9 @@
* dma buffer size.
*
*/
-void *grab_native(void) {
+void *grab_write_native(void) {
const char *dsppath = "/dev/dsp";
- int divisor = _alSpot(_AL_DEF_BUFSIZ) | (2<<16);
+ int divisor = _alSpot(_ALC_DEF_BUFSIZ) | (2<<16);
dsp_fd = open(dsppath, O_WRONLY | O_NONBLOCK);
@@ -219,7 +217,7 @@
return;
}
-float get_nativechannel(UNUSED(void *handle), ALuint channel) {
+float get_nativechannel(UNUSED(void *handle), ALCenum channel) {
int retval = 0;
channel = alcChannel_to_dsp_channel(channel);
@@ -242,7 +240,7 @@
*
* Kludgey, and obviously not the right way to do this
*/
-int set_nativechannel(UNUSED(void *handle), ALuint channel, float volume) {
+int set_nativechannel(UNUSED(void *handle), ALCenum channel, float volume) {
int unnormalizedvolume;
unnormalizedvolume = volume * 100;
@@ -313,7 +311,7 @@
UNUSED(unsigned int *bufsiz),
ALenum *fmt,
unsigned int *speed) {
- ALuint channels = _al_ALFORMAT(*fmt);
+ ALuint channels = _al_ALCHANNELS(*fmt);
if(dsp_fd < 0) {
return AL_FALSE;
@@ -365,3 +363,26 @@
UNUSED(unsigned int *speed)) {
return AL_FALSE;
}
+
+
+#define DONTCARE (1<<16)
+
+static ALboolean use_select = AL_TRUE;
+
+void *grab_read_native(void)
+{
+ static int read_fd;
+
+#ifndef CAPTURE_SUPPORT
+ return NULL;
+#endif
+
+ read_fd = aquire_read();
+ if( read_fd < 0) {
+ return NULL;
+ }
+
+ return &read_fd;
+
+}
+

View File

@ -1,21 +0,0 @@
--- src/Makefile.in.orig Sat Sep 9 07:15:48 2000
+++ src/Makefile.in Fri Oct 13 05:51:52 2000
@@ -81,7 +81,6 @@
rm -f $(EXT_OBJS)
rm -f $(EXT_DLL_OBJS)
rm -f libopenal.a
- rm -f libopenal.$(SO_EXT).$(VERSION)
rm -f libopenal.$(SO_EXT).$(MAJOR_VERSION)
rm -f libopenal.$(SO_EXT)
rm -f core
@@ -103,8 +102,8 @@
libopenal.so: $(AL_OBJS) $(ALC_OBJS) $(AC_OBJS) $(ALUT_OBJS) extensions
$(CC) -shared \
-Wl,-soname \
- -Wl,libopenal-$(MAJOR_VERSION).$(MINOR_VERSION).so \
- -o libopenal.so.$(VERSION) \
+ -Wl,libopenal.so.$(MAJOR_VERSION) \
+ -o libopenal.so.$(MAJOR_VERSION) \
$(AL_OBJS) \
$(ALC_OBJS) \
$(AC_OBJS) \

View File

@ -1,22 +0,0 @@
--- src/alc/alc_context.c~ Tue Aug 1 02:10:18 2000
+++ src/alc/alc_context.c Mon Sep 25 19:20:23 2000
@@ -65,7 +65,7 @@
static ALCenum _alcDestroyContext(AL_context *cc);
static void _alcReallocContexts(ALuint newsize);
static int _alcCidToIndex(ALuint cid);
-static ALuint _alcIndexToCid(int index);
+static ALuint _alcIndexToCid(int idx);
#ifdef JLIB
unsigned int jlib_debug = 0;
@@ -777,8 +777,8 @@
return cid - CONTEXT_BASE;
}
-static ALuint _alcIndexToCid(int index) {
- return index + CONTEXT_BASE;
+static ALuint _alcIndexToCid(int idx) {
+ return idx + CONTEXT_BASE;
}
/*

View File

@ -1,11 +1,20 @@
--- src/threads/posixthreads.c~ Mon Aug 28 19:14:08 2000
+++ src/threads/posixthreads.c Mon Sep 25 19:17:19 2000
@@ -82,7 +82,7 @@
--- src/threads/posixthreads.c.orig Wed May 9 12:40:39 2001
+++ src/threads/posixthreads.c Wed Feb 20 12:37:03 2002
@@ -19,6 +19,10 @@
extern int pthread_atfork(void (*)(void), void (*)(void), void (*)(void));
#endif
+#if defined(BSD_TARGET)
+int pthread_atfork(void (*a)(void),void (*b)(void),void (*c)(void)){return -1;}
+#endif
+
typedef int (*ptfunc)(void *);
static void *RunThread(void *data) {
@@ -88,7 +92,7 @@
}
extern unsigned int Posix_SelfThread(void) {
- return (unsigned int) pthread_self();
+ return (unsigned long)(unsigned long *) pthread_self();
}
extern void Posix_ExitThread(UNUSED(int retval)) {

View File

@ -1,8 +1,8 @@
include/AL/al.h
include/AL/alc.h
include/AL/alctypes.h
include/AL/alkludge.h
include/AL/alkludgetypes.h
include/AL/alext.h
include/AL/alexttypes.h
include/AL/altypes.h
include/AL/alu.h
include/AL/alut.h
@ -14,4 +14,5 @@ info/openal.info
lib/libopenal.a
lib/libopenal.so
lib/libopenal.so.0
lib/libopenal.so.0.0.6
@dirrm include/AL