This extension provides WBXML (Wireless Binary XML) conversion capabilities

using the libwbxml library, which can be found at https://libwbxml.opensync.org/

WWW:	http://pecl.php.net/package/WBXML/

PR:		ports/132552
Submitted by:	Florian Smeets <flo at kasimir.com>
This commit is contained in:
Martin Wilke 2009-03-12 16:41:31 +00:00
parent ee2657f9cd
commit e2307bb6cc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=229941
6 changed files with 69 additions and 0 deletions

View File

@ -821,6 +821,7 @@
SUBDIR += pecl-html_parse
SUBDIR += pecl-stem
SUBDIR += pecl-syck
SUBDIR += pecl-wbxml
SUBDIR += pecl-xdiff
SUBDIR += pecl-xslcache
SUBDIR += perl2html

View File

@ -0,0 +1,24 @@
# New ports collection makefile for: pecl-wbxml
# Date created: 2009-03-11
# Whom: Florian Smeets <flo@kasimir.com>
#
# $FreeBSD$
#
PORTNAME= wbxml
PORTVERSION= 1.0.3
CATEGORIES= textproc pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
EXTRACT_SUFX= .tgz
DIST_SUBDIR= PECL
MAINTAINER= flo@kaismir.com
COMMENT= A PECL extension that provides WBXML conversion capabilities
LIB_DEPENDS= wbxml2.0:${PORTSDIR}/textproc/wbxml2
USE_PHP= yes
USE_PHPEXT= yes
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (PECL/wbxml-1.0.3.tgz) = 9c6a4d347f9a2b4002ea0c83e4b14082
SHA256 (PECL/wbxml-1.0.3.tgz) = 8a2e36aa1e59712614734a150d4bc2c09c1e7d1f9b90404beeb99d32d19d15ae
SIZE (PECL/wbxml-1.0.3.tgz) = 5260

View File

@ -0,0 +1,24 @@
--- config.m4.orig 2009-03-11 17:57:16.000000000 +0100
+++ config.m4 2009-03-11 17:57:27.000000000 +0100
@@ -74,21 +74,6 @@
CFLAGS="$CFLAGS -Wall"
fi
- AC_DEFINE(WBXML_ENCODER_USE_STRTBL,1,[ ])
-
- AC_DEFINE(WBXML_SUPPORT_WML,1,[ ])
- AC_DEFINE(WBXML_SUPPORT_WTA,1,[ ])
- AC_DEFINE(WBXML_SUPPORT_SI,1,[ ])
- AC_DEFINE(WBXML_SUPPORT_SL,1,[ ])
- AC_DEFINE(WBXML_SUPPORT_CO,1,[ ])
- AC_DEFINE(WBXML_SUPPORT_PROV,1,[ ])
- AC_DEFINE(WBXML_SUPPORT_EMN,1,[ ])
- AC_DEFINE(WBXML_SUPPORT_DRMREL,1,[ ])
- AC_DEFINE(WBXML_SUPPORT_OTA_SETTINGS,1,[ ])
- AC_DEFINE(WBXML_SUPPORT_SYNCML,1,[ ])
- AC_DEFINE(WBXML_SUPPORT_WV,1,[ ])
- AC_DEFINE(WBXML_SUPPORT_AIRSYNC,1,[ ])
-
PHP_SUBST(WBXML_SHARED_LIBADD)
PHP_NEW_EXTENSION(wbxml, wbxml.c, $ext_shared)
fi

View File

@ -0,0 +1,13 @@
--- wbxml.c.orig 2009-03-11 18:12:19.000000000 +0100
+++ wbxml.c 2009-03-11 18:12:27.000000000 +0100
@@ -27,6 +27,10 @@
#include "ext/standard/info.h"
#include "php_wbxml.h"
+#ifdef HAVE_EXPAT
+#include "expat.h"
+#endif
+
#undef HAVE_LIBXML
#include "wbxml.h"

View File

@ -0,0 +1,4 @@
This extension provides WBXML (Wireless Binary XML) conversion capabilities
using the libwbxml library, which can be found at https://libwbxml.opensync.org/
WWW: http://pecl.php.net/package/WBXML/