Allow trn to build non-interactively
Cleanup pre-configure script -- from elm port Change lib search path from /usr/lib to /usr/lib/aout make install will no longer leave trn.old bogon
This commit is contained in:
parent
28def78e70
commit
e215e79f1b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=11247
@ -3,21 +3,33 @@
|
||||
# Date created: 21 October 1994
|
||||
# Whom: smace
|
||||
#
|
||||
# $Id: Makefile,v 1.12 1996/12/08 01:45:12 max Exp $
|
||||
# $Id: Makefile,v 1.13 1997/04/27 00:24:32 asami Exp $
|
||||
#
|
||||
|
||||
DISTNAME= trn-3.6
|
||||
CATEGORIES= news
|
||||
MASTER_SITES= ftp://ftp.uu.net/networking/news/readers/trn/
|
||||
|
||||
MAINTAINER= smace@FreeBSD.ORG
|
||||
|
||||
RUN_DEPENDS= munpack:${PORTSDIR}/converters/mpack
|
||||
|
||||
NO_PACKAGE= "Too many questions"
|
||||
IS_INTERACTIVE= yes
|
||||
WRKSRC= $(WRKDIR)/trn-3.6
|
||||
MAN1= trn.1 Pnews.1 Rnmail.1 newsetup.1 newsgroups.1
|
||||
|
||||
pre-configure:
|
||||
@echo "===> Running pre-configure target for ${DISTNAME}"
|
||||
@sh ${SCRIPTDIR}/preconf ${PORTSDIR} ${.CURDIR} ${WRKSRC}
|
||||
HAS_CONFIGURE= Yes
|
||||
CONFIGURE_SCRIPT= Configure
|
||||
CONFIGURE_ENV= PREFIX="$(PREFIX)"
|
||||
CONFIGURE_ARGS= -S
|
||||
|
||||
post-install:
|
||||
.if !defined(BATCH)
|
||||
@${ECHO} ""
|
||||
@${ECHO} "############################################################################"
|
||||
@${ECHO} "# Please edit lines 48 through 69 in ${PREFIX}/bin/Pnews #"
|
||||
@${ECHO} "# to customize news posting for your site. #"
|
||||
@${ECHO} "# Remember to set the NNTPSERVER environment variable to your news server. #"
|
||||
@${ECHO} "############################################################################"
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
5
news/trn/files/patch-ab
Normal file
5
news/trn/files/patch-ab
Normal file
@ -0,0 +1,5 @@
|
||||
--- hints/freebsd.sh.orig Thu Jun 4 09:45:34 1998
|
||||
+++ hints/freebsd.sh Thu Jun 4 09:44:16 1998
|
||||
@@ -1 +1,2 @@
|
||||
i_sysfilio='undef'
|
||||
+plibpth='$plibpth /usr/lib/aout'
|
10
news/trn/files/patch-ac
Normal file
10
news/trn/files/patch-ac
Normal file
@ -0,0 +1,10 @@
|
||||
--- Makefile.SH.orig Thu Jun 4 10:49:20 1998
|
||||
+++ Makefile.SH Thu Jun 4 10:49:50 1998
|
||||
@@ -133,6 +133,7 @@
|
||||
# won't work with csh
|
||||
export PATH || exit 1
|
||||
- (cd `./filexp $(rnbin)`; mv trn trn.old)
|
||||
+ - (cd `./filexp $(rnbin)`; rm trn.old)
|
||||
- if test `pwd` != `./filexp $(rnbin)`; then cp $(public) `./filexp $(rnbin)`;\
|
||||
(cd `./filexp $(rnbin)`; chmod o+x $(public); strip trn trn-artchk $(nntpbin)); fi
|
||||
- if test $(installfilexp) = Rnfilexp; then cp ./filexp `./filexp $(rnbin)/Rnfilexp`; fi
|
236
news/trn/scripts/pre-configure
Normal file
236
news/trn/scripts/pre-configure
Normal file
@ -0,0 +1,236 @@
|
||||
#!/bin/sh -
|
||||
#
|
||||
# pre-configure script for Trn port to FreeBSD 3.0
|
||||
# $Id: preconf,v 1.3 1996/12/06 23:58:51 ache Exp $
|
||||
|
||||
PortsDir=$PORTSDIR
|
||||
CurDir=$CURDIR
|
||||
WrkSrc=$WRKSRC
|
||||
|
||||
cat > ${WrkSrc}/config.sh << 'EOF'
|
||||
|
||||
|
||||
#!/bin/sh
|
||||
#
|
||||
# This file was produced by running the Configure script. It holds all the
|
||||
# definitions figured out by Configure. Should you modify one of these values,
|
||||
# do not forget to propagate your changes by running "Configure -der". You may
|
||||
# instead choose to run each of the .SH files by yourself, or "Configure -S".
|
||||
#
|
||||
|
||||
# Configuration time: Thu Jun 4 09:28:52 CDT 1998
|
||||
# Configured by: smace
|
||||
# Target system: freebsd metal.intt.org 3.0-current freebsd 3.0-current #1: tue jun 2 23:02:23 cdt 1998 smace@metal.intt.org:/usr/src/sys/compile/metal i386
|
||||
|
||||
d_bsd='define'
|
||||
d_eunice='undef'
|
||||
d_xenix='undef'
|
||||
eunicefix=':'
|
||||
Mcc='Mcc'
|
||||
awk='awk'
|
||||
basename='basename'
|
||||
bash='bash'
|
||||
cat='cat'
|
||||
cp='cp'
|
||||
cpp='cpp'
|
||||
csh='csh'
|
||||
date='date'
|
||||
diff='diff'
|
||||
echo='echo'
|
||||
ed='ed'
|
||||
egrep='egrep'
|
||||
expr='expr'
|
||||
grep='grep'
|
||||
inews='inews'
|
||||
ispell=''
|
||||
ksh='ksh'
|
||||
less='less'
|
||||
lint=''
|
||||
mail='mail'
|
||||
metamail='metamail'
|
||||
mhn='mhn'
|
||||
mkdir='mkdir'
|
||||
more='more'
|
||||
munpack='munpack'
|
||||
mv='mv'
|
||||
nroff='nroff'
|
||||
pg='pg'
|
||||
rm='rm'
|
||||
rmail='rmail'
|
||||
sed='sed'
|
||||
sendmail='sendmail'
|
||||
smail='smail'
|
||||
sort='sort'
|
||||
spell='spell'
|
||||
tail='tail'
|
||||
test='test'
|
||||
tr='tr'
|
||||
uname='uname'
|
||||
uniq='uniq'
|
||||
uuname='uuname'
|
||||
vi='vi'
|
||||
vspell=''
|
||||
who=''
|
||||
hint='recommended'
|
||||
myuname='freebsd metal.intt.org 3.0-current freebsd 3.0-current #1: tue jun 2 23:02:23 cdt 1998 smace@metal.intt.org:/usr/src/sys/compile/metal i386 '
|
||||
srcdir='.'
|
||||
vincludes=''
|
||||
vpath='.'
|
||||
Id='$Id'
|
||||
Log='$Log'
|
||||
active='none'
|
||||
acttimes='nntp'
|
||||
d_acttimes='define'
|
||||
myactive='.falseactive'
|
||||
bin='${PREFIX}/bin'
|
||||
binexp='${PREFIX}/bin'
|
||||
installbin='${PREFIX}/bin'
|
||||
cc='cc'
|
||||
ccflags=''
|
||||
cppflags=''
|
||||
ldflags=''
|
||||
lkflags=''
|
||||
optimize='-O'
|
||||
cf_by='smace'
|
||||
cf_time='Thu Jun 4 09:28:52 CDT 1998'
|
||||
contains='grep'
|
||||
cpplast='-'
|
||||
cppminus='-'
|
||||
cpprun='cc -E'
|
||||
cppstdin='cc -E'
|
||||
d_ftime='undef'
|
||||
aphostcmd='/bin/hostname'
|
||||
d_gethname='define'
|
||||
d_phostcmd='define'
|
||||
d_uname='undef'
|
||||
d_getpwent='define'
|
||||
d_getcwd='undef'
|
||||
d_getwd='define'
|
||||
d_havetlib='define'
|
||||
termlib='-ltermlib'
|
||||
d_ignoreorg='undef'
|
||||
d_internet='define'
|
||||
d_memcmp='define'
|
||||
d_memcpy='define'
|
||||
d_memset='define'
|
||||
d_mimeshow='undef'
|
||||
d_mimestore='define'
|
||||
mimeshow="none"
|
||||
mimestore="${PREFIX}/bin/munpack"
|
||||
d_newsadm='define'
|
||||
newsadmin='news'
|
||||
d_nntp='define'
|
||||
d_xdata='define'
|
||||
d_genauth='undef'
|
||||
servername='no default'
|
||||
d_nolnbuf='undef'
|
||||
d_normsig='define'
|
||||
jobslib=''
|
||||
d_novoid='undef'
|
||||
void=''
|
||||
d_portable='define'
|
||||
d_rdchk='undef'
|
||||
d_rename='define'
|
||||
d_sigblock='define'
|
||||
d_sighold='undef'
|
||||
d_sizet='undef'
|
||||
d_strccmp='define'
|
||||
d_strchr='define'
|
||||
d_strftime='define'
|
||||
strftimec=''
|
||||
strftimeo=''
|
||||
d_libndir='undef'
|
||||
d_usendir='undef'
|
||||
libndir=''
|
||||
ndirc=''
|
||||
ndiro=''
|
||||
d_vfork='define'
|
||||
d_voidsig='define'
|
||||
signal_t='void'
|
||||
defeditor='/usr/bin/vi'
|
||||
filexp='${PREFIX}/lib/trn/filexp'
|
||||
d_dirnamlen=''
|
||||
i_dirent='define'
|
||||
i_ptem='undef'
|
||||
i_stdlib='define'
|
||||
i_string='define'
|
||||
strings='/usr/include/string.h'
|
||||
i_sysdir='define'
|
||||
d_voidtty=''
|
||||
i_bsdioctl=''
|
||||
i_sysfilio='undef'
|
||||
i_sysioctl='define'
|
||||
i_syssockio=''
|
||||
i_sysndir='undef'
|
||||
i_sgtty='undef'
|
||||
i_termio='undef'
|
||||
i_termios='define'
|
||||
i_systime='define'
|
||||
i_time='undef'
|
||||
i_unistd='define'
|
||||
i_vfork='undef'
|
||||
ispell_options=''
|
||||
ispell_prg='none'
|
||||
libc='/usr/lib/aout/libc.a'
|
||||
plibpth='/usr/ccs/lib /usr/lib /usr/ucblib ${PREFIX}/lib /usr/lib/aout'
|
||||
xlibpth='/usr/lib/386 /lib/386'
|
||||
libs=' '
|
||||
citydist='none'
|
||||
cntrydist='none'
|
||||
contdist='none'
|
||||
locdist='none'
|
||||
multistatedist='none'
|
||||
orgdist='none'
|
||||
statedist='none'
|
||||
mailer='/usr/sbin/sendmail'
|
||||
mailfile='/var/mail/%L'
|
||||
installmansrc='${PREFIX}/man/man1'
|
||||
manext='1'
|
||||
mansrc='${PREFIX}/man/man1'
|
||||
mansrcexp='${PREFIX}/man/man1'
|
||||
mboxchar='F'
|
||||
c=''
|
||||
n='-n'
|
||||
d_berknames='define'
|
||||
d_passnames='define'
|
||||
d_usgnames='undef'
|
||||
nametype='bsd'
|
||||
inewsloc='inews'
|
||||
newslib='/tmp'
|
||||
newslibexp='/tmp'
|
||||
newsspool='/tmp'
|
||||
orgname='Unknown'
|
||||
package='trn'
|
||||
spackage='Trn'
|
||||
pager='/usr/bin/more'
|
||||
phost='.'
|
||||
phostcmd='hostname'
|
||||
prefshell='/bin/sh'
|
||||
installprivlib='${PREFIX}/lib/trn'
|
||||
privlib='${PREFIX}/lib/trn'
|
||||
privlibexp='${PREFIX}/lib/trn'
|
||||
rootid='0'
|
||||
sharpbang='#!'
|
||||
shsharp='true'
|
||||
spitshell='cat'
|
||||
startsh='#!/bin/sh'
|
||||
sysman='/usr/share/man1'
|
||||
d_usemt='define'
|
||||
d_useov='define'
|
||||
overviewdir='/tmp'
|
||||
threaddir='/tmp'
|
||||
trn_init='TRUE'
|
||||
trn_select='TRUE'
|
||||
nm_opt=''
|
||||
runnm='true'
|
||||
usenm='true'
|
||||
incpath=''
|
||||
mips=''
|
||||
mips_type=''
|
||||
usrinc='/usr/include'
|
||||
PATCHLEVEL="3.6 (20 Nov 1994)"
|
||||
CONFIG=true
|
||||
EOF
|
||||
|
||||
exit 0
|
||||
# END
|
Loading…
Reference in New Issue
Block a user